OPCODE DISCLAIMER

OPCODE SYSTEMS, INC. ("OPCODE") MAKES NO WARRANTIES, EXPRESS OR IMPLIED, INCLUDING WITHOUT LIMITATION THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, REGARDING THE OPCODE SOFTWARE. OPCODE DOES NOT WARRANT, GUARANTEE OR MAKE ANY REPRESENTATIONS REGARDING THE USE OR THE RESULTS OF THE USE OF THE OPCODE SOFTWARE IN TERMS OF ITS CORRECTNESS, ACCURACY, RELIABILITY, CURRENTNESS OR OTHERWISE. THE ENTIRE RISK AS TO THE RESULTS AND PERFORMANCE OF THE OPCODE SOFTWARE IS ASSUMED BY YOU. THE EXCLUSION OF IMPLIED WARRANTIES IS NOT PERMITTED BY SOME STATES. THE ABOVE EXCLUSION MAY NOT APPLY TO YOU.

IN NO EVENT WILL OPCODE, ITS DIRECTORS, OFFICERS, EMPLOYEES OR AGENTS BE LIABLE TO YOU FOR ANY CONSEQUENTIAL, INCIDENTAL OR INDIRECT DAMAGES (INCLUDING DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, AND THE LIKE) ARISING OUT OF THE USE OR INABILITY TO USE THE OPCODE SOFTWARE EVEN IF OPCODE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. BECAUSE SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITATIONS MAY NOT APPLY TO YOU.

ACKNOWLEDGMENTS

Program by
Dave Oppenheim
Ray Spears
Dan Timis
Aron Nelson
David Willenbrink
Andy Wolpert
Doug Wyatt
Daniel Steinberg
Dave Scoggin
Larry Gerndt
Tom Padula
Harvey Thornburg

Special thanks to Muscle Fish

Quality Assurance
Mike Rogers
James Livingston
Darin Marshall

Product Management
Jonnie Gillham

Documentation
Greg Thomas
Gregory A. Simpson
Jon Drukman
Rob Wenig
Boris Popkoff
Angela Hill

Manual Design
Gregory A. Simpson

Technical Editing
Dave Oppenheim
Tim Self
TABLE OF CONTENTS

PART ONE: Introduction 1

CHAPTER 1: Introduction to the MIDI Reference Manual 3
Welcome to Vision ................................................................. 3
How to Use this Manual ....................................................... 4
Manual Conventions ............................................................. 5

CHAPTER 2: About MIDI 7
What is MIDI? ........................................................................ 7
MIDI Terminology .................................................................. 8
Common Misconceptions about MIDI ............................... 9

CHAPTER 3: Vision Basics 11
The Open Music System (OMS) ........................................... 11
Tracks .................................................................................. 11
Sequences ............................................................................. 13
The Control Bar ..................................................................... 13
The Edit Windows ................................................................... 14
The Strip Chart ....................................................................... 16
Vision On-Screen Help .......................................................... 16

CHAPTER 4: Navigating in Vision 19
Navigating Windows, Sequences, and Tracks ..................... 19
Selector Dots and Move Cursor ............................................ 22
Moving and Resizing Columns ............................................. 23
Zooming, Scrolling, and Scrubbing ...................................... 24
Using Window Menus ........................................................ 26
Editing Different Field Types .............................................. 27
# Table of Contents

## PART TWO: Recording  29

### CHAPTER 5: Real-Time Recording  31
- Record Setup ....................................................................................... 31
- Recording a Track ............................................................................ 33
- Punch Recording ................................................................................ 34
- Loop Recording .................................................................................. 35

### CHAPTER 6: Inserting and Step Recording Notes  37
- The Pencil Tool .................................................................................. 37
- The Magic Drumstick Tool ............................................................... 40
- Step Recording ................................................................................... 42

### CHAPTER 7: Advanced Recording Techniques  45
- Drum Machine Style Loop Recording ............................................. 45
- Multi-Channel Recording ............................................................... 46

## PART THREE: Playback & Editing  51

### CHAPTER 8: Sequence and Track Controls  53
- Sequence Controls ............................................................................. 53
- Track Controls .................................................................................... 54

### CHAPTER 9: Basic Editing Procedures  57
- Cursor Tools ....................................................................................... 57
- The Ruler ............................................................................................. 59
- Note Editing ......................................................................................... 60
- Working with Track Blocks and Phrases .......................................... 62
- Selecting Data Regions ................................................................. 63
# Table of Contents

Edit Points—Defining the Current Selection ...................................66  
Loop Editing .................................................................................66

**CHAPTER 10: Quantize, Shift, and Nudge** 69  
About Quantize ..............................................................................69  
Applying Quantize .........................................................................70  
Record Quantize ............................................................................76  
Permanently Shifting Track Data ....................................................77

**CHAPTER 11: Transpose** 79  
Transposing in the Graphic, Notation, and List Windows ..............79  
Transposing with Nudge ..................................................................80  
The Transpose Command .................................................................80  
Transposing with Vision Instruments .............................................83

**CHAPTER 12: Arranging & Mixing** 85  
Arranging Sections of Music ...........................................................85  
Saving Patch Selections ..................................................................88  
Saving Volume and Pan Settings ....................................................89  
Saving a Mixer Snapshot ..................................................................89

**PART FOUR: Advanced Concepts** 91

**CHAPTER 13: Segments, Loops, and Sequence Events** 93  
Segments ........................................................................................93  
Sequence Events ............................................................................96  
Arranging/Editing Sequence Events ..............................................98  
Sequence Events in the List Window .............................................103  
Subsequences—the Old Way .........................................................104
# Table of Contents

## CHAPTER 14: Generated Sequences 107
- Generated Sequences .............................................................. 107
- Generated Sequence Components .......................................... 109

## CHAPTER 15: Players and Input Effect 113
- Players & Queue Window ....................................................... 113
- Input Effect Window ............................................................... 115

## CHAPTER 16: Select & Modify 119
- Select & Modify Window ......................................................... 120
- Select Attributes ..................................................................... 121
- Modify Types .......................................................................... 124
- Select & Modify Menu ............................................................. 125
- Modifying Note Properties and Automation Values ................. 126
- Set Density ............................................................................. 127
- Reassign ................................................................................ 127
- Trim Start Time ...................................................................... 129
- Quantize Parameters ............................................................. 129
- Transpose Types .................................................................... 134

## CHAPTER 17: Tempo, Time Scale, and Reclock 137
- Virtual Conducting—Recording Tempo Changes ..................... 137
- Change Tempo ......................................................................... 139
- Scale Time ............................................................................. 140
- Reclock .................................................................................. 142

## CHAPTER 18: Synchronization 147
- Syncing to Beat Clock ............................................................. 147
- Syncing to Time Code .............................................................. 148
- Recording with External Synchronization ................................. 149
- Automatically Changing Sync Modes ...................................... 149
- SMPTE Time Code Rates ......................................................... 150
- Slaving External Devices to Vision .......................................... 151
PART FIVE: Customizing Vision  153

CHAPTER 19:  What’s Saved Where  155
Vision Files ........................................................................................156
Vision Setup .......................................................................................157
Vision 4.5 Prefs ..................................................................................158

CHAPTER 20:  Templates  161
Sequence Templates .........................................................................161
Editing Templates .............................................................................163
Creating Your Own Grooves ............................................................167

CHAPTER 21:  Commands and MIDIKeys  169
The Commands Window ..................................................................169
The MIDIKeys Window ...................................................................171
Saving MIDIKeys and Commands ..................................................175

CHAPTER 22:  Custom Instruments  177
Creating a Layered Instrument with Octaves ...............................177
Creating a Split Instrument .............................................................178
Creating Voice-Allocated Instruments ............................................179

PART SIX: Windows  181

CHAPTER 23:  The Control Bar  183
Record Mode .....................................................................................183
Current Sequence ...........................................................................184
Current Track ..................................................................................184
Thru Instrument ...............................................................................184
# Table of Contents

Current Patch ................................................................................... 186  
Transport Controls ......................................................................... 187  
Locators ......................................................................................... 189  
Sync Pop-up ................................................................................... 189  
Begin Record Toggle ..................................................................... 190  
The Counter .................................................................................... 191  
Tempo Display ............................................................................... 192  
Memory Display ............................................................................. 193  
Marker Pop-up ............................................................................... 193  
Punch and Loop Controls ................................................................ 194  
Window Buttons ............................................................................. 196  

## CHAPTER 24: The Sequences Window  
197  
Selecting, Moving, and Copying Sequences ................................. 198  
Sequences Window Columns .......................................................... 198  
Sequences Window Menu ............................................................... 200  

## CHAPTER 25: The Tracks Window  
203  
Two Windows in One ..................................................................... 203  
Track Columns ............................................................................... 205  
Meter and Tempo Tracks ............................................................... 210  
Sequence Information ................................................................... 212  
Track Overview—Viewing and Editing Blocks ............................. 213  
Tracks Window Menu ..................................................................... 219  

## CHAPTER 26: The Pulse Window  
221  
Pulse Window ................................................................................ 221  
Drum Tracks .................................................................................. 223  
Note Grid ....................................................................................... 225  
Multiple Pulse Windows ............................................................... 230  
Pulse Window Menu ...................................................................... 230
# Table of Contents

## CHAPTER 27: The Graphic Window 233
- Selecting Notes in the Graphic Window 234
- Modifying Notes in the Graphic Window 236
- Moving Notes 236
- Transposing Notes 236
- Changing a Note’s Duration 236
- Graphic Window Menu 237

## CHAPTER 28: The Strip Chart 241
- What is the Strip Chart? 241
- Strip Chart Contents 243
- The Strip Chart Tools 243
- Non-Continuous Events in the Strip Chart 248
- Using the Strip Chart 249
- Multiple Tracks and Channels in the Strip Chart 257
- Resizing and Zooming the Strip Chart 258

## CHAPTER 29: The List Window 261
- Opts Menu 262
- Inserting Events 263
- List Window Menu 271
- Editing Events in the List Window 273

## CHAPTER 30: The Notation Window 275
- Selecting Notes in the Notation Window 275
- Modifying Notes in the Notation Window 277
- Changing Key and Meter 279
- Changing Appearance without Changing Data 280
- Notation Window Menu 281

## CHAPTER 31: The Print Preview Window 285
- The Print Preview Window 285
- Page Setup 288
Table of Contents

A Brief Discussion of Notation Terms ........................................... 288
Tips for Good-Looking Scores ...................................................... 289

CHAPTER 32: The Instruments Window 293
Instruments Window........................................................................ 293
Available Instruments ..................................................................... 299
Instruments Window Menu ............................................................ 299
Global Instrument Solo Indicator ................................................... 302

CHAPTER 33: The Names Window 305
Terminology ...................................................................................... 305
Names Window ................................................................................ 307
Names Menu .................................................................................... 311
Patch Name Editing ......................................................................... 313
Selecting Names ............................................................................... 321
Opening Files With Different Name Setups .................................. 323

CHAPTER 34: The Input Map Window 325
Input Map Display ............................................................................ 325
Trigger and Transpose Modes ....................................................... 326
Input Map Window Menu ............................................................... 327
When to Use an Input Map ............................................................. 328

CHAPTER 35: The Settings Window 331
Insert Note ........................................................................................ 331
Strip Chart & Nudge ........................................................................ 332
Editing ............................................................................................... 333
Real-Time ........................................................................................ 334
Controllers ....................................................................................... 336
Appearance ....................................................................................... 336
<table>
<thead>
<tr>
<th>Chapter</th>
<th>Title</th>
<th>Pages</th>
</tr>
</thead>
<tbody>
<tr>
<td>36</td>
<td>The Step Window</td>
<td>337</td>
</tr>
<tr>
<td></td>
<td>Spacing</td>
<td>337</td>
</tr>
<tr>
<td></td>
<td>Duration</td>
<td>339</td>
</tr>
<tr>
<td></td>
<td>Velocity</td>
<td>341</td>
</tr>
<tr>
<td>37</td>
<td>The Faders Window</td>
<td>343</td>
</tr>
<tr>
<td></td>
<td>About Faders</td>
<td>343</td>
</tr>
<tr>
<td></td>
<td>The Faders Window</td>
<td>344</td>
</tr>
<tr>
<td></td>
<td>Fader Functions</td>
<td>346</td>
</tr>
<tr>
<td></td>
<td>Copying Fader Settings</td>
<td>347</td>
</tr>
<tr>
<td></td>
<td>Changes in the way Vision Handles Faders</td>
<td>347</td>
</tr>
<tr>
<td>38</td>
<td>The Console Windows</td>
<td>351</td>
</tr>
<tr>
<td></td>
<td>About Consoles</td>
<td>351</td>
</tr>
<tr>
<td></td>
<td>Opening a Console Window</td>
<td>351</td>
</tr>
<tr>
<td></td>
<td>Basic Console Window Anatomy</td>
<td>352</td>
</tr>
<tr>
<td></td>
<td>Creating a Console “Snapshot”</td>
<td>355</td>
</tr>
<tr>
<td></td>
<td>The Console Window Menu</td>
<td>355</td>
</tr>
<tr>
<td></td>
<td>Fader Grouping</td>
<td>367</td>
</tr>
<tr>
<td></td>
<td>Moving Faders as a Group</td>
<td>368</td>
</tr>
<tr>
<td></td>
<td>Rearranging Console Strips</td>
<td>371</td>
</tr>
<tr>
<td></td>
<td>Dragging Strips Horizontally</td>
<td>371</td>
</tr>
<tr>
<td></td>
<td>Dragging Plug-Ins Vertically (Acadia only)</td>
<td>372</td>
</tr>
<tr>
<td>39</td>
<td>The MMC Window</td>
<td>375</td>
</tr>
<tr>
<td></td>
<td>Setting up Your MMC Devices</td>
<td>375</td>
</tr>
<tr>
<td></td>
<td>Anatomy of the MMC Window</td>
<td>375</td>
</tr>
<tr>
<td></td>
<td>Real-World Example—Tascam DA-88</td>
<td>381</td>
</tr>
<tr>
<td>40</td>
<td>The QuickTime Movie Window</td>
<td>385</td>
</tr>
<tr>
<td></td>
<td>Referencing a QuickTime Movie</td>
<td>385</td>
</tr>
<tr>
<td></td>
<td>Opening the QuickTime Movie Window</td>
<td>387</td>
</tr>
<tr>
<td></td>
<td>QuickTime Movie Window Anatomy</td>
<td>387</td>
</tr>
</tbody>
</table>
Table of Contents

QuickTime Movie Window Menu .................................................. 389
Setting SMPTE Frame Rates for Multimedia Movies .................. 391
Working with SMPTE Offsets ........................................................ 392
Using the Movie Player Window .................................................... 393

PART SEVEN: Menus  395

CHAPTER 41:  The File Menu 397

New .................................................................................................... 397
Open (Command-O) ................................................................. 398
Close Window (Command-W) ..................................................... 400
Close All (Command-Option-W) .................................................. 400
Save (Command-S) ................................................................. 400
Save As ......................................................................................... 400
Save a Copy As ................................................................................. 401
Save as Setup .................................................................................... 401
Revert ................................................................................................. 402
Export as MIDI File (Option-X) .................................................. 402
Export to Clipboard ........................................................................ 403
Export as QuickTime Movie ....................................................... 403
Import Audio (Option-H) .......................................................... 403
Import Audio Using QuickTime ................................................ 403
Export Audio Mix ............................................................................. 403
Export Audio Events ....................................................................... 404
Page Setup ....................................................................................... 404
Print Preview .................................................................................. 404
Print (Command-P) ......................................................................... 404
Quit (Command-Q) ......................................................................... 404

CHAPTER 42:  The Edit Menu 405

Undo (Command-Z) .......................................................................... 405
Cut (Command-X) ............................................................................ 406
Copy (Command-C) ......................................................................... 407
CHAPTER 43: The Do Menu

Window Submenu .............................................................................417
Transpose (Command-T) .................................................................418
Quantize (Option-G) .........................................................................418
Modify (Command-Y) .......................................................................418
Reassign .............................................................................................418
Set Instrument (Command-I)...........................................................418
Substitute ...........................................................................................419
Select/Modify Templates .................................................................421
Quantize (Command-G) ...................................................................421
Select & Modify (Command-R) .......................................................421
Copy Patches (Option-C) ...............................................................421
Reverse Time.....................................................................................422
Scale Time..........................................................................................422
Change Tempo (Option-) ...............................................................422
Reclock ...............................................................................................422
Insert Bar Marker (Command-`) ....................................................422
Insert SMPTE Marker (Command-;)..............................................423
Play from Selection (Command-Space) ..........................................423
Play Selection (Option-Space) .......................................................423
The Select Submenu .........................................................................423
# Table of Contents

<table>
<thead>
<tr>
<th>Opcode Systems, Inc.</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select by Rule (Command-E)</td>
<td>423</td>
</tr>
<tr>
<td>Select All (Command-A)</td>
<td>424</td>
</tr>
<tr>
<td>Split Notes (Command-)</td>
<td>424</td>
</tr>
<tr>
<td>Select Duplicates</td>
<td>425</td>
</tr>
<tr>
<td>Nudge Submenu</td>
<td>425</td>
</tr>
<tr>
<td>Mute Submenu</td>
<td>426</td>
</tr>
</tbody>
</table>

## CHAPTER 44: The Setups Menu

<table>
<thead>
<tr>
<th>Feature</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Keyboard Thru</td>
<td>427</td>
</tr>
<tr>
<td>Thru in Background</td>
<td>427</td>
</tr>
<tr>
<td>Input Effect Enabled</td>
<td>428</td>
</tr>
<tr>
<td>Input Map Enabled</td>
<td>428</td>
</tr>
<tr>
<td>MIDI Keys Enabled</td>
<td>428</td>
</tr>
<tr>
<td>Fader Remotes Enabled</td>
<td>428</td>
</tr>
<tr>
<td>Record Quantize Enabled</td>
<td>428</td>
</tr>
<tr>
<td>Record Filter</td>
<td>429</td>
</tr>
<tr>
<td>Enable Input Devices</td>
<td>429</td>
</tr>
<tr>
<td>OMS Studio Setup</td>
<td>430</td>
</tr>
<tr>
<td>OMS MIDI Setup</td>
<td>430</td>
</tr>
<tr>
<td>Undefined Channels</td>
<td>431</td>
</tr>
<tr>
<td>Auto Remappings</td>
<td>432</td>
</tr>
<tr>
<td>Commands</td>
<td>432</td>
</tr>
<tr>
<td>Colors</td>
<td>432</td>
</tr>
</tbody>
</table>

## CHAPTER 45: The Options Menu

<table>
<thead>
<tr>
<th>Feature</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sync Options</td>
<td>433</td>
</tr>
<tr>
<td>Send Sync Enabled (Command-)</td>
<td>437</td>
</tr>
<tr>
<td>Click in Record (Option-{})</td>
<td>437</td>
</tr>
<tr>
<td>Click in Play (Option-)</td>
<td>437</td>
</tr>
<tr>
<td>Click in Countoff Only</td>
<td>437</td>
</tr>
<tr>
<td>Metronome Sound (Option-)</td>
<td>437</td>
</tr>
<tr>
<td>Countoff in Play</td>
<td>438</td>
</tr>
<tr>
<td>Stop at Punch Out</td>
<td>438</td>
</tr>
<tr>
<td>Real Time Capture</td>
<td>438</td>
</tr>
<tr>
<td>Local Sequence Times</td>
<td>439</td>
</tr>
</tbody>
</table>
CHAPTER 46: The Windows Menu 441

Sequences Window (Option-Q) .......................................................... 441
Tracks Window (Option-S) ............................................................. 441
List Window (Option-L) ................................................................. 441
Pulse Window (Option-D) .............................................................. 442
Graphic Window (Option-E) ........................................................... 442
Notation Window (Option-N) .......................................................... 442
Instruments Window (Option-I) ....................................................... 442
Audio Instruments (Option-J) .......................................................... 442
Select & Modify Window (Option-Y) .............................................. 443
Names Window (Option-P) ............................................................. 443
Input Map Window (Option-M) ....................................................... 443
MIDI Keys Window (Option-K) ....................................................... 443
Faders Window (Option-F) .............................................................. 443
Console Windows .......................................................................... 444
Control Bar (Option-A) ................................................................. 444
Counter .......................................................................................... 444
Record Monitor (Option-W) ............................................................ 444
Input Effect .................................................................................... 444
Players & Queue ............................................................................ 445
Settings .......................................................................................... 445
MMC ............................................................................................... 445
QuickTime Movie ........................................................................... 445

CHAPTER 47: The Help Menu 447

About Online Help (Command-/) .................................................... 447
MIDI Data Flow ............................................................................. 447
Vision Files .................................................................................... 447
Generated Sequences .................................................................... 447
Sequences and Segments ............................................................... 447
Pop-up Help ................................................................................... 448
All Notes Off (!) ............................................................................. 448

PART EIGHT: Index 449
PART 1: Introduction
WELCOME TO VISION

Congratulations on your purchase of Opcode’s Vision—a powerful and intuitive sequencer for both MIDI and digital audio. With it, you can record and arrange music using your computer, MIDI instruments, and digital audio hardware.

Vision offers a wide range of capabilities for editing and mixing your music. You can even preview and print songs using standard music notation.

This MIDI Reference Manual should be your starting point for learning about how to use Vision. In addition, it contains tutorial and reference material for all of Vision’s MIDI features.

Digital audio topics, on the other hand, are covered in the Audio Reference Manual, which should be read after reading this manual.

IMPORTANT: The MIDI and Audio Reference Manuals are identical for both Vision and Studio Vision Pro. For the sake of consistency, however, both manuals refer to the discussed application as “Vision” (except, of course, when referring to topics and features specific to Studio Vision).

Installation and System Requirements

The Vision Quick Start card is your guide to configuring your computer for Vision. If you haven’t already, please read it. It contains:

• Detailed system requirements;
• Installation and configuration steps for Vision and OMS;
• Answers to frequently asked questions.

Registering your Software

If you are a new user, please complete and return your registration card right away. Doing so will enable Opcode to deliver the best possible support to you; it also ensures you’ll receive important update/upgrade notices.

IMPORTANT: Please write down your Vision serial number here. The serial number is located on your original Master Key disk.

S/ N _______________________________
Purchase Date ______________________
Contacting Opcode

Opcode provides a variety of phone, fax, and online support options. Consult your Technical Support Information booklet on how best to contact Opcode.

HOW TO USE THIS MANUAL

If you are reading this manual, we have assumed the following:

• You have a basic understanding of the Macintosh and its operating system;
• Your music hardware is properly connected and configured;
• You have already successfully installed Vision and the Open Music System (OMS);
  Consult the Vision Quick Start card for installation details.
• You have created an OMS Studio Setup with the OMS Setup application;
  Vision uses OMS to communicate with MIDI devices. Those unfamiliar with OMS should read the OMS Manual.

Manual Organization

This book is divided into the following seven parts:

• Part 1: Introduction is what you’re reading right now. It details the layout of the manual, MIDI fundamentals, and some Vision basics.
• Part 2: Recording has chapters on recording in real time, step time, and also inserting notes with the pencil and magic drumstick.
• Part 3: Playback & Editing covers basic track and sequence controls, transposing and quantizing, and mixing and arranging.
• Part 4: Advanced Concepts contains chapters on some of the more exciting features in Vision like segments, generated sequences, and the Players & Queue Window.
• Part 5: Customizing Vision explains how to save configuration settings, store and recall various templates, create custom Instruments, and customize key commands and MIDIKeys.
• Part 6: Windows is a reference section that details every button, command and option in each of Vision’s windows.
• Part 7: Menus is a reference section that details all of Vision’s menu commands.

NOTE: Although digital audio features may be mentioned from time to time in this manual, they are not covered in depth. For complete information about digital audio, consult the Audio Reference Manual.
CHAPTER 1: Introduction to the MIDI Reference Manual

MANUAL CONVENTIONS

The Vision manuals use a number of conventions that make it easier to discuss and understand the program.

Mouse Actions

The following terms are used to describe various mouse actions:

• **Click**: When the manual instructs you to click, position the mouse where you’re told and press once on the mouse button, then immediately release it.

• **Double-click**: When the manual instructs you to double-click, position the mouse where you’re told and rapidly press and release the mouse button twice.

• **Press and hold**: When the manual instructs you to press and hold, position the mouse where you’re told, press the mouse button and hold it down until instructed to release it.

• **Release**: When the manual instructs you to release, let up on the mouse button (which you were probably holding down because of an earlier press and hold instruction).

• **Drag**: When the manual instructs you to drag, position the mouse where you’re told, then press the mouse button and hold it down as you move the mouse.

• **Move**: When the manual instructs you to move the mouse, simply move it to another location on the screen without pressing its button.

Choose vs. Select

The words “choose” and “select” are often interchangeable in conversational English. In this manual, however, there is a distinction between the two terms.

• **Select**: When the manual tells you to select something, it stays selected. This is the case with menu options that turn something on/off.

• **Choose**: When the manual tells you to choose something, a one-time action is performed. This is the case with most commands; they perform their chosen action only once.

Menu Items

This manual uses a shorthand technique to invoke various menu items. For instance, this manual might say:

“Select Audio>Waveform Display>Fast.”

What this means in plain English is “select the Fast option from the Audio menu’s Waveform Display submenu.” Although the shorthand technique results in sub-standard grammar, it’s easier to read and decipher than a complete sentence because it displays the menu’s hierarchical structure plainly and simply.

![Figure 1.1: Shorthand Invocation of Menu Items](image)

CHAPTER 2: About MIDI

Before we start talking about Vision and its capabilities, we will first touch briefly on some MIDI fundamentals. Those already familiar with these topics can skip ahead to Chapter 3: Vision Basics.

In addition to MIDI, Vision can of course record digital audio. For a discussion of digital audio basics, see your Audio Reference Manual.

WHAT IS MIDI?

MIDI (an acronym for Musical Instrument Digital Interface) is a communication protocol for musical instruments. This industry standard enables connections between a variety of devices from different manufactures. MIDI compatible equipment includes synthesizers, sound modules, drum machines, patch bays, effects processors, MIDI interfaces, and sequencers.

MIDI devices are equipped with 5-pin DIN connectors, labeled as either IN, OUT, or THRU.

![Figure 2.1: MIDI connectors](image)

The MIDI OUT port transmits messages; the MIDI IN port receives messages; and, MIDI THRU echoes whatever is received from the IN port. MIDI devices are connected via “MIDI cables,” readily available at most music stores.

NOTE: Not all devices will have all three MIDI ports (IN, OUT and THRU).

A single MIDI cable can transmit a separate set of messages for each of 16 channels. These 16 channels correspond to separate MIDI devices or to multiple channels within a single device (if the device is multi-timbral). Fundamentally, each channel represents a discreet instrument sound; for instance, bass on channel 1, piano on channel 2 and drums on channel 10. Similar to a multitrack tape recorder, a MIDI sequencer can therefore record complex arrangements—even using a single multi-timbral keyboard.
MIDI Terminology

Basic MIDI terminology is used throughout this manual. If necessary, take a moment to familiarize yourself with the following terms:

• **MIDI Interface**: Hardware that allows computers to connect to and communicate with MIDI devices.

• **MIDI Device**: Any keyboard, sound module, effects device or other equipment that can send or receive MIDI information.

• **MIDI Controller**: Any MIDI device that transmits MIDI performance data. These include keyboards, MIDI guitar controllers, MIDI wind instruments, and others. Controllers transmit MIDI via their MIDI OUT ports.

• **MIDI Sound Source**: Any MIDI instrument that plays back in your arrangements. Sound sources receive MIDI from their MIDI IN ports.

• **Multi-timbral**: The capability of playing several different instrument sounds (i.e. piano, bass, and drums) simultaneously on separate channels. This makes it possible for a single MIDI sound source to play back entire arrangements.

• **MIDI Channel**: Up to 16 channels of MIDI performance data can be transmitted on a single MIDI cable. The channel number separates the different messages so your sound sources can receive the right ones.

• **Program Change Event**: A MIDI command that tells a sound source which sound patch to use. The MIDI protocol lets you choose from a range of 128 patches.

• **Bank Select Message**: A MIDI command that specifies the bank of patches from which to choose. Many devices have more than 128 patches and Bank Select messages provide a means of accessing them.

• **Local Control**: A controller setting found on most MIDI keyboards that allows it to play its own sound source. Disabling “local control” ensures that a device’s internal sound source is only played via external MIDI messages.

When using Vision, “local control” should be disabled. When “local control” is off, your keyboard still transmits data to its MIDI OUT port.

• **Continuous Controller Events**: MIDI instructions that allow real-time changes to notes that are currently sounding. These include pitch bend, modulation, volume, pan, and many others.

• **System Exclusive Data**: MIDI data commonly used for sending and retrieving patch parameter information for storage purposes.
Common Misconceptions about MIDI

It is important to understand that MIDI is not audio. The messages that travel down a MIDI cable are only numbers that translate to specific instructions. For instance, when you strike a key on your MIDI keyboard it sends a message to its MIDI OUT port telling another device (if connected and set to the same MIDI channel) to play that particular note.

However, in order to actually hear that second device (sound source) you’ll need to connect its audio outputs to a sound system. Your MIDI instruments therefore have two signal paths, one for audio and another for MIDI.

Another point to note is that MIDI does not allow you to use your devices beyond their capabilities; instruments have their own sound generation, polyphony, and multi-timbral limitations.
CHAPTER 3: Vision Basics

THE OPEN MUSIC SYSTEM (OMS)

To use Vision you must first install and configure the Open Music System (OMS). OMS, which is included with your Vision package, has the following capabilities:

- OMS keeps track of which MIDI devices you are using, how they are connected, and which patches (sounds) they are using;
- OMS makes it easy for music software to communicate with your MIDI hardware;
- OMS provides timing services and inter-application communication.

OMS stores a description of your MIDI studio in Studio Setup documents, which are created and edited in the OMS Setup application. Once OMS is configured, using Vision is quite seamless. Any devices contained in your Studio Setup are automatically available as Vision Instruments. If at some point you make changes in your current Studio Setup, Vision, and any other OMS applications, are updated.

It's very important that you have a clear understanding of OMS before attempting to use Vision. If you are new to Vision, and OMS, please read the OMS Manual included with your Vision package.

TRACKS

The most basic building block in Vision is a track. In addition to digital audio, tracks can record and play back a variety of MIDI data such as notes, aftertouch, pitch bend, modulation wheel, continuous controller events, patch changes, and system exclusive information.

Each of Vision's 99 tracks (per sequence) has its own track length and may be independently looped. Track's are viewed and edited in Vision's five edit windows: Tracks, Pulse, Graphic, Notation and List (see page 14).

Drum Tracks

Drum tracks are specially defined Vision tracks that are edited in the Pulse Window. A drum track is comprised of individual note lines that correspond to particular notes or drum sounds (i.e. bass drum, snare, hi-hat).
PART 1: Introduction

Instruments

Tracks are assigned to and play back via MIDI and Audio Instruments. Vision’s MIDI Instruments are automatically created from the current OMS Studio Setup. Audio Instruments, on the other hand, are based on your digital audio hardware.

NOTE: Tracks can contain data assigned to more than one Instrument. These tracks are referred to as “Multi” tracks.

NOTE: For drum tracks, each of its note lines can be assigned to a different MIDI Instrument.

Patch Names

An Instrument’s current patch determines the type of sound it plays. Using OMS Name Manager, Instruments can be subscribed to Patch Name documents; this lets you view and select patches, notes, and controllers by name instead of number.

You can get names from the Factory Names files included with OMS, Galaxy Bundles, or you can create your own custom (typed-in) Patch Name documents (see Chapter 33: The Names Window).
CHAPTER 3: Vision Basics

SEQUENCES

Vision records tracks into sequences, each of which can be thought of as a song, song section, or music layer. A Vision file can contain hundreds of sequences (limited only by the amount of RAM you have). Each sequence has its own name, length, meter, key, and tempo. Sequences can be triggered in real time from your computer keyboard or from a MIDI controller.

Arranging Sequences

Sequences can be chained together and layered to create song structures. Sequences are called from other (parent) sequences with sequence events. Sequence events describe how to play the referenced sequence from the parent sequence.

Segments and Loops

Tracks or portions of tracks can be made into segments, which are very similar to sequences. Segments provide a great way to turn existing track material into modular components that can be played from other sequences.

With segments you can loop any region of a track, and these regions can loop independently of the track’s loop setting—thereby creating a “nested loop.”

THE CONTROL BAR

Vision’s Control Bar acts as the control center for a host of commonly used functions. This section will briefly acquaint you with some of the more important Control Bar items.

For a complete and thorough explanation of the Control Bar, see Chapter 23: The Control Bar.

The Control Bar has traditional transport controls for play, stop, record, pause, fast-forward and rewind. In addition, there are 8 locator buttons for storing frequently accessed Counter locations.

PART 1: Introduction

The Counter provides feedback for the measure and SMPTE location of the current sequence. You can click in the Counter and type in a precise location to automatically locate there.

Figure 3.3: Counter in Control Bar

The left portion of the Control Bar (see Figure 3.4) contains a number of pop-ups related to where and how information is recorded. The Record Mode specifies whether Vision replaces or overdubs material, and whether recording is done in real time or step time. The Current Sequence and Current Track pop-ups determine where the data is recorded; and the Thru Instrument and Current Patch indicate the assigned Instrument and patch.

Figure 3.4: Control Bar pop-ups

In addition to acting as graphic labels, the buttons located to the left of the pop-ups in Figure 3.4 open an appropriate window when clicked. These buttons open the Record Monitor ( ), Tracks Window ( ), Graphic Window ( ), Instruments Window ( ), and Names Window ( ).

Figure 3.5: Punch and Loop controls in Control Bar

The Punch and Loop controls in Figure 3.5 determine the range of measures used when either punch or loop recording.

Figure 3.6: Window Buttons in Control Bar

THE EDIT WINDOWS

Vision has five edit windows, each of which has special capabilities suited for certain tasks. This section briefly touches on each of these windows.

For a complete and thorough description of Vision's edit windows, consult the chapters in Part 6: Windows.
The **Tracks Window** lists all tracks in a given sequence. In addition to having a variety of sequence and track controls, the Tracks Window also contains a “Track Overview” area for displaying individual track data.

The **Pulse Window** has a rhythmic-based “Note Grid” display for viewing and editing a sequence’s drum tracks.

The **Graphic Window** shows notes from a single track using a “Piano Roll” style of display.

The **List Window** displays all data contained in a single track using text and numbers. This window is great for precise editing over each MIDI event. The List Window displays every event contained within a track.

Notes are inserted in the Graphic Window with the Pencil tool. Notes can also be dragged to a new pitch or location, and even made longer or shorter.

List Windows are also used to display and edit Meter and Tempo tracks.
The **Notation Window** displays and edits multiple tracks with standard musical notation. From this window you can open the Print Preview Window, where tracks are prepared for printout.

![Notation Window](image)

**The Strip Chart**

Each of the graphic based edit windows (Tracks, Pulse, Graphic and Notation) has an option called the Strip Chart. The Strip Chart, which is very similar to a “bar graph” display, works with data that is in most cases not related to notes.

![Strip Chart](image)

Use the Strip Chart to insert and edit the following data types:

- Continuous events such as controllers, pitch bend, after touch, and tempo;
- System exclusive information;
- Patch change events;
- Note velocities and durations (edit only);
- Various forms of text.

**VISION ON-SCREEN HELP**

A useful tool for quickly learning about a feature in Vision is its online, context sensitive help. Just hold down the Command, Shift and Option keys and click on any field, button, icon or menu item for pop-up help on that item.

**NOTE:** Additional help items are available from Vision’s Help menu.

For instance, to get help on Vision’s Begin Record toggle:

1. **Hold down the Command, Shift and Option keys.**
2. The help cursor appears

![Help Cursor](image)
Position the cursor over the Begin Record toggle and press and hold.

A pop-up help screen for the Begin Record toggle appears.
CHAPTER 4: Navigating in Vision

This chapter discusses user-interface capabilities unique to Vision. Like most Macintosh applications, Vision’s windows contain scroll bars to navigate through data, and fields into which you can type new values. However, Vision also offers a number of flexible ways to navigate its various windows, select and organize data types (like sequences, tracks, and Instruments), and enter new values into edit fields.

Since these user-interface techniques are referred to frequently throughout this manual, you should familiarize yourself with them now.

NAVIGATING WINDOWS, SEQUENCES, AND TRACKS

Sequence and Track Select Pop-ups

When using Vision, you’ll often want to switch to working with another sequence or track. Rather than opening a new edit window each time, you can use the Sequence and Track Select pop-ups to easily switch the current sequence or track. These pop-ups are accessed by Option-clicking on the title bar of the desired edit window.

Switching the Current Sequence

To switch the current sequence from the Tracks or Pulse Window:

1. Hold down the Option key and click in the title bar of the Tracks Window. The Sequence Select pop-up appears.

2. Highlight the desired sequence and release the mouse.

A Tracks Window for the selected sequence replaces the previous one.
NOTE: When switching the current sequence with the Sequence Select pop-up, the newly opened Tracks or Pulse Window uses the display properties (window size, location, zoom value, etc.) stored with that sequence.

Switching the Current Track

The Track Select pop-up in the Graphic and List Windows works in similar fashion as the Sequence Select pop-up—only it switches the current track, rather than the current sequence.

NOTE: Unlike the Sequence Select pop-up, the Graphic and List Windows retain their display properties when selecting a track from the Track Select pop-up.

To add a new track from the Graphic and List Windows, choose **New Track** from the Track Select pop-up.

In the List Window, you can also use this pop-up to switch to the Meter or Tempo tracks.

---

Figure 4.1: Option-click the title bar of the Graphic and List Windows to switch the current track

Figure 4.2: Specifying a “New Track” from the Track Select pop-up in the Graphic Window

Figure 4.3: Using the Track Select pop-up to switch to the Tempo track in the List Window
CHAPTER 4: Navigating in Vision

Showing and Hiding Tracks in the Notation Window

The Track Select pop-up works a little differently in the Notation Window. Although it’s invoked in the same way, it instead adds or hides tracks to the display—as opposed to merely changing the current track.

![Figure 4.4: Option-click the title bar of the Notation Window to show and hide tracks]

Currently displayed tracks are shown as checked in the Track Select pop-up. To hide a displayed track, select it from the pop-up. When just one track is displayed, it appears as grayed out—you cannot have a Notation Window with no tracks.

To change the order of tracks in the Notation Window, rearrange them in the Tracks Window (see The Move Cursor (pg. 22)).

Open Windows Pop-up

The Open Windows pop-up lists all currently open windows. Choose any window title from this pop-up to bring that window to the front. The Open Windows pop-up is available at any time, anywhere in Vision:

1. Hold down the Command and Option keys and click in any Vision Window. The Open Windows pop-up appears.

   ![Synth Tracks](MMC Console 1 my song Intro MIDI Instruments Controls]

2. Highlight the desired window title and release the mouse. The specified window becomes activated and moves to the front.
SELECTOR DOTS AND MOVE CURSOR

Items in the Sequences, Tracks, Pulse, and Instruments Windows are highlighted with selector dots, and moved with the move cursor.

Selector Dots

When you need to select a sequence, track, drum note line, or Instrument, click on its selector dot in the left column of the window. A selected dot changes into a triangle and the item becomes highlighted.

The Move Cursor

When placed to the left of the selector dots, the cursor changes to a move cursor (↑). When the move cursor appears, click and drag up or down to move the item to a new location.

Repositioning items does not change your MIDI information—it only changes the position of your tracks, sequences or Instruments in their respective windows.

NOTE: Changing the position of tracks in the Tracks Window also changes their relative positions in the Notation and Print Preview Windows.

If more than one item is selected, you can drag them all to the new location while keeping their relative order.
MOVING AND RESIZING COLUMNS

Columns in the Sequences, Tracks, and Pulse Windows can be re-ordered and resized. This allows you to rearrange these columns as desired, using window and screen space more efficiently.

For instance, to resize the Instrument column in the Tracks Window:

1. Place the cursor in the column head near the line separating Instrument and Patch.
   The cursor turns into the resize cursor.

2. Click the mouse and drag to the left.
   An outline of the Instrument column's right side appears and moves left with the cursor.

3. When the Instrument column reaches the desired size, release the mouse.
   The Instrument column is resized to the new size and the columns to its right are adjusted accordingly.

To move the Key column in the Sequences Window:

1. In the Sequences Window, Option-click at the top of the Key column and drag to the left.
   An outline of the Key column appears and moves to the left with the cursor.

2. When the space to the right of the MIDI column becomes highlighted, release the button.
   The Key column moves to the new location and the MIDI column moves to the left to accommodate it.
PART 1: Introduction

ZOOMING, SCROLLING, AND SCRUBBING

Zooming

“Zooming” lets you view your music in different sizes. At small sizes, you can fit more music in an edit window. At large sizes, you can view your data in greater detail.

Depending on the particular zoom tool, you can zoom horizontally, vertically, or a combination of the two. Zooming out horizontally lets you see more bars; zooming out vertically lets you see more of the MIDI pitch range.

Zoom tools in Vision include the horizontal and vertical Zoom Buttons, located near the window scroll bars, and the Zoom to Fit button, located in the top of each edit window. You can also Option-click with the mouse for various zooming functions. Each of these is explained in the following sections.

NOTE: In addition to the zoom tools, the edit window menus have commands for **Zoom Back** (which recalls the previous zoom level) and **Zoom to Fit** (which views the entire contents of the edit window).

Zoom Buttons

- Click the **Zoom In** buttons (horizontal or vertical) to zoom in incrementally. Use Option-click to zoom all the way in, Shift-click to fit the current selection.
- Click the **Zoom Out** buttons (horizontal or vertical) to zoom out incrementally. Use Option-click to view the window’s entire contents, Shift-click to fit the current selection.

Zoom to Fit Button

- Click the **Zoom to Fit** button to fit the current selection in the active edit window. Option-click this button to view the entire track’s contents (or, in the case of the Tracks or Pulse Window, the entire sequence).
Zooming with the Mouse

Option-dragging a selection

- Option-click with the mouse to zoom out incrementally, or Option-drag around a selection to view it in more detail.
- Option-click in the ruler to zoom out horizontally, or Option-drag a section of the ruler to zoom into a range of measures.

Hand Scrolling

In the Graphic and Notation windows, you can change which part of the window is displayed by Shift-Option-dragging. This is helpful when you want to center a selection for better viewing.

To scroll with the hand cursor:

1. In the Graphic or Notation Window, position the cursor over the desired display area and hold down the Shift and Option keys.
   The hand cursor appears.

2. Click and drag the window’s contents to the desired position, then release the mouse.

Option-click in the left-margin to zoom out vertically, or Option-drag a section in the left margin to zoom a range of notes.
Auditioning with the Scrub Command

In the Tracks, Pulse, Graphic, and Notation Windows, you can Command-drag over a selection to audition it. This is commonly referred to as “scrubbing.”

To scrub a range of music:

1. Position the cursor in the edit area of one of the edit windows and hold down the Command key.
   The scrub cursor appears.

2. Click and drag the mouse (forward or backward) over the desired music.
   A vertical line appears, indicating which notes are auditioned.

Figure 4.16: Scrubbing with the mouse

Vision plays the data as the mouse “scrubs” over the notes. To play more slowly or quickly, vary the speed of the mouse movements.

USING WINDOW MENUS

In addition to the menus accessed in the menu bar at the top of the screen, Vision also uses specialized window based menus. These menus are accessed by clicking the small triangle located in the left side of the title bar (see Figure 4.17).

Figure 4.17: Menu in Sequences Window

The first item in the Do menu always lets you access the window menu for the active window. For example, when the Sequences Window is active, choose Do>Sequences Window> for a submenu of the commands located in the Sequences Window menu.

Figure 4.18: Sequence Window commands accessed from the Do menu

For more information on the Do menu, see Chapter 43: The Do Menu.
EDITING DIFFERENT FIELD TYPES

There are a number of different field types in Vision, each of which is edited differently. The track fields in the Tracks Window (see Figure 4.19) are a good example of this.

![Figure 4.19: Track fields in Tracks Window](image)

The track name column is a text field. To edit text fields, simply click in them and type.

![Figure 4.20: Track name column in Tracks Window](image)

The track length field is an example of a numerical field. Like a text field, it too can be edited by typing a new value. But numerical fields can also be changed by clicking and dragging up or down with the mouse; or to increment the value in single steps, you can click just once when the cursor changes to an up or down arrow; the “+” and “-” keys also work to increment and decrement the value.

![Figure 4.21: Track Length column in Tracks Window](image)

The track Instrument field is changed by choosing from a pop-up menu of choices. Click in the field and hold down the mouse for the menu to appear, then highlight the desired item and release the mouse. You can also use the “+” and “-” keys to scroll through choices in the pop-up menu, or you can type a number corresponding to a particular Instrument.

![Figure 4.22: Instrument column in Tracks Window](image)

NOTE: A shortcut for using the pop-up menu in the Patch column is to click in the field and then type the first few letters of the actual patch name (followed by Enter).

Changing Values with a MIDI Controller

In some cases you can highlight a MIDI value (such as a MIDI note or velocity values) and use your MIDI keyboard to enter a new value. This works well, for instance, for editing values in the List Window, defining MIDI events in the MIDIK ey Window, or when configuring the notes for the Metronome Sound.

![Figure 4.23: Metronome Sound settings](image)
PART 1: Introduction

To adjust the Velocity setting for the Metronome Sound, simply click in the field with the mouse and play a note on your MIDI controller. The field is automatically updated with the velocity played.

Editing Fields for Bar/Beat/Unit and SMPTE

Some fields in Vision require that you specify a location in either bar/beat/unit or SMPTE values. You can automatically enter a value in these fields based on a marker location.

NOTE: Markers, which reside in a sequence’s Meter track, are stored locations that can be recalled by name.

The following example shows how to define the Out Point using a marker location:

1. Option-click the Out Point field.

A pop-up menu of marker locations appears.

2. Select the desired marker and release the mouse.

The location for the selected marker is automatically entered into the Out Point field.

Typing into the Time Fields

Depending on the configuration in the Settings Window (see Clear Beat/Unit when Entering Bar (pg. 333)), typing into a field for bar, beat, hours, minutes, or seconds clears all fields to the right. See Figure 4.24.

Figure 4.24: Typing a new value in a time field on the left, clears all fields to the right

To avoid this, uncheck the option for Clear Beat/Unit when Entering Bar in the Settings Window. You can then type into any of the time fields and the others to the right remain unaffected.
CHAPTER 5: Real-Time Recording

Although this chapter focuses primarily on recording MIDI data in real time, it also covers basic recording topics relevant to recording in step time. Therefore, please read this chapter completely before moving on to Chapter 6: Inserting and Step Recording Notes.

RECORD SETUP

The following sections discuss a number of Vision record options you should be familiar with before attempting to record your tracks.

Record Mode

Vision’s Record Mode determines how track material is recorded.

The four available record modes, chosen from the Record Mode pop-up in the Control Bar, include:

- **Replace**: Records in real time, replacing existing track data.
- **Overdub**: Records in real time, adding to existing track data.
- **Step Replace**: Records in step time, replacing existing track data.
- **Step Overdub**: Records in step time, adding to existing track data.

**KEY EQUIVALENTS**: Type Shift-Tab to toggle between Real-time and Step recording; use Shift-5 to switch between Replace and Overdub.

**NOTE**: Step recording is a process where MIDI events are recorded individually, one step at a time. For details, see Chapter 6: Inserting and Step Recording Notes.

With Replace or Overdub, you can use loop recording (see page 35) or punch recording (see page 34). You can also use punch recording when step recording.
PART 2: Recording

Begin Record Toggle

The Begin Record toggle, located in the Control Bar, specifies how Vision starts recording. It's two options are:

- **Wait for Note**: Recording begins when the first MIDI note is received. This method ensures that you begin recording when you're ready to play, and that the first note is recorded at the precise beginning of the section.

  ![Figure 5.2: Wait for Note](image)

- **Countoff**: Recording begins after the Counter counts the number of bars specified in the Countoff field.

  ![Figure 5.3: Countoff with a setting of 2 bars](image)

Metronome Sound and Setup

In order to stay in time with the sequence's tempo setting, you must listen to the metronome while recording. This ensures that recorded material aligns with the bar and beat lines in Vision, which is very important for display and editing purposes.

To configure the metronome sound, choose **Options > Metronome Sound**. In the Metronome Sound dialog, set the metronome to either "Internal Click" or "MIDI Note." When using MIDI Note, you can have independent Note, Velocity and Duration settings for the accented and unaccented beats.

![Figure 5.4: Metronome Sound dialog](image)

Enable the **Click in Record** option so the click is heard while recording.

Meter and Tempo in Sequence

Although this may seem obvious, you'd be surprised how often this detail is overlooked. Before attempting to record you should make sure the sequence's meter and tempo are set appropriately. For information on settings these fields, see Chapter 25: The Tracks Window.

![Figure 5.5: Meter and tempo tracks](image)

If the meter does not match the music you're recording, the accented clicks of the metronome won't line up with what you're playing. In addition, the recorded material won't align with the bars and beats in Vision's edit windows.

And, to achieve good track recordings (with the right feel), it's always wise to record at or around the tempo that will eventually be used for the sequence.
CHAPTER 5: Real-Time Recording

More Miscellaneous Record Setup Details

Before moving on to the first recording example, there are just a few more details worth mentioning:

- **Keyboard Thru**: Make sure Setups>Keyboard Thru is enabled. It routes data from your MIDI controller to the current Thru Instrument, thereby allowing you to monitor what's being recorded. See Keyboard Thru (pg. 427).

- **Input Map Enabled**: Unless you're recording or routing multiple MIDI channels, make sure Setups>Input Map Enabled is not checked. See Chapter 34: The Input Map Window.

- **Record Quantize Enabled**: Uncheck this item in the Setups menu, unless you want your tracks quantized automatically when recorded. See Record Quantize Enabled (pg. 428).

- **Record Filter**: If you don't want certain types of MIDI events recorded, choose Setups>Record Filter to open this dialog—it specifies which MIDI events are recorded and which are ignored. See Record Filter (pg. 429).

- **Enable Input Devices**: Choose Setups>Enable Input Devices to open this dialog. Make sure to enable (check) any devices from which you will record MIDI data. See Enable Input Devices (pg. 429).

RECORDING A TRACK

This section explains how to record a track in real time with Replace mode. In this example, the track will be recorded from the beginning of the sequence without looping. Loop and punch recording are discussed later in this chapter, see Punch Recording (pg. 34) and Loop Recording (pg. 35).

To record a track in real time with Replace mode:

1. **In the Control Bar, select Replace from the Record Mode pop-up.**

2. **Use Replace to record over existing track material (replacing it), or use Overdub to add new material without replacing existing track contents.**

3. **For this example, disable the Punch and Loop toggles in the Control Bar.**

4. **In the Control Bar, set the Begin Record toggle to Wait for Note.**

   This ensures you'll begin recording precisely on bar 1, beat 1.

5. **Configure the Metronome Sound and set it to Click in Record.**

   See Metronome Sound and Setup (pg. 32) for details.
PART 2: Recording

5 Record-enable a track from the Tracks Window.
To do this, click in the Record column for the desired track.

6 Make sure Setups>Keyboard Thru is checked.

7 In the Control Bar's Thru Instrument pop-up, select the desired Instrument.

Play a few notes on your MIDI controller to verify data is routed to the selected Instrument.

8 Click the Record button in the Control Bar, or type the Tab key.

The metronome starts to click and the Record button flashes. If necessary, adjust the Sequence's Tempo setting.

9 Play some notes on your MIDI controller.
Vision enters record mode and the counter advances. When done, click the Control Bar's Stop button, or hit Return.
The record track is automatically named and assigned to the Thru Instrument. Any recorded data appears in the Track Overview section of the Tracks Window.

PUNCH RECORDING

Like on a tape deck, punch recording allows you to record only during a specified time range. Punch recording, often called “punching,” can fix an otherwise good performance by replacing only the bad material.

To enable punching, click the Punch toggle in the Control Bar. The punched region is defined by the In Point and Out Point.

The following example shows how to punch in and replace the material in measure 5:

1 In the Control Bar, set the Record Mode pop-up to Replace.
This ensures that the previously recorded material in measure 5 is replaced.
NOTE: Punch recording does function in Overdub mode. Use it to overdub material in the middle of a track.

2 Enable the Punch toggle in the Control Bar.
Set the In Point to 5¥1¥0 and the Out Point to 6¥1¥0.

To set the In/Out Points, click in each field and type in the desired location.

Make sure the Begin Record toggle is set to Countoff.

Using Countoff lets you hear the measures leading up to the In Point, thereby allowing for a smooth transition into recording the punch.

Record-enable a track and set the Current Thru Instrument.

Click the Record button to begin recording.

The sequence begins playing from the Countoff. The Record button flashes until the In Point is reached.

When the sequence nears the In Point, begin playing.

It is often helpful to play along during the Countoff period. Don’t worry though, material played before the In Point is not recorded.

Click the Stop button when you are finished recording.

If you want Vision to automatically stop playing at the Out Point, select (check) Options>Stop at Punch Out.

LOOP RECORDING

When loop is enabled, Vision plays continuously from the In Point to the Out Point. To enable looping, click the Loop toggle in the Control Bar.

You can record with loop enabled, building track data by adding more and more layers. The Thru Instrument and record track can even be changed “on the fly” while recording. While recording, material is saved by typing the Enter key, or discarded by typing the Delete key.

The following example shows how to configure Vision to loop record bars 1-2:

In the Control Bar, set the Record Mode pop-up to either Replace or Overdub.

In Replace mode, any data contained in the track before recording is erased. Anything recorded is not replaced when the sequence “loops around.”

Enable loop mode by clicking the Loop toggle in the Control Bar.
PART 2: Recording

3. Set the In Point to 1•1•0 and the Out Point to 3•1•0.

To set the In/Out Points, click in each field and type in the desired location.

4. Record-enable a track and set the Current Thru Instrument.

5. Click the Record button or type the Tab key to begin recording.

6. Begin playing when ready, you can jump in at anytime.
   Each time the sequence loops, the previously recorded material plays.
   When the sequence "loops" you will hear what you just recorded.

7. When satisfied with your performance, type the Enter key on your computer keyboard to keep the material.
   Vision continues loop recording.

8. To discard recorded material, type the Delete key.
   Vision erases everything recorded since the last time the Enter key was typed.

9. To change the record track, select from the Current Track pop-up in the Control Bar.
   You can also type Command-Shift-↑ to enable recording on the previous track, or Command-Shift-↓ to enable recording on the next track.

10. To change Instruments, select from the Thru Instrument pop-up in the Control Bar.

11. Repeat the above steps until you have recorded the desired performance. When finished recording, click the Stop button in the Control Bar.
CHAPTER 6: Inserting and Step Recording

Notes

In addition to recording in real time, Vision offers a few other ways of getting notes into tracks. This chapter discusses some of these other methods, which include inserting notes with the Pencil in the Graphic and Notation Windows, inserting notes with the Magic Drumstick in the Pulse Window, and step recording.

THE PENCIL TOOL

Use the Pencil tool to insert notes in the Graphic and Notation Windows. This allows note entry without a MIDI controller.

The duration and velocity of inserted notes is specified in the Insert Notes section of the Settings Window (see page 331). You can automatically go to these settings by double-clicking the Pencil tool from the Graphic and Notation Windows.

In the Graphic Window, notes can be “drawn” with variable durations by Shift-dragging in the edit area.

Before moving on to some tutorials, you should first become acquainted with Cursor Quantize and Cursor Display—toolbar items found in the graphic based edit windows.

Cursor Quantize restricts cursor movement to a specific rhythmic value. This allows for precise data selection, edit operations, and placement of inserted notes. To turn on Cursor Quantize, simply click on its icon—to turn it off, click it again. Choose from the Cursor Quantize pop-up to specify the rhythmic value.

The Cursor Display provides feedback for the current cursor position. When the cursor is moved into an edit area, the Cursor Display shows both pitch and location. Location can be displayed in bar/beat/unit or SMPTE (specified in the edit window’s menu), or click on the display toggle ( ) to show both time formats.
Inserting Notes in the Notation Window

Following is an example of entering a simple arpeggio of notes in the Notation Window:

1. Select a track in the Tracks Window and choose Windows>Notation.
   The Notation Window opens.
2. Double-click the Pencil tool to open the Insert Note section of the Settings Window.
   Set the Duration pop-up to Independent with a value of 8th notes (240 units). Set the Velocity value to 64.
3. Close the Settings Window.
4. In the Notation Window, turn on Cursor Quantize with a value of 8th notes.
5. Click on the Pencil icon to select it.
   The cursor changes to a note with a length corresponding to the Duration value in the Settings Window.

6. Enter a note of C3 on beat 1 of bar 1.
   If you’re unsure about the placement, watch the Cursor Display. When it reads as in Figure 6.1, click the mouse (you can drag the note into the correct position before releasing the mouse).

   ![Figure 6.1: Cursor Display](image)

   The note is entered as in Figure 6.2. The remaining portion of the measure is automatically filled with rests.

   ![Figure 6.2: Entered Note](image)

7. Next enter a note of E3 by clicking directly on the rest next to the first note—this will ensure it’s correct placement.
   With each new note entered, move the cursor to the right so the note is placed on the next 8th beat.

   ![Figure 6.3: Entered notes](image)

   Continue entering each note until your measure looks like Figure 6.3.
Painting Notes in the Graphic Window

Notes can also be inserted with the Pencil in the Graphic Window. One advantage of using this window is that you can Shift-click and drag to “paint” in notes of any duration:

1. **Select a track in the Tracks Window and choose Windows>Graphic.**
   The Graphic Window opens.

2. **Click the Pencil icon to select it.**
   The cursor changes to a note with a length corresponding to the Duration value in the Settings Window.

3. **Position the note cursor in the edit area at the desired pitch and location.**
   If necessary, use the Cursor Display to verify the desired note placement.

4. **Hold down the Shift key and click and drag to the right.**
   Release the mouse when the note is the desired duration.

When entering notes in this fashion, the parameters in the Insert Note section of the Settings Window are almost completely irrelevant, since the duration is determined “on the fly.” The only Insert Note parameter that is used is the **Velocity** setting.

**NOTE:** The placement and duration of Shift-clicked notes is also affected if Cursor Quantize is enabled. The entered notes will snap to the location and duration as specified by the Cursor Quantize value pop-up.

Click-Dragging to the Correct Pitch and Location

When using the Pencil tool, you can drag a note to the correct location and pitch even after you’ve clicked (so long as the mouse button has not been released). This is very useful because you can actually see the note’s placement within the Graphic or Notation Windows:

1. **From either the Graphic or Notation Window, select the Pencil tool and move the cursor over the edit area.**

2. **Click and hold the mouse button while dragging vertically and/or horizontally.**
   Release the mouse button once the desired pitch and location are found.
If necessary, use Cursor Feedback to verify the precise placement of the note.

**THE MAGIC DRUMSTICK TOOL**

Vision's Pulse Window provides an intuitive environment for creating and editing drum tracks (see Chapter 26: The Pulse Window). The Magic Drumstick tool is used to insert and delete notes in the Note Grid area of the Pulse Window.

The Magic Drumstick works as a toggle for inserting and deleting notes. Notes are entered by clicking in an empty grid space. To remove an existing note, simply click on it with the Drumstick.

A series of notes can be entered, or removed, by clicking and dragging with the Drumstick. The spacing, duration and velocity for the entered notes is taken from the Insert Note settings in the Settings Window (see page 331).

Figure 6.5: Drag-entering with Magic Drumstick

**Building a Drum Track**

Following is a short example of how to build a drum track using the Magic Drumstick:

1. Choose Windows>Pulse.
   The Pulse Window opens.

2. Choose New Drum Track from the menu in the Pulse Window.
   A new drum track, containing just one note line, is added to the sequence and is displayed in the Pulse Window.

3. Use the Note and Instrument pop-ups to specify the note line’s drum sound. For this note line, use a bass drum sound.

   You can view and select notes by name if you’re subscribed to a Patch Names document that contains note names.

4. Click the Add button to add another note line to the drum track.
Use the Note and Instrument pop-ups to assign a snare sound to the new note line.

<table>
<thead>
<tr>
<th>Note</th>
<th>Instrument</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bass 1</td>
<td>SnareDrum</td>
</tr>
<tr>
<td>Note4</td>
<td>SnareDrum</td>
</tr>
</tbody>
</table>

5. Set the Pulse Window’s **Display Mode** pop-up to **Matrix** with a value of **16ths**.

   ![Matrix Display](image)

   This specifies the number of grid lines and spaces displayed per measure.

6. Double-click the Drumstick tool to open the Insert Note settings.

   ![Insert Note Settings](image)

   Set the Duration pop-up to **Percent of Spacing** with a value of **100**. Set the Velocity value to **64**.

7. Choose a value of **16ths** from the pop-up next to the Drumstick.

   ![16ths Pop-up](image)

   This pop-up corresponds to the Spacing parameter in the Insert Note section of the Settings Window.

8. Select the Magic Drumstick tool and click in notes on beats 1 and 3 for the “bass drum” line; then add notes on beats 2 and 4 for the “snare” line. See Figure 6.6.

   ![Drum and snare notes](image)

   **Figure 6.6: Drum and snare notes**

9. Click the **Play** button in the Control Bar to audition the track.

   If desired, set the drum track to loop for 1 bar so it plays continuously as you work.

10. Click the **Add** button to add another note line to the track. Assign this note line to a closed hi-hat sound.

11. For these notes we will want some control over the velocities. Click the Velocity toggle for the “hi-hat” note line.

   ![Velocity Toggle](image)

   The grid display expands for displaying velocities on that note line.

12. Click in the first grid space with the Drumstick and drag to the right, moving up and down as necessary to vary the velocities.
PART 2: Recording

42 Opcode Systems, Inc.

Release the mouse button when each of the spaces in the first measure is filled with a note.

3 Click the Velocity toggle to hide the velocities for the “hihat” line.

4 To add even more variety to the hihat notes you could assign some of them to a different note line (one set to playback with an open hihat sound).

Select the Pencil tool, place your cursor over the note, drag down, and release the mouse button.

Figure 6.7: Dragging a note to a different note line

STEP RECORDING

Step recording uses a MIDI controller to enter notes individually, one step at a time (while ignoring tempo). This allows precise control over note duration, placement, and velocity. Properties and spacing for step entered notes are specified in the Step Window.

Using a MIDI controller to step record notes has several advantages over inserting notes with the Pencil or Magic Drumstick:

• The insertion point automatically advances after each note is entered;
• Velocity can be entered “As Played,” allowing the dynamics to occur more naturally;
• Chords can be entered as easily as single notes by simply playing a chord on the MIDI controller.

Following is an example of step recording a simple C major scale:

1 In the Control Bar, set the Record Mode pop-up to Step Replace.

2 Record-enable a track and press the Record button in the Control Bar.

The Step Window opens.

3 Set the Step Spacing to 8th notes (240 units).

This value determines how far the Counter advances each time a note is entered.
Configure the Step Duration pop-up to Percent of Spacing with a value of 100, and set the Step Velocity to As Played.

Play a C major scale on your MIDI controller, starting at C3 (middle-C) and ending at C4. Each time you play a note, it is recorded into the track and the Counter advances.

When done, press the Stop button in the Control Bar, or type the Return key. Step recording also stops when you're in Punch mode and the Out Point is reached, or if you close the Step Window.

You can step record most types of MIDI data—notes, chords, patch changes, and even sequence events. Music appears in the edit windows as it is step recorded.

You cannot use step recording to record pitch bends, aftertouch, or controller information. In addition, you will not hear other tracks play when step recording.

For a complete explanation of each component in the Step Window, see Chapter 36: The Step Window.

Step Recording Tips

- **Entering Chords**: Step record chords by playing the desired notes simultaneously; or hold down your MIDI controller’s sustain pedal and enter the chord’s notes one at a time. The Counter doesn’t advance while the sustain pedal is held down.

- **Sustaining Individual Notes**: To record notes that are longer than the Duration value in the Step Window, simply hold down the notes and advance the Counter (by either pressing the Spacebar or by playing another note). The length of the recorded notes is equal to the number of steps advanced while holding down the note.

- **Deleting Notes**: Type the Delete key on your Macintosh keyboard to erase previously entered notes. Each time you press this key, the last step is erased and the Counter moves backward.

- **Entering Rests**: Type the Spacebar to advance the Counter without entering any data. This will effectively enter a rest.

- **Entering Patch Events**: You can send a program change from your MIDI controller and Vision will record a patch change event. Alternatively, you could choose from the Patch pop-up in the Control Bar to record the patch change event. See Current Patch (pg. 186) for details. NOTE: The Counter does not advance when patch change events are recorded.

- **Sequence Events**: Type a sequence’s key equivalent to step record a sequence event for that sequence. In this case, the Counter advances the length of the referenced sequence, not the Spacing Size. See Chapter 13: Segments, Loops, and Sequence Events for more information on sequence events.
PART 2: Recording

• **Changing Spacing Size:** The Step Spacing is easily changed by typing the corresponding key equivalent on your Macintosh keypad. You can even use the “+” and “-” keys to calculate the Step Spacing.

  See *Using Keystrokes to set the Spacing* (pg. 338) for details.
CHAPTER 7: Advanced Recording Techniques

DRUM MACHINE STYLE LOOP RECORDING

Using techniques commonly found on drum machines, you can record drum patterns with the following Vision features:

- Record Quantize (see page 76)
- MIDIKeys (see page 171)
- Input Effect (see page 115)

For the following procedure, you should use a “drum kit” patch on your MIDI sound source—one that allows you to access many different drum sounds from a single MIDI channel.

The following section illustrates how to enable Record Quantize, erase notes “on the fly” with MIDIKeys, and record repeated notes with the Input Effect:

1. Select Setups>MIDIKeys Enabled so it is checked, then choose Windows>MIDIKeys.
   The MIDIKeys Window opens.

2. Define the Erase and Input Effect MIDIKeys with a MIDI event that you will not use while recording.

Foot switches and MIDI notes (that are out of the normal record range) should work well for this procedure.

To define one of the special MIDIKeys, click in the desired MIDI Event field and play the event on your MIDI controller.

   The Input Effect Window opens.

4. Disable the Input Effect toggle and set the type pop-up to Repeat.

You’ll want the Input Effect disabled so you can toggle it “on” from the special MIDIKey in real time, when you want to record the repeated notes.

5. Set the Input Effect’s Spacing to Grid mode with a value of 16th notes.

6. Choose Windows>Settings to open the Settings Window.
PART 2: Recording

7 From the Real-Time section of the Settings Window, enable **Aftertouch sets Effect Velocity**.

This lets you use key pressure on your MIDI controller to affect the velocity of notes recorded with the Input Effect.

Not all keyboards have aftertouch, consult your manufacturer’s documentation if unsure.

8 Use the procedure described in Loop Recording (pg. 35) to configure Vision for loop recording.

9 Select **Setups>Record Quantize Enabled** so it is checked.

10 Record-enable a track. Then click this track’s selector dot to view and configure it’s **Play Quantize settings**.

   ![Image]

   **Play Quant**

Set the Quantize value to **16th notes**.

**NOTE**: Each track has its own set of Play Quantize settings, which are used when Record Quantize is enabled.

11 Click the **Record button** in the Control Bar and play some notes on your MIDI controller.

The notes are recorded and automatically quantized.

12 To record a string of repeated notes, hold down the MIDI note or pedal defined as the **Repeat MIDIKey** while simultaneously playing the desired note or notes.

The notes are repeated (and recorded) with the rhythmic value specified by the Input Effect’s Spacing settings.

13 To erase a note, hold down the MIDI note or pedal defined as the **Erase MIDIKey** along with the note you wish to erase (while it is playing).

**MULTI-CHANNEL RECORDING**

Although Vision doesn’t record on more than one track at a time, it can record multiple MIDI channels onto a single track.

Tracks containing data for multiple channels are called “M ulti” tracks; they can be unmerged into separate tracks by choosing **Edit>Separate Multi Track**.

In order to record multiple channels in Vision, you must set up an **Input Map**. Input Maps route incoming MIDI channels to individual Vision Instruments. For a complete explanation of Input Map capabilities, see Chapter 34: The Input Map Window.

Recording tracks with Vision’s Input Map lets you:

- Record multiple tracks from an external MIDI sequencer in a single pass;
- Record data from a single controller that transmits on multiple channels (like some guitar synths);
- Record data from more than one MIDI controller, such as in a “jam session.”
The next sections discuss how to record data from an external MIDI sequencer into Vision using an Input Map.

**Recording Tracks from an External MIDI Sequencer**

Transferring tracks from an external MIDI sequencer is comprised of three steps: configuring an Input Map, recording the data, and unmerging the multi-channel track.

**Create an Input Map**

To configure an Input Map that routes external sequence tracks into Vision:

1. **Make sure the device from which you are recording is contained in your OMS Studio Setup.**
   
   This device must be defined as a Controller, and set to transmit MIDI Beat Clock.

2. **Launch Vision and make sure that Setups>Input Map Enabled is checked.**

3. **Choose Windows>Input Map** (or type Command-M) to open the Input Map Window.

4. **Next choose Add Line from the menu in the Input Map Window.**
   A line is added to the Input Map Window.

5. **Click in the Input Device column and select the device from which you are recording (in this case, the MC50).**

6. **Add an additional line for each channel you wish to record.**
   An easy way to add lines in the Input Map Window is to type Option-=.
   For each line added, specify the correct Input Channel. These channels should correspond to the data received from the external sequencer.

7. **Next, assign an Instrument in the Thru/Trigger column for each line.**

Once the data is recorded from the external sequencer, the Thru/Trigger Instruments are automatically assigned to their corresponding channels.

**NOTE**: Don’t worry about the Sequence and Player columns in the Input Map Window. These items are not relevant to this tutorial.
Record a Multi-Channel Track

The following example shows how to sync to and record from the external MIDI sequencer:

1. **Choose Options>Sync Options.**
   The Sync Options dialog opens.

   ![Sync Options dialog](image)

   Figure 7.1: Sync Options dialog

2. Configure the Receive Sync mode to **External Beat Clock** and set the sync source to the external sequencer device.

   Make sure the external sequencer device is enabled (checked) as an input device. Then click **OK**.

3. **Click OK** to close the Sync Options dialog.

4. **Choose Setups>Enable Input Devices.**
   The Enable Input Devices dialog opens.

5. **In the Control Bar, select Replace from the Record Mode pop-up.**
   Also, set the Begin Record toggle to **Wait for Note**.

6. **Record-enable a track and press the Control Bar’s Record button.**
   The Record button flashes, indicating Vision is waiting for sync from the external sequencer.

7. **Hit play on the external sequencer.**
   Vision begins recording as soon as the sync is received. The Control Bar’s Tempo Display indicates the received tempo.

   *NOTE:* If nothing happens, verify that your external sequencer is configured to send “sync.”

8. **When you have finished recording, stop the external sequencer, then click the Stop button in Vision’s Control Bar.**
   Data for the new track appears in the Tracks Window and shows up as assigned to **Multi** in the Instrument col-
Tracks appear as "Multi" whenever they contain data for more than one channel.

To audition the new track, set the Sync Mode in the Control Bar to Internal and then press the Play button.

The tracks recorded from the external sequencer play back on the Instrument channels assigned in the Input Map.

Choose File>Save As to save the new file.

**Separating the Multi-Track**

Once you’ve recorded your multi-track, you may wish to unmerge the channels into separate tracks—thereby making it easier to work with the data.

To unmerge a multi-track:

1. In the Tracks Window, highlight the multi-track by clicking its selector dot.
2. Choose Edit>Separate Multi Track (or type Command-U).
   
   The MIDI channels are unmerged and placed on their own tracks. Tracks are assigned based on the routings in the Input Map Window.
3. Rename each track as desired.
4. To save changes, choose File>Save.
CHAPTER 8: Sequence and Track Controls

This chapter discusses the sequence and track controls that primarily affect playback. For a complete description of every component in the Tracks Window, please see Chapter 25: The Tracks Window.

SEQUENCE CONTROLS

The following sequence settings are available from both the Tracks and Pulse Windows.

- **Meter**: A sequence’s meter determines the number of beat lines displayed in Vision’s edit windows, and the number of unaccented clicks heard when the metronome sounds. “Meter Track” is displayed in this area when a sequence contains meter changes. Double-click the Meter track’s selector dot to open a List Window for the sequence’s meter events.

- **Tempo**: Specifies how fast the sequence plays back, and the speed of the metronome click. “Tempo Track” is displayed in this area when a sequence contains tempo changes. Double-click the Tempo track’s selector dot to open a List Window for the sequence’s tempo events.

  The Tempo track can be record-enabled (️) or muted (️️). For details on setting the tempo, or recording into the Tempo track, see Virtual Conducting—Recording Tempo Changes (pg. 137).

- **Sequence Length/Loop**: Determines the number of measures the sequence plays, and whether it loops. Click in the left or right edge of this field (.SelectedItem) to turn looping on and off. You can Option-click in this field to lock the sequence length. When locked (️️️), the sequence length is not automatically adjusted after recording.
PART 3: Playback & Editing

**Information Toggle**

Figure 8.2: Information toggle in Tracks Window

Click on the Information toggle ( ) in the Tracks and Pulse Windows to view sequence settings for Offset, Start, and Sync mode.

![Figure 8.2: Information toggle in Tracks Window](image)

**Figure 8.3: Offset, Start, and Sync mode settings**

- **SMPTE Offset**: The sequence begins playing at this SMPTE time. The Offset ensures that sequence tracks line up with video or film (or tape tracks) when syncing to SMPTE, and that SMPTE event times are displayed accurately in Vision's edit windows.

- **Sequence Start Point**: The sequence starts playing at this bar, beat and unit. Adjust the Start Point if your sequence contains a pickup note.

  For instance, a sequence with a quarter-note pickup would have a Start time of 0•4•0.

- **Sync Mode**: Determines how the sequence "syncs" to the Master Tempo when played from a parent sequence, or when triggered in real time from the Players & Queue Window.

  When set to “Off,” the sequence plays with its own tempo, independent of the Master Tempo.

  “Speed” ignores the sequence's own tempo setting so it plays in sync with the Master Tempo.

  “Start,” which also uses the Master Tempo, waits until the sequence's Start Point is reached before triggering its playback.

**TRACK CONTROLS**

Each of a sequence's 99 tracks has the following controls, which are available from the Tracks Window. Some of these controls are duplicated in other edit windows.

![Figure 8.4: Track columns in Tracks Window](image)

- **Record ( )**: Click in this column to record-enable the track. Only one track can be record-enabled at a time.

- **Mute ( )**: Click in this column to mute playback for a track (or group of tracks). This lets you listen to and focus on other tracks within sequence.

  Click in the column head to toggle the mute status of all selected tracks. Command-click to unmute all tracks.
• **Solo** ( ): Click in this column to hear only that track, or group of tracks. Click in the column head to toggle the solo status of all selected tracks. Command-click to unsolo all tracks.

• **Track Length/Loop**: Determines the number of measures the track plays, and whether it loops. Click in the left or right edge of this field ( ) to turn looping on and off. You can Option-click in this field to lock a track's length. When locked ( ), a track's length is not automatically adjusted after recording.

• **Drum Track** ( ): This column toggles whether the track is defined as a drum track, which allows it to be viewed and edited in the Pulse Window.

• **Instrument**: Choose from this pop-up menu to assign a MIDI Instrument for playback. The Instrument's color determines the color of track data displayed in the various edit areas. If a track contains data assigned to multiple Instruments, the word “Multi” appears in this column.

• **Patch**: Choose from this pop-up menu to insert a patch event in the track for the assigned Instrument. A patch displayed in parenthesis in this column indicates it is current, but has not been inserted in the track. Patch names appear in this column only if the track’s Instrument is subscribed to a Patch Name document.

---

**Track Controls in Graphic and List Windows**

![Figure 8.5: Track controls in Graphic Window](image)

Some of the track controls are also available from the Graphic and List Windows. These controls, which apply to the individual track displayed in the edit window, include Instrument, track length, loop on/off, and buttons for record, mute and solo.

One advantage to adjusting the track length from the List Window is that you can specify a finer control over the length (with beats and units), unlike in the Tracks or Graphic Windows.

![Figure 8.6: Track length field in List Window](image)

**Play Quantize Settings**

When a track’s selector dot is clicked, that track’s Play Quantize settings appear in the info area of the Tracks and Pulse Windows.

![Play Quantize settings](image)
To enable either Play Quantize or Play Shift for the selected track, click the appropriate toggle button. The Quantize and Shift values used are displayed directly to the right of each button. To view all of the Play Quantize parameters, click the info area's triangle (▲).

![Click triangle to open and close info area](image)

Figure 8.7: Info area, open

Play Quantize and Play Shift are discussed in greater detail in Play Quantize (pg. 72).
CHAPTER 9: Basic Editing Procedures

This chapter explores some basic editing procedures, which include cursor tools, note editing, selecting and copying track regions, and selecting and copying track blocks and phrases.

It’s pretty important to that you understand these concepts before moving on to the following chapters on Quantize, Transpose, and Mixing and Arranging.

CURSOR TOOLS

Following is a description of the edit cursors found in Vision’s edit windows:

• **Arrow tool**
  The Arrow tool is only available in the Tracks Window. Use it to select and drag track blocks in the Track Overview section.

• **Marquee tool**
  The Marquee tool is available in the Tracks, Pulse, Graphic and Notation Windows. Use it to select a range of pitches and time, or portions of one or more tracks in the Tracks Window. Shift-drag with the Marquee to extend the selection, or Command-Shift-drag to add a non-contiguous selection.

• **I-beam tool**
  The I-beam tool is available in the Tracks, Graphic, and Notation Windows. Click and drag with this tool to select a time range of notes in the Graphic and Notation Windows—or a time range of all data in the Tracks Window. Use Shift-drag to extend the selection, or Command-Shift-drag to add a non-contiguous selection.

• **Pencil tool**
  Use the Pencil tool to insert notes in the Graphic, Notation, and Pulse Windows. See The Pencil Tool (pg. 37).

• **Magic Drumstick tool**
  Use the Magic Drumstick tool to insert and delete notes in the Note Grid area of the Pulse Window. You can even click and drag to insert and delete a range of notes. See The Magic Drumstick Tool (pg. 40).

In addition to the above mentioned items, there are a number of specialized tools available in Vision’s Strip Chart. For a description of these, please see Chapter 28: The Strip Chart.
Although not a tool, the Cursor Quantize option (found in the Tracks, Pulse, Graphic, and Notation Windows) is very much related to editing with the cursor. Once enabled, all cursor selections and movements are restricted in time to the value specified in the Cursor Quantize pop-up. This allows you to make precise selections and edits that "snap" to the Cursor Quantize value.

To turn on Cursor Quantize, simply click its toggle button—to turn it off, click it again. Choose from the Cursor Quantize pop-up to specify the rhythmic value.

The Graphic, Notation, and Pulse Windows share the same Cursor Quantize settings—change the settings in one window and they change in the others. The Cursor Quantize settings in the Tracks Window are independent of the other edit windows.

Whenever the cursor is moved into an edit area, the Cursor Display provides feedback on its position. For the Track Overview and Note Grid areas, location is displayed; for the Graphic and Notation Windows, location and note pitches are displayed; and for the Strip Chart area, location and event values are displayed.

NOTE: If an Instrument is subscribed to a Patch Name document that contains note names (i.e. bass drum, snare, crash), the Cursor Display uses note names instead of pitches.

The cursor location is displayed in either bar/beat/unit or SMPTE (specified in the edit window's menu). To display both time formats, click the Cursor Display toggle.

Use the Cursor Display information to ensure accurate positioning of inserted notes and Strip Chart data, and to verify correct placement of dragged notes and track blocks.
CHAPTER 9: Basic Editing Procedures

**Exact Mode**

![Exact](Exact.png)

It is often helpful to specify exact values when editing or inserting certain data types. Using **Exact** mode allows precise adjustments that might not be possible from one of Vision’s edit windows.

Exact mode is enabled by clicking its toggle, which is located in the tool palette of the Tracks and Pulse Windows, and at the bottom of the Graphic and Notation Windows.

When Exact mode is enabled, performing any of the following operations opens the Select & Modify Window, appropriately configured, for fine tuning the command:

- Dragging notes up or down with the mouse accesses the Transpose command;
- Resizing notes accesses the Change Duration command;
- Dragging notes or track blocks forward or back in time accesses the Move Events command;
- Inserting events in the Strip Chart automatically accesses the Change Value command;
- Selecting a data range in the Graphic and Notation Windows accesses the Select command.

For details on Select & Modify capabilities, see Chapter 16: Select & Modify.

**THE RULER**

The Ruler is part of the Tracks, Pulse, Graphic, and Notation Windows. Use it as a reference for locating, selecting and editing track data.

![Loop Indicator](Loop Indicator.png)

**Loop Indicator**

The Ruler shows the time scale in bars, beats, and divisions of beats. Whether bar and beat numbers are displayed depends on the horizontal zoom level.

**Edit Indicators**

The edit indicators show the Edit In/Out points for the current selection. Vision updates these indicators as the selection changes, see **Edit Points—Defining the Current Selection (pg. 66)**.

**Loop Indicators**

These are displayed in the Notation and Graphic Windows if the current track is looped. The loop indicators show the points where the track repeats.
NOTE EDITING

The following sections discuss basic note editing operations.

### Adjusting Notes in the Graphic and Notation Windows

A note's pitch, duration and placement can be edited with the mouse in the Graphic and Notation Windows. Depending on where the cursor is placed in relation to the note, one of the following special cursor types appear:

- **Move cursor**
  - If positioned to the left of a note, a Move cursor appears. Click and drag left or right with the Move cursor to change the start time of a note. Any other selected notes are dragged along with it. You can only move notes horizontally with this cursor.

- **Transpose cursor**
  - When positioned in the middle of a note, the Transpose cursor appears. Drag up or down with this cursor to change the pitch of all selected notes.

- **Duration cursor**
  - When placed just near the right edge of a note, the cursor becomes a Duration cursor, which lets you change the length of the note. In the Graphic Window drag left or right to shorten or lengthen any selected notes; in the Notation Window, click and hold the mouse for a pop-up of duration values.

Regardless of the currently selected edit cursor (Marquee, I-beam, or Pencil), the note edit cursors always appear when moving the mouse near a note.

Each of the edit cursors can also be used to select a note by clicking on it (hold down the Shift key to select multiple notes). And, when moving or transposing notes, you can hold down the Option key to perform the edit on a copy of the note—leaving the original data intact.

**NOTE:** The note edit cursors work a little differently in the Pulse Window. For details, see Chapter 26: The Pulse Window.
Editing Notes in the List Window

Vision's List Window provides precise editing of each individual event. In fact, the List Window is the only place where you can actually see every event contained within a track.

In addition to listing the type of each event and its location, all other relevant event values are also displayed. A note event, for instance, has values for pitch, duration, velocity on, and velocity off.

![Figure 9.5: List Window](image)

Any property of a note event is easily edited in the List Window. Simply click in the desired numerical field and type in a new value—or drag up or down with the mouse.

Note Velocities in the Strip Chart

You can affect the dynamics and phrasing of notes by editing their velocities. The Strip Chart is the perfect environment with an impressive array of tools for shaping note velocities.

The following example adds a slight crescendo to a group of note velocities with the Strip Chart's Parabola shape:

1. Select the desired Track and choose Windows>Graphic.
   The Graphic Window opens.
2. Open the Strip Chart by clicking its toggle button.
   The Strip Chart opens.
3. Make sure the Strip Chart is set to display Key Velocity.
PART 3: Playback & Editing

4 Select the Strip Chart’s Pencil tool.

Specify Parabola as the drawing shape.

5 Zoom out so you can see the desired note range. Do this by Option-clicking in the edit area of the Graphic Window.

6 In the Strip Chart area, click at the beginning of the note range (near the desired velocity start point) and drag to the right and up slightly.

Once the range of notes is covered by the shape of the velocity curve, release the mouse button.

The note velocities are automatically adjusted based on the drawn curve.

WORKING WITH TRACK BLOCKS AND PHRASES

The Track Overview section of the Tracks Window provides a graphic overview of the data contained in each track. Depending on the Display Mode pop-up, track data is displayed as Phrases, Blocks, or Tracks.

These different display modes offer you the flexibility of viewing your music as you see fit—based either on the type of music contained in the tracks, or the type of edit operations to be performed.

In Phrases mode, track data is broken up by a specified amount of silence, which is effective when working with music that doesn’t begin and end cleanly on the bar line. In Blocks mode, data is broken down into contiguous, equally sized blocks; you can specify the size of the blocks. In Tracks mode, the track’s contents are displayed as a single block.
The **Markers Break Blocks** option further breaks the blocks based on markers.

The important thing to remember about the Track Overview section is that it lets you get at any of your track data rather easily. This is handy for performing edit operations, or for moving blocks around to try out different arrangements.

In the Track Overview section you can use the Arrow tool to:

- Click on a block to highlight it, or Shift-click to select several blocks;

- Click and drag a block to a new location or another track;

- Option-drag a block, or group of blocks, to make a copy of the data.

- Double-click a block to open an edit window for that data.

### Selecting Data Regions

Before data can be cut, copied, moved, or modified by an edit operation, it must first be selected. To select an entire track, simply click its selector dot; to select track blocks, click or Shift-click them with the arrow tool; and to select individual notes, click or Shift-click them with any cursor tool.

The Marquee and I-beam tools, on the other hand, are used to select contiguous regions of tracks, thereby allowing you to affect just the data you want. The following sections discuss these methods.

#### Selecting Data with the Marquee

Use the Marquee tool to select groups of notes in the Graphic and Notation Windows. Simply click and drag around the desired region. Notes that begin within the dragged rectangle are selected. In these windows, the Marquee does not select pitch bend, modulation, or controller events.

![Figure 9.9: Selecting with Marquee in Graphic and Notation Windows](image)
In the Track Overview section of the Tracks Window, use the Marquee tool to select portions of blocks, or even groups of blocks across several tracks. All data types (notes and continuous controller events) falling within the highlighted region are selected.

Figure 9.10: Selecting with Marquee in Tracks Windows

In the Note Grid section of the Pulse Window, use the Marquee tool to select notes across several note lines and tracks. The Marquee tool does not select pitch bend, modulation, or controller events in the Note Grid area.

Figure 9.11: Selecting with Marquee in Pulse Window

NOTE: You can Shift-drag with the Marquee tool to extend a selection, and even Command-Shift-drag to add a non-contiguous selection.

Selecting all Notes in a Time Range with the I-Beam

In the Graphic and Notation Windows, use the I-beam tool to select all notes in a time range. With the I-beam tool selected, click and drag across the edit area to select the desired time range. All highlighted notes in the displayed track(s) are selected.

Selecting All Data in a Time Range

Move the cursor into the Ruler of the Graphic and Notation Windows to automatically switch to the I-beam tool. Dragging horizontally with this tool in the Ruler selects all data types in the track (including pitch bend data, patch events, digital audio events, etc.).
CHAPTER 9: Basic Editing Procedures

Selecting All Notes in a Pitch Range with I-Beam

Move the cursor into the left margin of the Graphic and Notation Windows to get a horizontal I-beam tool. Click and drag vertically with this tool in the margin to select all notes within a pitch range. Selecting a pitch range in this fashion selects over the entire track length.

![Figure 9.14: Selecting a pitch range in the Notation Window](image)

Selecting Multiple Tracks with I-Beam

Use the I-beam tool in the Tracks Window to select a time range on all tracks. With the I-beam tool selected, you can click anywhere in the Track Overview section and drag horizontally to select all track blocks that fall in that range.

![Figure 9.16: Selecting all tracks in the Track Overview](image)

Selecting Multiple Note Lines with the I-Beam

You can also select across multiple note lines and tracks in the Pulse Window. To do this, move your cursor into the Ruler and click and drag horizontally. This selects all data contained within the highlighted region.

![Figure 9.17: Selecting all note lines in the Note Grid](image)

NOTE: Since Vision allows selection of multiple tracks from the Tracks and Pulse Windows, any edit functions may be applied to all selected tracks.
EDIT POINTS—DEFINING THE CURRENT SELECTION

The current selection defines the time range of data affected when you perform an edit operation. Vision displays the current time selection in the Edit Points of all edit windows.

These Edit Points are updated automatically each time the current selection changes. This includes dragging in the Ruler, clicking on a note, or dragging a selection rectangle with the Marquee tool.

You can enter an Edit Point manually by clicking in its field and typing a new value, or by clicking and dragging with the mouse (you can also Option-click the field to grab a marker location).

When you adjust Edit Points manually, the edit indicators in the Ruler are automatically updated, and MIDI events are either selected or de-selected as a result.

LOOP EDITING

Any of Vision's vast array of editing capabilities can be performed in real time, while the sequence plays.

Loop editing is a powerful interactive process allowing construction of complex sequences from loops created “on the fly.” After creating a loop, the MIDI data may be edited while listening to the loop, without stopping playback.

The following example sets up a loop to perform editing functions from the Graphic Window, though this procedure will work from any edit window.

1. Select the desired track to edit and choose Windows>Graphic.
   The Graphic Window opens.

2. In the Ruler, select the time range that will be looped.

3. In the Control Bar, enable Loop mode by clicking its toggle.

4. Click the Set In Point and Set Out Point buttons.
   The loop range is set based on the previously selected time range.
5. Click the **Play** button or press the Spacebar.
   The sequence starts playing.

6. **Perform any edits within the selected time range.**
   When the sequence loops back and starts playing from the In Point, edits from the previous pass are heard.

7. **When finished editing, click the Stop button.**

   **NOTE:** Choosing **File>Undo** undoes the previous edit made while playing.
CHAPTER 10: Quantize, Shift, and Nudge

ABOUT QUANTIZE

Quantize adjusts event locations so that a track's timing is improved or altered—or so that a certain rhythmic “feel” is achieved.

Events such as notes, audio events, and sequence events, can be quantized to the nearest beat boundaries with Grid Quantize, or they can be quantized based on an existing Vision track with Groove Quantize.

Tracks in Vision can be adjusted permanently with the Quantize command, or for playback only with the Play Quantize settings. In addition, you can use Record Quantize to automatically quantize material as it's recorded.

Grid Quantize

Grid Quantize aligns events to the nearest beat boundary as defined by standard note durations. For example, if you quantize by eighth notes, the selected events are moved to the nearest eighth note beat.

Figure 10.1 shows how a note quantized by eighth notes, previously residing at 1•2•50, is moved to 1•2•0 (the nearest eighth note beat).

Note durations can also be quantized. Figure 10.2 shows the result of quantizing both the placement and duration of notes. Notes that are slightly shorter or longer than the specified note value are automatically adjusted.
In addition to getting your music to play back properly, Grid Quantize (for both note placement and duration) helps clean up tracks for printout by eliminating unwanted rests and tied or dotted notes.

**Groove Quantize**

While Grid Quantize moves events to regular intervals (like 16th notes), Groove Quantize is based on the rhythm, velocities, and durations of an existing Vision track. This allows you to map the “feel” of one track (with notes starting at wildly irregular times) to another. And, since durations and velocities are automatically copied from the “groove source,” Groove Quantize can be used to achieve the desired phrasing for your tracks.

For example, imagine trying to duplicate the feel of a hi-hat track consisting of 16th notes played with a shuffle feel. Since the start times are slightly “swung,” using Grid Quantize to accomplish this would likely not work. In addition, certain notes and beats may be emphasized with velocities and durations. Trying to map start times, durations, and velocities to a different track would be a tedious job, particularly if it needs to be done more than once. With Groove Quantize, you can use the hi-hat track as the groove source and have Vision do the work for you (see Figure 10.3).

The Groove Quantize source tracks are stored in the “Vision Grooves” file. You can edit this file as you would any other Vision file—it must, however, remain in the same folder as your Vision application.

See Creating Your Own Grooves (pg. 167) for details on customizing the Vision Grooves file.

**APPLYING QUANTIZE**

Vision’s Grid and Groove Quantize capabilities can be used for Play Quantize, or for permanently quantizing data with the Quantize command.
When using the Quantize command, the quantize parameters are configured in the Select & Modify Window. When using Play Quantize, an identical set of quantize parameters (for each track) is configured in the info area of the Tracks and Pulse Windows; Record Quantize uses the Play Quantize settings for each track.

The quantize parameters vary depending on whether you are using Grid or Groove. Use the Type pop-up to specify Grid or Groove.

When using Grid, the Quantize Value determines the grid size used for the quantize.

When using Groove, the Seq and Track pop-ups determine the source material for the quantize.

Because there is such a wide range of possible quantize configurations, Quantize Templates can be used to store and recall your favorite settings. For details, see Quantize and Transpose Templates (pg. 163).

This chapter is a general discussion of quantize methods and types. While this chapter frequently refers to the settings for Play Quantize and the Quantize command, it does not go into detail about their various parameters. For detailed information on each quantize parameter, please see Quantize Parameters (pg. 129).
PART 3: Playback & Editing

Play Quantize

Play Quantize is non-destructive and only affects how a track plays back—it does not change MIDI data. Each track can have its own Play Quantize settings, using either Grid or Groove.

Play Quantize settings are accessed from the info area in the Tracks and Pulse Windows. Once a track is selected, its Play Quantize parameters appear:

- **Play Quantize**: Enables Play Quantize for the selected track.
- **Play Quantize Value**: Specifies the rhythmic value (or Groove source) used for the track’s Play Quantize.
- **Play Shift**: Enables Play Shift for the selected Track.
- **Play Shift Value**: Specifies how many units (+/-) the selected track is shifted for playback.

There is, however, a much larger number of parameters that specify how a track is Play Quantized. These parameters are visible when clicking the info area’s triangle.

![Figure 10.10: Open/close triangle for info area](image)

Figure 10.10 shows the info area open, displaying all Play Quantize parameters.

The Type pop-up specifies whether Grid or Groove is used. The Template pop-ups are for saving and recalling Quantize Templates. See Quantize Parameters (pg. 129) for an explanation of each quantize parameter.

Enabling Play Quantize

The following example shows how to enable Play Quantize for a track with an eighth note “swing” feel:

1. From either the Tracks or Pulse Window, highlight the desired track.
2. Click the info area’s triangle so all of the Play Quantize parameters are visible.
Enable Play Quantize for the track by clicking its toggle button.

Select Grid from the Quantize Type pop-up.

Next specify eighth notes in the Quantize Value pop-up.

Enter a value of 60.0% for Swing.

Leave Shift and Smear set to 0 units, Sensitivity and Strength to 100%.

Click the Play button in the Control Bar to audition the Play Quantize settings.

Enable Play Shift causes a track’s MIDI events to play back early or late. It shifts the contents of the track by the number of units specified in the Play Shift field.

You can use Play Shift to:
- Compensate for synth patches with slow attacks;
- Achieve a certain “pushed” or “laid back” feel;
- Create MIDI delays (copy a track, lower its volume, and apply Play Shift).

To enable Play Shift for a track:

Select the desired track from the Tracks or Pulse Window.
PART 3: Playback & Editing

2. Click the Play Shift toggle and enter a value (+/- 480 units) in the Play Shift field.

    Play Shift: 0

Positive values cause events to play later than the rest of the sequence—negative values cause events play earlier.

To permanently shift your MIDI data see Permanently Shifting Track Data (pg. 77).

The Quantize Command

The Quantize command permanently alters the selected track data. There are several reasons you’d want to use the Quantize command instead of Play Quantize:

- While Play Quantize affects all notes, audio events, and sequence events contained within a track, the Quantize command can be used selectively on portions of a track—and on other event types.
- Track data is always displayed based on the original MIDI data—not the Play Quantize values. Permanently quantizing a track ensures that its playback will match what’s displayed in the edit windows.
- Permanently quantizing data, rather than having Vision calculate for playback, increases your computer’s processor performance.

You can use the Quantize command on any selected sequence, track, group of tracks, or track region. Parameters for the Quantize command reside in the Select & Modify Window. Choose Do>Quantize to open the Select & Modify Window automatically configured for Quantize.

![Figure 10.12: Select & Modify Window, configured for Grid Quantize](image)

The Quantize parameters in the Select & Modify Window are identical to (but independent of) those used for Play Quantize.

To actually invoke the Quantize command, click the Quantize button in the Select & Modify Window. Click Undo to revert back to the original data (clicking the Undo button turns it into a Redo button, and vice versa).

You can also call the Quantize command by choosing Do>Quantize Track (or, depending on the selected material, Do>Quantize Selection), or type Command-G.

IMPORTANT: Unlike other Select & Modify commands, the Quantize command is always accessible from the Do menu, or by typing its key equivalent (Command-G).
Quantize Value Pop-up

The Quantize Value pop-up, found in the Graphic, Notation and List Windows, offers a way of remotely adjusting Quantize parameters in the Select & Modify Window. Setting this value from one window, changes it in all others.

With the Quantize command set to Grid, click this pop-up to set the note duration for the grid size.

Figure 10.13: The Grid Size pop-up

With the Quantize command set to Groove, click this pop-up to choose the track used for the groove source.

Figure 10.14: Groove Source pop-up

The Quantize Value pop-up can also be used for the following purposes:

- Command-click to toggle between Grid and Groove Quantize;
- Shift-click when in Groove mode for a pop-up of groove sequences;
- Option-click to open the Select & Modify Window configured for Quantize.

NOTE: Changing the Quantize Value pop-up from the Select & Modify Window, or from the Graphic, Notation or List Windows, does not affect Play Quantize settings for any tracks.

Groove Quantizing a Track Region

Following is an example of quantizing a track region with one of the groove examples:

1. **Highlight the desired track region and choose Do>Quantize.**
   The Select & Modify Window, configured for Quantize, opens.

2. **Select Groove from the Type pop-up.**

3. **From the Seq pop-up, select 1•Shuffles.** From the Track pop-up, select 3•Med Shuffle A.
PART 3: Playback & Editing

4 Click the Quantize button.

The selected material is modified according to the settings in the Select & Modify Window.

5 Click the Play button in the Control Bar to audition the change.

To go back to the original MIDI data, click the Undo button before performing any other operations.

Experimenting with Quantize

Using quantize, with either the Quantize command or Play Quantize, takes some experimenting. In fact, you won’t always get the results you’re expecting.

You may have to try different values for Sensitivity and Strength; these parameters determine which notes are affected and how drastically they are changed. In addition, the Smear parameter, which adds a percentage of randomness to the quantize, can be used to make tracks feel less mechanical—less perfect. For an explanation of these and other Quantize parameters, see Quantize Parameters (pg. 129).

Although quantize is a wonderful tool for cleaning up tracks and working with the feel of your music, sometimes the recorded data may not be salvageable. In these instances it is wise not to spend too much time trying to fix something that should probably just be rerecorded.

RECORD QUANTIZE

Select Setups>Record Quantize Enabled to turn on Record Quantize, or simply click the toggle in the info area of the Tracks or Pulse Window.

![Record Quantize](image)

Figure 10.15: Record Quantize toggle, enabled

By default, the recorded track uses its own Play Quantize settings for Record Quantize. If you have a set of Quantize parameters that work well for Record Quantize, choose Save as Default from the Template pop-up in the Info Area—each new track will then use those Quantize settings.

![Save as Default](image)

Figure 10.16: Saving default Quantize parameters

To record durations as quantized, make sure to check that option as well.

For details on changing the Record Quantize source, see Record Quantize Source (pg. 335).
PERMANENTLY SHIFTING TRACK DATA

If you find a Play Shift setting you like, you can permanently shift the data so that what you hear matches what’s displayed.

Although there are many ways to shift events in Vision, the following sections describe how to use the Move Events and Nudge commands.

NOTE: If the beginning of a selection starts at 1•1•0, it will not be possible to shift any of the selected events back in time with Move Events or Nudge.

NOTE: The Nudge and Move Events commands are not affected by Cursor Quantize settings.

Move Events

Following is an example of permanently shifting track data with the Move Events command. This example assumes you have a track Play Shifted by 30 units and would like to permanently shift the data.

1 Select the desired track or track region.
2 Choose Edit>Move Events (or type Command-,).

The Move Events Window opens.

For complete information on this dialog box, see Move Events (Command-,) (pg. 413).

3 Select the Move later option with a value of 30 units.

4 Click the Move button.

The data is permanently shifted.

5 Disable the Play Shift toggle for the track.

If you don’t complete the last step, your data will be shifted again during playback, which is probably not desirable.
PART 3: Playback & Editing

Nudge

You can also use the Nudge command to permanently shift track data. Unlike the Move Events command, Nudge is typically used for tweaking the “feel” of a track during playback.

The Nudge command can be invoked from the Do menu—or by typing Command → for forward, Command ← for back. The amount nudged is specified in the Strip Chart & Nudge section of the Settings Window.

Following is an example of nudging a track forward by 10 units:

① Disable the Play Shift toggle for whichever tracks you will Nudge.

While this step is not mandatory, it will lessen the confusion in keeping track of whether the track is “shifted” or “nudged.”

② Choose Windows>Settings. The Settings Window opens.

③ With the Settings Window pop-up set to Strip Chart & Nudge, set the Nudge direction value to 10 units.

Figure 10.18: Nudge transpose set to 10 units

④ Highlight the desired track data and choose Do>Nudge>Later (or type Command →). The track data is nudged later by 10 units.

If you don’t like the effect of a Nudge command, simply use the opposite Arrow key to return to the previous event locations.
CHAPTER 11: Transpose

This chapter discusses the many ways that Vision transposes notes, which include dragging notes in the Graphic and Notation Windows, editing pitch values in the List Window, using the Transpose command, and defining transposed Vision Instruments.

TRANSPOSING IN THE GRAPHIC, NOTATION, AND LIST WINDOWS

Notes and groups of notes can be transposed in the Graphic and Notation Windows by dragging up or down with the mouse.

Figure 11.1: Transposing in the Graphic Window

When positioning the cursor in the middle of a note, it becomes a transpose cursor ( ), which can be dragged up or down to change the pitch of the note. In addition, you can use Option-drag to transpose a copy of the note.

Figure 11.2: Transposing in the Notation Window

To transpose a chord or a group of notes (or even an entire track), simply make the selection and then drag just one of the notes. All of the selected notes will follow the dragged note.

Figure 11.3: Transposing a chord in the Graphic Window

You can also edit the pitch of individual notes in the List Window. To do so, click in the pitch field and drag up or down with the mouse, or type in a new value.

Figure 11.4: Editing a note’s pitch in the List Window
PART 3: Playback & Editing

TRANPOSING WITH NUDGE

A quick and easy way to transpose tracks (or portions of tracks) by semitones, octaves, or scale degrees is with the **Nudge** command. The transpose type used with Nudge is specified in the Settings Window.

To transpose a track up by an octave with Nudge:

1. Choose **Windows>Settings**. The Settings Window opens.
   
   ![Figure 11.5: Settings Window set to display Strip Chart & Nudge parameters](image)

2. With the Settings Window pop-up set to Strip Chart & Nudge, set the transpose value to **1 octaves**.

   ![Figure 11.6: Nudge transpose set to 1 octave](image)

3. Close the Settings Window.

4. Select the desired track or track region from the Tracks Window and choose **Do>Nudge>Up** (or type **Command-↑**). The track data is transposed up an octave.

Invoking Nudge with the Command and Arrow keys is a very convenient method of auditioning transpositions while Vision plays. And if you don't like a nudged transpose, simply use the opposite Arrow key to return to the previous pitch values.

THE TRANPOSE COMMAND

Vision's Transpose command offers the widest range of capabilities for performing transpositions. Choose **Do>Transpose** to open the Transpose Window.

![Figure 11.7: Transpose Window](image)

The Transpose Type pop-up specifies what kind of transposition is used. Following is a brief explanation of each type:

- **Chromatic** transposes by a specified number of semitones.
- **Interval** transposes by semitones, as expressed by one specified pitch to another.
- **Diatonic** transposes by scale degrees for a specified key and scale type.
• **Invert** creates a mirror transposition (chromatically or diatonically) around a specified pitch.

• **Key/Scale** transposes from one key and scale type to another.

• **Auto Map** lets you specify the number of notes per octave for source and destination maps.

• **Octave Map** is just like Auto Map except you can specify which notes are contained in the octave.

• **Manual Map** lets you remap any of the 128 MIDI pitches to any other pitch.

• **Drum Map** is for remapping drum assignments from one Instrument to another. This is the same as Manual Map except note names are displayed instead of pitches.

Once a Transpose Type is chosen and its settings are configured, click the **Transpose** button to modify the selected data. Alternately, click the **Harmonize** button to automatically make a transposed copy of the original data.

For a detailed description of the Transpose Window, including configuration details on each Transpose Type, see Transpose Types (pg. 134).

The following sections illustrate some practical applications for the Transpose command.

---

**Transpose up a Fifth**

To transpose up a fifth using a Transpose Type of Chromatic:

1. **Highlight the desired track or track block from the Tracks Window.**

2. **Choose Do>Transpose.**

   The Transpose Window opens.

3. **Set the Transpose Type to Chromatic.**

   ![Transpose Type: Chromatic]

4. **Set the Transpose direction pop-up to Up, then click and drag in the Transpose value field until “a perfect fifth” is displayed.**

   ![Transpose up a perfect fifth (7 semitones)]

   You can also type a value of 7 into this field (referring to the number of semitones).

5. **Click the Transpose button.**

   The selected material is transposed up a fifth.
PART 3: Playback & Editing

Using Transpose to Add Harmony

To harmonize a track with thirds using a Transpose Type of Diatonic:

① **Highlight the desired track.**
   This example assumes the selected track material is in the key of C major.

② **Choose Do>Transpose.**
   The Transpose Window opens.

③ **Set the Transpose Type to Diatonic.**
   

④ **Set the direction pop-up to Up**
   and specify a transpose value of “a third.” In addition, make sure
   that C major is the specified key.

⑤ **Click the Harmonize button.**

A transposed copy of the selected track data is merged into the source track.

Drum Instruments and the Transpose Command

Most MIDI keyboards and drum machines map a number of different drum
and percussion sounds across a range MIDI note numbers. When drum tracks
in Vision are recorded, each note corresponds to a specific drum sound.
Transposing these notes, therefore, usually results in a different (or even no)
drum sound playing back.

To avoid this problem, Vision lets you define Drum Instruments. Tracks
assigned to Drum Instruments (which are defined as such in the Instruments Win-
dow) are not altered with the Transpose command.

To define a Drum Instrument:

① **Choose Windows>Instruments**
   to open the Instruments Window.

② **Click in the Drum Transpose column ( )**
   for the desired Instrument.

The Drum Instrument icon is added to the Drum Transpose column, indicating
that Instrument is a Drum Instrument.

NOTE: Click again in the column to turn the Drum Instrument back to a normal Instrument.

Drum Instruments and the Transpose Command

Most MIDI keyboards and drum machines map a number of different drum
and percussion sounds across a range MIDI note numbers. When drum tracks
in Vision are recorded, each note corresponds to a specific drum sound.
Transposing these notes, therefore, usually results in a different (or even no)
drum sound playing back.

To avoid this problem, Vision lets you define Drum Instruments. Tracks
assigned to Drum Instruments (which are defined as such in the Instruments Win-
dow) are not altered with the Transpose command.

To define a Drum Instrument:

① **Choose Windows>Instruments**
   to open the Instruments Window.

② **Click in the Drum Transpose column ( )**
   for the desired Instrument.

The Drum Instrument icon is added to the Drum Transpose column, indicating
that Instrument is a Drum Instrument.

NOTE: Click again in the column to turn the Drum Instrument back to a normal Instrument.
For information on MIDI Instruments, see Chapter 32: The Instruments Window.

**TRANSPOSING WITH VISION INSTRUMENTS**

Another way to transpose in Vision is with MIDI Instruments. An Instrument can be transposed by octaves or semitones by editing the appropriate fields in the Instruments Window (see Figure 11.8).

![Figure 11.8: Instrument transposed up 1 octave and 5 semitones](image)

An Instrument can also use Transpose Maps, thereby taking advantage of any of the capabilities in Vision’s Transpose Window. With Transpose Maps, you can have Instruments that are “constrained” to playing notes only in a certain key, that map notes played in one key or mode to another, or that remap drum sounds from one device to another.

The following example illustrates how to add a map that restricts an Instrument to only playing notes in the key of C major:

1. **Choose Windows> Instruments** to open the Instruments Window.
2. **Click in the Map column of the desired Instrument.**
3. **Set the Transpose Type to Diatonic.**
   - **Type:** Diatonic
   - Set the transpose value to “0 semitones” and make sure that C major is the specified key.
4. **Enable the Constrain to Scale option by clicking its checkbox.**
   - **Constrain to Scale**
PART 3: Playback & Editing

5 Click OK.

The Transpose Map dialog closes and the column in the Instruments Window indicates a Transpose Map is in use.

<table>
<thead>
<tr>
<th>CS</th>
<th>Instrument</th>
<th>MI</th>
<th>TrnsMap</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1 misdemeanor</td>
<td>0</td>
<td>Top</td>
</tr>
<tr>
<td>1</td>
<td>NightWave 1</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>NightWave 2</td>
<td>1</td>
<td></td>
</tr>
</tbody>
</table>

Once an Instrument is transposed, any tracks assigned to that Instrument play back with that transposition. The main advantage of using transposed Instruments is that the original track data remains unaltered.

For detailed information on MIDI Instruments, see Chapter 32: The Instruments Window.
CHAPTER 12: Arranging & Mixing

Once your tracks are recorded and edited as you like, the next logical step is to finalize the arrangement. This chapter explores building song structures, saving patch selections, and saving volume and pan settings.

ARRANGING SECTIONS OF MUSIC

Vision is both a pattern and linear based sequencer. This means you can build your music by creating individual sequences that are chained together, or you can work within a single, linear sequence (much like a multitrack recorder). Vision provides the flexibility to work with either method—or even a combination of the two.

Chaining Existing Sequences

A very powerful capability of Vision is playing existing sequences from other parent sequences, which makes it very easy to chain together sequences, or even play back multiple sequences at the same time. This modular approach to using sequences as building blocks is a very flexible and effective way of constructing music in Vision.

Sequences (and segments) are called from parent sequences by inserting or recording sequence events, which describe how to play back the referenced data.

The following example illustrates how to chain together three existing sequences (Verse, Chorus, and Bridge) with step record:

1. From the menu in the Sequences Window, choose **New Sequence**.

2. In the Control Bar, set the Record Mode pop-up to **Step Replace**.

3. Record-enable a track in the Tracks Window.

4. Click the **Record** button in the Control Bar.

Vision enters record mode and the Step Window opens.
5. Type the key equivalent for each sequence in the desired order.

   The Counter advances each time a sequence’s key trigger is typed, and a corresponding sequence event block appears in the Track Overview section of the Tracks Window.

   ![Figure 12.1: Step Recorded Sequence Events](image)

6. When done, press the Stop button in the Control Bar.

7. To audition the new arrangement, click the Play button in the Control Bar.

Sequence events show up in the Track Overview section as white (named) blocks. Like other data in the Track Overview, sequence event blocks can be dragged, copied, and pasted. If you wish to edit the referenced sequence, double-click the sequence event block to open a Tracks Window for that sequence.

**NOTE:** Sequence event blocks that reference single-track sequences (or segments) are not named, and instead display the data from the referenced track. For details, see Single-track Segments (pg. 94).

---

**Adding Linear Tracks to Chained Sequences**

Within a parent sequence, you can add or record additional (linear) tracks on top of the chained sequences. This is an important feature because phrases or notes may sometimes overlap song sections. You can also use these extra tracks to add mix and patch events for the Instruments contained in the chained sequences.

![Figure 12.2: Sequence with chained sequences and additional linear tracks](image)

---

**Making Segments**

As discussed in Working with Track Blocks and Phrases (pg. 62), it’s pretty easy to try out different song arrangements by moving around and copying track blocks in the Track Overview section. This can, however, get rather laborious if your sequences have a lot of tracks.

One way to simplify this process is to combine the various track sections into segments. Once this is done, rearranging song sections is a much simpler process.

1. Open the Tracks Window for the desired sequence.

2. Turn on **Cursor Quantize** and set it to **whole notes**.
Using the Marquee tool, click and drag around the track regions that comprise the first song section.

Release the mouse button to select the track regions.

Choose Edit>Make Segment Loop. The Make Segment dialog opens.

Enter a Name for the new segment.

Click the Make one segment option.

This combines the selected track regions into a single segment, making it easier to move or copy.

If you would like the flexibility of keeping the individual track data separate, choose the Make single track segments option.

Choose the Make button. The selected track material is turned into a segment (which then appears in the Segments section of the Sequence Window).

Select the new segment. The previously selected track blocks are replaced by a single sequence event block in the Track Overview section.

Repeat the previous steps until each of the song sections is turned into a segment.

Once the segments are created, you can rearrange them as desired—drag them to a new location, or use copy and paste. Individual sequence events can also be resized to play just a portion of the original data, looped (independently of their parent track), and even transposed.

For more information on segments and sequence events, see Chapter 13: Segments, Loops, and Sequence Events.
SAVING PATCH SELECTIONS

Part of finalizing your songs is making sure your MIDI devices play back with the right patches. Patch events can be recorded or inserted into a track in a number of ways. You can insert them in the List Window or Strip Chart, and you can even step record them.

NOTE: The following sections assume that your Instruments are subscribed to Patch Name documents, see Chapter 33: The Names Window.

Using the Patch Column in the Tracks Window

Perhaps the easiest way to insert a patch event into a track is with the Patch column in the Tracks Window:

1. In the Tracks Window, click in the Patch column for the desired track. If there is a current patch selection for the assigned Instrument, that patch appears in the column in parentheses.

A pop-up menu of patches appears.

2. Highlight the desired patch and release the mouse.

A patch event is inserted into the track at 1-1-0. The patch name appears in the Patch column (without parentheses).

Using the Copy Patches Command

One drawback of using the Patch column in the Tracks Window is that the inserted patch events are erased if you record over the track (in Replace mode).

Another method of recalling patch events is to insert them into their own, dedicated track with the Copy Patches command:

1. Using the Current Patch pop-up in the Control Bar, select a patch for each Instrument used in your sequence.

2. Choose Do>Copy Patches.

The current patches are copied to the Clipboard.
Select a blank track in the Tracks Window and choose Edit>Paste Track.

The patch events are pasted into the selected track. The track is automatically named “Patches” and the Instrument column is assigned to Multi.

To view the pasted patch events, open the List Window.

Patch Event Placement

Some MIDI devices have trouble switching patches while playing. As a result, these devices may “hiccup” or drop some notes when receiving a patch event.

To get around this problem, you’ll need to allow enough time between the patch event and track playback. If a track begins playing at 1•1•0, you can use a pickup measure for the patch event (see Sequence Start (pg. 212)).

Another method is to put all of your patch events into a dedicated sequence and play it back separately—triggering it with its key equivalent, or playing it from an optimally placed sequence event.

SAVING VOLUME AND PAN SETTINGS

This section discusses how to set the volume and pan levels for Instruments, and how to save them to a sequence.

Volume and pan data can be inserted in the List Window and Strip Chart, or it can be recorded or copied from consoles and faders.

Saving a Mixer Snapshot

The following example explains how to copy and save the mixer settings from a Console Window:

1. Once your tracks are recorded and assigned to the correct Instruments, choose Windows>Consoles>Console 1.

   The Console Window opens.

2. From the menu in the Console Window, choose Build Consoles From>All Instruments In Use.

   Each of the Instruments used in your sequence is automatically assigned to a console channel.

3. Click the Play button in the Control Bar to listen to the sequence.
PART 3: Playback & Editing

4. Make any **Mute** or **Solo** settings that apply at the beginning of the sequence.

   ![Mute and Solo symbols]

Click to enable or disable any mutes or solos.

5. While the sequence plays, adjust the **Volume** and **Pan** sliders for each console channel.

   ![Volume and Pan sliders]

Click and drag horizontal sliders to adjust pan

Click and drag vertical sliders to adjust volume

You can also adjust these values by typing into their fields.

6. Once the desired volume and pan levels are achieved, choose **Edit>Copy Faders**.

The volume and pan data is placed on the Clipboard.

7. **Select an empty track in the Tracks Window and choose Edit>Paste Track.**

The volume, pan, mute, and solo events are pasted into the selected track. One of each type of event is pasted in for each Console channel.

8. **Choose File>Save** to save the new track containing the fader values.

9. Also, when prompted, make sure to **Save** the Fader Values and Fader Assignments with the sequence.

   ![Save changes dialog]

Fader movements can also be recorded in real time while the sequence plays back. This lets you create dynamic mixes for your tracks. For more details on using faders and consoles, see Chapter 37: The Faders Window and Chapter 38: The Console Windows.
CHAPTER 13: Segments, Loops, and Sequence Events

SEGMENTS

Segments, which are very similar to sequences, are created from tracks or groups of tracks. Segments provide a great way to turn existing material into modular components that can be played from any of the sequences in a file. Use them as song sections, music layers, reoccurring phrases and riffs, or even nested track loops. They can also be used to break an existing linear sequence into sections that can be rearranged.

Segments are “made” by selecting track material (which can reside across several tracks) and choosing Edit>Make Segment/Loop. The selected material is replaced by a sequence event block that references the new segment. The original material then resides in the newly created segment, which is listed in the Segments section of the Sequences Window.

Once they’re created, segments act pretty much like regular sequences; double-click on them from the Sequences Window and they open up in a Tracks Window, where they can be played or edited. There are, however, some important differences between segments and sequences:

• Segments and sequences reside in different sections of the Sequences Window;
• Unlike sequences, key equivalents and MIDIKeys cannot be assigned to segments;
• When no longer referenced by any parent sequences, segments are automatically deleted.

NOTE: If you uncheck the Automatically Remove Unused Segments option in the Sequences Window menu, segments are not auto-deleted.

If you need to assign a key equivalent or MIDIKey to a segment, you can turn it into a sequence. Do this in the Sequences Window by dragging it from the Segments section to the Sequences section.

For details on sequence event parameters, which describe how to play segments and sequences, please see Sequence Events (pg. 96).
PART 4: Advanced Concepts

Making a Segment

The following example illustrates how to make a segment from existing tracks:

1. In the Tracks Window, highlight the desired track blocks.

   ![Sequence event block](image1)

2. Select Edit>Make Segment/Loop. The Make Segment dialog opens.

   ![Make Segment/Loop dialog](image2)

   With multiple tracks selected, you can specify to combine them into one segment by choosing “Make one segment with multiple tracks,” or you can keep the tracks separate with “Make single-track segments.”

3. For this example, specify the **Make one segment** option. Enter a name for the segment and click **Make**.

   ![Making a single-track segment](image3)

   The previously selected track material is replaced by a sequence event block in the Tracks Window, and the new segment is listed in the Segments section of the Sequences Window.

   ![Figure 13.2: Sequence event block](image4)

   **Figure 13.2: Sequence event block**

**Single-track Segments**

In the previous example, four existing tracks were combined into one segment. As seen in Figure 13.2, sequence events that reference segments, or sequences, with multiple tracks are displayed as white (named) blocks.

However, when you make a segment from just one track (or if you choose the “Make single-track segments” option in the Make Segment/Loop dialog), the resulting sequence event block displays the track data and color, see Figure 13.3.

   ![Figure 13.3: Making a single-track segment](image5)

   **Figure 13.3: Making a single-track segment**

   **NOTE:** Double-clicking a single-track sequence event opens the default edit window (Graphic or List), instead of a Tracks Window.

   Single-track segments always play back using their parent track’s Instrument.
Looping Track Regions with Segments

Segments can loop independently of tracks. This means that tracks can contain nested loops. For instance, your track could be set to loop for 12 bars while a 3 bar segment, within the track, also loops a number of specified times. Looped segments can begin playing anywhere within a track, and can be set to any loop length.

The following example illustrates how to loop a one measure phrase by turning it into a segment:

1. Highlight the desired track region and select Edit>Make Segment/Loop.

2. In the Make Segment/Loop dialog, check the Loop option and specify the number of times you’d like the material to repeat.

3. Enter a name for the segment and click Make.

The previously selected track material is replaced by a sequence event block in the Tracks Window, and the new segment is listed in the Sequences Window.

Figure 13.4: Looped segment

The resulting sequence event block displays the looped material, followed by grayed regions that indicate the number of times it repeats (see Figure 13.4).

Using Segments to Create Loops in the Middle of a Track

An advantage of using segments for loops is that they can start and end anywhere in a track. The material you select, just before “making” the segment, doesn’t have to start at measure 1; in fact, it can start anywhere in the track and it needn’t fall precisely on the bar line.

Figure 13.5 illustrates looping a track region that begins just before the bar line.

Figure 13.5: Use segments to loop any region of a track
When making a segment that doesn’t fall squarely on the beat, make sure to uncheck **Round to nearest bar lines** in the Make Segment/Loop dialog.

Of course once a segment is made, it can, like any other track block, be moved or nudged to your liking.

**Resizing Segments/Loops Graphically**

Once a segment is made you can still adjust the loop length and number of repeat times. You can type in new values for these numbers in the info area or List Window (see Sequence Events (pg. 96)), or you can graphically edit the segment in the Tracks Window.

When moving the cursor near the end of a looped segment, the Repeat cursor appears. Click and drag left or right to change the number of times the segment repeats.

![Repeat cursor](repeat_cursors.png)

When placed near a segment’s loop end point, your cursor changes to a Resize cursor. Click and drag to the left or right to resize the loop range.

![Resize cursor](resize_cursors.png)

**SEQUENCE EVENTS**

Sequence events are aliases to sequences and segments. Sequence events, which reside in a parent sequence, describe how to play the referenced material.

Sequence events can be:

- Recorded in step or real time by typing a sequence’s key equivalent;
- Inserted in the List Window from the Insert Event pop-up.
- Pasted into a Tracks or List Window (after copying a sequence or segment from the Sequences Window).

In addition, whenever using the **Do>Make Segment/Loop** command, (see page 94), a corresponding sequence event is automatically inserted to replace the original material.

**Sequence Event Parameters**

Sequence event parameters can be viewed and edited from the Info Area of the Tracks and Pulse Windows. Simply click on the sequence event block and information for that sequence event is displayed, see Figure 13.6.

![Figure 13.6: Sequence event info](sequence_event_info.png)
The sequence event parameters from the info area, as shown in Figure 13.7, are described below:

1. **Sequence/segment**: This pop-up lists the name of the referenced sequence or segment. Choose from the pop-up to reference a different sequence or segment.

2. **Record**: Use this toggle, which is only available for single-track sequence events, to record-enable the referenced track, which lets you record into the track from the parent sequence.

3. **Mute**: This toggle mutes all tracks in the referenced sequence (for that sequence event). Selected sequence events can also be muted by choosing Do>Mute>Mute Seq & Audio Events.

4. **Length**: Specifies the duration of the sequence event. This value is independent of the actual length of the referenced sequence or segment. For instance, you could have a sequence that is 32 measures long and only play the first 8 measures.

   Click in the left or right edge of this field (•) to turn looping on and off. You can also change sequence event lengths graphically in the Track Overview section (see page 96).

5. **Loop**: If the sequence event is looped, this field determines how many times the material repeats. You can also edit the number of repeats graphically in the Track Overview section (see page 96).

6. **Transpose**: Click in this field to transpose the referenced material up or down by a specified number of semitones.

   This lets you transpose a sequence’s playback without affecting the original track material.

7. **Instrument**: Use this pop-up, which is only available for single-track sequence events, to reassign the parent track’s Instrument. A single-track sequence event always plays back with the parent track’s Instrument.

8. **Player**: Determines the assigned Player for the sequence event. This parameter is only visible with the info area open.

   In order for two sequence events to play at the same time in the same time track, they must be assigned to different Players. Each track can use up to 9 Players.

**NOTE**: A similar set of sequence event parameters can also be viewed and edited in the List Window. For details see Sequence Events in the List Window (pg. 103).
With the info area open, you can view and edit the Play Quantize settings for single-track sequence events. These settings are those of the track residing in the referenced sequence or segment—all parent tracks referencing that sequence will be affected by changes.

Click the open/close triangle to open the info area in the Tracks and Pulse Windows.

**ARRANGING/EDITING SEQUENCE EVENTS**

You can work with sequence event blocks in the Track Overview much like any other track data. Simply drag, copy, paste and nudge the sequence events blocks as desired. As mentioned on page 96, you can also graphically adjust the length or number of times the event loops.

NOTE: Deleting the sole remaining sequence event that points to a segment, automatically deletes that segment, removing it permanently from the Sequences Window. You can avoid this by unchecking **Automatically Remove Unused Segments** in the Sequences Window menu.

**The Parent-Child Relationship**

Generally, sequence event material acts as part of the parent sequence that contains it. Even though referenced sequences and segments have their own Meter and Tempo tracks, these tracks are usually ignored when the material plays from a parent sequence. Instead, the meter and tempo information from the parent sequence is used.

NOTE: If a sequence’s Sync Mode is set to “Off,” it will use its Tempo track when playing from a sequence event. See **Sequence Controls** (pg. 53) for details.
CHAPTER 13: Segments, Loops, and Sequence Events

**Opts: Song Track and Keep Sequences End-to-End**

![Sequence event pop-up menu](image)

When selecting a track that contains sequence events in the Tracks Window, the **Opts** pop-up menu displays the following options:

- **Song Track**
  Check this option to copy the tempo information from the referenced sequences (in that track) to the parent sequence. This lets the parent sequence play back with the tempo of the referenced material.
  The parent sequence’s Meter and Tempo tracks are updated automatically if any changes are made to the sequence events contained in the Song Track.
  Each sequence can only have one Song Track. If you already have Song Track enabled for one track, enabling it for another track disables the option for the previous track.

- **Keep Sequences End-to-End**
  When both Song Track and Keep Sequences End-to-End are checked, Vision keeps sequence event blocks neatly together, one after another (the end point of one sequence event is the start point of the following sequence event). This is a handy option when chaining together sequences to make songs.

Dragging, resizing, or changing the number of repeats for any sequence event block (as well as inserting or deleting sequence events), causes existing sequence events to move accordingly.

![Meter and Tempo tracks](image)

Also, the Meter and Tempo tracks of the parent sequence automatically change to match those of the sequence events residing in the Song Track. All meter, tempo, key, and marker events in the referenced sequences therefore end up in the parent sequence. In addition, a marker is automatically inserted at the beginning of each sequence event with the name of the referenced sequence or segment.

**IMPORTANT:** In order for a parent sequence to use both the Meter and Tempo tracks of the sequence events in the Song Track, both options in the Sequence Event pop-up must be checked.
The Opts pop-up also displays "Song Track" and "Keep Sequences End-to-End" in the List Window of any track containing sequence events.

![Figure 13.10: Sequence Event pop-up in List Window](image)

For information about "Lock Event SM PTE Times", see Opts Menu (pg. 262).

**Editing the (Actual) Referenced Material**

You can double-click a sequence event block to edit the referenced sequence or segment. Doing so opens a Tracks Window for the referenced material. If, however, you double-click a single-track sequence event, the default edit window opens instead.

NOTE: Double-clicking a single-track sequence event that references a drum track opens a Pulse Window.

Referenced material is displayed in edit windows in terms of its place within the parent sequence. For instance, if the sequence event starts at bar 5, each of its edit windows display barlines beginning with bar 5, using the parent sequence’s meter. The SMPTE times shown are based on the parent sequence's SM PTE offset and tempo track. There are, however, two exceptions to this:

- If **Options>Local Sequence Times** is checked, editing and playing a sequence event works independently of the parent sequence. Its SM PTE offset, markers, meter, and tempo will all affect display and playback. However, even in this case, playing the parent sequence still ignores meter and tempo information in the referenced sequence or segment.

- If a sequence’s **Sync Mode** is set to "Off," then its tempo is used when playing from a sequence event. However, the SM PTE and bar/ beat/ unit times shown in edit windows will still use those of the parent sequence—unless **Options>Local Sequence Times** is checked.

NOTE: Double-clicking any sequence or segment from the Sequences Window will open it as a normal sequence. It will use its own Meter and Tempo tracks, and all edit windows will use "local" sequence times.

**References**

Remember, it is possible for a sequence or segment to be referenced by many parent sequences. Therefore, editing a referenced sequence or segment affects its playback in all parent sequences.

If you need to keep tabs on how a sequence or segment is referenced, just look in the Sequences Window. The References column lists each reference for both sequences and segments. Although the column displays just one reference at
a time (the first one), you can click in that column for a complete pop-up listing of each track (along with its first bar occurrence) that references it. See Figure 13.11.

**Figure 13.11: Pop-up of sequence event references**

### Nested Sequence Events

A sequence event can contain other sequence events. This is known as having “nested” sequence events. However, this can lead to some confusion when double-clicking a number of sequence events to make edits.

You can, however, check the nesting of sequence event material by Command-clicking the title bar of its Tracks Window (or any edit window). A pop-up will show you the heritage of the sequence event(s). Choosing from the pop-up opens the Tracks Window for that sequence (or a List Window for a track).

For example, assume you have a sequence called “Chorus” that contains a track called “Track 1.” Within “Track 1” is a sequence event referencing a segment called “Ostinato.” Command-clicking the title bar of the “Ostinato” Tracks Window produces a pop-up menu as seen in Figure 13.12.

**Figure 13.12: Nested sequence event**

**NOTE:** The heritage pop-up menu only appears in edit windows when opening a sequence or segment by double-clicking a sequence event from a parent sequence.
Unmaking Sequence Events

This section describes how to unmake a sequence event—which is not the same as deleting it. When you unmake a sequence event, Vision takes the referenced material and places it in the parent sequence.

To unmake a sequence event:

1. **Click on the sequence event block in the Tracks Window to select it.**

   ![Tracks Window](image)

   The track material from the referenced segment is placed in the appropriate tracks in the parent sequence.

2. **Choose Edit>Unmake Sequence Event.**

   ![Tracks Window](image)

   For each track in the sequence event that does not have a matching track in the parent sequence, Vision adds a new track at the bottom of the parent's Tracks Window.

   **NOTE:** If a segment has just one sequence event referencing it, unmaking that sequence event will automatically remove the segment permanently from the Sequences Window. You can avoid this by unchecking **Automatically Remove Unused Segments** in the Sequences Window menu.

   **IMPORTANT:** If, in the Track Overview area, you select a sequence event block that overlaps with other events, Vision selects the overlapped events as well as the sequence event. When any events other than a sequence event are selected, the command in the Do menu read “Make Segment” rather than “Unmake Sequence Event.” To isolate the sequence event from the other events, open a List Window and select it there (see Sequence Events in the List Window (pg. 103)).

When unmaking sequence events, Vision places the track data in tracks with similar names and similar Instrument assignments. This ensures that if you had originally turned track material into a segment from this parent sequence, the original data returns to its previous tracks.
SEQUENCE EVENTS IN THE LIST WINDOW

Sequence events can be inserted and edited from the List Window. The List Window displays a set of sequence event parameters very similar to those found in the info area of the Tracks and Pulse Windows (see Sequence Event Parameters (pg. 96)).

While sequence events are transposed from the info area by a number of semitones (+/-), transposing in the List Window is done by adjusting a transpose value around C3; set it to D3 for instance and the sequence plays back a whole step higher. And while sequence events can be muted and record-enabled from the info area, the List Window can only mute the sequence event.

To select a sequence event in the List Window, click on its selector dot, located to the left of its bar/beat/unit location. Another selector dot, directly to the left of the sequence name, can be double-clicked to open an edit window for the referenced sequence or segment.

Inserting Sequence Events in the List Window

Use the List Window's Insert Event pop-up to insert sequence events. When sequence events are inserted, they reference an existing segment or sequence. If there are no other sequences or segments in the file (aside from the parent), a new segment is automatically created when inserting the sequence event.

Sequence Event Types

Using Vision's Players & Queue Window (see page 113), multiple sequences can be triggered for playback "on the fly." And, you can use the Trigger modes from the Control Bar (page 185), or from an Input Map (page 326), for special gating effects and real-time transpositions.

This real-time interaction can be recorded into a track. What actually gets recorded are sequence events. In addition to basic sequence events (which is what most users will likely encounter), there are special sequence event types that may show up in the List Window—depending on how the sequences were triggered.
Each of the sequence event types, which can also be inserted from the Insert Event pop-up, are described below:

- **Sequence Event**
  This is a basic sequence event; it stops all sequences playing on that Player and plays the referenced sequence.

- **+Sequence Event**
  +Sequence events is similar to a basic sequence event, except that it does not stop sequences already playing on the Player. When you record a performance in Trigger mode, the first key you play records a basic sequence event. Each additional (simultaneous) key you play records a +sequence event. This way, if you play a three-note chord, three copies of the sequence play simultaneously. When you release it and play a new note, the three copies stop, and a new one begins. When you record a performance in Continuous Trigger mode, each key you play records a +sequence event.

- **Gated Sequence Event**
  A gated sequence event is displayed in the List Window with a ± sign. It is like a +sequence event, but it has a duration. It starts the current sequence playing on the current Player, transposed as indicated, and stops it after the duration indicated. Every note played in Gated mode records one gated sequence event.

- **Stop Sequence**
  A Stop Sequence event is recorded in Vision by typing Shift-Return during playback. It stops all sequences playing on the indicated Player.

- **Transpose**
  This inserts a transpose event, not a sequence event. It transposes all sequences playing from the parent track, regardless of the Player being used. This event cancels any previous transposition value and sets a new one.

### SUBSEQUENCES— THE OLD WAY

Vision 3.5 and earlier used to use subsequences, not segments. Instead of “making” segments, subsequences were made and they resided within their parent sequence. In addition, when inserting or step recording sequences, the referenced, original sequence was cloned and placed in the parent sequence.

Subsequences did not appear in the Sequences Window. Therefore, the only way to view and edit them was to double-click them from their parent sequence.

When opening older Vision files, each occurrence of a subsequence is converted into a segment, which then resides in the Segments Section of the Sequences Window. Also, within each parent sequence a sequence event is inserted that points to the newly converted segments.
Although the older files should play as before, realize that the new sequence events work as aliases that point to the sequences and segments in the Sequences Window.
CHAPTER 14: Generated Sequences

GENERATED SEQUENCES

Generated sequences are a special class of sequences. Vision uses these sequences to generate new and interesting music from existing notes and rhythms.

Use generated sequences to create:
• ostinato patterns
• random percussion parts
• experimental track morphings (superimpose rhythms from one track onto pitches from another)

To open a new generated sequence, choose New Generated Sequence from the menu in the Sequences Window.

The Generated Sequences Window has some similarities to the Tracks Window—such as fields for Meter, Tempo and Sequence length, Edit In/Out points, and even a Record column (for an explanation of these items, please see Chapter 25: The Tracks Window).

NOTE: Generated sequences are listed in the Sequences section of the Sequences Window, and can also be saved as Sequence Templates.

Generated sequences consist of a Note track and Rhythm track. The Note track stores notes, chords, and even sequence events. The frequency at which the events in the Note track play back is determined by the Attack Mode; the durations for these events is determined by the Duration Mode.

If the Attack Mode pop-up is set to Rhythm track, the events in the Note track play back with the rhythms stored in the Rhythm track. The actual order in which the data in both tracks play is determined by the Order pop-up.

For right now you don't need to know about all of the details for each of these options (they are discussed in Generated Sequence Components (pg. 109)).
best way to learn about generated sequences is to actually make one and experiment with some of the possibilities.

Creating a Generated Sequence

The following example shows how to create a very basic generated sequence, one which uses the notes in a C major scale:

1. **Choose New Generated Sequence** from the menu in the Sequences Window.
   The Generated Sequences Window opens.

2. **Set the Record Mode pop-up in the Control Bar to Step Replace**, then Record enable the Note track in the generated sequence.

3. **Click the Record button in the Control Bar.**
   Vision enters record mode and the Step Window opens. Set the Step Size to eighth notes.

4. **Using your MIDI controller, play in a C major scale (starting with C3 and ending with C4).**
   The notes are step recorded into the Note track.

5. In the pop-ups for **Attack and Duration**, select **Note track**.
   ![Note track pop-up](image)

   This configures the Note track to play back with its own rhythm and durations.

6. **Set the sequence length to 2** and turn on loop. Click the **Play** button in the Control Bar.
   ![Sequence length](image)

   The sequence loops through the notes in the C major scale.

7. **Next select Random from the Note track’s Order pop-up.**
   ![Order pop-up](image)

   The notes are played in random order.

8. **To break up the monotony of the Note Tracks’ rhythm, select Random in the Duration Mode’s pop-up and set the fields to 1, 2, and 16th notes.**
   ![Duration mode](image)

   The notes are randomly played back every 8th or 16th note.

9. **Click the Stop button in the Control Bar to stop playing.**
The previous example represents just the tip of the iceberg in terms of possibilities for generated sequences. If desired, you could have recorded a Rhythm track and used its timing, even in random order. And instead of just single notes, you could have recorded chords or even sequence events into the Note track.

**GENERATED SEQUENCE COMPONENTS**

The following sections discuss each of the main components used in generated sequences, which include Attack Mode, Duration Mode, Note and Drum Tracks, and Order Mode.

**Attack Mode**

The Attack Mode determines how Vision generates the timing used for playing the notes from the Note track. The following choices are available from the Attack Mode pop-up:

- **Rhythm Track**
- **Note Track**
- **Constant**
- **Random**

**Rhythm Track**

The Note track plays back with the rhythm of the Rhythm track. Use the Velocity value to influence the note velocities (100% uses only the Rhythm track velocities, 0% uses only the velocities in the Note track; intermediate values average the two). Click the Quantize toggle to enable Grid Quantize for the Rhythm track’s playback.

**Note Track**

The Note track plays back with its original timing. Click the Quantize toggle to enable Grid Quantize for the Note track’s playback.

**Constant**

Notes from the Note track are played at a constant rate, as specified by the number of note values. In the above example, Vision generates a note every eighth note (i.e., every 2 sixteenth notes).

**Random**

Notes from the Note track are played at a random rate, based on the range specified in the fields. In the above example, Vision...
PART 4: Advanced Concepts

110 Opcode Systems, Inc.

generates a note every eighth note (1 x 8), quarter note (2 x 8), or dotted quarter note (3 x 8).

Duration Mode

The Duration Mode determines how Vision generates durations for the notes in the Note track. The following choices are available from the Duration Mode pop-up:

Rhythm Track

The durations from the Rhythm track are used for playing the notes in the Note track. Click the Quantize toggle to quantize the durations in this track.

Note Track

The Note track plays back with its original durations. Click the Quantize toggle to quantize the durations in this track.

Constant

The notes in the Note track play with durations that are constant, as specified by the number of note values.

Random

The notes in the Note track play with random durations, as specified by the range in the fields. The above example randomly chooses between eighth notes (1 x 8), quarter notes (2 x 8), dotted quarters (3 x 8), and half notes (4 x 8).

Constant Gap

The Note track plays back with a constant gap between each note. The gap size is specified by the number of note values (for instance, 2 eighth notes =1 quarter note gap).
CHAPTER 14: Generated Sequences

Random Gap

The Note track plays back with a random gap between each note, as specified by the range in the fields.

Percent

The Note track plays back with note durations that are a percentage size. A value of 100% results in legato; use over 100% for notes that overlap; durations under 100% result in gaps between the notes.

Random Percent

Similar to the Random setting, this option sets the durations to a random percentage value within the specified range.

FOR ILLUSTRATIONS of gap and percent settings, see the section on Duration (pg. 339) in Chapter 36: The Step Window.

Generated Sequence Tracks

Tracks in a generated sequence include Meter, Tempo, Rhythm, and Note. Meter and Tempo tracks work just as they do in regular sequences.

The Note and Rhythm tracks are recorded just like tracks are in the Tracks Window. You can also edit these tracks or paste data into them from other sequences.

Rhythm Track

The Rhythm track, which is optional, stores rhythmic patterns that can be assigned to the notes in the Note track. The Rhythm track is only used if the Attack Mode or Duration Mode is set to Rhythm Track. Otherwise, it is ignored.

When recording or pasting into the Rhythm track, the only events recognized are notes, chords, patch and sequence events (other data types are discarded). It is only the durations and spacings of these events that is significant—Vision ignores all other information during playback.

Note Track

The Note track stores the notes, chords, patch and sequence events that Vision uses to generate the sequence. The Rhythm Mode determines the spacing of the events, the Duration mode determines their durations.
When recording or pasting into a Note track, Vision removes all events except notes, chords, patch events, and sequence events. The durations and spacings are not significant unless the Attack Mode or Duration Mode is set to Note Track. Otherwise, the original durations and spacings are ignored.

**Order Mode Pop-up**

The Order Mode pop-up determines the order in which the contents of the Note track and Rhythm track are played. The choices available from this pop-up are:

- **Forward** plays track events in their original order.
- **Reverse** plays track events in reverse order.
- **Alternate** plays track events in their original order, then in reverse order. First and last events are only played once.
- **Random** plays track events in random order.

**Looping Generated Sequences**

There are a few things you need to know about looping tracks in a generated sequence. Unlike normal tracks, the length of a track is not important in a generated sequence—the number of events is what matters.

An unlooped generated sequence stops playing after it has played all of the events in an unlooped Note track. However, if its Order Mode is set to Alternate, Vision plays twice as many notes since it plays through the data twice.

If the Note track is looped, the generated sequence plays for its Sequence Length (or indefinitely if the sequence is looped or set to infinity).

When using a Rhythm track that isn’t set to loop, the generated sequence stops at the end of the Rhythm track. This of course depends on the Order Mode of the Rhythm track, just like with the Note track.
CHAPTER 15: Players and Input Effect

PLAYERS & QUEUE WINDOW

Sequences can be triggered for playback by typing their assigned key equivalent, or you can use the sequence's MIDI Key. With the Players & Queue Window, you can “queue up” several sequences to audition a playback order, and you can even have multiple sequences playing at the same time on different “Players.”

![Figure 15.1: The Players & Queue Window](image)

Queue Mode

When the Queue option is checked, you can type up to 12 sequence letters, placing them in a “queue.” When the current sequence is finished playing, the next sequence in the queue is played. This is useful for auditioning different arrangements of your sequences.

NOTE: If you trigger a sequence whose length is set to infinity, that sequence will play forever (unless stopped) and other sequences in the queue will never play.

If the Queue option is unchecked and you type a new sequence letter, Vision stops the current sequence and plays the new one.

Players

The Players & Queue Window has up to 9 Players, each of which can play its own sequence. Therefore you can have up to 9 sequences playing simultaneously from the Players & Queue Window.

Each of the players has its own queue for up to 12 sequences. When Queue is enabled, typed sequences are entered into the queue of the currently selected Player. To switch to another Player, click on its number in the Players & Queue Window—or simply type the Player’s number.

NOTE: Typing a Player’s number switches to that Player only if the Players & Queue Window is open.
NOTE: When using the Control Bar to play a sequence that has a record-enabled track, that sequence is not played by a Player. It therefore will not be interrupted by typing another sequence key.

Following is a short example of how to queue up multiple sequences from the Players & Queue Window:

① Choose Windows>Players & Queue.
   The Players & Queue Window opens.
② Make sure the Queue option is checked (enabled).
③ Select a Player by clicking its number, or by typing its number.
④ Type the sequence keys you’d like played on the current Player.
   The first typed sequence plays and the others are placed in the queue.
⑤ To play other sequences simultaneously, switch to a different Player and type the desired sequence keys.

Sync Mode Affecting Playback

To trigger a sequence’s playback “on the beat,” instead of when you type the sequence letter, set the sequence’s Sync mode to Start. If you want the sequence to play with its own tempo setting, independent of the Master Tempo, set the sequence’s Sync mode to Off.

Stopping a Player

Typing the Return key stops all Players and clears all queues.

However, you can type Shift-Return to stop the sequence on the current Player. If there are more sequences in that Player’s queue, the next sequence in the queue begins playing.

Trigger and Transpose Modes

You can use Vision’s Trigger modes to affect how sequences play back when triggered in real time. These special Trigger modes can be accessed from the Thru Instrument pop-up in the Control Bar.
(see page 185), or they can be defined as part of a key zone in an Input Map (see page 326). Depending on the particular Trigger mode, sequences can be transposed “on the fly” by playing different notes on your MIDI controller, or they can be gated with the duration of played notes.

Playing multiple sequences, with or without the Trigger modes, can be recorded into a track. The events recorded are not actual notes but sequence events describing how the sequences were triggered for playback. For a description of the various sequence event types, see Sequence Event Types (pg. 103).

INPUT EFFECT WINDOW

The Input Effect Window processes notes from your MIDI controller. Depending on the mode of the Input Effect, the processed notes are either repeated or arpeggiated. The rhythm of the notes played can use either Grid or Groove Quantize values.

Choose Windows>Input Effect to open the Input Effect Window:

Following is a description of the components in the Input Effect Window:

1. **Enable**: Click this toggle button to enable the Input Effect.

   The Input Effect can also be enabled by selecting **Setups>Enable Input Effect**. In addition, the Input Effect can be enabled “on the fly,” temporarily, with the Input Effect MIDI Key (see page 173).

2. **Input Effect type**: This pop-up determines which Input Effect is used.

   “Arpeggiate” plays the notes one after another, based on the setting in the Order pop-up.

   “Repeat” plays repeated notes.

3. **Latch**: When checked, you can play a chord and remove your fingers from the keys—the input effect will continue to play until you strike a new set of notes.

4. **Sync to Counter**: Check this option if you’d like the Input Effect to play in sync with the Counter (and current sequence).

   The placement of the played notes is determined by the Spacing value. If it’s set to 8th notes, for instance, notes are played on every 8th beat.
PART 4: Advanced Concepts

5 **Order**: Determines the order of notes played with the Arpeggiate mode.
   “Up” plays the notes in ascending order (lowest notes first).
   “Down” plays the notes in descending order (highest notes first).
   “Alternate” plays the notes up and then down. First and last events are played just once.
   “Random” plays the notes in random order.

6 **Octaves**: For Arpeggiate mode, expands the range of notes played by a specified number of octaves (up to 3).

7 **Spacing**: Determines the rhythmic spacing of the played notes. Click on this pop-up to specify the duration when using Grid, or the “Groove Source” when using Groove. Command-click the pop-up to switch between Grid and Groove. To see the full set of Spacing (Quantize) parameters, click the open/close triangle.

8 **Duration**: Specifies the duration of the played notes.
   “Independent” sets the duration independently of the Spacing size. The value can be specified by a note duration or number of units.
   “Spacing Minus Gap” lets you set the rest space (gap) between notes. The gap can be specified by a note duration or number of units.
   “Percent of Spacing” sets the duration to a specified percentage of the Spacing size.

9 **Open/Close Triangle**: Click this toggle to open and close the lower portion of the Input Effect Window.

With the lower portion open, all of the Spacing’s Quantize parameters are accessible. For a description of these parameters, see Quantize Parameters (pg. 129).

**Configuring the Input Effect Window**

The following example shows how to configure the Input Effect as an arpeggiator:

1. **Choose Windows>Input Effect.**
   The Input Effect Window opens.
2. **Enable the Input Effect by clicking its toggle, and set the mode to Arpeggiate.**

   ![Input Effect Window](image)
3. Set the Spacing value to 16th notes.

If the Spacing mode is set to Groove, Command-click on the pop-up to switch to Grid.

4. Set the Duration pop-up to Percent of Spacing.

Then type in a value of 50%. This will make the notes play back with a duration of 60 units (half that of the spacing), adding a staccato feel.

5. Select Alternate from the Order pop-up.

6. Enable the Latch option by clicking its checkbox.

7. Play a chord on your MIDI controller.

The notes are played arpeggiated in forward and then reverse order.
You don’t have to hold the chord down since Latch is enabled.

8. Play a different chord on your MIDI controller.

The previous set of notes from the first chord automatically stop and the new notes are arpeggiated.

9. Enter a value of +1 in the Octaves field.

The range of arpeggiated notes is doubled by adding an octave for each note in the chord.

10. To stop the Input Effect, uncheck the Latch option.

Recording with the Input Effect

If the Input Effect is enabled while recording, notes played by the Input Effect are recorded. Enable Sync to Counter to ensure that each note is recorded precisely on the beat, or disable it if you want the notes recorded as you trigger them—either way, the Input Effect uses the tempo of the recorded sequence (and the distance between the notes is determined by the Spacing settings in the Input Effect Window).

Setting the Input Effect to Repeat works well for recording repeated rhythmic notes and drum rolls. You can even apply aftertouch pressure to affect the velocity of the played notes (check the option for “Aftertouch Sets Effect Velocity” in the Settings Window).
For details on using the Input Effect while recording, see Drum Machine Style Loop Recording (pg. 45).
CHAPTER 16: Select & Modify

Use the Select & Modify Window to perform precise and exacting selections and edits. This window offers such a wide range of capabilities you can even store and recall Select & Modify Templates with your favorite settings (see Chapter 20: Templates).

The Select & Modify Window has primarily two functions: (1) to select data and (2) to modify it. The upper portion of the window determines the selection criteria for the data, the lower portion of the window determines the type of modification performed.

Since both portions of the Select & Modify Window can be opened and closed by clicking the corresponding triangle ( ), you can use either function of the window—or both.

When invoking some of the commands in the Do menu, the Select & Modify Window opens and is automatically configured for that task. This is the case with Transpose, Quantize, Modify, Reassign, Set Instrument, and Substitute.

If you choose Do > Select > Select by Rule, the Select & Modify Window opens with just the “Select” function activated.

![Figure 16.1: Select & Modify Window]

![Figure 16.2: Set Instrument]

![Figure 16.3: Select by Rule]
PART 4: Advanced Concepts

The Select & Modify Window can also be opened by choosing *Windows>Select & Modify*. Doing so opens the window in its most recent state.

No matter how the Select & Modify Window is accessed, its upper and lower portions can always be opened and closed. And you can always completely reconfigure either the selection criteria or the modify task as desired.

**SELECT & MODIFY WINDOW**

![Select & Modify Window](image)

Following is a brief description of the items in the Select & Modify Window:

1. **Event Type pop-up**: Specifies the type of events from which to select. Depending on the range of events selected, these can include events (all), note events, audio events, and various automation events.

The events available from this menu are those residing in the selected track or sequence. If the selected track or sequence contains more than one event type, “Events” appears selected by default.

2. **Select area**: Displays attribute lines that further define the selection.

   - Click the add button to add an attribute line.
   - Click the remove button to remove a line.

3. **Modify Type pop-up**: Specifies the modify type used. The available Modify types in this pop-up menu are determined by what's selected in the Event Type pop-up. See *Modify Types* (pg. 124) for a complete list.

4. **Modify area**: Displays all parameters for the specified Modify type.

5. **Select button**: Selects events based on the attributes listed in the Select area.

6. **Add To button**: Adds events (matching the attributes in the Select area) to the current selection.

7. **Refine button**: Further refines the current selection using the attributes in the Select area.

8. **Modify button**: Performs the modify function as described by the parameters in the Modify area. The name of this button changes depending on the Modify type (Quantize, Move, Reassign, Delete, etc.).

   IMPORTANT: Clicking this button automatically selects the material based on the attributes in the Select area (if the Select area is open).
Double button: Performs the modify function on a copy of the selection, leaving the original data unaltered. When the Modify type is set to Transpose, this button is named Harmonize.

IMPORTANT: Clicking this button automatically selects the material based on the attributes in the Select area (if the Select area is open).

Undo/Redo button: Undoes or redoes the most recent modify function. This command is also available at the top of the Edit menu.

IMPORTANT: If selected tracks or sequences contain sequence events, material referenced by the sequence events is also affected by Select & Modify operations.

Select & Modify Buttons

The buttons in the Select & Modify Window are active even if the window is not in front. You can click on the Quantize or Transpose buttons, for instance, and the window won't come to the front.

SELECT ATTRIBUTES

The Event Type pop-up specifies the type of events selected from. Attribute lines allow further refinement of the selection. For instance, you could specify "Notes" in the Event Type pop-up and then you could add an attribute line for selecting only notes that fall within a certain velocity or pitch range.

![Figure 16.5: Select Attributes](image)

Click the add button (+) to add an attribute line in the Select area. The type of attribute is chosen from the pop-up in the new line. The line can be removed by clicking the remove button (-).

NOTE: The available attribute types is determined by what's selected in the Event Type pop-up.
Attribute Types

Following is a list of attribute types:

- **Position**: Selects events based on their location or time range.
- **Event Type**: Selects events based on their event type.
- **Pitch**: Selects note events based on their pitch range.
- **Velocity**: Selects note or audio events based on their velocity range.
- **Duration**: Selects note or audio events based on their duration.
- **Value**: Selects continuous controller events based on their value, or range of values.
- **Instrument**: Selects events based on their assigned instrument.
- **Position in bar**: Selects events based on their quarter note/units position within a bar.
- **Position in beat**: Selects events based on their beat position, as specified by a number of units (+/-) from the beat boundary.
- **Position is between bracketed events**: Selects events that occur between two specified event types.
- **Position in every group**: Selects events based on their numeric position within a sequential group of events (i.e. position in every group of “4” of these events is “3”).

Attribute Conditions

Part of each attribute line is its conditional statement, which gives you even more flexibility in defining the selection. The following conditionals are available:

- **is**
  - Includes events only if they have one specified value.
- **is not**
  - Includes events if their value is anything except a particular value.
- **is... or less**
  - Includes events equal or less than a certain value.
- **is... or more**
  - Includes events equal or more than a certain value.
- **is from... thru**
  - Includes a range of events.
- **is not from... thru**
  - Excludes a range of events.
- **is... or**
  - Includes two different values to search for.
Making a Selection

The following example illustrates some of Vision’s selection capabilities.

In this example we want to select some hi-hat notes that are too loud so we can edit just them, and not the other notes in the track. We know that they are somewhere in bar 2 and have velocities around 100 or higher.

1. Select the desired track and choose Do>Selection>Select by Rule.
   The Select & Modify Window opens configured for Select.
2. Click the add button (+) to add an attribute line.
3. Make the new line read Position is from.
   Specify “2·1·0 thru 3·1·0” for the Position range.
   This determines that we will only select notes from bar 2.
4. Add another attribute line and make it read Pitch is F#1.
   This specifies that only the hi-hats (F#1) are selected.
5. Lastly, add a line that reads Velocity is 100 or more.
   This last line specifies that only notes with velocities equal to 100 or more are selected.
6. Click the Select button to make the selection based on the defined attributes.
   The notes are selected based on the specified attributes.

Figure 16.6: Selected notes in Graphic Window

Figure 16.7: Selected notes in List Window
MODIFY TYPES

The Modify Type pop-up determines which modify operation is performed, and which parameters are displayed in the Modify area.

NOTE: The available Modify types are determined by what's selected in the Event Type pop-up.

Figure 16.8: Modify type and parameters

The following Modify types are available:

- **Transpose**: Transposes or remaps the pitches of selected note events with any of 9 Transpose types (discussed on page 134).

  Click the **Harmonize** button to transpose a copy of the selected material, leaving the original data unaltered.

- **Change Velocity**: Adjusts the velocities of the selected note or audio events.

- **Change Release Velocity**: Adjusts the release velocities of the selected note events.

- **Change Duration**: Adjusts the durations of the selected note or audio events.

- **Quantize**: Quantizes the specified events with either Grid or Groove Quantize.

  NOTE: When “Events” is selected in the Events Type pop-up, Quantize only affects note, audio, and sequence events. All other event types (like continuous controllers) must be specified in the Events Type pop-up before they will be Quantized.

  For a description of each Quantize parameter, see Quantize Parameters (pg. 129).

- **Change Value**: Adjusts the values for the selected continuous controller events. For details, see Modifying Note Properties and Automation Values (pg. 126).

- **Set Density**: Adjust the density of the selected continuous controller events. For details, see Set Density (pg. 127).

- **Reassign**: Changes one continuous automation type (MIDI controllers, pitch bend, aftertouch, velocity scale, audio volume and pan, send levels, continuous EQ parameters, and continuous plug-in parameters) to another. For details, see Reassign (pg. 127).

- **Move**: Moves selected events to a specific location, or by any increment forward or back. For details, see Move Events (Command-) (pg. 413).

  Click the **Double** button to move a copy of the selected data, leaving the original data unaltered.
• **Trim Start Time**: Changes the start times of note and audio events without changing their end times. For details, see Trim Start Time (pg. 129).

• **Set Instrument**: Sets the Instrument for selected events. For details, see Set Instrument (Command-I) (pg. 418).

  Click the Double button to assign a copy of the selected data to a new Instrument.

• **Substitute**: Replaces selected events with the contents of the Clipboard. For details, see Substitute (pg. 419)

• **Delete**: Deletes the selected events.

---

**SELECT & MODIFY MENU**

- **Save Settings**
  Stores the configuration of the Select & Modify Window to the currently selected template.

- **Save Settings As**
  Stores the configuration of the Select & Modify Window to a new template. With this command you are prompted to name the new template.

- **Delete Template**
  Deletes the currently selected template.

- **Load From**
  Lets you load a set of templates from a Vision Editing Templates file that is not current. The loaded templates are merged with the current set.

---

**Templates**

The current set of templates is listed at the bottom of the Select & Modify menu. These templates represent those stored in the Vision Editing Templates file.

**NOTE:** The items listed in the Select & Modify menu are also available from the Do menu (when the Select & Modify Window is the active window).
PART 4: Advanced Concepts

MODIFYING NOTE PROPERTIES AND AUTOMATION VALUES

With the Modify Type pop-up set to Change Velocity, Change Release Velocity, Change Duration, or Change Value, the following operations are available:

- **Set to**
  Sets the note property or continuous controller value to a specified amount.

- **Scale by**
  Scales the note property or continuous controller value by a specified percentage.

- **Add**
  Adds to the note property or continuous controller value by a specified amount.

- **Max Limit to**
  Note properties or continuous controller values above the Max Limit value are reduced to that value.

- **Min Limit to**
  Note properties or continuous controller values below the Min Limit value are increased to that value.

- **Compress**
  Compresses or expands the data range while keeping the relationship between existing events proportional. With this command you can specify an upper and lower region for which events are selected, and an upper and lower region for the range of compression.

- **Set Legato to**
  (Change Duration only)
  Modifies the space between notes by a percentage of the distance between their note-on locations.

**Change Methods**

When modifying note properties or controller data, values can be specified as Constant, Changing, or Oscillating:

- **Constant** sets a constant data value for all events within the selected time range. This is just like using the Flat drawing shape in the Strip Chart (see page 247).

- **Changing** sets a start and end value for the selected range of data. The shape determines how values are drawn for events between the start and end points. For a description of the Change shapes, see The Edit Shapes Pop-up (pg. 246).
CHAPTER 16: Select & Modify

Oscillating sets a start and end value for the selected range of data. The oscillator determines how values are drawn for events between the start and end points. The period of the oscillator is specified by a number bars, beats, or units. For a description of each oscillator type, see Oscillator Shapes (pg. 247).

Controller Values

When the Change is modifying controller values, you can also specify the density of the data, and which Instruments are affected. See Figure 16.12

SET DENSITY

The density of data for continuous controller events (MIDI controllers, pitch bend, aftertouch, and other automation events) can be modified with Set Density.

The selected data is affected by the specified percentage (of the MIDI data stream). If the original events were entered at 5% for instance, using Set Density with 10% would make the data twice as dense.

NOTE: Set Density is only available if the Event Type pop-up in the Select Area is set to a continuous controller type.

REASSIGN

Reassign changes one continuous controller type (MIDI controllers, pitch bend, aftertouch, velocity scale, audio volume and pan, send levels, continuous EQ parameters, and continuous plug-in parameters) to another.

Continuous parameters are those parameters that have a numerical range of values. Parameters whose possible settings are on/off, etc. are not continuous,
and will not enable the Reassign command or appear as destinations that continuous controllers can be assigned to.

Events can be changed to any MIDI controller, pitch bend, aftertouch, velocity scale, audio volume and pan, send level, continuous EQ parameter, or continuous plug-in parameter (if a plug-in is assigned).

**NOTE:** Reassign is only available if the Event Type pop-up in the Select Area is set to a continuous controller type.

Reassign submenus have the following options:

- **MIDI**
  - Contains pitch bend, aftertouch, poly aftertouch, velocity scale, a generic “controller” option, and the eight Favorite Controls (as defined in the Settings window. When “Controller” is selected, controller #7 (Volume) is chosen by default. You can then click on “Volume” and select a new controller from the pop-up that appears.
  - **Automation**
    - Contains audio volume, audio pan, and send levels.
  - **EQ Band Parameter**
    - Contains only continuous EQ parameters. Note that EQ Type and Enable, the other two EQ parameter types that are available in the List window, are not available here because they are not continuous events.
  - **Plug-in Parameter**
    - Contains the names of plug-ins assigned to audio instruments in the sequence. After choosing a plug-in, another pop-up appears to the right displaying the selected plug-in’s parameters. Because of the way that VST plug-ins are written, all parameters are considered continuous, so all parameters are listed in this pop-up.
Depending on the event types chosen in the Select and Reassign areas, another pop-up menu may appear asking which instrument the events should be reassigned to. The Instrument may be Audio or MIDI, depending on the event type chosen in the Reassign area. If the instrument pop-up is not shown, the reassigned events will be assigned to the same instrument that the selected events were assigned to in the first place.

For example, if you wish to reassign audio volume to audio pan, the Instrument pop-up won’t appear because audio pan defaults to the same Instrument that the selected audio volume is assigned to.

If, on the other hand, you wish to reassign audio volume to mod wheel (MIDI controller #1), the Instrument popup will appear.

The default Instrument (the Instrument that the selected events are assigned to before the Reassign command is executed) is an Audio Instrument, and MIDI controllers cannot be assigned to Audio Instruments. So, you are prompted to select a MIDI instrument. Click and hold on the Instrument name to see a pop-up of available instruments.

**TRIM START TIME**

This command changes the start times of note and audio events without changing their end times.

![Figure 16.15: Trim Start Time](image)

You can trim the start times earlier or later by a specified amount, or you can move them to start at a precise location. Values for the move can be in “bars & beats” or “SMPTE time,” as specified by the Trim by popup.

**QUANTIZE PARAMETERS**

This section describes the Quantize parameters for both Grid and Groove. In addition to the Select & Modify Window, the Quantize parameters are found in the info area (of the Tracks and Pulse Windows) when viewing track Play Quantize settings, and in the Input Effect Window’s Spacing settings.

NOTE: For a more general discussion of Quantize procedures, for both Grid and Groove, see Chapter 10: Quantize, Shift, and Nudge.

For information on Quantize Templates and creating or modifying the Vision Grooves file, see Chapter 20: Templates.
Use the Quantize Type pop-up to switch between Grid and Groove. The available parameters change depending on the selected Quantize type.

**Grid Parameters**

- **Quantize Value**
  - When using Grid, the Quantize Value determines the grid size used for the quantize. This value can be specified with a duration from the note pop-up, or with a number of units.

- **Strength**
  - The Strength setting determines how far notes are moved from their current location toward the quantize boundary. There are no negative settings.
    - A setting of 100% aligns selected notes on the quantize boundary.
    - A setting of 0% leaves the notes unchanged.
    - Other settings move selected notes the specified percentage toward the quantize boundary from their current location.

- **Sensitivity**
  - The Sensitivity setting defines a region in which notes are either selected (positive values) or excluded (negative values) from being quantized.

**Grid**

Check the Grid option to define the grid size as a tuplet.

The grid size is calculated from the Tuplet fields and the Quantize Value. If the Quantize Value is set to 8th notes, for instance, and the Tuplet specifies “5 in time of 1,” then the grid size is equal to one fifth of the 8th note value (or 48 units).

**Tuplet**

Check the Tuplet option to define the grid size as a tuplet.
The Sensitivity value is expressed as a percentage that, at a maximum setting of ±100%, defines a region equal to the Quantize Value. This region extends half the distance from the quantize boundary to the next and previous quantize boundaries, respectively (see Figure 16.20).

NOTE: Since this maximum region exists for every quantize boundary in the area selected for quantization, neighboring regions are contiguous.

Positive and negative values for Sensitivity define the same region but perform inverse actions, both achieving useful but different musical effects:

- **Positive values:** Notes located within the region defined by the selected percentage are quantized. Notes beginning outside this region remain unchanged. This synchronizes notes near the quantize boundary but treats notes further from the boundary as deliberate phrasing accents.

- **Negative values:** Notes located within the area defined by the selected percentage remain unchanged. Notes outside this region are quantized. This considers notes close to the quantize boundary as deliberate phrasing accents and treats notes outside the region as mistakes.

- **-100%:** Although this setting creates the maximum region size, no quantize occurs.

- **0%:** No quantize occurs.

- **100%:** All notes are selected for quantize.

For example, a 50% Sensitivity setting applied to a Grid Quantize Value of 8th notes defines an area 120 units wide (50% of an 8th note), extending 60 units ahead and behind the quantize boundary. Figure 16.21 illustrates this region. Notice that the note is not selected because it doesn’t begin in the region.

When using Groove Quantize, the regions created from a Sensitivity setting may be unequal in size. They may also surround the quantize boundaries asymmetrically due to the irregular size of the grid ele-
ments created from the Groove Source. Although the exact region is harder to define, it doesn’t change the way the Sensitivity works. See Groove Parameters (pg. 133).

Smear

Smear adds randomness to the selected notes by moving them backward or forward in time after the defined quantize occurs. Values are selected randomly within the range specified by the Smear percentage to the Quantize Value.

For example, a smear value of 50% with a Quantize Value of quarter notes could result in a note appearing up to a 16th note before or after the quantize boundary. Smear also affects durations if Quantize Durations is checked.

Shift

The Shift setting is applied after the defined quantize operation occurs. Shift values range between -999 and 999 units.

- A negative shift moves the post-quantized notes earlier in time.
- A positive shift moves the post-quantized notes later in time.

Swing

Jazz musicians often play written 8th notes with a “swing” feel resulting in pairs of notes with durations between the triplet and dotted rhythms (see Figure 16.22). Other durations can also be swung but 8th notes are the most common.

![Figure 16.22: Triplet and dotted representations for swung 8th notes](image)

The two notes occupy the same amount of time as two “straight” durations, but their relative durations are different. The Swing setting shifts every other quantize boundary in the selection forward or backward in time to reflect the unequal division of duration between each pair of notes. A swing value of 50% is the same as no swing at all. Raise the swing percentage to add a swing beat.

Quantize Durations

If this option is checked, the durations of notes are quantized to the closest multiple of the Quantize Durations amount. This number is also the minimum note size—notes will not be quantized to zero.
The Duration Quantize Value does not necessarily have any relation to the Quantize Value, but the default amount is the same. The procedure for setting Quantize Duration parameters is the same as discussed in Quantize Value (pg. 130).

**Groove Parameters**

![Figure 16.23: Groove Quantize parameters](image)

**Groove Source**

*Groove Quantize* can dramatically improve the musical integrity resulting from a quantized performance by using irregular, non-linear quantize boundaries derived from a “Groove Source.” A Groove Source is a normal Vision track selected from a sequence stored in the “Vision Grooves” file (a normal Vision document that must be located in the same folder as the Vision application). The notes in the Groove source act as a rhythmic template by imposing their rhythmic values in a one to one correspondence with the notes in the track being quantized.

Select any sequence from the Vision Grooves file from the **Seq** pop-up. Each track in the selected sequence becomes available as a Groove Source from the **Track** pop-up.

The **Sensitivity**, **Strength**, **Shift**, and **Smear** parameters work as previously discussed in Grid Parameters (pg. 130).

**Duration and Velocity**

The *Duration* and *Velocity* fields allow the durations and velocities of notes in the Groove Source to influence the quantize. Resulting values for both fields are calculated in the same manner:

- A value of 100% uses the velocities or durations from the Groove Source.
- A value of 0% leaves durations or velocities unchanged.
- Intermediate values combine the velocities or durations of the Groove Source track and the track being quantized:

\[
X \cdot D + (100 - X) \cdot Q.
\]

For example, if a note in the Groove Source has a duration of 80 units, and the corresponding note in the track being quantized has a duration of 100 units, and the Duration field is set to 75% then the actual duration used is

\[
.75(80) + (1.0 - .75)(100) = 85 \text{ units}.
\]
This section discusses each of the different Transpose types and their parameters. The Transpose parameters appear in the Select & Modify Window, and when assigning a Transpose Map in the Instruments Window.

NOTE: For a general discussion of Transpose operations, see Chapter 11: Transpose. For details on creating Transpose Templates, see Chapter 20: Templates.

Use the Transpose Type pop-up to specify which type of transpose is used. The available parameters change depending on the selected Transpose type.

**Chromatic**

Transposes up or down by a specified interval (also displayed as a number of semitones). Enter a value in the Octaves field to extend the transposition by a number octaves.

**Interval**

Transposes chromatically by semitones, as expressed by the difference between the two specified pitches.

**Diatonic**

Transposes up or down by scale degrees in a specified key and scale type. Enter a value in the Octaves field to extend the transposition by a number octaves.

Click the Constrain to Scale option to restrict all transposed notes to the specified key and scale.
CHAPTER 16: Select & Modify

**Invert**

![Figure 16.28: Transpose type set to Invert](image)

Invert creates a mirror transposition (chromatically or diatonically) around a specified pitch.

**Auto Map**

![Figure 16.31: Transpose type set to Auto Map](image)

Auto Map lets you specify the number of notes per octave for source and destination maps. Use Auto Map to:

- Transpose all notes to just one note with a 128-note octave mapped to a 1-note octave.
- Perform obscure transpositions like a 24-notes per octave scale to a 12-notes per octave scale.
- Use an Instrument Transpose Map to play semitones on a device tuned to quarter-tones.

**Key/Scale**

![Figure 16.30: Transpose type set to Key/Scale](image)

Key/Scale transposes from one key and scale type to another. Enter a value in the Octaves field to extend the transposition by a number of octaves.

Click the Constrain to Scale option to restrict all transposed notes to the specified key and scale.

**Octave Map**

![Figure 16.32: Transpose type set to Octave Map](image)

Octave Map is the same as Auto Map except you can specify which notes are contained in the destination octave. To change a destination pitch, click in the fields located in the scrollable Map area.

Before transpose

![Before transpose](image)

After transpose

![After transpose](image)
PART 4: Advanced Concepts

Manual Map

Remaps any of the 128 MIDI pitches to any other pitch. To change any destination pitch, click in the fields located in the scrollable Map area.

Drum Map

Remaps drum assignments from one Instrument to another. Drum Map is essentially the same as Manual Map except that note names are displayed instead of pitches.

This Transpose type is very useful for remapping tracks in Vision so they play correctly from one device to another. For instance, if you have a track assigned to your Roland R-8, you could use a Drum Map to make it play back correctly on your Korg M-1.

A Drum Map can be used destructively with the Transpose command (permanently altering the note data), or for playback only as a Transpose Map assigned in the Instruments Window.
CHAPTER 17: Tempo, Time Scale, and Reclock

VIRTUAL CONDUCTING—RECORDING TEMPO CHANGES

Recording a MIDI performance usually means playing along with a metronome. Of course you don’t need to—but if you don’t, Vision has no reference for accurately displaying and editing your tracks.

Vision can, however, address material recorded without a metronome using the Reclock command (see page 142). You can also use the Scale Time command (see page 140) for global or bar-by-bar tempo adjustments.

If you use a metronome while recording, you may notice that your performances can sound somewhat stiff. The following sections illustrate three ways you can manually record tempo changes to add a “human feel” to these performances—allowing you to “conduct” a sequence after you have recorded it, speeding up and slowing down whenever you want.

Changing the Tempo in the Control Bar’s Tempo Display

If you mute the Tempo track in the current sequence, you can use the Control Bar’s Tempo Display to change the Master Tempo. If you change the Master Tempo while recording, Vision records these changes as tempo events to the sequence’s Tempo track.

To record tempo events from the Control Bar’s Tempo Display:

1. Record-enable the Tempo track in the Tracks Window.
2. Mute the Tempo track in the Tracks Window.

The Control Bar’s Tempo Display becomes editable.

3. Set the Begin Record toggle to Countoff.
4. Click the Record button.
5. Highlight the Tempo Display and set it to the desired tempo as the sequence plays.
   You can use the plus and minus keys on the Macintosh keypad, or you can click and drag with the mouse.
6. When finished recording, click the Stop button.
PART 4: Advanced Concepts

Tapping the Tempo

You can set the tempo in the Control Bar’s Tempo Display by tapping the single quote (’) key on your Macintosh keyboard—you can even record this into the sequence’s Tempo track. When tapping the tempo, Vision averages the last four taps.

To record a tapped tempo:

1. Record-enable the Tempo track in the Tracks Window.
2. Mute the Tempo track in the Tracks Window.
3. Set the Begin Record toggle to Countoff with a value of perhaps 6 to 8 bars.
   This ensures enough time to get the feel of the desired tempo.
4. Click the Record button.
5. Tap the single quote key (’) on your Macintosh keyboard at the desired tempo.
6. When finished recording, click the Stop button.

Using MIDIKeys you can map any MIDI event to the single quote key, thereby allowing you to use it as the source of the tempo tapping. See The MIDIKeys Window (pg. 171) for details.

Using a Fader to Record Tempo Changes

You can also assign a fader to control the Master tempo. Then, while recording, just move the fader to record the tempo changes:

1. Record-enable the Tempo track in the Tracks Window.
2. Mute the Tempo track in the Tracks Window.
3. Choose Windows>Faders.
   The Faders Window opens.
4. Assign the Tempo field to F1 and set the Settings field to Send.

To ensure the maximum fader resolution, enter an approximate range of tempos in the Range field for the tempos you will record.

5. Set the Begin Record toggle to Countoff and then click the Record button.
6. While the sequence plays, drag the F1 Fader to record the new tempo events.
7. When finished recording, click the Stop button.
CHAPTER 17: Tempo, Time Scale, and Reclock

CHANGE TEMPO

In addition to setting a tempo for a range of measures, the Change Tempo command lets you:

• Fit a range of measures into a precise time range;
• Create tempos that smoothly accelerate or ritard;
• Scale existing tempos.

Choose Do>Change Tempo to open the Change Tempo dialog:

![Figure 17.1: Change Tempo dialog]

Following is a description of the various options in the Change Tempo dialog:

1 Tempo
Select this radio button to enter a tempo (or tempo change range) in the accompanying Tempo fields for the specified Bar•Beat•Unit range. The new time range is automatically calculated (based on the specified tempo) and is displayed in the Time Range fields.

2 Time Range
Select this radio button to enter a time range in the accompanying time fields for the specified Bar•Beat•Unit range. The new tempo is automatically calculated (which makes possible the new time range) and is displayed in the Tempo field(s).

3 Bar•Beat•Unit range
These fields determine the Bar•Beat•Unit range affected. When opening the Change Tempo dialog, the Edit In/Out points define this range. Entering a new value in the Start field automatically updates the corresponding field in the Time Range row.

4 Use constant tempo
This option sets a constant tempo for the entire Bar•Beat•Unit range affected.

5 Accelerate/Ritard from initial tempo
This option creates a series of linear (smooth) tempo changes between the Start and End tempos.

6 Scale existing tempos
With the Tempo radio button selected, this option scales existing tempo events by a specified average tempo amount. With the Time Range radio button selected, this option scales existing tempo events (while keeping them relative to one another) so they fit in the specified Time Range.
You can use the Strip Chart to visually draw a tempo change (see page 250). If Exact Mode is enabled, the Change Tempo dialog automatically opens when inserting or editing tempo events in the Strip Chart.

NOTE: Change Tempo always preserves the metrical placement of events residing in the affected time range.

## SCALE TIME

The Scale Time command compresses or expands the time range for selected events. It is most often used to fit a musical passage into range of time (sometimes for the sake of conforming it to bar and beat lines).

NOTE: Scale Time changes the metrical placement for all events residing within the specified time range of the selected tracks. To affect all events in the sequence, use the Track Overview to define the selection.

Choose **Do>Scale Time** to open the Scale Time dialog:

![Figure 17.2: Scale Time dialog](image)

1. **Old Start/End Time**
   These fields define the time range of events that will be scaled.
2. **New Start/End Time**
   These fields define the new time range in which the selected events will fit.
3. **Duration (Old and New)**
   These fields display the actual length of the Old and New time ranges. Editing these fields automatically updates their corresponding End Time fields.
4. **Display**
   This pop-up determines the time format (SMPTE or Bars/Beats) displayed in the Start, End, and Duration fields.
5. **Scale Factor**
   Indicates the amount the selected events are scaled. Changing this field automatically updates the New End Time field, and vice versa.
6. **Insert Tempos to maintain timing**
   If you are happy with the speed at which the current selection plays, check this option and Vision inserts the necessary Tempo events so that the original timing is retained.
7. **Restore original tempo**
   Check this option and Vision will insert a tempo event (equal to the original tempo) at the End Time. This ensures that material residing after the End Time plays back as it did before using the Scale Time command.
Using Scale Time
(to fit an audio loop)

The following example scales time to fit a 1-bar audio loop. Although we’re not sure of the actual tempo of the audio, we can use Scale Time to fit the audio (without altering it) perfectly into 1 measure in Vision:

1. Select the desired track block in the Track Overview area and choose Do>Scale Time.

The Scale Time dialog opens.

Notice that the Start/End fields are automatically set based on the Edit In/Out points.

2. Enter 2•1•0 into the New End Time field.

Notice that the Scale Factor field is automatically updated based on the New End Time.

3. Check the option for Insert Tempos to maintain timing.

4. Click the Scale button.

A new tempo is calculated and automatically inserted at the Start Time. As a result, the audio block now fits cleanly into one measure.

Scaling Time in the Ruler

You can also Scale Time in the Ruler of the Graphic and Notation Windows. Rather than aligning music to bars, you can drag individual bar and beat lines to line up with your music.

If there are events selected, scaling time in the Ruler adjusts the duration and placement of those events so they line up with the bar and beat lines. If there are no events selected, Vision inserts the necessary tempo events to retain the original timing of the events in that bar.
The following example shows how to drag a bar line to align four notes (previously recorded without listening to the metronome) to the beat. These notes start at around 2•1•0 and need to be adjusted so they take up that entire measure (ending at around bar 3).

1. Open the Graphic Window and Shift-click the desired notes so each is selected.

2. Position the cursor in the Ruler over the bar/beat indicator of 3¥1.

3. Then press and hold the Option and Shift keys so the Scale Time cursor appears.

   Unless you position the cursor over a quarter note indicator, it will become the hand cursor. Otherwise, the cursor will indicate that you can now scale the selected time.

4. Click and drag the bar line so it lines up with the end of the last note.

   Then release the mouse button.

   The new bar line is drawn and the duration and placement of the selected notes are adjusted (scaled) so they align with each beat.

   NOTE: If the notes had not been selected, Vision would have also inserted the necessary tempo changes so that their original timing was retained.

**RECLOCK**

Reclock takes a sequence recorded without a metronome (or from an audio source) and aligns it to bars and beats by conforming it to a click track. You can use material already in the sequence as the source of the click track, or you can record a click track while listening to the sequence.

Reclocking scales the time of all tracks in the sequence so that the click events end up as exact bars and beats. It also modifies the Tempo track to preserve sequence playback.

For step-by-step instructions on using the **Reclock** command, see Reclocking to a Click Track (pg. 144).
CHAPTER 17: Tempo, Time Scale, and Reclock

Choose **Do>Reclock** to open the Reclock dialog:

![Reclock dialog](image)

Following is a description of the various options in the Reclock dialog:

1. **Clicks on downbeats only**
   - Select this option to reclock the first beat of each measure, instead of every beat. The number of beats in each measure is determined by the current meter of the first bar of the sequence. All other meter events are ignored.

2. **Same click on every beat**
   - For maximum flexibility in expressing the tempo, select this option to reclock each click event on each beat.

3. **Different click on downbeat**
   - If your sequence has varying meters, you can have Vision automatically create a Meter track from your click events. In this mode, you must use two click events: one for the beat of every measure, and a different one for each of the other beats.

4. **Every beat recorded**
   - If this option is checked, Vision assumes that a click event has been recorded for each beat (or each bar if **Click on downbeats only** is selected) in the sequence. This allows dramatic, quick tempo changes.
   - If this option is unchecked, you won't need a click event for every beat in the sequence. However, you must have a click event for at least the first two beats to establish the initial tempo.

5. **Click events are**
   - “Only” specifies a single event (continuous controller or note) on a particular Instrument as the click source. This option is useful if there are other events in the same track that are not click events.
   - “Selected notes” uses the notes that were selected before opening the Reclock dialog as the click source.
   - “Any note event” uses all notes (from the specified source track) for the click source.
   - NOTE: When using **Different Click on Downbeats**, you must define two different events for the downbeat and upbeat of the click.

6. **In track**
   - Choose from this pop-up the source track that contains the click events. All click events must reside on a single track.
Following are some possible click track sources for reclocking:

- Try using material from the MIDI tracks that need reclocking. If a piano type performance was recorded, perhaps the notes in the left hand, which often fall on the main beats, can be used successfully for the click source.
- If the material that needs reclocking came from a multitrack tape, a click track or kick drum track also from the tape can make a good click source.
  
  Record it directly into Vision as audio, use Strip Silence/Slice Audio to make each beat an individual event, then specify the audio events as the click source in the Reclock dialog.
  Or run the click track from the tape through the Studio 5's footswitch input and record them as MIDI notes. Then specify those notes as the click source in the Reclock dialog.
- While recording a rubato performance (without the metronome), try also recording pedal taps (from a sustain or sostenuto pedal) on each beat. Then in the Reclock dialog, specify the pedal events as the click source.
  
  This is a pretty good method which ensures that the click track will line up with the recorded material.

## Editing a Rubato Performance

Rubato is a performance that doesn't adhere to a strict sense of time—although you can feel a pulse, an expressive performance may speed up and slow down. You don't need to use a metronome when you record, and when you want to play rubato, you probably will not use one.

This raises a potential problem. If you don't record while listening to a metronome, the Counter will not accurately reflect the music, and the bar and beat boundaries in the edit windows will not line up with the recorded tracks. This is especially apparent in the Notation Window, but affects almost all commands, and makes it almost impossible to use quantizing features.

## Reclocking to a Click Track

The following procedure illustrates how to conform a rubato performance to Vision's bar and beat lines by “reclocking” a click track. The Reclock command will automatically add tempo changes and meter changes to reflect the performance.

1. Record-enable a new track. Name this track “Click Track.” Set the Instrument of the Click Track to a “click” sound.
2. Set the Begin Record toggle to Wait for Note and then click the Play button.
3  As you listen to the performance, tap the tempo on the MIDI keyboard.
If there are multiple meter changes, you should play two different keys (one for downbeats and one for upbeats).

4  When you are finished recording, click the Stop button.

5  Play it back and, if necessary, edit the click track to correct any mistakes.

6  Select the click track and choose Do>Reclock.
   The Reclock dialog opens, see Reclock (pg. 142) for details on each of its parameters.

7  After making the appropriate settings, click the Reclock button.
   Vision inserts the necessary tempo and meter events so that the rubato performance lines up with the bar and beat lines.

NOTE: In general, you should use Reclock first and then use Scale Time afterwards for minor changes.
CHAPTER 18: Synchronization

There are two basic scenarios that necessitate the use of external sync:

- **Syncing to external MIDI devices**
  Vision can be “slaved” to another sequencer or drum machine so both sets of tracks play in sync.

- **Syncing to a tape deck**
  Vision can be “slaved” to tracks on tape. This is a powerful method of blending conventional recording techniques with the flexibility of MIDI.

Vision uses the following MIDI synchronization protocols:

- **MIDI Beat Clock**: Sends timing pulses for each beat, speeding up and slowing down as necessary for tempo changes.

- **MIDI Time Code**: MIDI representation of SMPTE Time Code and synchronizes time with no concept of beat or tempo.

Vision can also control devices that support MIDI Machine Control (MMC). For more information on this capability, see Chapter 39: The MMC Window.

All of Vision’s sync settings are configured from the Sync Options dialog. See Sync Options (pg. 433) for details.

**SYNCING TO BEAT CLOCK**

MIDI Beat Clock with Song Pointer provides Start, Stop and Continue functions, and location information (which allows you to start playback in the middle of a sequence).

To slave Vision to an external MIDI device:

1. **Open the sequence that will sync to the external MIDI device.**

2. **Choose Options>Sync Options.**
   The Sync Options dialog opens.

3. **In the Receive Sync line, set the sync format to External Beat Clock.**
   In addition set the source of the Beat Clock to the desired device.

   Click the **OK** button to close the Sync Options dialog.

   **NOTE**: The Beat Clock sync source device must be defined as such in the current OMS Studio Setup. If not, it will not appear in the Sync Source pop-up.
PART 4: Advanced Concepts

4 In the Control Bar, click the **Play** button, or press the Spacebar.
The **Play** button flashes, indicating it is waiting for sync information from the external device.

5 **Initiate playback of the external device.**
Vision locates the sequence to the requested start time and begins playing.
NOTE: Make sure the external MIDI device is configured to send MIDI Beat Clock.

**SYNCING TO TIME CODE**

Synchronizing with SMPTE requires an external SMPTE to MIDI Time Code converter (such as Opcode’s Studio 64 XTC or Studio 5).

To slave Vision to MIDI Time Code:

1 **Open the sequence that will sync to tape.**
2 **Choose Options>Sync Options.**
The Sync Options dialog opens.
3 **In the Receive Sync line, set the sync format to MIDI Time Code.**
   In addition set the sync source to the desired device (usually your MIDI interface).

If you would like Vision to begin playing and recording automatically when receiving time code, check the **Remote Start** option.

4 **Choose the desired frame rate from the SMPTE Format pop-up.**
   ![Remote Start](image)
   Click the **OK** button to close the Sync Options dialog.

5 **Click the Play button in the Control Bar, or press the Spacebar.**
The **Play** button flashes, indicating it is waiting for sync information from the tape.

6 **Start the tape.**
   Make sure the tape is striped with SMPTE and allow some leader time before the sequence is supposed to start. Also, make sure the sequence’s SMPTE offset matches what’s on tape. See SMPTE Offset (pg. 150) for more details.

Vision determines if the received time code is before or after the beginning of the sequence:

- **If before,** the Counter displays negative bar numbers and counts towards bar 1.
- **If after,** Vision locates the sequence to the correct start time and begins playing.
NOTE: If the tape is played while Vision is stopped, Vision still displays the scrolling SMPTE numbers in the Counter.

**RECORDING WITH EXTERNAL SYNCHRONIZATION**

You can record into Vision while synchronized with an external source, using either MIDI Beat Clock or MIDI Time Code. Make sure Punch mode is enabled or Vision is in Overdub mode. To begin to recording, click the **Record** button (or type the Tab key). The Record button flashes.

**Wait For Note**

In Wait for Note mode, when you start the external device, Vision begins playing the sequence and the Record button will not be highlighted. Vision will punch in when you play a note or press the Spacebar—at which time the Record button becomes highlighted.

**Auto Punch**

A Countoff can't be guaranteed because Vision cannot control the sequence starting point, so Countoff automatically becomes Auto Punch when you select an external sync mode. In Auto Punch mode, the Record button does not become highlighted if you start before the Punch In point (or after the Punch Out point). Vision will automatically punch in when you reach the Punch In point and will automatically punch out when you reach the Punch Out point. If you start the sequence in-between the two points, Vision punches in and the Record button becomes highlighted.

When finished recording, click the Stop button or press the Return key (or just stop the tape). Whenever Vision loses the sync signal, it stops recording.

NOTE: A bad sync signal from the SMPTE/MIDI converter can interrupt recording. Don’t try to keep recording! Restripe the tape with a fresh SMPTE signal.

The number of bars of Countoff set in Internal mode controls the metronome. If a 2 bar Countoff is set and the tape starts 5 bars before the Punch In point, the metronome doesn't play until 2 bars before the Punch In point.

**AUTOMATICALLY CHANGING SYNC MODES**

When using external sync, Vision automatically (and temporarily) enters Internal mode when you perform the following actions:

- Start a sequence by typing its key;
- Choose **Do>Play Selection**;
- Choose a specific Counter location when Vision is not already playing the active sequence in sync.
Once the function is completed, Vision automatically returns to External sync.

**SMPTE TIME CODE RATES**

Vision supports five SMPTE frame rates:

- **24 Frame**
  This is the rate used by feature films.

- **25 Frame**
  This rate is used by EBU (European) television.

- **29.97 Drop Frame**
  This rate is used by NTSC (American) color television.

- **29.97 Non-Drop Frame**
  This rate is used to sync to NTSC color television without dropping frames. SMPTE time does not match real time, but playback pitch is unaffected. Video decks run at 29.97 frames per second.

- **30 Non-Drop Frame**
  This was the original NTSC black and white television standard. This is often used in audio-only situations since there are no dropped frames and the SMPTE time is equal to a real clock.

The difference between **29.97 Non-Drop and 30 Non-Drop**

These formats are actually the same but played at different speeds. Vision can’t differentiate between 29.97 non-drop on a video machine and 30 non-drop on a slightly slow audio machine.

If 29.97 non-drop is specified, Vision skews the tempos so that if the tape plays at exactly 29.97 frames per second (as all video decks do), and the tempo is 120, then Vision plays 1200 beats in 10 minutes of “real time.” This is faster than the SMPTE time.

If 30 non-drop is specified, the deck plays at 30 frames per second, and the tempo is 120, then Vision plays 1200 beats in 10 minutes of SMPTE time and “real time.”

If 30 non-drop is specified, but the deck plays at 29.97 frames per second, and the tempo is 120, then Vision plays 1200 beats in 10 minutes of SMPTE time. This is slower than “real time.”

**SMPTE Offset**

The SMPTE Offset time points to a location on tape that corresponds to the beginning of a sequence. Each Vision sequence has its own SMPTE Offset setting. When syncing to time code, the sequence begins playing after Vision receives the offset time code location.

For information on setting a sequence’s SMPTE Offset, see Information Toggle (pg. 212).
CHAPTER 18: Synchronization

SLAVING EXTERNAL DEVICES TO VISION

Vision can also send sync signals to a “slaved” external device:

1. **Choose Options>Sync Options.**
   The Sync Options dialog opens.

2. **In the Send Sync pop-up,**
   specify the type of sync sent (MIDI Time Code or Beat Clock).

3. **Click OK** to close the Sync Options dialog.

4. **Make sure Options>Send Sync Enabled** is checked.

5. **Click the Play button in the Control Bar.**
   Visions initiates playback and sends the sync to the slaved device.
   Make sure the device is configured to sync to an external clock source, and is set to begin playing.

NOTE: In order to appear as a Send Sync device, a device must be defined as such in the current OMS Studio Setup.
Customizing Vision
CHAPTER 19: What’s Saved Where

In addition to saving your basic sequence files, Vision can also save a wide range of configuration settings, preferences, and templates. Following is a description of what’s saved where:

**Vision Files**

Each Vision file saves sequences and segments, Instruments, patch subscriptions, and edit window information (location and size). Optionally, Vision files can also include MIDI Keys, Input Map settings, Fader and Console assignments, and Fader and Console values. See Vision Files (pg. 156) for specifics.

**Vision Setup**

Vision Setup is automatically updated to save any changes to your MIDI Keys, Commands Window settings, and Sequence Templates. Optionally, you can use **Save As Setup** to save a snapshot of Instruments, patch subscriptions, Input Map settings, Fader and Console assignments, and Fader and Console values. For more details, see Vision Setup (pg. 157).

**Vision 4.5 Prefs**

This file (which resides in the Preferences folder, inside your System Folder) stores information from Vision’s Settings Window, as well as many other items. See Vision 4.5 Prefs (pg. 158) for details.

**Vision Editing Templates**

This file stores saved templates for Select & Modify, Quantize, and Transpose. For tips on creating and saving templates, see Chapter 20: Templates.

**Vision Effects Templates**

This file saves all EQ templates, VST plug-in Program Templates, VST plug-in Bank Templates, and TDM plug-in templates. For more information, see your Audio Reference Manual.

**Console Layout Templates**

This folder stores all console layout templates (each of which is its own file). Each Console Layout Template file contains information about the Console display settings. For more information about these files and a complete list of what is stored in them, see page 366.
Vision Grooves

This Vision file contains the source sequences and tracks for Groove Quantize. It must be named as such and reside in the same folder as your Vision application. See Creating Your Own Grooves (pg. 167) for more information.

OMS Studio Setup

In addition to containing a description of your MIDI studio, this file also stores the Current Thru Instrument, current patches, metronome channels, receive sync device, send sync device(s), enabled input devices, and Auto Remappings.

VISION FILES

Each Vision file can store the following objects:

- **Sequences**
  Saves all sequences and segments listed in the Sequences Window.

- **Instruments**
  Saves all Instrument definitions, including any assigned transpose maps and patch subscriptions.

- **Input Map**
  Saves the routings in the Input Map Window.

- **MIDI Keys**
  Saves the MIDI Key assignments.

- **Fader Assignments**
  Saves all Instrument assignments for Faders and Consoles.

- **Fader Values**
  Saves all Fader and Console values.

- **Audio Preferences**
  Saved in their current state when the file is saved.

- **Sync Options**
  If Remember these settings in sequence files is checked, all settings are saved.

- **DSP Preferences**
  If Save with Sequence Files is checked, these settings are saved.

- **Audio Recording Preferences**
  If Save with Sequence Files is checked, these settings are saved.

You can specify which objects are saved with a Vision file by clicking the What to Save button in the Save dialog (see Figure 19.1).
When saving a Vision file, sequences and Instruments must always be included, but the other items are optional. Fader Assignments and Fader Values are enabled by default, though you can uncheck them if desired.

In addition, you can specify which objects are opened when opening a Vision file (click the **What to Open** button in the Open dialog). This lets you, for instance, open a set of Instruments or Fader Assignments without closing your current set of sequences. By default, all objects found in a file are opened.

### VISION SETUP

The Vision Setup file is just like a regular Vision file except that the sequences it contains are used for Sequence Templates. The Vision setup file, which must reside in the same folder as your Vision application, lets you recall commonly used setup items (like Fader and Console configurations, Instrument definitions, Input Maps, etc.) for each newly opened Vision file.

Below is a complete list of the items saved in the Vision Setup file:

- Sequence Templates (automatic)
- Instruments
- Input Map
- MIDIKeys (automatic)
- Commands (automatic)
- Fader and Console Assignments
- Fader and Console Values

Sequence Templates, MIDIKeys, and Commands are saved automatically whenever there are changes made to them. This ensures that any changes made to these items will not be lost.

**NOTE:** Even if you have not yet chosen **File > Save As Setup**, making changes to Sequence Templates, MIDIKeys, or Commands will automatically create a new Vision Setup file.

To save the other Vision Setup items (Instruments, Input Map, and Fader and Console information), you must choose **File > Save As Setup**. If changes are made to any of these items and you have not saved them, you will be prompted before closing Vision.

When opening a Vision file, any objects unchecked in the **What to Open** dialog are not loaded—and as a result, the corresponding Setup items are instead used.

You can also click the **Use Setup Instruments** option in the Open dialog to use the Setup Instruments for any existing file. This would be handy for opening someone else’s file (with a different set of Instruments) at your studio—thereby letting you use your Instruments saved in the Setup file.
PART 5: Customizing Vision

The Vision Setup file is saved in the same folder as the Vision application. It must remain in this folder, with its name intact, for Vision to access it.

Vision Setup files are very much like regular Vision files—they can even be opened as such. This lets you rename and save as many different "Vision Setup" files as you like, opening them as necessary to return to those particular configuration settings.

VISION 4.5 PREFS

The Vision Prefs file stores a large number of configuration settings. This file is automatically written each time Vision is closed. It resides in the Preferences folder inside the System Folder. If you ever need to return Vision to its default state, remove this file from the Preferences folder and the Vision Setup file from the Vision folder before launching the program.

NOTE: It can take quite a while to actually configure Vision with all of your favorite settings. Once this is done, it is a good idea to make a backup copy of the Vision Prefs file.

NOTE: For Studio Vision Pro users, the name of the preferences file is "Studio Vision Prefs."

While not an exhaustive list, following is a compilation of some of the items saved in the Vision Prefs file:

- **File Menu**: Open (what to open), Save (what to save), Export as MIDI File (Multitrack option), Export As QuickTime Movie (movie settings), Export Audio Mix (file format), Export Audio Events (file format)

- **Setups Menu**: Keyboard Thru, Thru in Background, Input Effect Enabled, Input Map Enabled, MIDIKeys Enabled, Fader Remotes Enabled, Record Quantize Enabled, Record Filter settings, Colors

- **Options Menu**: Sync Options settings, Send Sync Enabled, Click in Record, Click in Play, Click in Countoff Only, M etronome Sound settings, Countoff in Play, Stop at Punch Out, Real Time Capture, Local Sequence Times

- **Audio Menu**: Audio System, Waveform Height, Waveform Display, Display Names, Mix Audio on Capture, Audio Preferences

- **DSP Menu**: DSP Preferences

- **Control Bar**: Record Mode, Countoff/Wait Note, Punch toggle, Loop toggle
• **Sequences Window**: Set Default Location

• **Tracks and Pulse Window**: Auto Scroll, Time Display (Bar/Beat/Unit, Absolute SM PTE, or Relative SM PTE), Set Default Location, Show Offset Info, Detailed Track Overview, Show Vertical Line, Cursor Quantize toggle, Cursor Quantize value

• **Graphic Window**: Auto Scroll, Time Display (Bar/Beat/Unit, Absolute SM PTE, or Relative SM PTE), Set Default Location, Play Edited Note, Show Bouncing Ball, Show Vertical Line, Show Piano Keyboard, Cursor Quantize toggle, Cursor Quantize value

• **Notation Window**: Auto Scroll, Time Display (Bar/Beat/Unit, Absolute SM PTE, or Relative SM PTE), Set Default Location, Play Edited Note, Show Bouncing Ball, Show Vertical Line, Cursor Quantize toggle, Cursor Quantize value, Notation Resolution

• **List Window**: Auto Scroll, Time Display (No SM PTE, Absolute SM PTE, or Relative SM PTE), Set Default Location, View settings, Play Edited Note, Show Event End Times, Show Event Durations

• **Counter Window**: Bar/Beat/Unit, Absolute SM PTE, Relative SM PTE, Font

• **Record Monitor**: Thru Mode, Stereo on/off, Auto Compact on/off, Sample Size, Record File Preferences

• **Step Window**: Spacing value, Tuplet, Duration, Velocity

• **Players & Queue Window**: Queue toggle

• **Input Effect Window**: Arpeggiate/Repeat, Latch toggle, Sync to Counter toggle, Octaves, Order, Spacing, Duration

• **Faders Window**: Tempo Fader assignment and range

• **Select & Modify Window**: All settings

• **Settings Window**: All settings, which include Insert Note, Strip Chart & Nudge, Editing, Real-Time, Controllers, and Appearance

• **Audio Preferences**: All settings

• **DSP Preferences**: All settings as they are when the program quits

• **Audio Recording Preferences**: All settings as they are when the program quits
CHAPTER 20: Templates

This chapter explores saving templates in Vision. The types of templates supported include:

• Sequence
• Transpose
• Quantize
• Select & Modify

This chapter also discusses how to save your own tracks as custom Groove sources for Quantizing.

For information about Console templates, please see Chapter 38: The Console Windows.

For information about EQ templates, please see your Audio Reference Manual.

SEQUENCE TEMPLATES

Sequence Templates are starting points for opening new sequences. If, for instance, you have a sequence (or segment) with useful track assignments, appropriate meter and tempo settings, patch and controller configurations, or anything else, you can save it as a Sequence Template. Then whenever you wish to open a new sequence based on that template, simply double-click it from the Sequences Window.

Sequence Templates are stored in the Vision Setup file.

Saving a Sequence Template for Orchestral Music

The following example shows how to configure and save a Sequence Template for orchestral music:

1. Open a new sequence and assign an Instrument and patch for each of the desired orchestral tracks.

2. If desired, set volume and pan levels for each of the assigned Instruments. For details, see Saving a Mixer Snapshot (pg. 89).

This example uses a GM device as its sound source.
PART 5: Customizing Vision

3 Set the sequence’s Meter and Tempo. Use values that make the most sense for your type of music.

<table>
<thead>
<tr>
<th>Meter</th>
<th>4/4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tempo</td>
<td>96.00</td>
</tr>
<tr>
<td>SeqLen</td>
<td>99</td>
</tr>
</tbody>
</table>

These sequence settings needn’t be exact, they can always be changed later when re-opening the template.

4 Choose Save As Template from the menu in the Sequences Window.

5 When prompted, enter a name for the template, then click OK.

Opening a Sequence Template

To open a new sequence based on a Sequence Template:

1 Open the Templates section of the Sequences Window, so you can view the current set of templates.

   Use the open/close triangle to open the different sections in the Sequences Window.

2 Locate the desired Sequence Template and double-click it, or simply type its key equivalent.

   A new sequence is created, using the material from the specified template, and is placed in the Sequences section of the Sequence Window. A Tracks Window for the new sequence opens.

   The new sequence is not named after the template source; it instead uses Vision’s naming scheme when creating new sequences (Sequence A, Sequence B, etc.).

Sequence Templates are stored in the Vision Setup file. Each time you save a Sequence Template, it is automatically written to the Setup file, thereby making it available each time you launch Vision.
EDITING TEMPLATES

Vision can save templates for Transpose, Quantize, and Select & Modify, which enables you to store and recall your favorite parameter settings for these commands. These templates are written to the file Vision Editing Templates, which resides in the same folder as your Vision application. In order for the templates to be available this file must not be moved or renamed.

Quantize and Transpose Templates

Quantize and Transpose Templates are stored and recalled with a similar set of pop-up menus.

The Quantize parameters are found in the following locations:

- Info area of the Tracks and Pulse Windows when viewing a track's Play Quantize settings;
- Select & Modify Window when its modify type is set to Quantize;
- Input Effect Window (for its Spacing settings).

To recall a template, simply choose it from the Template pop-up. This pop-up menu lists all templates stored in the current Vision Editing Templates file.

The Template Functions pop-up is used to save and copy parameter settings, and to delete existing templates.

The Transpose parameters are found in the following locations:

- Select & Modify Window when its modify type is set to Transpose;
- Transpose Map dialog for an Instrument.

To recall a template, simply choose it from the Template pop-up. This pop-up menu lists all templates stored in the current Vision Editing Templates file.

The Template Functions pop-up is used to save and copy parameter settings, and to delete existing templates.
PART 5: Customizing Vision

Following is a description of each item in the Template Functions pop-up menu:

- **Save Settings**: Stores the current parameter settings to the currently selected template.

- **Save Settings As**: Stores the current parameter settings to a new Quantize or Transpose Template.
  
  With this command you are prompted to enter a name for the new template.

- **Delete Template**: Deletes the currently selected template.

- **Load From**: Lets you load a set of templates from a Vision Editing Templates file that is not current. The loaded templates are merged with the current set.

- **Copy Settings**: Copies the current set of parameters to the Clipboard. This is handy for copying Play Quantize settings between tracks, or to and from the Select & Modify Window.

- **Paste Settings**: Pastes a set of Quantize or Transpose parameters from the Clipboard to the current location.

- **Save As Default**: This command is only available for track Play Quantize settings. Once you have a set of Play Quantize parameters that you like, use this command to make them the “default” for each new track.

**Saving a Transpose Template**

The following example shows how to save a set of Transpose parameters to a template:

1. **Choose Do>Transpose**.

   ![](image)

   The Select & Modify Window opens, automatically configured for the Transpose command.

2. **Choose the desired Transpose Type and make the necessary changes to the Transpose parameters**.

   For information on the different Transpose types, see Transpose Types (pg. 134).

3. **Choose Save Settings As from the Template Functions pop-up**.

   ![](image)
4 When prompted, enter a name for the new template and click **OK**.

The new Transpose Template is saved to the Vision Editing Templates file.

**Select & Modify Templates**

Any configuration of the Select & Modify Window can be saved as a template. These Select & Modify Templates store both the “select” and the “modify” settings of the window, and can be used to recall your most commonly used edit operations.

Like Quantize and Transpose Templates, Select & Modify Templates are stored in the Vision Editing Templates file.

Select & Modify Templates are recalled from the menu in the Select & Modify Window. Simply select the desired template, and the window is automatically reconfigured with the stored settings in the template. See Figure 20.6.

The lower portion of this menu lists all Select & Modify Templates stored in the Vision Editing Templates file. The top portion has commands for saving, loading, and deleting templates. For details on each of these commands, see Select & Modify Menu (pg. 125).
PART 5: Customizing Vision

Saving a Select & Modify Template

The following example shows how to save a Select & Modify Template for quantizing just the snare hits with “swing”:

1. **Highlight the sequence or tracks you wish to edit and then choose **Do>Quantize.**

   ![](image1.png)

   The Select & Modify Window opens, automatically configured for the Quantize command.

2. **Open the Select area of the Select & Modify Window by clicking the open/close triangle.**

3. **Add a Select attribute for only selecting the pitch range containing the snare notes (D1).**

4. **Set the Quantize Type to Grid with a Quantize value of 8th notes. Also, enter a value of 70% in the Swing field.**

   ![Swing](image2.png)

   Also, enter a value of 70% in the Swing field.

5. **Choose Save Settings As from the menu in the Select & Modify Window.**

6. **When prompted, enter a name for the new template and click OK.**

   ![Save Settings](image3.png)

   The new Select & Modify Template is saved to the Vision Editing Templates file.
CREATING YOUR OWN GROOVES

With Groove Quantize, Vision uses a custom alignment grid based on the Groove Source track. Vision maps the start times, velocities, and durations (or any combination thereof) from the Groove Source onto the selected track.

Groove Source tracks reside in the Vision Grooves file, which resides in the same folder as the Vision application. In order to access the Groove sources, the Vision Grooves file must not be moved or renamed.

To create your own custom groove, all you need to do is save the desired track to the Vision Grooves file. Then you can use it as a Groove Source track with Quantize.

You can save a Groove Source track by directly editing the Vision Grooves file:

1. Record a track you would like to use as a Groove source.
2. Select the track in the Tracks Window and choose Edit>Copy Track.
3. Next, open the file “Vision Grooves.”
4. Make the Sequences Window active and then choose Edit>Paste Sequence.
   Before pasting, make sure no sequences are selected in the Sequences Window.
5. Rename the sequence as desired and choose File>Save.
   The new sequence along with the Groove Source track is saved.

You can also paste into the Vision Grooves file remotely, when it's not even open:

1. Record a track you would like to use as a Groove source.
2. Select the track in the Tracks Window and choose Edit>Copy Track.
3. Choose Do>Quantize to open the Quantize Window.
4. Set the Grid Type to Groove.
5. From the Seq pop-up, select a sequence source into which you will paste. Then choose Paste as New Groove Track from the Track Functions pop-up.
6. When prompted, enter a name for the new Groove Source track and click OK.

The new Groove Source track is saved to the Vision Grooves file.
CHAPTER 21: Commands and MIDIKeys

THE COMMANDS WINDOW

The Commands Windows lets you assign key equivalents and MIDI events to practically any function or menu item in Vision. Changes made in the Commands Window are automatically saved to the Vision Setup file.

To open the Commands Window, choose Setups>Commands.

The Digits section determines how Vision responds to typed numbers. For example, Figure 21.2 illustrates that to clear a Locator button you must hold down the Command and Option keys (the Modifier) while typing the Locator’s number; in addition, the digit can be typed from the row of number keys at the top of the Keyboard, or from the numeric Keypad (since both columns are checked).

To edit the modifier for a digit, click in that Modifier column and type in the desired keys. To change the Keyboard and Keypad status of a digit, click in the column to check or uncheck as desired.

The Commands section lists categories of commands, along with their assigned key equivalents and MIDIKeys.
To change a command's keyboard equivalent, click in the Keyboard column for the desired command and type the new key (or key combination). See Figure 21.3.

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transport Controls</td>
<td>Tab</td>
</tr>
<tr>
<td>Record</td>
<td></td>
</tr>
</tbody>
</table>

Figure 21.3: Keyboard column, Commands Window

To assign a MIDIKey, click in the column for the desired command and play the MIDI event on your controller. The event, device, and channel automatically appear in the column when received. See Figure 21.4.

<table>
<thead>
<tr>
<th>MIDI Event</th>
<th>Device</th>
<th>Channel</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>Yonah 1</td>
<td></td>
</tr>
</tbody>
</table>

Figure 21.4: MIDI Event column, Commands Window

NOTE: The column for MIDI Event, Device and Channel is grayed out if MIDIKeys are not enabled.

To clear a key equivalent or MIDIKey in the Commands Window, click in the desired column and type the Delete key.

Highlighting the Edit Out Field

It is now possible to highlight the Edit Out field by typing back slash (\), or whatever key equivalent is assigned to “Select End Time” in the Commands Window.

Previously, this key equivalent would always highlight the Punch Out field. Now, as long as an edit window is the top window, it will select the Edit Out field.

To highlight the Punch Out field, type “=” (which will highlight the Counter, making the Control Bar the top window) followed by back slash.

Commands Window Menu

The Commands Window has a menu with the following items:

- Load From...
- Restore Factory Defaults

Figure 21.5: Commands Window Menu

Load From

Choose this menu item to load a set of Commands from a Vision Setup file.

Restore Factory Defaults

This command restores the settings in the Commands Window to their original “factory” state.

Assigning Key Commands

Following is a short example of assigning a key equivalent and MIDIKey for the Record command:
CHAPTER 21: Commands and MIDIKeys

1. Choose **Setups > Commands** to open the Commands Window.

![Figure 21.6: Commands Window](image)

2. Locate and click in the Keyboard field for the Record command.

3. Type Shift-Space on your computer keyboard.
   The new key equivalent appears in the Keyboard column for the Record command.

![Command Transport Controls](image)

![Keyboard](image)

**NOTE:** If the new key equivalent is in use by another command or function, you are informed.

4. Next click in the MIDI Event field for the Record command.

![MIDI Event](image)

If this column is grayed out, select **Setups > MIDIKeys Enabled** to enable MIDIKeys.

5. Play a note on your MIDI keyboard controller.
   The note, and the device that played it, appears in the MIDI Event column for the Record command.

![MIDI Event](image)

Any changes made in the Commands Window are automatically saved to the Vision Setup file. To return to the factory Commands set, choose **Restore Factory Defaults** from the menu in the Commands Window.

**THE MIDIKEYS WINDOW**

MIDIKeys let you assign events from a MIDI controller to trigger nearly any key or key combination. This is particularly useful for controlling Vision remotely from your MIDI devices (without using your computer keyboard). There are also four special MIDIKeys with functions designed to facilitate interactive and loop recording.
Choose **Windows > MIDIKeys** to open the MIDIKeys Window, or type Option-K.

The four “special” MIDIKeys occupy the top section of the MIDIKeys Window while the user-defined MIDIKeys are assigned and displayed in the lower section.

**NOTE:** Any MIDIKeys assigned in the Commands or Sequences Window automatically appear as user-defined lines in the MIDIKeys Window.

Each MIDIKey assignment has four attributes: Function, MIDI Event, Device, and Channel.

**Function** is the key equivalent, or special MIDIKeys function, to which the **MIDI Event**, occurring on the selected **Device** and **Channel**, is assigned.

To assign MIDIKeys (special MIDIKeys or user-defined), simply click in the MIDI Event column for the desired line and play the MIDI event on your controller. The event, device, and channel automatically appear in the column when received. New lines are added by choosing **Add Line** from the menu in the MIDIKeys Window.

You can also manually assign or edit MIDI events with the mouse. Following is a description of the items that define the MIDI event:

1. **Shift**: Click in this column to toggle MIDIShift for a user-defined MIDIKey.
2. **Event Type**: Choose from this pop-up an event type of either note, controller, or program change.
3. **Event Value**: Click in this column to specify a value for the event type.
4. **Input Device**: This pop-up sets the input device.
5. **Input Channel**: Click in this column to set the channel for the input device.

**Special MIDIKeys**

The four special MIDIKeys functions allow you to perform different actions when MIDIKeys are enabled. You can assign each one of these functions to a different MIDI event.
MIDIShift

The MIDIShift function allows a MIDI event assigned as a MIDIKey to trigger its function only when the MIDI event assigned as the MIDIShift function is active at the same time. Vision must receive both MIDI events for the corresponding function to be performed.

For example, suppose you'd like to use the MIDI note G3 to trigger recording by assigning it to the Tab key. The G3 note can be insulated from triggering recording every time it is played by using the sustain pedal as a MIDIShift function.

NOTE: Redefining the MIDI event associated with the MIDIShift function causes any MIDIKeys using MIDIShift to respond to the new event.

Erase

The Erase MIDIKey allows notes to be erased in the record-enabled track during playback or recording. Pressing the Erase MIDIKey and playing some notes on the MIDI controller erases all matching notes in the track. This is similar to the erase feature found on many drum machines.

See Drum Machine Style Loop Recording (pg. 45) for more information on using the Erase MIDIKey.

Input Effect

The Input Effect MIDIKey, when invoked, enables Vision's Input Effect. The Input Effect processes MIDI input. Depending on the settings in the Input Effect Window, the processed notes are either repeated or arpeggiated (see Input Effect Window (pg. 115) for details).

Vision's Input Effect can be turned on and off from the Input Effect Window, or by choosing Setups > Input Effect Enabled.

The Input Effect MIDIKey, on the other hand, offers a way to temporarily turn on the Input Effect in real time, on-the-fly.

Extend

This Extend MIDIKey performs a similar function as a sustain pedal, but without the hazards associated with sustain pedal events. Typically, you map your sustain pedal to the Extend MIDIKey.

The advantage of using the Extend MIDIKey to sustain notes is that note durations are actually lengthened, whereas sustain pedals work by combining short notes with pedal controller information. It is much easier to view and edit only the note durations, rather than the sustain pedal and note data.
MIDIKeys Window Menu

MIDIKeys Enabled
When checked, this menu item activates the current set of MIDIKeys.

Add Line (Option-=)
Choose this command to add a new MIDIKey.

Remove Line (Option—–)
Choose this command to remove the selected MIDIKey. Although the four special MIDIKeys cannot be removed, you can clear their MIDI event definition. To do this, click in the MIDI event field for the special MIDIKey and type Delete.

Load From
Choose this command to merge a set of MIDIKeys (from a Vision file) with the current set.

Clear All
This command removes all user MIDIKeys, and clears all MIDI definitions for the four special functions.

Defining MIDIKeys
The following example shows how to define a MIDIKey:


2. Choose Add Line from the menu in the MIDIKeys Window. A new line is added to the MIDIKeys Window.

3. Click in one of the MIDI event fields for the new line and play the desired MIDI event on your controller.

4. Click in the Function field and type the desired key equivalent to be triggered.

Click here and play a MIDI event

Click here and type key
MIDIKeys can trigger any Vision function that uses a key combination. They can also trigger sequence playback by using the same key as the sequence’s key equivalent from the Sequences Window (see page 197).

For a list of Vision’s default keyboard equivalents, consult the Quick Reference card in your Vision package. These keys can, however, be reassigned in the Commands Window—so always check there for the current key assignments.

Any changes made in the MIDIKeys Window are automatically saved to the Vision Setup file. Also, MIDIKeys can optionally be saved with regular Vision files (see Chapter 19: What’s Saved Where).

NOTE: MIDIKeys only work in Vision. You cannot assign a MIDIKey to work in another application. However, MIDIKeys can still control Vision when it’s running in the background (as long as “Run MIDI in background” is checked in the OMS MIDI Setup dialog).

Deleting MIDI Keys

To remove a user-defined MIDIKey, click in either the function or MIDI event field and select Remove Line from the menu in the MIDIKeys Window.

Although the four special MIDIKeys cannot be deleted, you can clear their MIDI event definition. To do this, click in the MIDI event field for the special MIDIKey and type the Delete key.

SAVING MIDIKEYS AND COMMANDS

As mentioned previously, any changes in the MIDIKeys Window are automatically saved to the Vision Setup file. This lets you have a default set of MIDIKey definitions that are used when opening new files.

MIDIKeys can optionally be stored with regular Vision files, creating an automatic association between the sequence and the MIDIKeys. To do this you’ll need to specify “what to save” in Vision’s Save dialog, see Figure 21.9.

Figure 21.9: Saving MIDIKeys with Vision file

To load a set of MIDIKeys from a Vision file, choose the Load From command in the MIDIKeys Window menu. The MIDIKeys from the specified Vision file are merged into the existing set of MIDIKeys.
PART 5: Customizing Vision

The settings in the Commands Window are also saved to the Vision Setup file automatically. Unlike MIDIKeys, Commands cannot be saved with regular Vision files.

You can, however, backup and rename your Vision Setup files to create a library of Commands files. To restore a particular set of Commands, choose **Load From** in the Commands Window menu.
CHAPTER 22: Custom Instruments

Vision's MIDI Instruments are defined by a number of parameters, including name, color, device and channel assignment, velocity scaling, transposition, key range, and voice allocation. Custom Instruments can be created by editing any of these parameters.

Since Instruments can be comprised of several layers (lines), specialized Instruments functioning as splits and layers can be created. This chapter discusses how to create some of these custom Instruments.

NOTE: Instruments are remembered with saved Vision files. They also can be saved in the Vision Setup file.

For a detailed discussion of the Instruments Window, see Chapter 32: The Instruments Window.

CREATING A LAYERED INSTRUMENT WITH OCTAVES

This example shows how to create a layered Instrument with one of the layers transposed up an octave.

1. Choose Windows>Instruments to open the Instruments Window.
2. Highlight an existing Instrument and choose New Instrument from the menu in the Instruments Window.
   A new Instrument, based on the previously selected Instrument, is added at the bottom of the Instruments Window.
3. Highlight the name of the new Instrument and type in an appropriate name.

For this example, the name “Layered Octaves” is used.
PART 5: Customizing Vision

4. Highlight the Layered Octaves Instrument and choose Add Line to Instrument from the menu in the Instruments Window.
A new line is added to the Instrument.

Make sure that the Instrument is set to Layered, if not, click on the word “Overflow” to toggle the mode.

5. In the Output column, specify a Device and Channel for both Instrument lines.
For an interesting effect, you can choose separate devices and channels that are set to vastly different patches.

6. In the Transpose column, set the Octave for one of the layers to +1.

CREATING A SPLIT INSTRUMENT

This section explains how to create an Instrument “split” using two layers set to different key ranges.

1. Choose Windows>Instruments to open the Instruments Window.

2. Highlight an existing instrument and choose New Instrument from the menu in the Instruments Window.
A new Instrument, based on the previously selected Instrument, is added at the bottom of the Instruments Window.

3. Highlight the name of the new Instrument and type in an appropriate name.
For this example, the name “Middle-C Split” is used.

4. Highlight the Middle-C Split Instrument and choose Add Line to Instrument from the menu in the Instruments Window.
A new layer is added to the Instrument.

5. In the Output column, specify a device and channel for each Instrument line.
You might want to assign a piano in one line and a bass in the other.

6. In the Range column, set the Lo value to “C3” for the top line; then set the Hi value to “B2” for the other line.

For an easy way of entering values into the Lo and Hi fields, highlight the field and play the desired note(s) from your controller keyboard.
CREATING VOICE-ALLOCATED INSTRUMENTS

This section discusses how to create a voice-allocated Instrument. Suppose, for example, you have two MIDI devices each with small polyphony capabilities.

You can use an Instrument in “overflow” mode to automatically allocate notes to different instrument lines, based on their individual voice definitions.

1. Choose **Windows> Instruments** to open the Instruments Window.

2. Highlight an existing Instrument and choose **New Instrument** from the menu in the Instruments Window.
   A new Instrument, based on the previously selected Instrument, is added at the bottom of the Instruments Window.

3. Highlight the new Instrument and choose **Add Line to Instrument** from the menu in the Instruments Window.
   A new line is added to the Instrument.

4. Set the mode of the Instrument to **Overflow**.

5. In the Output column, specify a device and channel for each Instrument line.

6. In the Voices column, enter the number of voices for each Instrument line.

These values should equal the number of simultaneous notes each device (assigned to the line) is capable of playing.

Whenever Vision sends data to such an Instrument, it routes to the correct instrument line based on their Voice allocations.
Windows
PART 6: Windows
CHAPTER 23: The Control Bar

The Control Bar contains the major controls for Vision. It’s normally located just below the Macintosh menu bar, but it can be moved by either dragging the drag strip (at the left edge), or by Option-dragging any blank area in the Control Bar itself.

Unlike most Macintosh windows, the buttons in the Control Bar are always active. Clicking one will not move the Control Bar in front of another active window—this lets you access Control Bar functions without de-activating another window.

The Control Bar cannot be closed.

RECORD MODE

![Replace](image)

The Record Mode determines how Vision records tracks. The four available record modes, chosen from the Record Mode pop-up, include:

- **Replace**: Records in real time, replacing existing track data.
- **Overdub**: Records in real time, adding to existing track data.
- **Step Replace**: Records in step time, replacing existing track data.
- **Step Overdub**: Records in step time, adding to existing track data.

![Record Indicator](image)

**Record Indicator**

The Record Indicator button( ), located next to the Record Mode pop-up, blinks when Vision receives MIDI. It also indicates if digital audio recording and Record Quantize are enabled.

Clicking on the Record Indicator button opens the Record Monitor Window, which is used for recording digital audio.
CURRENT SEQUENCE

The Current Sequence is the sequence to which recording takes place. Whenever a Tracks Window for a different sequence is brought to the front, the Current Sequence pop-up changes to show that sequence's name (except if you're actively recording into another sequence).

Seq Button
Click on the “Seq” button ( ) to bring the Tracks Window for the current sequence to the front.

CURRENT TRACK

Whenever a track is record-enabled, that track’s name is displayed in the Current Track pop-up menu.

Trk Button
To open an edit window for the current track, click on the “Trk” button ( ).

THRU INSTRUMENT

The Thru Instrument pop-up displays the MIDI Instrument to which your controller sends MIDI. This Instrument is always assigned to recorded data.

The Thru Instrument sounds when you play your controller keyboard (provided Options>Keyboard Thru is enabled).

When you record-enable a different track from the Tracks Window, or from one of the other edit windows, this pop-up automatically displays the Instrument assigned to that track. In addition, if you change the Instrument used by the current track, the Thru Instrument pop-up changes as well.
KEY EQUIVALENTS: You can use your computer keyboard to set the Thru Instrument. Hold down the Option key while clicking the Thru Instrument pop-up for a list of key equivalents. Also, you can use the Asterisk (*) key on the numeric keypad to highlight the Thru Instrument.

Trigger and Transpose Items

The Thru Instrument pop-up also lists Vision’s four Trigger modes: Transpose, Trigger, Cont Trig, and Gated. These items, which are not MIDI Instruments, are performance modes used in triggering sequences in real time.

NOTE: These Trigger modes work independently of similar items in the Input Map Window, which are described in Trigger and Transpose Modes (pg. 326).

- **Transpose**
  Choosing this item temporarily puts Vision in transpose mode, which automatically transposes the currently playing sequence when you play a note on your MIDI keyboard.

- **Trigger**
  In trigger mode, every note you play restarts the currently playing sequence. Sequences playing are stopped when you strike a new key. You can play more than one note in this mode to produce automatic harmonies.
  If the Thru Instrument pop-up in the Control Bar is set to Trigger, typing a sequence key does not initiate playback—instead, this makes that sequence “triggerable.” Play any note on your MIDI controller to start all triggerable sequences simultaneously.

- **Cont Trig**
  Continuous Trigger Mode is the same as Trigger Mode, except that sequences are not stopped when triggering a new sequence.

- **Gated**
  Gated is the same as Trigger mode, except that each sequence plays for the length of time you hold down the key. When you lift your finger, the sequence stops.
Instruments Button

Click on the Instruments button ( ) to open the MIDI Instruments Window. For information on the Instruments Window, see Chapter 32: The Instruments Window.

Global Instrument Solo Indicator

Instead of the Instruments button, the Control Bar displays a Global Instrument Solo Indicator whenever any Instrument (Audio or MIDI) is soloed.

Figure 23.6: Global Instrument Solo Indicator

Click the Solo Indicator to open any windows that contain soloed Instruments. Option-click the Solo Indicator to automatically unsolo all soloed instruments. For more details, see Global Instrument Solo Indicator (pg. 302).

CURRENT PATCH

The Current Patch pop-up shows the patch used by the Thru Instrument. It is automatically updated when sending patch changes to the Thru Instrument, either when editing or playing.

Vision remembers the last patch change sent to each Instrument. When a new Instrument is chosen from the Thru Instrument pop-up, the Current Patch pop-up changes to display the patch last sent to that Instrument. This setting is remembered even when you quit Vision.

Figure 23.7: Current Patch pop-up displaying names

If the Thru Instrument is subscribed to a Patch Name document (see Chapter 33: The Names Window), the Current Patch pop-up displays actual patch names. Otherwise, patch and bank numbers are used.
Choose an item from the Current Patch pop-up to send a patch event to the Thru Instrument. This does not, however, add a patch event to the current track unless you are recording. For information on saving patch events, see Saving Patch Selections (pg. 88).

**Patch Button**

Click on the Patch button ( ) to open the Names Browser for auditioning patches, see Names Browser (pg. 321).

**Transport Controls**

The transport controls, located in the middle of the Control Bar, give you control over the playback and recording of sequences.

**Record**

KEY EQUIVALENT: Type the Tab key to begin recording.

Click the **Record** button to initiate recording. During playback or recording, you can click the record button to punch in or out at any time (on-the-fly). If the button is highlighted, you are recording. If the button is flashing, this means that recording will occur when the Counter reaches the In Point. If the record button is disabled (grayed out), you cannot record—this usually means there is no track record-enabled.

**Play from Start**

KEY EQUIVALENT: Type the Spacebar to initiate playback from the beginning.

Click the **Play from Start** button to start playback from the beginning of a sequence, or from the In Point in the punch area of the Control Bar. If the sequence is paused, clicking this button continues playing from the pause point.
PART 6: Windows

Stop

KEY EQUIVALENT: Type the Return key to stop playback or recording.

Click the Stop button to stop playback or recording.

Play from Counter

KEY EQUIVALENT: Type the Semicolon key to initiate playback from the Counter’s current location.

Click the Play from Counter button to start playing from the current Counter location. If the sequence is paused, clicking this button continues playing from the pause point.

Pause

KEY EQUIVALENT: Type the Spacebar or Semicolon key to pause playback or recording.

Click Pause to pause recording or playback. This button highlights when playback is paused.

Shuttle Bar

KEY EQUIVALENT: Type the Comma key to shuttle left, type the Period key to shuttle right.

The Shuttle bar moves the Counter at variable speeds. Drag the Shuttle bar to the left to rewind the Counter; drag the Shuttle bar to the right to fast forward. The further you move the Shuttle bar from the center, the faster the Counter scrolls. You can also click anywhere on the bar itself and the button will jump to the mouse location.

The Shuttle bar can be used during playback, or when a sequence is stopped.

If the sequence is stopped and an edit window is active, the track displayed in the window will play back as the Shuttle bar moves (this is similar to “scrubbing,” see Auditioning with the Scrub Command (pg. 26)).

Previous and Next Marker Buttons

KEY EQUIVALENT: Type Shift-Comma (**) and Shift-Period (>) to move between the previous and next markers.

These buttons step back and forward through the marker locations listed in the Marker pop-up.
LOCATORS

The Locator buttons store Counter locations. After setting a Locator, clicking it causes the Counter to jump to the stored location. Each sequence stores its own set of eight Locators.

KEY EQUIVALENTS: Type the number of the desired Locator to recall that location. You can Option-type a number to set a Locator, and you can Option-Shift-type a number to clear it.

Setting a Locator

Undefined Locator buttons are grayed. You can set Locators to the current Counter location while the Counter is moving, or while it is stopped.

To set a Locator:

1. Move the Counter to the desired location.
   If you don’t know the exact location, you can instead listen for the desired location during playback, adding Locators on-the-fly.

2. Option-click the Locator button you wish to set.
   You can also hold down the Option key and type the number of the desired Locator.

Clearing a Locator

To clear a Locator button:

1. Option-Shift-click the desired Locator button.
   The button turns gray, indicating it is undefined.
   You can also hold down the Option and Shift keys and type the number of the desired Locator.

SYNC POP-UP

KEY EQUIVALENT: Type ~ to toggle between Internal and the most recently selected “External” mode.

The Sync pop-up displays the source of Vision’s sync.

The available sync sources include:

- Internal: Uses the internal clock of the Macintosh. In this mode, sequences play at their own tempo.
- External Beat Clock: Syncs to an external source, usually from a hardware-based sequencer or drum machine. In this mode, sequences...
play at the tempo of the external sync device, and locate and play as determined by MIDI Song Pointer messages.

- **MIDI Time Code**: Uses time code from a SMPTE or MTC source. The sync source is usually a tape track but could be from another application or MIDI device that sends MTC. In this mode, Vision reads the incoming time code and begins playback when the sequence’s SMPTE offset is encountered; the sequence uses its own tempo.

- **MTC/Machine Control**: Syncs Vision to an MMC compatible device. In this mode, Vision automatically sends MMC commands to control the sync device. For more details, see Chapter 39: The MMC Window.

- **Remote Start**: Check this option to automatically start or stop Vision from an external device or program. When Remote Start enabled, Vision’s **Play** button flashes in the Control Bar, indicating that it is waiting for sync or a start command from an external device (or other application). When unchecked, you must always hit **Play** in Vision to initiate playback, even after receiving external sync.

For more information on sync settings, see Chapter 18: Synchronization.

**BEGIN RECORD TOGGLE**

The Begin Record toggle determines how Vision begins recording. There are two modes:

### Wait for Note

![Wait Note]

Figure 23.10: Begin Record toggle in Wait for Note mode

When using Wait for Note, recording does not begin until the first MIDI note is received. This method ensures you begin playing when you’re ready to record, and that the first note is recorded at the precise beginning of the section.

**NOTE**: The metronome does start when clicking the **Record** button so you can get a feel for the tempo.

### Countoff

![Countoff]

Figure 23.11: Begin Record toggle in Countoff mode
When using Countoff, Vision plays a specified number of measures before entering record mode.

You can change the number of bars in the Countoff field by using the mouse or Macintosh keyboard. If Punch recording, playback begins this number of bars before the In Point.

### THE COUNTER

The Control Bar’s Counter displays the current location for the current sequence. The Counter displays location information in two ways:

- Bars/ beats/ units
- SMPTE (Hours:Minutes:Seconds:Frames)

By default, the bars/ beats/ units are in large text and the SMPTE frames are in small text, see Figure 23.13.

You can switch the positions of the two displays (making SMPTE the large display) by clicking the Counter Display toggle (↑). Click it again to return the display to its default.

![Figure 23.12: Changing the Countoff](image)

The Counter scrolls automatically during playback. When Vision is stopped, the Counter is updated whenever the Edit In Point changes—such as when clicking in an edit window.

You can change a Counter value by clicking on it and typing a number, or by clicking and dragging with the mouse.

![Figure 23.13: The Counter](image)

NOTE: You can also open a larger version of the Control Bar’s Counter by choosing Windows>Counter. Because the Counter Window is resizable you can make it as big as you want—and you can switch its display font. See Counter (pg. 444) for details.
PART 6: Windows

About Units

Vision uses a 480 pulses-per-quarter note (ppq) resolution. This means that there are 480 units in each quarter note, and that there are 480 possible locations within each quarter note for a MIDI event to occur.

About Frames and Bits

Frames and bits are part of the SMPTE time code specification. The number of frames in one second depends on the type of time code used—see SMPTE Time Code Rates (pg. 150) for a description of the different frame rates. There are 80 bits in a frame. Bits are shown in a sequence’s SMPTE offset, and in edit windows for event locations.

Vision rounds each SMPTE location to the nearest 480th of a beat. When typing in a SMPTE number (for an event location, for example), you may notice that Vision rounds the entered number to the nearest bar/beat/unit—which in the process may alter slightly the SMPTE location.

TEMPO DISPLAY

The Control Bar’s Tempo Display usually shows the tempo of the current sequence. It is updated automatically if the tempo of the current sequence changes, or if you are syncing to External Beat Clock.

Normally, you cannot change the Tempo Display. However, by muting the current sequence’s Tempo track, you can temporarily adjust the tempo in the Control Bar:

1. Open the Tracks Window for the current sequence.
2. Click the Mute column for the Tempo track.

The Control Bar’s Tempo Display becomes editable.

3. Click in the Tempo Display field and type in the desired tempo, or click and drag with the mouse.

NOTE: Changing the Display Tempo while recording, records these changes to the current sequence’s Tempo track.

There are actually many ways to change or adjust a sequence’s tempo track. See Virtual Conducting—Recording Tempo Changes (pg. 137) for more details.

To open a List Window for the current sequence’s Tempo track, click the Metronome button ( ).
CHAPTER 23: The Control Bar

MEMORY DISPLAY

The Memory Display indicates the available memory in Vision. For a more detailed look, click on the Memory Display for a pop-up.

The “Largest free block” shows the largest contiguous amount of available memory.

If the “Total free space” is substantially larger than the “Largest free block,” you may have fragmented memory. You can sometimes correct this by quitting and relaunching Vision.

To increase the available memory for Vision, Get Info on the application from the Finder and increase the “Preferred Size.” This must be done while Vision is not launched.

IMPORTANT: Before allocating more memory to Vision, make sure your computer has enough installed RAM. See your Macintosh operating manuals for more information.

MARKER POP-UP

The Marker pop-up lists any markers contained in the current sequence’s Meter track. Selecting a marker from this pop-up moves the Counter to that marker’s location.

Before creating any markers, the Marker pop-up contains items for beginning, in point, and end of sequence. These items, shown in parentheses, are not user-defined and do not appear in the Marker Display.

When the Counter reaches a marker’s location, the Marker pop-up automatically displays the name of that marker.

To open a List Window for the current sequence’s Meter track, click the Marker button ( ).

To add new markers, choose either Do>Insert Bar Marker or Do>Insert SMPTE Marker (see page 422), or use the Insert pop-up in the List Window to insert a marker (see page 271).
PART 6: Windows

PUNCH AND LOOP CONTROLS

Figure 23.18: The Punch Controls in the Control Bar

Use these controls to enable and disable Punch and Loop modes, and to specify a range for playing, recording, and looping.

Punch Toggle

KEY EQUIVALENT: Type Shift-6 to toggle Punch mode.

Click the Punch toggle to enable or disable Punch mode. Punch mode allows you to record or play a precise portion of a sequence (based on the In Point and Out Point fields).

When Punch mode is enabled:

• The Play From Start button initiates playback from the In Point.
• Recording only occurs within the range specified by the In and Out Points—Vision disables recording before the Counter reaches the In Point, and after the Counter reaches the Out Point.
• You can manually enter record mode, during playback, by typing the Tab key or by clicking the Record button.
• If Options>Stop at Punch Out is checked, Vision automatically stops playback at the Out Point.

When Punch mode is disabled:

• The Play From Start and Record buttons always start playback from the beginning of the sequence.
• Recording with one of the “replace” modes replaces the entire track, regardless of how much recording was done.

Loop Toggle

KEY EQUIVALENT: Type Shift-7 to toggle Loop mode.

Click the Loop toggle to enable or disable Loop mode. When enabled, Vision continuously repeats the portion of the sequence determined by the In and Out Points (for both playback and recording).

During playback, Loop mode lets you take full advantage of Vision’s real-time editing capabilities. You can listen to specific sections of a track, perform edits, and then immediately listen to the results—without stopping and restarting the sequence.

With overdub recording, you can use looping to build track data, without exiting record mode. This is effective when working with drum tracks, repeating musical patterns, and multi-timbral takes.
CHAPTER 23: The Control Bar

Following are some helpful features relevant to recording in Loop mode:

- Type the Enter key when satisfied with a performance—the material is saved to the track and Vision continues loop recording.
- If you make a mistake, type the Delete key to erase anything recorded since the last time Enter was typed.
- Type Command-Shift- to record-enable the next track; use Command-Shift- to record-enable the previous track.

For more information on Loop recording, see Loop Recording (pg. 35).

**In Point and Out Point Fields**

![Figure 23.19: In/Out Point fields, disabled]

KEY EQUIVALENT: You can set the In Point and Out Points by typing and then on your computer's numeric keypad.

The In and Out Points determine the range played or recorded when Punch and Loop modes are enabled.

These fields, which are always displayed as bars/beats/units, can be set by manually typing in the desired fields; or you can use the Set In and Set Out Point buttons to automatically set them.

When both Punch and Loop are disabled, the In Point and Out Point fields are grayed out.

NOTE: When the **Punch Points follow Edit Points** option is enabled in the Settings Window, any changes made to the Edit In/Out points (when playback is stopped) are automatically entered into the In Point and Out Point fields.

**Set In Point Button**

![Set In Point Button]

KEY EQUIVALENT: Type to set the In Point.

Click this button during playback to set the In Point to the Counter location. When playback is stopped or paused, this button sets the In Point to that of the Edit In location.

**Set Out Point Button**

![Set Out Point Button]

KEY EQUIVALENT: Type to set the Out Point.

Click this button during playback to set the Out Point to the Counter location. When playback is stopped or paused, this button sets the Out Point to that of the Edit Out location.
Click one of Control Bar’s Window buttons to open the Sequences, Tracks, Pulse, List, Graphic, or Notation Windows. If the window is already open, it is brought to the front.

Clicking any of the Window buttons is the same as choosing the corresponding command from the Windows menu.
CHAPTER 24: The Sequences Window

The Sequences Window lists all sequences and segments contained in the current Vision file. Also listed are the sequence templates stored in the Vision Setup file. These three items are listed in separate sections of the Sequences Window.

![Figure 24.1: Sequences Window](image)

Although sequences, segments, and templates share some common characteristics, there are important differences between the three:

- **Sequences** are groups of up to 99 tracks. At their most basic, sequences can be viewed as single songs; however, with the use of sequence events, they can also be used as song sections or even music layers within a parent sequence.
  
  Unlike segments, sequences can be triggered by a key equivalent or MIDI event.

- **Segments** are just like sequences except they are usually made from existing track material (by choosing **Edit > Make Segment/Loop**). Unlike sequences, segments cannot be assigned a key or MIDI trigger.
  
  Also, segments have the option of being automatically deleted when no longer referenced by a parent sequence.

  Segments can be turned into sequences by dragging them into the Sequences section.

- **Templates** are starting points for opening new sequences. If, for instance, you have a sequence (or segment) with useful track assignments, appropriate meter and tempo settings, or anything else, you can save it as a sequence template.
  
  Templates cannot be opened directly for editing or playback. Instead, they are copied to a new sequence when double-clicked, or when invoked by their key or MIDI trigger.
SELECTING, MOVING, AND COPYING SEQUENCES

You can hide or view the items contained in each section of the Sequences Window by clicking the open/close triangle.

As discussed in Selector Dots and Move Cursor (pg. 22), sequences and segments can be selected and highlighted with their selector dots. Once a sequence or segment is selected, it can be deleted, copied and pasted to another Vision file, copied and pasted as a sequence event into the Tracks or List Window, or modified with any of Vision’s edit commands. In addition, they can be moved to another position within their section with the move cursor (¶).

NOTE: Drag a segment into the Sequences section of the Sequences Window to turn it into a sequence. Sequences, in turn, can be dragged into the Segments section.

SEQUENCES WINDOW COLUMNS

The columns in the Sequences Window include Name, Key, MIDI, References, and Comments. As discussed in Moving and Resizing Columns (pg. 23), these columns can be moved or resized as desired—allowing you to best utilize screen space.

Following is a description of each Sequences Window column:

Name

Although sequences are named automatically when created (segments can be named when they are made with the Make Segment/Loop command), they can be easily renamed from this column.

To enter or change a name, simply click in the field and type the new name; then type Enter, or click anywhere else in the window, to enter the new name.

Key

Use the Key column to assign a key equivalent to the sequence. Click in the field and type the key or key combination; keys in use by the program cannot be entered and you’ll be prompted if you try to use a key already assigned to another sequence. If necessary, you can enter key combinations that use the Shift and Control keys.
Use the key trigger to initiate playback of the sequence, or to record it as a sequence event.

NOTE: Key and MIDI triggers cannot be assigned to segments. If you must assign a trigger to a segment, turn it into a sequence by dragging it to the Sequences section.

MIDI

Just like key equivalents, MIDI events can also trigger a sequence’s playback. To assign a MIDI trigger, click in the column and send the desired event from your MIDI controller. If the MIDI column is resized large enough, you will see the event type and the device that sent it. To clear an assigned MIDI event, click in the column and type Delete.

The MIDI column lets you create and edit MIDIKeys for your sequences without opening the MIDIKeys Window (discussed on page 171).

You can also use the MIDIKeys Window to manually enter a MIDI event and device, or to edit an existing assignment. For details on using the MIDIKeys Window, see The MIDIKeys Window (pg. 171).

NOTE: The MIDI triggers for sequences are only available if Setups>MIDIKeys Enabled is checked.

NOTE: Key and MIDI triggers cannot be assigned to segments. If you must assign a trigger to a segment, turn it into a sequence by dragging it to the Sequences section.

References

When a sequence or segment is referenced by a parent sequence, information about the sequence event is displayed in the Reference column. The column lists the name of the parent sequence and track, and the measure location of the sequence event (see Figure 24.3).

NOTE: Sequence events describe how to play a sequence or segment from a parent sequence.

Figure 24.3: Pop-up of sequence event references

Although the column normally displays just the first reference, you can click in it for a complete pop-up listing of each track containing a reference (with the first bar shown), see Figure 24.3.

Comments

Use the Comments column to enter descriptive text about the sequence or segment. Resize the column, as necessary, to display more of the sequence’s comments.
SEquences Window Menu

The following commands are available from the menu in the Sequences Window:

- **New Sequence (Command-N)**
  Creates a new sequence and automatically opens its Tracks Window. The new sequence is automatically named and assigned a key trigger.

- **New Generated Sequence**
  Creates a new generated sequence and opens its Tracks Window. These special sequences generate new and interesting music from existing notes and rhythms.

- **Duplicate (Command-D)**
  Makes a copy of the selected sequence or segment. The new sequence is automatically named (based on the original) and assigned a key trigger.

  NOTE: Segments are always duplicated as sequences and placed in the Sequences section.

- **Save as Template**
  Use this command to save the selected sequence or segment as a template. When saving a template, you are prompted to name the new template.

  IMPORTANT: Sequences containing sequence events or digital audio events cannot be saved as sequence templates.

- **Remove Unused Segments**
  When chosen, all segments without references are deleted. This command is only available if the **Automatically Remove Unused Segments** item is unchecked.

- **Automatically Remove Unused Segments**
  Check this option if you want segments automatically deleted when no longer referenced by any parent sequences.

For more information, see Chapter 14: Generated Sequences.
Set Default Location

Saves the location, size, and column configuration of the Sequences Window as default. These settings are then used for any new Vision files.
CHAPTER 25: The Tracks Window

The Tracks Window lists all tracks in a given sequence. In addition to having a variety of sequence and track controls, the Tracks Window also contains a “Track Overview” and Strip Chart for displaying and editing individual track data.

For information on edit tools and edit functions common to all of Vision’s edit windows, see Chapter 9: Basic Editing Procedures. For information on navigating Vision’s windows, see Chapter 4: Navigating in Vision.

TWO WINDOWS IN ONE

The Tracks Window is divided into two basic areas: the Track Columns and the Track Overview section. Vision responds differently depending on which area you are working in. This distinction is subtle, but crucial to working with Vision.

When selecting items in the track columns, or selecting tracks using the selector dots (left side of the window), Vision is in “Tracks” mode, indicated by the entire track line (Name, Length, Instrument, and Comments) becoming highlighted, as shown in Figure 25.2. In this mode, edit operations affect the selected track or tracks and their entire contents.
When selecting tracks or portions of tracks in the Track Overview (right side of the window), Vision is in “Events” mode, indicated by highlighted track blocks (not highlighted track lines). In this mode, edit operations affect only the events in the selected track regions.

Window Divider

Use this divider to specify how the Tracks Window divides its space between the Track columns and Track Overview area. When the mouse is positioned over the divider, the cursor changes into a resize cursor ( ). The divider can be dragged, changing the size of both areas, which could cause the Track Overview area to cover Comments and other columns.

NOTE: You can also double-click the Window Divider to move it all the way to the left or right.
CHAPTER 25: The Tracks Window

Expanded Info Area and Strip Chart

The lower portion of the Tracks Window can be expanded by clicking the open/close triangle. The lower-left area, when opened, displays expanded Play Quantize settings for selected tracks, or sequence event info for selected sequence event blocks. The lower-right area displays the Strip Chart.

Figure 25.6: Tracks Window with expanded info area and Strip Chart

For information on the info area's Play Quantize controls, see Play Quantize (pg. 72). For information about the Opts menu, see Opts Menu (pg. 262). For information on sequence event controls, see Sequence Event Parameters (pg. 96). And, for details on using the Strip Chart, see Chapter 28: The Strip Chart.

TRACK COLUMNS

<table>
<thead>
<tr>
<th>#</th>
<th>Name</th>
<th>Len</th>
<th>Instrument</th>
<th>Patch</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Track 1</td>
<td>0</td>
<td>Monophone 1</td>
<td>Set It Grow</td>
<td></td>
</tr>
</tbody>
</table>

Figure 25.7: Track columns in Tracks Window

As mentioned in Moving and Resizing Columns (pg. 23), each of the track columns can be moved (and some resized) as desired—allowing you to best utilize screen space.

Each of the track columns are discussed in the following sections.

Select and Move

As discussed in Selector Dots and Move Cursor (pg. 22), tracks can be selected and highlighted with their selector dots. Once a track is selected, it can be deleted, copied and pasted to another sequence, or modified with any of Vision's edit commands. In addition, they can be moved to another position within the Tracks Window with the move cursor (△).

Record

Click in this column to record-enable the track. Only one track can be record-enabled at a time. An "R" appears in the track's column when record-enabled. Clicking again disables the track for recording.

Type Command-Shift-↑ to enable recording on the previous track, or Command-Shift-↓ to enable recording on the next track.
Mute

Click in this column to mute playback for a track (or group of tracks). This lets you listen to and focus on other tracks within the sequence. An “M” appears in the track’s column when it is muted.

Click on the M in the column head to toggle the mutes for all selected tracks. Command-click the M in the column head to unmute all tracks in the sequence.

Solo

Click in this column to hear only that track, or group of tracks. An “S” appears in this column when the track is soloed.

Click on the S in the column head to toggle the solos for all selected tracks. Command-click the S in the column head to unsolo all tracks in the sequence.

Track Name

To enter or change the name of a track, highlight this field and type the desired name, then type Enter or click anywhere else on the screen to enter the new name.

Length and Looping

These fields display the length of the sequence and tracks. Option-click to lock or unlock a length. To loop a track or sequence, click on either edge of this field.

Vision automatically sets the sequence length to that of the greatest track length. If all tracks are looped, the sequence length becomes infinity (∞). If this field displays a “>” or “<” symbol, the sequence doesn’t end cleanly on the barline.

Locking a Track or Sequence Length

Option-click a track or sequence length to lock or unlock it. When a length is locked, a small padlock icon (■) appears, indicating that Vision cannot automatically change it—although you can do so manually by typing a new value into the field, or by clicking and dragging with the mouse.

Normally, track lengths are automatically updated, if necessary, after recording. And if you record a track that is longer than the sequence length, Vision lengthens the sequence automatically.
**Looping a Track or Sequence**

Set the loop option to play a track or sequence indefinitely by clicking either edge of the length field.

![Figure 25.9: Setting a sequence to loop](image)

When a track loops, Vision plays the track's contents (beginning at the sequence start point) repeatedly, regardless of what the other tracks are playing. All tracks loop independently of each other. For example, if one track is set to loop every 2 bars, and another every 3 bars, the tracks coincide every 6 bars.

When a sequence loops, Vision restarts all tracks at the sequence Start Point, after it reaches the end of the sequence. This includes the Tempo and Meter tracks.

![Figure 25.10: Setting a track to loop](image)

To loop or unloop several tracks simultaneously:

1. **Select the desired tracks.**

   ![Table](image)

2. **Click in the Length column heading.**

   The loop mode for each selected track is toggled.

   ![Table](image)

**Drum ((mx)**

Click in this column to specify that the track is a drum track, which allows it to be viewed and edited in the Pulse Window.

Drum Instruments do not allow a note to be retriggered until that note is finished playing. Also, notes on Drum Instruments don't play if playback begins after the note's onset. This is useful when working with drum loops on samplers, where it doesn't make sense to trigger the note anywhere except at the start. For example, a note beginning on beat 1 and ending
on beat 4 won’t play if playback begins on beat 2. This concept applies to mutes and solos as well; if a drum instrument or track is soloed or unmuted on beat 2, a note beginning on beat 1 and ending on beat 4 won’t play.

For more information about drum tracks, please see Drum Tracks (pg. 223).

Instrument

The Instrument column displays the assigned Instrument for each track.

When recording a track, the current Thru Instrument (shown in the Control Bar) is automatically assigned to the track.

To change a track’s Instrument assignment, choose a new Instrument from the pop-up that appears when clicking in the Instrument column for that track.

Multi Instruments

Although each track is usually assigned to a single Instrument for playback, tracks can contain events to be played on several Instruments (up to 16). “Multi” tracks can be created from one or more selected tracks by choosing Edit>Combine Tracks (see page 413).

Multi-tracks can also be created by recording on multiple channels into a single track via the Input Map. For details, see Multi-Channel Recording (pg. 46).

To reassign Instruments within a multi-track:

1. Click in the Instrument column for the multi-track.

Vision displays a list of Instruments used by the track, plus a “Remap Instruments” option.

2. Choose the Remap Instruments option to open the following dialog.

3. Click on an Instrument pop-up to reassign its data to a different Instrument.
Multi-tracks can be split into separate tracks by choosing **Edit>Separate Multi Track**. See page 413 for details.

### Patch

The Patch column shows the name or number of the patch associated with the Instrument. For details on how Vision uses names, see Chapter 33: The Names Window.

NOTE: For multi-tracks, the patch column is blank.

The Patch column displays its contents in five different ways:

- **Patch name in normal type**
  There is a patch event residing in one of the sequence's tracks.

- **Patch name in italics**
  The patch isn't currently loaded in the Instrument, but there is a patch event specifying it in one of the sequence's tracks.

- **Patch name in parentheses**
  There is no patch event for this Instrument anywhere in the sequence. The name shown in the Patch column is the last one sent to the Instrument (probably from the Control Bar's Current Patch pop-up).

- **“Various”**
  The word “Various” in the Patch column indicates that there is more than one patch event for that Instrument in the sequence (muted tracks are ignored).

- **Number**
  Instruments that aren't subscribed to a Patch Name document (see page 305) display a numerical representation of the current or stored patch.

Patch events can be changed by clicking the Patch column and choosing from the pop-up menu of patches associated with the track's Instrument. Option-clicking the column opens the Name Browser—see Names Browser (pg. 321) for a complete description. A patch can also be selected by typing the first few letters of its name, and typing Enter.

Clicking on a patch name in parentheses and selecting a patch from the pop-up inserts a patch event at the beginning of that track (and removes the parentheses). When selecting a patch, the Patch column changes even if the original patch event is located in another track.

The Patch column can reference a multi-track containing only patch events for multiple Instruments, such as that created by the Copy Patches command (see page 421). Each patch from the multi-track is displayed in the Patch column of tracks assigned to their corresponding Instruments. Changing patches in the Patch column simultaneously updates the multi-patches track.
PART 6: Windows

The Patch column also supports having a separate “setup” sequence that sends patches and perhaps sysex. After having played the setup sequence, the current patches displayed in the normal sequences will all be correct, though they are displayed in parentheses.

It is possible to make a window to monitor the current patches for several Instruments just by creating an empty sequence containing tracks assigned to those Instruments. As various patch events are played, the new current patches are displayed.

Comments
Type any text into this field to make notes or comments about any of the tracks.

METER AND TEMPO TRACKS

The Meter Track

Every sequence has a Meter track that can contain three types of information: meter changes, key signature changes, and markers.

If a sequence has a constant meter, it is displayed in the Tracks Window, where it can be edited by clicking the top or bottom number and entering a new value. See Figure 25.11.

Figure 25.11: Setting the meter from the Tracks Window

Meter Changes
If a sequence contains more than one meter event, the Tracks Window displays “Meter Track” in the Meter field. In this case, editing the Meter track must occur from a List or Notation Window. To open a List Window of meter events, double-click the selector dot.

Figure 25.12: Meter Track in the Tracks Window

See also Changing the Meter in Notation Windows (pg. 279) and Inserting Meter Changes in a List Window (pg. 270). To automatically add meter changes, see Redocking to a Click Track (pg. 144).

Key Signature Changes
Key changes must be viewed and edited from within a List or Notation Window. See Changing the Key in Notation Windows (pg. 279) and Inserting Key Changes in a List Window (pg. 271) for details.
Markers

Markers allow you to move quickly to different counter locations. For information on recalling markers, see Marker Pop-up (pg. 193). For information on inserting markers, see Insert Bar Marker (Command-) (pg. 422) in Chapter 43: The Do Menu, and Inserting Markers in a List Window (pg. 271).

The Tempo Track

The Tempo field shows the tempo for the sequence. A sequence’s Tempo track contains only tempo change events. For a new sequence, the tempo track contains one tempo change event at the beginning of the sequence.

If a sequence’s Tempo track contains just one tempo event, the value is editable from the Tracks Window. If the sequence contains more than one tempo event, “Tempo Track” is displayed in the Tempo field.

Other tempo related topics:

- To change the tempo in the Strip Chart, see Tempo (pg. 250).
- To insert tempo changes in a List Window, see Tempo Track List Windows (pg. 271).
- To record tempo changes in real time, see Virtual Conducting—Recording Tempo Changes (pg. 137).
- To make the sequence play at the Master tempo setting in the Control Bar, see Tempo Display (pg. 192).
- To allow simultaneously playing sequences to use their own Tempo tracks, see Sync Mode (pg. 212).
- To add tempo changes automatically while scaling time, see Editing a Rubato Performance (pg. 144).
- To display the Tempo field with more resolution (4 decimal places), see Clean Tempo Display (pg. 334).
SEQUENCE INFORMATION

Information Toggle

The Sync and Offset settings, if used at all, are usually set once and not used again. Choose Show Info from the Tracks Window menu to show and hide this information—or click the Information toggle.

Figure 25.14: Click the Information toggle to show and hide sequence information

SMPTE Offset

The SMPTE Offset sets the SMPTE start time of a sequence and is also used as the basis for computing SMPTE times displayed in List Windows.

SHORTCUT: Click the Offset button to grab the current SMPTE location from the Counter in the Control Bar. The SMPTE Offset field is updated automatically with the new location.

Sequence Start

Use the sequence Start Point to create a pickup for the sequence. Each sequence's Start Point can only be defined as 1•1•0 or earlier (anywhere in Bar 0).

For example, to set an eighth note pickup for the sequence:

1. Set the sequence Start Point to 0•4•240.

Opening an edit Window shows the sequence starting at 0•4•240, an eighth note earlier than bar 1.

NOTE: Setting a sequence’s Start Point to somewhere in bar 0, shifts all existing events back by one measure. Events residing before the Start Point are played at the Start Point.

Sync Mode

Figure 25.15: Sync Mode pop-up
Each sequence has its own Tempo track that usually determines its playback tempo. However, Vision also allows playback of several sequences simultaneously (see Players (pg. 113)). In these cases, you can specify whether the sequence uses the Master Tempo (and plays in sync with the other sequences), or whether it uses its own Tempo track.

The Sync mode pop-up allows selection of one of the following choices:

- **Off**
  The sequence plays independently of the Master Tempo (except when synced to MIDI Beat Clock). In this mode, Vision is substantially burdened with real-time computations; you should therefore only use this mode when you need to play simultaneous sequences with independent tempos.

- **Speed** (default)
  The sequence uses the Master Tempo. If a new sequence is triggered when other sequences are already playing, the new sequence starts playing immediately.

- **Start**
  The sequence uses the Master Tempo. When a sequence is already playing, triggering a new sequence causes a delay in playback until the Counter returns to the playing sequence’s Start Point, thereby keeping both sequences in sync.

You cannot change the Sync mode while playing or recording.
Display Modes

The Track Overview has three display modes: Phrases, Blocks, and Tracks. In addition, there is an option for Markers Break Blocks.

NOTE: In all Display modes, a sequence event is displayed as its own block.

Phrases

Phrases mode groups MIDI events into blocks created from MIDI events occurring closely together in time, but separated from other MIDI events by silence longer than the value selected in the Silence pop-up (see page 215).

Blocks

Blocks mode displays blocks of equal size. The Block size is set using the Block Size pop-up (see page 215).

Tracks

In Tracks mode, the entire track is a single block. This allows the entire track to be selected with a single mouse click in the Track Overview.

Markers Break Blocks

Check this option and Vision will break the material in the Track Overview into blocks wherever it encounters a marker.

For example, when using Tracks mode with Markers Break Blocks checked, Vision breaks your Track Overview into blocks that correspond exactly with every marker.
This has numerous uses. For example:

- Figure 25.18 shows a case where an EDL (Edit Decision List) was made using markers—the Markers Break Blocks option lets you quickly locate your individual musical passages visually in the Track Overview.

- If you record your entire song in a single sequence and use markers to define the sections (intro, verse, chorus, bridge), then by using the Markers Break Blocks option, you can easily locate to various portions of your song using only the visual feedback in the Track Overview.

If you display either Phrases or Blocks and check the Markers Break Blocks option, Vision continues to break up the Track Overview using the options set in either the Silence or Size selectors, but it further breaks the Track Overview at every marker.

NOTE: Markers are set, stored, and edited in the Meter track as described in Inserting Markers in a List Window (pg. 271).

You can also insert markers by selecting either Do>Insert Bar Marker or Do>Insert SMPTE Marker.

**Cursor Display**

![Image](image_url)

The Cursor Display constantly reflects the placement of your cursor in the track overview.

This is useful when you prefer more specific numeric feedback to graphical feedback about your cursor's position. For example, when making selections, dragging, etc., it is often helpful to know exactly where your cursor is.

Clicking on the I-beam icon in the Cursor display (as shown in Figure 25.19) toggles a SMPTE display on and off.

![Figure 25.19: Cursor display](image_url)

The SMPTE display is especially useful when scoring to film or video; for instance, if you need to insert a sound effect at a specific SMPTE location, use the SMPTE cursor display to ensure that the data is entered accurately.

**Block Size/Phrase Silence Size Pop-Up**

![Image](image_url)
When viewing tracks in Phrases or Blocks mode, the display resolution is specified in this pop-up. In Phrases mode, the value defines the amount of time that a track must be silent in order for Vision to break it into separate blocks. In Blocks mode, the value defines the size of the block.

**Using the Arrow Tool in Track Overview**

With the Arrow tool selected, clicking on blocks selects them. Shift-clicking additional blocks allows multiple, possibly discontiguous, blocks to be selected.

Using the Arrow tool selects all types of MIDI data in addition to notes.

Dragging a selection rectangle with the Arrow tool selects any block touched by the rectangle.

**Using the Marquee Tool in Track Overview**

Use the Marquee tool to select a time range of blocks in the Track Overview by dragging a rectangle around the block(s).

This selects all types of MIDI data in the tracks in addition to notes.

**Using the I-Beam Tool in Track Overview**

Use the I-Beam tool to select a time range in all tracks in a sequence, including the Tempo track.

This selects all types of MIDI data in the tracks in addition to notes.
Selecting in the Track Overview

Ruler

When the cursor is moved into the Ruler (regardless of the selected tool), it turns into the I-beam tool. Dragging the cursor in the Ruler selects a time range in all tracks in the Track Overview. Clicking in the Ruler sets the Edit In point, but doesn’t select all the tracks. This allows copying a selection, clicking in the Ruler to set a destination time, then pasting the data at the selected point. This method can considerably ease the task of locating the same data in other windows.

Dragging Blocks in Track Overview

Use the Arrow tool to drag blocks in the Track Overview. Dragging a block from one track to another merges the contents of the block with the contents of the destination track. The information is assigned to the Instrument of the destination track.

Dragging a block to a multi-track maintains the block’s original Instrument assignment.

NOTE: When dragging blocks, Cursor Quantize helps position the block precisely on bar and beat lines. See Cursor Quantize (pg. 58) for more information.

Option–dragging blocks keeps the original block untouched while copying it to a new location.

Vertical Zooming

Zooming vertically in the Tracks Window works a little differently than Vision’s other edit windows.
NOTE: With the Strip Chart open, the Tracks Window has an extra set of vertical Zoom buttons (located below those of the Track Overview).

To increase the display height for all tracks in the Track Overview, click the **Zoom In** vertical (+) button. This lets you see more track detail in each track block, but decreases the number of tracks visible in the Tracks Window.

**SHORTCUT:** Option-click the Zoom In button to zoom the Track Overview to its maximum height.

Click the **Zoom Out** vertical (-) button to decrease the display height for all tracks in the Track Overview. This lets you see more tracks in the Tracks Window, but decreases the amount of visible detail within each track block.

**SHORTCUT:** Option-click the Zoom Out button to zoom the Track Overview to its minimum height.

The Tracks Window supports four vertical zoom levels, shown in Figure 25.28. Select a zoom level that gives you the optimum trade-off between track detail and number of visible tracks.

**NOTE:** When zooming vertically in the Tracks Window, Vision recalculates the window size, if necessary, so that partial tracks are not displayed.
CHAPTER 25: The Tracks Window

TRACKS WINDOW MENU

- Auto Scroll (Shift-4)
- Jump to Selection ( Command-J)
- Zoom to Fit ( Option-Z)
- Zoom Back ( Option-B)
- Bar/Beat/Unit
- Absolute SMPTE
- Relative SMPTE
- Set Default Location
- Show Offset Info
- Detailed Track Overview
- Show Vertical Line

Following is an explanation of the items in the Tracks Window menu:

**Auto Scroll (Shift-4)**

When checked, Vision follows the Counter and automatically scrolls the contents of the Track Overview section.

**NOTE:** If **Auto Scroll Top Window Only** is checked in the Editing section of the Settings Window, Vision only scrolls the top window.

**Jump to Selection (Command-J)**

Choose this command to automatically scroll the contents of the Track Overview to the Edit In point.

**Zoom to Fit (Option-Z)**

Choose this command to view the contents of the entire sequence in the Track Overview section.

**Zoom Back (Option-B)**

Choose this command to return to the previous zoom level (acts to "undo" the last zoom).

**Tools**

This item chooses from the Arrow, Marquee, and I-beam tools. Only one can be selected (checked) at a time. Selecting one deselects the others.

Choosing one of these items is identical to selecting the corresponding tool in the actual Tracks Window. For a description of the different tool types, see Cursor Tools (pg. 57).

**Bar/Beat/Unit**

Specifies that bars/ beats/ units are displayed for the Edit In/ Out points, and for the event times in the Cursor Display.

**Absolute SMPTE**

Specifies that absolute SMPTE is displayed for the Edit In/ Out points, and for the event times in the Cursor Display.
Absolute time values are derived from adding the sequence’s offset time to the actual event times.

NOTE: The offset time for a sequence references a SMPTE time (location) on tape, usually corresponding to the beginning of a song or musical passage.

**Relative SMPTE**

 Specifies that relative SMPTE is displayed for the Edit In/Out points, and for the event times in the Cursor Display.

Relative time values represent the actual elapsed time from the beginning of the sequence—without adding the sequence’s offset.

**Set Default Location**

Saves as default the current position and size of the Tracks Window. Any newly opened Tracks Windows use these defaults.

**Show Offset Info**

This option opens and closes the Information area of the Tracks Window. Checking this item is the same as clicking the Information toggle in the upper-left corner of the Tracks Window (see Information Toggle (pg. 212)).

**Detailed Track Overview**

When checked, Vision displays detailed MIDI information in the Track Overview area of the Tracks Window. You will be able to see the data in a piano roll or Strip Chart format (or audio where applicable).

When unchecked, Vision instead displays patterned blocks where data is present—which speeds screen redraws.

**Show Vertical Line**

When checked, Vision displays a scrolling vertical line in the Track Overview area, indicating the location of the Counter as the sequence advances.
CHAPTER 26: The Pulse Window

PULSE WINDOW

Vision's Pulse Window provides a visual and intuitive environment for creating and editing drum tracks. To open the Pulse Window choose Windows>Pulse, or click the Pulse Window button in the Control Bar.

As can be seen in Figure 26.1, the Pulse Window is in many ways very similar to the Tracks Window. For instance, the sequence's Tempo, Meter, and Length fields are included and displayed in the same place; in addition, Track columns are listed on the left with corresponding track data displayed on the right in the Note Grid area.

One important difference between the Tracks and Pulse Window is that only drum tracks (which are comprised of individual note lines) can be viewed in the Pulse Window. For an explanation of drum tracks, see Drum Tracks (pg. 223).

Features common to both the Tracks and Pulse Windows are discussed in Chapter 25: The Tracks Window. If necessary, go back and read that chapter for information on the following topics:

- Track column descriptions, page 205;
- Sequence Length and Loopping, page 206;
- Meter and Tempo tracks, page 210;
- Sequence Information (Offset, Start Point, and Sync mode), page 212;
- Info area and Strip Chart, page 222.

Note Grid Toggle

You can show or hide the Note Grid area by clicking the Note Grid toggle, see Figure 26.2.
Window Divider

Use this divider to specify how the Pulse Window divides its space between the Track columns and Note Grid. When the mouse is positioned over the divider, the cursor changes into a resize cursor ( ). The divider can be dragged, changing the size of both areas, which could cause the Note Grid to cover some of the track and note line columns.

![Figure 26.3: Resizing the Note Grid area](image)

Expanded Info Area and Strip Chart

The lower portion of the Pulse Window can be expanded by clicking the open/close triangle. The lower-left area, when opened, displays expanded Play Quantize settings for selected drum tracks. The lower-right area displays the Strip Chart.

![Expanded Info Area and Strip Chart](image)

Figure 26.4: Pulse Window with expanded info area and Strip Chart

For information on the info area’s Play Quantize controls, see Play Quantize (pg. 72). See Opts Menu (pg. 262) to learn about the Opts menu. And, for details on using the Strip Chart, see Chapter 28: The Strip Chart.

NOTE: You can also double-click the Window Divider to automatically move it all the way to the left or right.
CHAPTER 26: The Pulse Window

DRUM TRACKS

The Pulse Window displays all drum tracks contained in the sequence. To create a new drum track, choose New Drum Track from the menu in the Pulse Window. In addition, any existing track can be turned into a drum track by clicking in the Drum column from the Tracks Window (see Figure 26.6).

NOTE: When opening older Vision files, some tracks (those containing Drum Instruments or Instruments with note names) are automatically designated as drum tracks.

Drum tracks, like regular tracks, can be selected and highlighted with their selector dots, and moved to another position within the window with the move cursor ( '). See Selector Dots and Move Cursor (pg. 22) for details.

As in the Tracks Window, the Pulse Window has track columns for Record, Mute, Solo, Length and Loop, and Comments, which are discussed in Track Columns (pg. 205).

NOTE: Instrument and Patch columns are part of the note line description.

Each of the track columns can be moved (and some even resized) as desired—allowing you to best utilize screen space. For details, see Moving and Resizing Columns (pg. 23).

Playback

In most cases, making a track a drum track will have no impact on the way the track sounds during playback.

However, there is one exception to this rule. If playback of a drum track begins during a note, or if the track is unmuted or soloed during a note, that note will not sound. Only notes whose note on events occur after playback begins (or after the track is soloed or unmuted) will sound. Soloing or unmuting the Instrument that the track is assigned to does not demonstrate the same effect; it works just as if the track is not a drum track.

This feature can be useful in live playback situations where a user might want to mute and solo tracks but only trigger note events that occur after the time that the solo button is enabled or mute is disabled. For example, if the triggered note is a sample loop, you would probably want to hear only full instantiations of the loop.
Quantize settings

Unlike the Tracks Window, the Pulse Window has a Play Quantize column containing a Quantize Value pop-up and Play Quantize toggle. This column lets you easily view the Play Quantize status of each drum track. To enable Play Quantize, simply check or uncheck the toggle.

![Figure 26.7: Play Quantize toggle (enabled)]

The function of the Quantize Value pop-up changes depending on whether the track is using Grid or Groove for its Play Quantize:

- Command-click the pop-up to toggle between Grid and Groove Quantize;
- When in Grid mode, choose a note duration for the Quantize value;
- When in Groove mode, specify the source track for the Groove;
- When in Groove Mode, Shift-click on the pop-up to specify the source sequence for the Groove.

To access the complete list of Play Quantize parameters, select the desired track and click the open/close triangle in the info area (see Expanded Info Area and Strip Chart (pg. 222)).

Drum Note Lines

When creating a new drum track, it contains just one note line. Additional note lines are added by clicking the Add button in the Select & Move column.

![Figure 26.8: Adding drum note lines](image)

Each drum track can contain multiple drum note lines. Each note line corresponds to a single drum or percussion sound, which is defined with columns for Note, Instrument, and Patch.

![Figure 26.9: Assigning a sound in the Note column](image)

Click in the Note column to assign a sound to the note line. If the assigned Instrument is subscribed to a Patch Name document that contains note names, the Note column displays those names—as opposed to MIDI note numbers.)
Drum tracks containing note lines assigned to different Instruments are “multi” tracks and are displayed as such in other Vision windows.

NOTE: When recording or inserting notes into a drum track from another window, drum note lines, corresponding to the new data, are automatically added.

Individual drum note lines can be selected for editing by clicking on their respective selector dots. When selected, all notes in the note line become highlighted, and can be modified with any of Vision’s edit commands.

Figure 26.10: Selecting a drum note line

Selected note lines can also be dragged to a different position within a drum track, or to another track—drag beyond all current drum tracks to add a new track automatically.

To remove a drum note line, select it and choose **Edit>Clear Selection**.

NOTE: You can use **Separate Multi Track** to unmerge all note lines in a drum track to separate tracks.

NOTE: A drum track’s Play Quantize settings affect all note lines contained in that track. If individual settings for Play Quantize and Play Shift are desired for a particular note line, simply drag it to a new drum track where it can have its own settings.

Using Separate Multi Track with Drum Tracks

If a drum track is selected, the **Separate Multi Track** command can be used to separate each note line on the track into its own track. Select the track in the Tracks window and choose **Edit>Separate Multi Track** to create an individual track for each note line.

**NOTE GRID**

The Note Grid displays data for each of the note lines in each drum track. In addition to the normal methods of recording and inserting MIDI data, notes can be inserted and deleted in the Note Grid with the Magic Drumstick or Pencil tools. Data displayed in the Note Grid is restricted to notes.

The Note Grid is viewed in one of two modes as specified by the Display pop-up.
PART 6: Windows

Figure 26.12: Display Mode and Grid Size pop-ups

Both display modes provide vertical grid lines that help illustrate the “beat” boundaries in the Note Grid. The number of grid lines, and their spacing, is based on the setting in the Grid Size pop-up (just to the right of the Display Mode pop-up).

Matrix Display Mode

The Matrix display mode is optimized to provide an evenly spaced grid for inserting and deleting notes.

In this mode, inserted notes are seen as small squares centered cleanly within each grid space. Although note durations are not displayed, and note start times are not always clearly represented, Matrix mode provides a good environment for building and editing rhythms and patterns.

You can zoom horizontally while in Matrix mode—with the Zoom buttons in the scroll bar, or by Option-clicking with the mouse. Changing the zoom levels, however, automatically adjusts the Grid Size pop-up to the appropriate corresponding resolution.

NOTE: When zooming out, groups of individual notes are displayed as single blocks equal to the Display mode's Grid Size.

Graphic Display Mode

Unlike Matrix, the Graphic display mode accurately displays where each note begins and ends (with relation to bar and beat lines). In this mode, the notes displayed are just like those used in the Graphic Window.

This mode provides better horizontal zooming than Matrix mode—zooming in and out does not adjust the Grid Size and individual notes are almost always visible. Hence, the Graphic display mode provides an excellent environment for adjusting note durations and start times within the context of the Note Grid’s vertical lines.

NOTE: When zooming out past a certain point while in Graphic display mode, the vertical grid lines disappear.
Inserting Notes with Magic Drumstick

To insert a note in the Note Grid, simply select the Magic Drumstick and click in the desired grid location. The Drumstick works as a toggle for inserting and deleting notes. To remove a note, just click on it with the Drumstick.

The Drumstick points in a different direction depending on its mode of operation (inserting or deleting).

A series of notes can be entered, or removed, by clicking and dragging with the Drumstick. The spacing, duration and velocity for the entered notes is taken from the settings in the Insert Note section of the Settings Window, see Figure 26.16.

The Spacing size can also be set from the note pop-up directly to the right of the Drumstick tool in the Pulse Window. And, if Duration is set to “Percent of Spacing” with 100% (in the Settings Window), adjusting the Spacing pop-up also sets the Duration value.

Notes can also be entered in the Note Grid area with the Pencil tool. It cannot, however, erase notes or click and drag a range of notes like the Magic Drumstick.

For a short tutorial on using the Magic Drumstick tool, see Building a Drum Track (pg. 40).

NOTE: If a drum note line is set to display note velocities, the vertical placement of the mouse determines the velocity for the entered note. See Note Velocities (pg. 228) for details.
Note Velocities

In the Note Grid area, individual note lines can be displayed with or without velocities. A Velocity button, located just to the left of the Note Grid, toggles the display of velocities on and off for each line. Option-click on any one Velocity toggle to set all note lines to that velocity view.

When enabling the Velocity toggle, the height of the display for that particular note line gets taller, thereby allowing the velocity range of its notes to be seen. In this mode, notes entered with the Drumstick or Pencil tools will have velocities based on the vertical placement of the mouse.

Adjusting Notes in the Note Grid

With the Note Grid set to Matrix, you can drag notes to another grid space—forward or back in time, or up and down to another note line. Select the Pencil or Marquee tool, place your cursor near the desired note, and one of the following note edit cursors will appear:

- Click and drag left or right with this cursor to change the note’s location. Any other selected notes are dragged as well. You can only move notes horizontally with this cursor. Dragging notes in this fashion (while set to Matrix) always moves them in increments of the note value defined in the Spacing pop-up—regardless of the Cursor Quantize setting.

- Click and drag up or down with this cursor to move the note to a different note line. Any other selected notes are dragged as well. You can only move notes vertically with this cursor.
With the Note Grid set to Graphic, the note edit cursors work just like they do in the Graphic Window. See Modifying Notes in the Graphic Window (pg. 236) for details.

**NOTE:** You must choose either the Marquee or Pencil tool in order for the note edit cursors to show up in the Note Grid.

### Editing Velocities in the Note Grid

If velocities are displayed for a note line, you can use the Marquee or Pencil tool to edit their values.

If the Note Grid is set to Graphic, place your cursor near the center of the note. Once the Change Velocity cursor appears, click and drag up or down to set the new velocity value (see Figure 26.20).

**NOTE:** When viewing velocities for a note line, it is not possible to drag those notes to another drum note line.

**TIP:** You can adjust the velocities of entered notes on-the-fly with the Drumstick or Pencil tools. While viewing velocities, click a note into a grid space and hold down the mouse button; then drag up or down until the desired velocity is achieved—release the mouse button to enter the note.

### Nudge

Data contained in any drum track or note line can easily be nudged back or forward in time. This nudging capability provides an easy way to tweak the subtle timing of tracks or notes.
To nudge a drum track or note line, simply select it and type Command→ (forward) or Command← (back). To see the notes actually move, you’ll need to set the Display mode to Graphic.

The nudge amount, set from either the Pulse Window or the Settings Window, is defined by a number of bars, beats, units, seconds, frames, or bits.

NOTE: Unlike settings for Play Quantize or Play Shift, nudging tracks and notes permanently alters the data.

MULTIPLE PULSE WINDOWS

It is possible to have multiple Pulse Windows open for the same sequence, which is desirable if you’d like them set to different Matrix values.

With a Pulse Window active (in front), simply choose Windows>Pulse, or click on the Pulse button in the Control Bar, to open an additional Pulse Window.

With a Pulse Window in the background, you can also open additional Pulse Windows by Shift-double-clicking a drum track’s selector dot or track block, or by Shift-clicking the Pulse button in the Control Bar.

Following is an explanation of the items in the Pulse Window menu:

New Drum Track (Command-Shift-N)

Choose this command to add a new drum track to the current sequence.

NOTE: Only drum tracks can be viewed and edited in the Pulse Window.
Auto Scroll (Shift-4)

When checked, Vision follows the Counter and automatically scrolls the contents of the Note Grid.

NOTE: If Auto Scroll Top Window Only is checked in the Editing section of the Settings Window, Vision only scrolls the top window.

Jump to Selection (Command-J)

Choose this command to automatically scroll the contents of the Note Grid to the Edit In point.

Zoom to Fit (Option-Z)

Choose this command to set the size of the Note Grid to whole notes, which is the widest zoom level.

Zoom Back (Option-B)

Choose this command to return to the previous zoom level (acts to “undo” the last zoom).

Tools

This item chooses from the Marquee, Pencil, and Magic Drumstick tools. Only one can be selected (checked) at a time. Selecting one deselects the others.

Choosing one of these items is identical to selecting the corresponding tool in the Pulse Window’s tool palette. For a description of the different tool types, see Cursor Tools (pg. 57).

Bar/Beat/Unit

Specifies that bars/ beats/ units are displayed for the Edit In/ Out points, and for the event times in the Cursor Display.

Absolute SMPTE

Specifies that absolute SMPTE is displayed for the Edit In/ Out points, and for the event times in the Cursor Display.

Absolute time values are derived from adding the sequence’s offset time to the actual event times.

NOTE: The offset time for a sequence references a SMPTE time (location) on tape, usually corresponding to the beginning of a song or musical passage.

Relative SMPTE

Specifies that relative SMPTE is displayed for the Edit In/ Out points, and for the event times in the Cursor Display.

Relative time values represent the actual elapsed time from the beginning of the sequence—without adding the sequence’s offset.

Set Default Location

Saves as default the current position and size of the Pulse Window. Any newly opened Pulse Windows use these defaults.
Show Offset Info

This option opens and closes the Information area of the Pulse Window. Checking this item is the same as clicking the Information toggle in the upper-left corner of the Pulse Window (see Information Toggle (pg. 212)).

Play Edited Note

When checked, Vision plays any note clicked. Notes inserted with the Pencil and Magic Drumstick are also audible. When unchecked, note editing does not trigger any sound.

Show Vertical Line

When checked, Vision displays a scrolling vertical line in the Note Grid area, indicating the location of the Counter as the sequence advances.
CHAPTER 27: The Graphic Window

The Graphic Window displays and edits MIDI data in a “Piano Roll” format. The “piano keys,” or pitches, are oriented at the left edge of the screen, descending in pitch from top to bottom. The display may be scrolled to display all 127 MIDI pitches. The horizontal direction, representing time flowing from left to right, is denoted by bars and beats. Although only one track can be displayed in a Graphic Window, many Graphic Windows can be open simultaneously.

In Graphic Windows, notes are displayed graphically as rectangles (very short notes are displayed as X’s). The vertical position of each rectangle denotes the pitch while the horizontal location of the left edge of the note marks the time at which the note occurs. The duration is represented by the length of the rectangle. If the track contains multiple Instruments, the note color indicates the assigned Instrument.

For information on edit tools and edit functions common to each of Vision’s edit windows, see Chapter 9: Basic Editing Procedures. For information on navigating Vision’s windows, see Chapter 4: Navigating in Vision.
SELECTING NOTES IN THE GRAPHIC WINDOW

Click a note to select a it. Shift-click to select additional notes. Selected notes are hollow instead of solid. Shift-click to deselect a selected note.

NOTE: Once a note is selected, you can automatically select the previous or next note by typing the appropriate Arrow key (left or right) on your Macintosh keyboard. Hold down the Shift key and the previously selected notes remain selected.

In addition to selecting notes individually, they can also be selected in groups, as discussed in the following sections.

Using the Marquee Tool

Use the Marquee tool to select notes in a rectangular area. Choose the Marquee tool, click in one corner of the rectangle and drag to the other corner. All notes beginning within the drawn rectangle are selected.

Figure 27.3: Selecting notes with the Marquee tool

Make sure the cursor is a “cross” when beginning to drag the rectangle rather than a note edit cursor (indicated with small arrows, discussed at the end of this chapter). The note edit cursors appear when the cursor is located over a note, indicating that the note will either be dragged to a new pitch or location, depending on which part of the note the cursor is above.

Using the I-Beam Tool to Select a Time Range

Notes in a time range are selected with the I-beam tool by dragging across the time area within the Piano Roll. Unlike the Marquee tool, which allows a vertical component to the selection, using the I-beam tool in this manner selects all pitches in the selected time range (see Using the I-Beam Tool to Select a Pitch Range (pg. 235)).

Figure 27.4: Defining a time range in the Piano Roll
This method does not select pitch bend, modulation or controller events. To select these type of MIDI data, see Selecting all Types of MIDI Data in a Time Range (pg. 235).

Using the I-Beam Tool to Select a Pitch Range

By moving your mouse into the left margin of the Graphic Window, where the pitches are displayed, the cursor changes to a horizontal I-beam. This tool allows selection of all notes in a specified pitch range over the entire track length.

Selecting all Types of MIDI Data in a Time Range

To select all MIDI data, position the cursor within the Ruler and drag horizontally. All MIDI data contained within the time range is selected (including notes, patch changes, pitch bend, etc.).

The I-beam tool is available in the Ruler at all times, even if the Marquee tool is currently selected.
MODIFYING NOTES IN THE GRAPHIC WINDOW

There are three note edit cursors to modify notes in the Graphic Window. As the cursor moves over different portions of the note, the cursor changes to reflect the operation that occurs when the note is dragged. The following sections discuss these note edit cursors.

NOTE: Use the Cursor Display area (see page 58) to monitor changes to the note properties.

NOTE: When you are moving or transposing notes, you can hold down the Option key on your computer keyboard to copy the note before modifying it. This leaves the original data intact.

Moving Notes

Position the cursor over the left section of a note to get the Move cursor, which allows modification of the note’s start point by clicking and dragging left or right. Any other selected notes are also dragged. The Move cursor changes only the start time of the note, not its pitch or duration.

Transposing Notes

Position the cursor in the middle of a note to get the Transpose cursor, which allows modification of the note’s pitch by dragging up or down. The start time and duration of the note are not changed.

Changing a Note’s Duration

Position the cursor over the right section of a note to get the Duration cursor, which allows modification of the note’s duration. Dragging to the left shortens the note and dragging to the right lengthens it.

Figure 27.7: Moving a note with the Move cursor

Figure 27.8: Transposing with the Transpose cursor

Figure 27.9: Changing duration with the Duration cursor
CHAPTER 27: The Graphic Window

GRAPHIC WINDOW MENU

- Auto Scroll
- Jump to Selection
- Zoom to Fit
- Zoom Back
- Tools

- Bar/Beat/Unit
- Absolute SMPTE
- Relative SMPTE

- Set Default Location
- View...
- Play Edited Note
- Show Vertical Line
- Show Piano Keyboard

Following is an explanation of the items in the Graphic Window menu:

Auto Scroll

When checked, Vision follows the Counter and scrolls the contents of the Graphic Window.

NOTE: If Auto Scroll Top Window Only is checked in the Editing section of the Settings Window, Vision only scrolls the top window.

Jump to Selection (Command-J)

Choose this command to automatically scroll the contents of the Graphic Window to the Edit In point.

Zoom to Fit (Option-Z)

Choose this command to view the contents of the entire track in the Graphic Window.

Zoom Back (Option-B)

Choose this command to return to the previous zoom level (acts to "undo" the last zoom).

Tools

This item chooses from the Marquee, I-beam, and Pencil tools. Only one can be checked at a time. Selecting one deselects the others.

Choosing one of these items is identical to selecting the corresponding tool in the actual Graphic Window. For a description of the different tool types, see Cursor Tools (pg. 57).

Bar/Beat/Unit

Specifies that bars/ beats/ units are displayed for the Edit In/ Out points, and for the event times in the Cursor Display.
PART 6: Windows

Absolute SMPTE

Specifies that absolute SMPTE is displayed for the Edit In/Out points, and for the event times in the Cursor Display.

Absolute time values are derived from adding the sequence’s offset time to actual event times.

NOTE: The offset time for a sequence references a SMPTE time (location) on tape, usually corresponding to the beginning of a song or musical passage.

Relative SMPTE

Specifies that relative SMPTE is displayed for the Edit In/Out points, and for the event times in the Cursor Display.

Relative time values represent the actual elapsed time from the beginning of the sequence—without adding the sequence’s offset.

Set Default Location

Saves as default the current position and size of the Graphic Window. Any newly opened Graphic Windows use these defaults.

View (Option-V)

Choose this menu item to open the View dialog. It specifies which Instrument events are displayed for the selected track in the Graphic Window.

Choose from the following radio buttons:

- **all**
  Displays all Instruments.

- **only**
  Displays only the selected Instruments.

- **all except**
  Displays only the Instruments not selected.

The View dialog not only determines which data is displayed, but also which data is editable. Data not displayed, therefore, cannot be selected, edited, or modified.
CHAPTER 27: The Graphic Window

**Play Edited Note**

When checked, Vision plays any note clicked. If transposing a note, the different transposition values are audible as the note is dragged. Notes inserted with the Pencil tool are also audible. When unchecked, note editing does not trigger any sound.

**Show Vertical Line**

When checked, Vision displays a scrolling vertical line in the Graphic Window, indicating the location of the Counter as the sequence advances.

Both the bouncing ball and vertical line may be displayed simultaneously.

**Show Piano Keyboard**

Check this option to display a graphic keyboard in the left margin of the Graphic Window (instead of pitch and note names).
CHAPTER 28: The Strip Chart

WHAT IS THE STRIP CHART?

The Strip Chart is a powerful editing tool found in the Tracks, Pulse, Graphic, and Notation Windows. It provides graphic viewing and editing of a variety MIDI data. The Strip Chart can also be used to insert events, and in the process, create many interesting musical effects like decrescendo, accelerando, or vibrato.

The following event types can be viewed and edited in the Strip Chart:

- velocity
- release velocity
- duration
- tempo
- markers (view only)
- patches
- text events (view only) including lyrics and copyrights
- aftertouch and poly aftertouch
- pitch bend
- MIDI Controllers (volume, pan, sustain, mod wheel, etc.)
- automation events (including volume, pan, mute/ solo, send levels, EQ enable, and phase inversion)
- EQ band parameter events
- Plug-in parameter events

Each event in the Strip Chart is displayed as a rectangle. The height of the rectangle determines the value, the left edge signifies the start time, and the width determines the duration of the event.

Figure 28.1: The Strip Chart

The Strip Chart consists of the following items:

1. I-beam tool
2. Pencil tool
3. Variable pop-up
4. Edit Shapes pop-up
5. Strip Chart toggle (shown enabled)
6. Strip Chart contents
7. Density setting
8. Exact toggle (shown disabled)
Opening the Strip Chart

To open the Strip Chart in the Graphic Window, click the Strip Chart toggle at the bottom of the Window (see Figure 28.2). In addition, choosing an event type from the Strip Chart Contents pop-up will automatically open the Strip Chart.

![Figure 28.2: Clicking the Strip Chart toggle](image)

To open the Strip Chart in the Tracks and Pulse Windows, click the open/close triangle in the lower-left corner of the Window (see Figure 28.3).

![Figure 28.3: Opening Strip Chart in Tracks Window](image)

KEYBOARD EQUIVALENT: Type Shift-3 on your computer keyboard to toggle the Strip Chart between open and closed.

Defining the Strip Chart Contents

To choose the event type displayed in the Strip Chart:

1. Click on the Contents pop-up and select the desired event type.

![Figure 28.4: Defining the Strip Chart Contents](image)

Event types contained within the track are displayed in **bold** text in the Contents pop-up. This provides immediate feedback on which types of data are contained in the track. If a track contains only note data, the Contents pop-up displays only three event types in bold: Velocity, Release Velocity, and Duration.

NOTE: Choosing **No Strip Chart** from the Contents pop-up closes the Strip Chart.
CHAPTER 28: The Strip Chart

STRIP CHART CONTENTS

Modifying Events in the Strip Chart

In the Graphic and Notation Windows, the Strip Chart displays information only for the track in that window. In this case, inserting new events in the Strip Chart places the data in the displayed track (even if other tracks are selected in the Tracks or Pulse Window).

In the Tracks and Pulse Windows, the Strip Chart displays information for all selected tracks. In this case, inserting new events in the Strip Chart places the data in each selected track.

However, modifying existing events in the Strip Chart modifies all events of that type in all selected tracks for the selected time range. This is the case for the Strip Chart in each edit window (despite the absence of these track events in the Graphic and Notation Windows).

THE STRIP CHART TOOLS

The I-Beam Tool (Select)

Use this tool to click and drag over a selected time range in the Strip Chart. The I-beam tool in the main window’s tool palette works similarly, but each tool operates independently.

The Strip Chart I-beam tool is also independent from the Marquee tool in the main window’s tool palette.

The Pencil Tool

The Pencil tool allows drawing a new set of values for a selected event or group of events. It works with the Shapes defined in the Edit Shapes pop-up (see page 246).

The Variable pop-up

The Variable pop-up, providing access to several types of tools with special functions, works in conjunction with the Edit Shapes pop-up.
Scale

Using the Scale tool, Strip Chart data can be modified by a factor ranging from 25% to 400%, labelled in the left margin. Vision multiplies the value of each event by the Scale factor. The resulting value is confined to limits imposed by the event type.

Max/Min Limit

The range of values created by Strip Chart edit operations can be limited by setting the Variable pop-up to either Max or Min Limit.

For example, values greater than 48 can be reduced to 48 by selecting Max Limit and drawing a line at 48 across the desired time range, leaving all values less than 48 unchanged.

Add Amount

The Add Amount tool causes values to be added to or subtracted from the values of the event according to the points on the line drawn.

For example, drawing a sloping line from 10 to 20 in the time range of notes having a velocity of 64, increases the values from 74 to 84.

Legato

In Legato mode, the ending times of selected notes are changed with respect to their proximity to the next note. The duration is changed but not their start times.

For example, using Legato on durations with a value of 100% extends each note until the beginning of the next note.
NOTE: Legato is grayed out when the Strip Chart displays anything other than note durations.

NOTE: The Legato tool in the Strip Chart uses the setting in the Select & Modify Window (for Change Duration, Set Legato to) when deciding the gap size over which notes are not affected. For details, see Change Methods (pg. 126).

**Thin**

Using Thin eliminates some controller data to require fewer events to achieve a similar effect. This saves memory and speeds up operations. Aftertouch, pitch bend, and volume controllers are notorious for clogging up MIDI transmissions with high data densities.

For example, if a sequence is mixed and a track contains too much volume controller data:

1. Choose the **Thin** tool from the Variable pop-up.
2. **Set the Density to a small amount (perhaps 3%).**
   - The **Density** field is located to the left of the Exact mode toggle.
3. **Drag across the control data to thin.**

   **NOTE:** By using **Undo**, different Density settings can be auditioned to find the smallest setting that produces the desired effect.

The Density setting can also be increased from the current setting, creating interpolated values to “smooth out” overly noticeable controller changes.

**Compress**

The Compress tool compresses and expands Strip Chart data while keeping the relationships between existing events proportional.

For instance, Figure 28.9 shows the Compress tool expanding a range of key velocities. Notice that the basic shape of the data remains similar, but its range is expanded to fit the height of the drawn rectangle.

![Figure 28.9: Expanding data range in Strip Chart with Compress tool](image)

To compress the data, draw a rectangle around the events with a narrow range—the events increase or decrease as necessary to fit within the new data range.
PART 6: Windows

The Compress tool affects all events in the time region of the dragged rectangle, even if they are above or below it. Events at the bottom of the data range are assigned a new value corresponding to the bottom of the rectangle, events at the top of the range are assigned a new value corresponding to the top—all others get proportional new values somewhere in-between.

The Edit Shapes Pop-up

<table>
<thead>
<tr>
<th>Straight</th>
<th>Free</th>
<th>Parabola</th>
<th>Flat</th>
<th>Random</th>
<th>Sine</th>
<th>Square</th>
<th>Triangle</th>
<th>Sawtooth</th>
</tr>
</thead>
</table>

Figure 28.10: Edit Shapes pop-up

**Parabola**

The Parabola shape draws a parabolic curve from left to right (steeper at right) or from right to left (steeper at left).

The shape and size of the parabola is defined by the direction and amount dragged:

![Four parabolas drawn differently, arrows indicating the mouse direction](image)

Figure 28.11: Four parabolas drawn differently, arrows indicating the mouse direction

The Parabola is especially useful when creating fade outs:

1. With the Strip Chart open, choose **Volume** from the Contents pop-up.
2. Select the Pencil tool.
3. Choose **Parabola** from the Edit Shapes pop-up.
4. Drag a parabola from the top of the Strip Chart to the bottom, starting at the time to begin fading, and stopping at the end of the track.

**Straight**

The Straight shape draws a line in any direction, making linear changes to Strip Chart events.

**Free**

The Free shape draws a freehand line and is especially helpful when using the Pencil tool, Min Limit, or Max Limit.
Flat

The Flat shape draws straight, horizontal lines. All affected data either assumes the value drawn, has a constant amount added, or is scaled by a constant amount, depending on the modification tool selected from the Variable pop-up.

This is especially useful with the Percent tool to scale all events by the same percentage.

Random

The Random option drags a rectangular selection around the events to randomize. Vision randomly chooses values falling within the range of the rectangle and applies the changes to the selected events. When the Variable pop-up is set to Add Amount, Vision adds a random amount between values outlined. When using Scale, Vision chooses random values for scaling the selection.

Oscillator Shapes

Use the Oscillator shapes to insert or shape data with periodic waveforms. The available waveshapes include Sine, Square, Triangle, and Sawtooth. These shapes can be used to draw in expression data for filter sweeps, or volume data for tremolo effects—and they can be in perfect sync with your sequences.

Figure 28.13 shows controller events inserted with the Sawtooth waveshape.
PART 6: Windows

The height of the drawn events is determined by how far up or down you drag the mouse after the initial click. The direction of the waveform is determined by whether the mouse was dragged up or down.

The Waveform Period is set in the Strip Chart & Nudge section of the Settings Window, see Figure 28.14, and determines the length of each cycle for the Oscillator shape. The period can be specified as a number of bars, beats, units, seconds, frames, or bits.

The Waveform Period pop-up also has an option called Use Meter. Check this item when using “bars” as the period; this ensures that the bar’s size is based on the Meter for the affected track region. Use Meter is checked by default.

Use the Waveform Period along with Cursor Quantize to ensure that the wave shapes are drawn cleanly on the desired beats.

NOTE: When using an Oscillator Shape in the Strip Chart with the Pencil tool selected, you can click the Pencil tool to automatically open the Settings Window — where the Waveform Period may be specified.

NON-CONTINUOUS EVENTS IN THE STRIP CHART

The Strip Chart can display many non-continuous types of events, including Mute, Solo, Plug-In Bypass, EQ Enable, etc. In these cases, events drawn in the top half of the Strip Chart result in an “On” event and events drawn in the bottom half of the Strip Chart result in an “Off” event.

Regardless of where you position the pencil tool when inserting these events, On events will be drawn at the very top of the window and Off events will be drawn
at the very bottom of the window. This results in a situation where Off events themselves cannot be seen in the Strip Chart, except as the "end" of an on event.

As a rule of thumb, if you see a colored rectangle in the Strip Chart, the parameter selected in the Strip Chart contents pop-up is On. If you do not see a colored rectangle, the parameter is Off.

**Velocity and Release Velocity**

The Strip Chart displays two types of velocity:

- velocity (key velocity)
- release velocity

Since Velocity is not displayed in the Graphic or Notation Windows, the Strip Chart provides viewing and editing for these important events.

When either type of velocity is selected from the Strip Chart's Contents menu, the Strip Chart displays a vertical bar for each note's velocity value. The values are shown on the left side of the Strip Chart.

An audio event's velocity setting affects the playback volume of the audio event; the higher the number is, the louder the event will be.

**Duration**

Note Durations can be viewed and modified in the Strip Chart.

This section describes how to use the Strip Chart to view and change various event types.

**NOTE:** When editing data in the Strip Chart, holding down the Shift-key affects only previously selected events.

**NOTE:** During operations that add to or subtract from Strip Chart data, Vision automatically limits the resulting values to their legal minimum or maximum bounds.
When viewing durations in the Strip Chart, vertical bars are displayed denoting the duration for each note. The value of the bar is shown on the left side of the Strip Chart. The scale maximum is a whole note except when Add Amount is the selected tool. The scale is then denoted by \( \text{\textbf{\textbullet}} \) to \( \text{\textbf{\textbullet}} \) indicating that a maximum value of \( \text{\textbf{\textbullet}} \) may be added to or subtracted from a note duration.

**Tempo**

Although tempo events are stored in the Tempo track of each sequence, the Tempo track is directly editable from the Strip Chart—simply choose Tempo from the Contents pop-up.

Editing or inserting tempo events in the Strip Chart automatically updates the sequence’s Tempo track.

NOTE: When using the Straight tool to draw an accelerando or ritardando in the Strip Chart, Vision draws a curve instead. Linear changes to tempo are not perceived as linear, or smooth.

**Markers**

Markers are stored in the Meter track, but can be viewed in any track’s (MIDI or Audio) Strip Chart. For example:

If the Markers in your Meter track look like this...

- 1 • 1 • 0
- 9 • 1 • 0
- 25 • 1 • 0

...the Markers would look like this when displayed in the Strip Chart.
Patches

Insert a Patch Change in the Strip Chart by using the Pencil tool to click at the desired time for the Patch Change. A pop-up menu appears listing the patches available for the track’s Instrument.

If the Instrument doesn’t have names assigned in the Names Window, a dialog appears allowing numeric entry for bank select and program change values:

Text-type submenu

Text-type events allow storage of text comments, copyright information, descriptions of Instruments, lyrics, or cue points in tracks, along with MIDI information.

The Strip Chart displays each text event on its own horizontal text line. When enough text events have been displayed to fill the entire strip chart (vertically), display begins again at the top of the window. The Strip Chart can only display the first 62 characters of any text-type event. Text-type events may actually occupy several lines in the Text Edit dialog but only the information that fits is displayed in the Strip Chart.

Text-type events include:

- **Text**
  Can be used for any text including comments, reminders etc.

- **Copyright**
  Provides a place to store a copyright notice.

- **Instruments**
  Verbal descriptions of Instruments can enable subsequent orchestration in a different MIDI environment.

- **Lyrics**
  Words may be exported to notation programs supporting this feature.
• **Cue Points**
  Typically describes action taking place on film or video occurring at a specific SMPTE time.

Inserting a new text-type event opens the Text Edit dialog allowing display and editing for the entire event. Any text can be typed in, and cut, copy, and paste operations can be performed by typing Command-X, Command-C, and Command-Y, respectively (these commands are not available from the *Edit* menu). When finished, type the Enter key to insert the text into the track.

### MIDI submenu

**MIDI**

![MIDI submenu](image)

**MIDI events include:**

- **Pitch Bend**
  Pitch Bend events can have values from -8192 to +8191. They are displayed as events above and below a horizontal line. Events above the line have positive values, and events below the line have negative values.

![Pitch bend events](image)
• **Aftertouch**
  Aftertouch events can have values between 0 and 127.

• **Poly Aftertouch**
  When using the Strip Chart to display and edit Poly Aftertouch, a note number appears in the second pop-up next to the Strip Chart’s Contents pop-up. The Strip Chart displays and edits Poly Aftertouch events for one note at a time. To select a different note, click the Note pop-up and change it using either the mouse or a MIDI controller.

![Figure 28.21: Viewing Poly Aftertouch in the Strip Chart](image)

• **Velocity Scale**
  Velocity Scale events can have values between 0 and 127. For more information about Velocity Scale, see Velocity Scale (pg. 297).

• **MIDI Controllers**
  A general Controller option and all eight Favorite Controllers are available from the MIDI submenu. To define your Favorite Controllers, see Favorite Controllers (pg. 336).
  Choosing any of these items gives you a second pop-up containing all controller types.

  When one of the eight favorite controllers is selected, the name and number of the controller appears in the second pop-up (to the right of the Strip Chart’s Contents pop-up). When “Controller” is selected, the second pop-up displays Controller 7 (Volume) by default.

  In both cases, any new controller may be selected from the second pop-up.

![Figure 28.22: Controller pop-up in the Strip Chart](image)
• **Fine Controls**
  Vision allows controllers numbered 0-63 to be in Fine or Coarse mode. In Coarse mode, Vision displays and edits values in a range of 0-127. In Fine mode, controllers 32-63 are interpreted as “fine tuning” for controllers 0-31. In this case, the combined value limits are 0 to 16383. Fine Controls are enabled from the Settings Window (see page 331 for details).
  
  **NOTE:** Most MIDI devices don't use Fine controls. Consult your device manual to find out if this feature is available.

### Automation submenu

- **Audio Volume**
  Values can range from negative infinity to +24 dB. For details, see your Audio Reference Manual.

- **Audio Pan**
  Values range from <100.00 (left) to 100.00>(right).

- **Mute**
  Events drawn in the top half of the strip chart will result in a “Mute On” event, and events drawn in the bottom half will produce a “Mute Off” event.
  
  Unlike most of the other commands in this menu, Mute can affect Audio or MIDI Instruments. Keep in mind that these events affect Instruments rather than tracks.
  For details, see your Audio Reference Manual.

- **Solo**
  Events drawn in the top half of the strip chart will result in a “Solo On” event, and events drawn in the bottom half will produce a “Solo Off” event.
  
  Unlike most of the other commands in this menu, Solo can affect Audio or MIDI Instruments. Keep in mind that these events affect Instruments rather than tracks.
  For details, see your Audio Reference Manual.

- **Send (1-4) Level**
  These options can write Send Level events for each specific send. Values range from negative infinity to +24 dB.
• **Plug-in (1-4) Bypass**

  **Plug-in Bypass** events can have Off and On values. When set to Off, the plug-in will be applied to the audio signal. When set to On, the plug-in will be bypassed.

  Events drawn in the top half of the strip chart will result in a “Plug-in Bypass On” event, and events drawn in the bottom half will produce a “Plug-in Bypass Off” event.

• **Phase Invert**

  Events drawn in the top half of the strip chart will result in a “Phase Invert On” event, and events drawn in the bottom half will produce a “Phase Invert Off” event.

• **EQ Enable**

  Events drawn in the top half of the strip chart will result in an “EQ Enable On” event, and events drawn in the bottom half will produce an “EQ Enable Off” event.

For more information about these automation events, please see your Audio Reference Manual.

**EQ Band Parameter submenu**

- **Frequency**

  Controls the frequency of the specified EQ band. Values can range from 20.00 Hz to 20000.00 Hz.

- **Gain**

  Controls the gain of the specified EQ band. Values can range from -18.00 dB to +18.00 dB.

- **Width**

  Controls the width of the specified EQ band. Values can range from 0 to 4.00 octaves.

- **Type**

  Allows you to change the EQ type for the specified band.

- **Enable**

  Events drawn in the top half of the strip chart will result in a “EQ Band Enable On” event, and events drawn in the bottom half will produce a “EQ Band Enable Off” event for the specified band.

For more information about these automation events, please see your Audio Reference Manual.
PART 6: Windows

Plug-in Parameter submenu

The Plug-in Parameter submenu lists the plug-ins that are assigned to the selected track’s Audio Instrument. For example:

After you select a plug-in, another pop-up menu appears to the right. This menu displays the selected plug-in’s parameters. For example, if you select opECHO, you will see the following:

Open the plug-in edit window for opECHO, and you will see that the parameters listed in the pop-up menu correspond to the parameters of the opECHO plug-in.

Vision can automate up to 1024 parameters per VST plug-in.

For more information about these automation events, please see your Audio Reference Manual.

Using the Density Setting

When choosing the Pencil or Thin tools to edit continuous automation data, the Density setting appears next to the second Strip Chart pop-up.

Vision setting in the Strip Chart
NOTE: The Density setting can also be set from the Settings Window. See Strip Chart Settings (pg. 332) for details.

MIDI is capable of communicating approximately 1000 events per second. If pitch bend was entered at this maximum speed, MIDI wouldn’t have time to transmit anything but pitch bend. The Density setting, scaled from the maximum MIDI transmission rate, allows restriction of this data to levels that are musically meaningful. The minimum density is 0.1% of MIDI capacity.

The goal is to achieve a musical effect with controller data, without hearing individual steps, while using a minimum Density setting.

Use Undo to audition different Density settings to find the smallest setting that provides a satisfying musical effect.

When entering pitch bend for a patch whose pitch bend range is a whole step, a Density of 1% is adequate. If the pitch bend range is two or three octaves, a Density of 20% is appropriate.

MULTIPLE TRACKS AND CHANNELS IN THE STRIP CHART

The Strip Chart in the Tracks and Pulse Windows can simultaneously display and edit data for more than one track. This is helpful for scaling or thinning data on several tracks at the same time, or for inserting identical volume and pan events across several tracks.

Figure 28.27 shows pan data from two separate tracks being displayed in the Strip Chart. Viewing related data from separate tracks is useful for checking their relationship.

Figure 28.27: Pan data from two separate tracks

Inserting data in the Strip Chart for the Tracks and Pulse Windows places the data in all selected tracks. If a track is a “multi” and contains several channels, a copy of the data is inserted for each channel.

Although the Strip Chart in the Graphic Window cannot display data for multiple tracks, it can display data for multiple channels if the displayed track is a “multi” track. However, it can only insert data on one channel at a time (see Figure 28.28). Edits, on the other hand, affect all displayed channels.

Figure 28.28: Specifying Instrument for inserted Strip Chart events
RESIZING AND ZOOMING THE STRIP CHART

The Strip Chart in the Tracks and Pulse Windows can be resized and vertically zoomed for greater detail and data resolution.

Resizing the Strip Chart

To resize the Strip Chart in the Tracks and Pulse Windows:

① Open the Strip Chart by clicking the open/close triangle in the lower-left corner of the Tracks or Pulse Window.

② Place your cursor at the top of the Strip Chart area so the resize cursor (↑) appears.

③ Click and drag up to resize the Strip Chart area.

Once the desired size is reached, release the mouse button to resize the area.

The contents in the Strip Chart are redrawn to take advantage of the larger edit area.

④ If necessary, resize the entire Tracks (or Pulse) Window to make room for the larger Strip Chart.

Zooming Vertically in the Strip Chart

Normally, the entire value range for events fits into the height of the Strip Chart. You can, however, zoom vertically for greater resolution, which can be important for inserting and editing data.
To zoom vertically in the Strip Chart, click the Zoom buttons in the lower-right corner of the Tracks (or Pulse) Window. Make sure not to confuse the vertical Zoom buttons for the Strip Chart with those of the Track Overview, see Figure 28.29.

Figure 28.29: Vertical Zoom buttons and scroll bar for Strip Chart

When viewing zoomed data in the Strip Chart, use the vertical scroll bar to navigate up or down.

Figure 28.30 illustrates the Strip Chart at three different zoom levels. The more you zoom vertically, the smaller the displayed data range becomes. View the left margin of the Strip Chart for the actual range of the displayed data.

Figure 28.30: Strip Chart data, zoomed vertically
CHAPTER 29: The List Window

The List Window displays a chronological list of all events in a track as text and numbers. List Windows are used for the following track types:

- Performance track (normal track)
- Tempo track
- Meter track

List Windows for normal tracks may contain events for notes, patch changes, digital audio, text-type, pitch bend, controllers, aftertouch, poly aftertouch, automation (plug-in and EQ parameters, etc.), system exclusive, and sequence events.

List Windows for Meter tracks contain events for meter changes, markers, and key signatures.

List Windows for Tempo tracks contain events for tempo changes.
OPTS MENU

In previous versions of Vision, a **Seqs** menu appeared in the List window and Tracks/Pulse window expanded info area for tracks with sequence events in them. The menu is now called **Opts**, and it contains an additional command that can apply to any track, regardless of whether or not the track contains sequence events. For that reason, the menu appears in the List window (and Tracks/Pulse Window expanded info area) for all performance tracks.

**Song Track**

**Song Track** is available only when the List window displays a performance track containing sequence events.

Check this option to copy the tempo information from the referenced sequences (in that track) to the parent sequence. This lets the parent sequence play back with the tempo of the referenced material.

The parent sequence’s **Meter** and **Tempo** tracks are updated automatically if any changes are made to the sequence events contained in the **Song Track**.

Each sequence can only have one **Song Track**. If you already have **Song Track** enabled for one track, enabling it for another track disables the option for the previous track.

**Keep Sequences End-to-End**

**Keep Sequences End-to-End** is available only when the List window displays a performance track containing sequence events.

When both **Song Track** and **Keep Sequences End-to-End** are checked, Vision keeps sequence event blocks neatly together, one after another (the end point of one sequence event is the start point of the following sequence event). This is a handy option when chaining together sequences to make songs.

Dragging, resizing, or changing the number of repeats for any sequence event block (as well as inserting or deleting sequence events), causes existing sequence events to move accordingly.

Also, the **Meter** and **Tempo** tracks of the parent sequence automatically change to match those of the sequence events residing in the **Song Track**. All meter, tempo, key, and marker events in the referenced
sequences therefore end up in the parent sequence. In addition, a marker is automatically inserted at the beginning of each sequence event with the name of the referenced sequence or segment.

IMPORTANT: In order for a parent sequence to use both the Meter and Tempo tracks of the sequence events in the Song Track, both options in the Sequence Event pop-up must be checked.

Figure 29.4: Sequence Event pop-up in List Window

**LOCK EVENT SMPTE TIMES**

**Lock Event SMPTE Times** is available for all performance tracks.

When checked, this option locks the SMPTE time of each event in the track so that even if you change the tempo of the sequence, each event in the track will play at the appropriate SMPTE time.

This is especially useful if you are scoring a film and want to set up a "sound effects" track. Simply check **Lock Event SMPTE Times** in the **Opts** menu for that track, and you can freely change the tempo of the music in the sequence without affecting the sound effects.

You can check **Lock Event SMPTE Times** for any number of performance tracks.

**INSERTING EVENTS**

Choose an item from the Insert Events pop-up to insert it into the track at the Edit In point. The available event types depend on the type of List Window currently active.

After inserting a particular event type into the List Window, you can click the Insert Events icon like a button (without highlighting the event type in the pop-up) to insert the same event type again.

**Performance Track List Windows**

**Notes**

![Figure 29.5: Insert Event pop-up for performance Track](image)

Note events display the pitch (note number), duration, velocity, and (optionally) release velocity.
Durations are displayed as quarter notes and units. Durations, pitch and velocity are editable using the mouse or computer keyboard. Pitch and velocity are also editable by selecting the item and playing a MIDI controller.

**Audio Event**

Choosing **Audio Event** automatically opens the **Import Audio** dialog box. The audio event(s) inserted will be placed at the current insertion point.

For more information about **Import Audio**, see your MIDI Reference Manual.

**Patch**

Patch events can be displayed as numbers or names. After being inserted with the Insert Events pop-up, they can be changed by clicking them and selecting a new patch from the Patch pop-up that appears.

Unless you use the Names Window to assign a Patch Name document to a device, it will display its patch changes as numbers. For more information, see Chapter 33: The Names Window.

The rightmost part of the patch line contains a pop-up menu.

---

**NOTE FOR MIDI NOVICES:** The maximum number that can be sent in a MIDI program change message is 127. However, double program change and bank select messages can be used to access patches beyond the “127” limit.

Using this menu accesses the five different types of patch change messages. The different types allow patch changes on synths that have more than 128 patches via bank select messages, or multiple program change messages. In all cases, there will be numericals next to the boxed icons that can be set to the appropriate values. If you are using the OMS Name Manager to provide patch names, you won’t need to set the numericals manually; they will be filled in automatically whenever a patch is selected.

Following is a description of the five types of patch change messages:

- **PC**: Sends a program change message only.
- **PC PC**: Sends two program changes in rapid succession. Some synths use the first message to set the hundreds digits and the second message to set the tens and ones digit. For example, PC 105 PC 38 would set the channel to program 538.
- **B0 PC**: Sends a bank select 0 message followed by a program change.
- **B32 PC**: Sends a bank select 32 message followed by a program change.
- **B0 B32 PC**: Sends a bank select 0 message, a bank select 32 message, and a program change.
Check your synthesizer’s documentation to find out which patch change messages it supports.

**Text-type**

Text-type events allow storage of text comments, copyright information, descriptions of Instruments, lyrics, or cue points in tracks, along with MIDI information. The List Window displays as much of the text event as fits on one line. Text-type events may actually occupy several lines in the Text Edit dialog but only the information that fits is displayed on one line in the List Window.

Text-type events include:

- **Cue Points**
  Typically describes action taking place on film or video occurring at a specific SMPTE time.

- **Lyrics**
  Words may be exported to notation programs supporting this feature.

- **Instruments**
  Verbal descriptions of Instruments can enable subsequent orchestration in a different MIDI environment.

- **Copyright**
  Provides a place to store a copyright notice.

- **Text**
  Can be used for any text including comments, reminders etc.

Inserting a new text-type event, or clicking on an existing one, opens the Text Edit dialog allowing display and editing for the entire event. Any text can be typed in, and cut, copy, and paste operations can be performed by typing Command-X, Command-C, and Command-Y, respectively (these commands are not available from the Edit menu). When finished, type the Enter key to insert the text into the track.

Pasting markers from the Meter track into a normal track converts bar markers to text-type events, and SMPTE markers to cue point events. This process may also occur in reverse with cue points and text-type events pasted into the Meter track.

**MIDI**

- **Pitch Bend**
  Pitch Bend events display the bend amount as a number from -8192 to +8191.
PART 6: Windows

• **Aftertouch**

  Aftertouch events are displayed as an editable number between 0 and 127.

• **Poly Aftertouch**

  Polyphonic Aftertouch events display the pitch and controller amount (0–127). The pitch is edited by selecting it and either playing a new note on a MIDI controller, or by using the mouse or computer keyboard.

• **Velocity Scale**

  Velocity Scale events are displayed as a number from 0 to 127. For more information about Velocity Scale, please see page 297.

• **Controllers**

  Controller events display the controller name, number and value (in that order). The eight Favorite Controllers (as defined in Favorite Controllers (pg. 336)) and a generic “Controller” item are available in the MIDI pop-up menu. When “Controller” is selected, a Volume event (MIDI Controller #7) is inserted by default. You can then click on “Volume” and select a new controller from the pop-up that appears.

  Controller events previously inserted are also changed by clicking them and selecting a new controller from the pop-up that appears.

  If Fine Controls is checked in the Settings Window, values for pairs of controllers are shown as numbers from 0 to 16383.

**Automation submenu**

- **Audio Volume**

  Values can range from $-\infty$ to $+24$ dB. For details, see your Audio Reference Manual.

- **Audio Pan**

  Values range from $<100.000$ (left) to $100.000>$ (right).
• **Mute**

<table>
<thead>
<tr>
<th>Mute</th>
<th>Off</th>
</tr>
</thead>
</table>

Mute events can have values of Off and On. The value is toggled by clicking on the word “Off” (or “On”).

Unlike most of the other commands in this menu, Mute can affect Audio or MIDI Instruments. Keep in mind that these events affect Instruments rather than tracks.

For details, see your Audio Reference Manual.

• **Solo**

<table>
<thead>
<tr>
<th>Solo</th>
<th>Off</th>
</tr>
</thead>
</table>

Solo events can have values of Off and On. The value is toggled by clicking on the word “Off” (or “On”).

Unlike most of the other commands in this menu, Solo can affect Audio or MIDI Instruments. Keep in mind that these events affect Instruments rather than tracks.

For details, see your Audio Reference Manual.

• **Send (1-4) Level**

<table>
<thead>
<tr>
<th>Send 1 Level</th>
<th>0.000 dB</th>
</tr>
</thead>
</table>

These options can write Send Level events for each specific send. The number of the Send that will be effected is displayed in the left column. Values range from negative infinity to +24 dB.

• **Plug-in (1-4) Bypass**

<table>
<thead>
<tr>
<th>opB0XDLY</th>
<th>Bypass</th>
<th>On</th>
</tr>
</thead>
</table>

Plug-in Bypass events can have Off and On values. When set to Off, the plug-in will be applied to the audio signal. When set to On, the plug-in will be bypassed. The value is toggled by clicking on the word “Off” (or “On”).

In the List window, these events appear with the name of the effected plug-in on the left, followed by the word “Bypass”, followed by the On/Off status.

• **Phase Invert**

<table>
<thead>
<tr>
<th>Phase Invert</th>
<th>Off</th>
</tr>
</thead>
</table>

Phase Invert events can have values of Off and On. The value is toggled by clicking on the word “Off” (or “On”).

• **EQ Enable**

<table>
<thead>
<tr>
<th>EQ Enable</th>
<th>Off</th>
</tr>
</thead>
</table>

EQ Enable events can have values of Off and On. The value is toggled by clicking on the word “Off” (or “On”).

For more information about these automation events, please see your Audio Reference Manual.
EQ Band Parameter submenu

**Frequency**

EQ Band 1 Freq 125 Hz

Controls the frequency of the specified EQ band. Values can range from 20.00 Hz to 20000.00 Hz.

**Gain**

EQ Band 1 Gain 0.000 dB

Controls the gain of the specified EQ band. Values can range from -18.00 dB to +18.00 dB.

**Width**

EQ Band 2 Width 2.000 oct

Controls the width of the specified EQ band. Values can range from 0 to 4.00 octaves.

**Type**

EQ Band 2 Type

Allows you to change the EQ type for the specified band. Clicking on the EQ Type setting opens a pop-up menu with all five EQ types.

- Low Cut
- Low Shelf
- Parametric
- High Shelf
- High Cut

**Enable**

EQ Band 1 Enable Off

EQ Band Enable events can have values of Off and On. The value is toggled by clicking on the word “Off” (or “On”).

For more information about these automation events, please see your Audio Reference Manual.

Plug-in Parameter submenu

The **Plug-in Parameter** submenu lists the plug-ins that are assigned to the selected track’s Audio Instrument. For example:

---

...then the Plug-in Parameter submenu looks like this.

---

After you select a plug-in, another pop-up menu appears to the right. This menu displays the selected plug-in’s parameters.
For example, if you select opECHO, you might see the following:

```
+----------------+----------------+--------+
| opECHO         | Dry/Wet        | 0.0000 |
+----------------+----------------+--------+
```

“Dry/Wet” is the default parameter because it is the first parameter of the selected plug-in. Clicking on “Dry/Wet” will produce a pop-up menu that contains the selected plug-in’s parameters.

If you open the plug-in edit window for opECHO, you will see that the parameters listed in the pop-up menu correspond to the parameters of the opECHO plug-in.

Vision can automate up to 1024 parameters per VST plug-in.

All plug-in parameters, regardless of their ranges in the plug-in edit window, will have values between 0.0000 and 100.0000 in the list window. The plug-in’s range of possible parameters in the plug-in edit window is mapped onto this scale. When the events are played back, they are mapped the opposite way; plug-in automation will still have appropriate values in the plug-in edit windows.

For more information about these automation events, please see your Audio Reference Manual.

**System Exclusive**

```
SysEx (60): F0 41 10 16 12 10 00 00 3F 08
```

The number in parenthesis indicates the length of the event, in bytes. To edit the system exclusive data, click on the actual event.

When inserting a System Exclusive event, the Sysex Edit dialog appears, allowing viewing and editing of the sysex data.

```
Figure 29.10: System Exclusive dialog
```

In this dialog, entry is limited to valid hexadecimal characters. Each byte (2 hex characters) is separated by spaces.
NOTE: There are 16 possible hex digits: 0-9, and A–F (corresponding to 10-15). Consult a MIDI reference text to learn more about hex numbers and their use in MIDI applications.

You can cut, copy, and paste within the Sysex Edit dialog by typing Command-X, Command-C, and Command-Y, respectively (these commands are not available from the Edit menu). When pasting into the Sysex Edit dialog, all non-hexadecimal characters are removed. Click OK to exit the dialog box. The computer beeps to indicate invalid entries and highlights them for correction. Of course, clicking Cancel exits without changing any events.

Sequence Events submenu

There are five different types of sequence and transpose events. See Sequence Events in the List Window (pg. 103) for more information.

Meter Track List Windows

When the List Window of a Meter track is active, there are three event types available from the Insert Events pop-up menu. See Figure 29.11. Changes to meter and key signature affect every track in the sequence.

![Meter Change](image)

Figure 29.11: Insert Event pop-up in Meter track List Window

Inserting Meter Changes in a List Window

Meter change events can be located only at the beginning of a measure. Both the top and bottom numbers of the meter are editable. The metronome click rate and the number of measures the meter will be active are also editable.

![Meter Change Event](image)

Figure 29.12: Meter Change Event
Inserting Key Changes in a List Window

After inserting a key change event by choosing Key Signature from the Insert Events pop-up, the key can be edited by clicking the key and selecting from a pop-up of available keys. Clicking the word “major” or “minor” toggles the value back and forth.

![Figure 29.13: Key Change Event](image)

Inserting Markers in a List Window

There are two types of markers—SMPTE markers and bar markers. When you insert a marker, the default type is bar marker. You can change this to a SMPTE marker by clicking the icon. Click in the name field and type a new name.

![Figure 29.14: Two Different types of Markers](image)

NOTE: SMPTE Markers retain their SMPTE times, even if you change the tempo or SMPTE offset of the sequence using any method. However, they will move if you use Move Events—they are not “locked.”

Markers are displayed in the Marker pop-up in the Control Bar (see page 193), and in the Tracks Window ruler.

Tempo Track List Windows

Fig 29.15: Insert Event pop-up in Tempo track List Window

Inserting a tempo change affects the tempo for all tracks in the sequence. The Insert Event pop-up for the Tempo track contains Tempo as its sole entry.

![Figure 29.16: Tempo Change Event](image)

LIST WINDOW MENU

- **AutoScroll**
- **Jump to Selection**
- **No SMPTE**
- **Absolute SMPTE**
- **Relative SMPTE**
- **Set Default Location**
- **View...**
- **Play Edited Note**
- **Show Event End Times**
- **Show Event Durations**
- **Show Release Velocities**

Following is an explanation of the items in the List Window menu:
Auto Scroll (Shift-4)
When checked, Vision follows the Counter and scrolls the contents of the List Window.

NOTE: If Auto Scroll Top Window Only is checked in the Editing section of the Settings Window, Vision only scrolls the top window.

Jump to Selection (Command-J)
Choose this command to automatically scroll the contents of the List Window to the Edit In point.

No SMPTE
Turns on and off SMPTE display for event times, Edit In/Out points, and track length. Bar/beat/unit times are always displayed in the List Window.

Absolute SMPTE
This item specifies that absolute SMPT times are displayed. Absolute time values are derived from adding the sequence’s offset time to actual event times.

NOTE: The offset time for a sequence references a SMPT time (location) on tape, usually corresponding to the beginning of a song or musical passage.

Relative SMPTE
This item specifies that relative SMPT times are displayed. Relative time values represent the actual elapsed time from the beginning of the sequence—without adding the sequence’s offset.

Set Default Location
Saves as default the current position and size of the List Window. Any newly opened List Windows use these defaults.

View (Option-V)
Choose this menu item to open the View dialog. It specifies which events are displayed in the List Window. And, if the track is a “multi,” containing events assigned to more than one Instrument, you can use this dialog to choose which Instruments are displayed.

Figure 29.17: List Window’s View dialog
For each type of criteria, choose the radio button that makes the most sense:

- **all**
  Displays all events or Instruments.

- **only**
  Displays only the selected events or Instruments.

- **all except**
  Displays only the events or Instruments not selected.

The View dialog not only determines which data is displayed, but also which data is editable. Data not displayed, therefore, cannot be selected, edited, or modified.

There are two checkbox options at the bottom of the View dialog. Checking either option lets you apply changes in the dialog to:

- **all open List Windows**
- **all new List Windows**

**Play Edited Note**
When checked, notes are sounded when clicked, or when changing their pitch.

**Show Event Durations**
When checked, durations for note and audio events are displayed, instead of end times.

**Show Release Velocities**
Turns on and off the display of release velocities for note events. Most MIDI devices don’t respond to release velocities, so you may wish to suppress viewing them.

**EDITING EVENTS IN THE LIST WINDOW**

To select events for modification in a List Window, click on the event’s selector dot at the far left. The selector dot becomes an open triangle, signifying that the item is selected. The entire event description is also highlighted.

When changing the bar of an event in the List Window, the beat and unit are set to the beginning of the bar. This makes it easy to enter events at bar or beat locations. To change one of the bar/beat/unit numbers without affecting the others, Command-click the number.

To select a group of adjacent events, click on the first event’s selector dot and drag up or down across the events.

To select many events, click on the first event, scroll to the last one, and Shift-click. All events between them are selected.
To select several non-adjacent events, hold down the Command-key while clicking on each of the events.

Clicking on the time or description of an event deselects all currently selected events and selects the new event.

NOTE: Use the Select submenu commands in the Do menu to utilize rules that aid specific selection. For a complete description of these commands, see The Select Submenu (pg. 423).

Event Times and Moving Events

After moving any event in the List Window, the window scrolls to display the event.

Edit the event time to move an individual event. Click the bar/beat/unit fields and type the desired values (or use the mouse).

After entering event times, click elsewhere or type the Enter key. The event moves to its new location, scrolling the window if necessary.

Re-ordering Simultaneous Events

Due to MIDI transmission rates (and possibly computer processor speed), large numbers of simultaneous events can’t all be sent at once. If some notes (i.e. drums) require more rhythmic precision than other notes, move the less important notes a unit or two later in time. Since it usually takes MIDI about one unit of time to send a MIDI event, several simultaneous events are already being transmitted over a period of several units. Changing some events by a few units changes their “priority,” but generally doesn’t delay them by a musically significant amount.

Several events occurring at the same time can be re-ordered to be transmitted sequentially by changing the units field of the events. Typing the Enter key displays the event in the new order. Use the playback quality as a guide indicating whether this process is necessary.
CHAPTER 30: The Notation Window

Vision Notation Windows display MIDI information using standard music notation. The displayed track’s note range determines which clefs are used. Multiple tracks can be viewed in a Notation Window, and several Notation Windows may be open simultaneously. The contents of the Notation Window determine which tracks are printed.

For information on edit tools and edit functions common to all of Vision’s edit windows, see Chapter 9: Basic Editing Procedures. For information on navigating Vision’s windows, see Chapter 4: Navigating in Vision.

**SELECTING NOTES IN THE NOTATION WINDOW**

Notes can be selected individually or in groups (note heads are hollow):

- To select a single note, click on the note head.
- Use Shift-click to select additional notes.
- Shift-click to de-select selected notes.

When selected, note heads are hollow instead of solid.

**NOTE:** Select notes connected by ties by clicking on the first note of the group. The note edit cursors appear over the first note-head, not for the subsequent note-heads.

**Selecting Tracks in a Notation Window**

When selecting notes in one or more tracks in the Notation Window, the Tracks Window updates to show currently selected tracks.

Although the Notation Window shows multiple tracks, only one can be the “current track,” indicated by a small triangle, as shown in Figure 30.1.

For more information on showing multiple tracks in a Notation Window, see Showing and Hiding Tracks in the Notation Window (pg. 21).
Using the Marquee Tool

Select notes using the Marquee tool by clicking and dragging a rectangular area. The area highlights signifying that all notes beginning within the highlighted rectangle are selected.

NOTE: The first note in Figure 30.2 is not selected because the beginning of the note does not occur within the selection rectangle.

Pitch bend, modulation, or controller events are not selected with the Marquee tool (see Selecting all Types of MIDI Data in a Time Range (pg. 277)).

NOTE: When using the Marquee tool, note that the cursor is a cross when starting to drag the rectangle. If it's one of the note edit cursors, the note will instead be modified.
CHAPTER 30: The Notation Window

Using the I-Beam Tool to Select a Time Range

Select notes in a time range using the I-beam tool by dragging across the relevant time area. All notes in displayed tracks, beginning within the highlighted area, are selected.

Selecting all Types of MIDI Data in a Time Range

Select all MIDI data by positioning the cursor within the Ruler and dragging a selection. This selects all MIDI data contained within the highlighted time range.

This I-beam tool appears whenever the cursor is moved into the Ruler, even if another tool is selected.

Using the I-Beam Tool to Select a Pitch Range

Select a specific pitch range, for the entire track length, using the I-beam tool. The horizontal I-beam is available at the left of the Notation Window.

MODIFYING NOTES IN THE NOTATION WINDOW

By positioning the cursor over different parts of the note head, three note edit cursors appear—indicating that the pitch, start time, or duration will change if the note is dragged.
When you are moving or transposing notes, you can hold down the Option key on your computer keyboard to copy the note before modifying it. This will leave the original data intact.

Transposing Notes

The Transpose cursor appears over the center of a note-head. Clicking and dragging a note up or down changes the pitch without changing the duration or start time. All selected notes are transposed the same amount.

Moving Notes

The Move cursor appears over the left side of the note head. Clicking and dragging a note to a different location alters the start time without changing the pitch or duration. All selected notes are moved the same amount.

Changing a Note’s Duration

The Duration cursor appears over the right side of the note head. Clicking the mouse opens the duration pop-up, allowing selection of a new duration. The pitch and start time are unchanged.
CHAPTER 30: The Notation Window

NOTE: When moving or transposing, Option-clicking the note copies the note before modifying it, leaving the original data unchanged.

Rests are automatically inserted by Vision in the absence of notes and cannot be explicitly modified using the techniques discussed in the previous sections. To change or eliminate a rest, modify the notes around the rest.

For example, lengthening a note the duration of a neighboring rest eliminates the rest. Setting a larger Notation Resolution can also decrease the number of rests.

For information on reducing rests see Notation Resolution (pg. 280). For other tips on improving score appearance, see Tips for Good-Looking Scores (pg. 289).

CHANGING KEY AND METER

Changing the Meter in Notation Windows

To change the meter in a Notation Window, click on the upper or lower element of the time signature. To change the top number, select it and enter a new number. To change the bottom number, click on it and select a new value from the pop-up that appears (see Figure 30.10). Vision automatically changes the meter in the Meter track, affecting all subsequent bars. New meter changes are inserted in the List Window.

Figure 30.10: Changing the meter in a Notation Window

Changing the Key in Notation Windows

To change the key in a Notation Window, choose a new key signature from the Key Signature pop-up. Vision automatically changes the key in the Meter track, affecting all subsequent bars. To insert a new key change, use the List Window.
When positioning the mouse over the key signature, the cursor changes into a sharp (♯), indicating that the key signature can be changed.

To set the Notation Resolution, select a note value from the Notation Resolution pop-up.

Figure 30.11: Music with Notation Resolution set to 16th notes

The same music with Notation Resolution set to eighth notes

**Notation Resolution**

The Notation Resolution pop-up allows changing the quantization level for notation displayed in the Notation Window, without affecting playback or the stored MIDI data. This technique is very helpful for creating clear scores because there are often subtle differences between the way music is played and how it should appear in a written score.

**Octave Display Area**

The octave for tracks displayed in a Notation Window is set by positioning the cursor under the staff. When the cursor changes into an “8,” clicking causes a pop-up to appear containing the options for octave display. See Shifting the Music by Octaves (pg. 290) for more information.
NOTATION WINDOW MENU

| Auto Scroll | ⌘ ⌥ | Jump to Selection | ⌘ J | Zoom to Fit | ⌘ Z | Zoom Back | ⌘ B | Tools | ⌘ T |

- Bar/Beat/Unit
  - Absolute SMPTE
  - Relative SMPTE

Set Default Location

View...
  - ⌘ Y
  - Play Edited Note
  - Show Bouncing Ball
  - Show Vertical Line

Following is an explanation of the items in the Notation Window menu:

**Auto Scroll**

When checked, Vision follows the Counter and scrolls the contents of the Notation Window.

**NOTE:** If **Auto Scroll Top Window Only** is checked in the Editing section of the Settings Window, Vision only scrolls the top window.

**Jump to Selection (Command-J)**

Choose this command to automatically scroll the contents of the Notation Window to the Edit In point.

**Zoom to Fit (Option-Z)**

Choose this command to view the contents of the entire track (or tracks) in the Notation Window.

**Zoom Back (Option-B)**

Choose this command to return to the previous zoom level (acts to “undo” the last zoom).

**Tools**

This item chooses from the Marquee, I-beam, and Pencil tools. Only one can be checked at a time. Selecting one deselects the others.

Choosing one of these items is identical to selecting the corresponding tool in the actual Notation Window. For a description of the different tool types, see Cursor Tools (pg. 57).

**Bar/Beat/Unit**

Specifies that bars/ beats/ units are displayed for the Edit In/ Out points, and for the event times in the Cursor Display.
PART 6: Windows

Absolute SMPTE

Specifies that absolute SMPTE is displayed for the Edit In/Out points, and for the event times in the Cursor Display.

Absolute time values are derived from adding the sequence’s offset time to actual event times.

NOTE: The offset time for a sequence references a SMPTE time (location) on tape, usually corresponding to the beginning of a song or musical passage.

Relative SMPTE

Specifies that relative SMPTE is displayed for the Edit In/Out points, and for the event times in the Cursor Display.

Relative time values represent the actual elapsed time from the beginning of the sequence—without adding the sequence’s offset.

Set Default Location

Saves as default the current position and size of the Notation Window. Any newly opened Notation Windows use these defaults.

View (Option-V)

Choose this menu item to open the View dialog. It specifies which Instrument events are displayed for the selected track in the Notation Window.

Choose from the following radio buttons:

- **all**
  Displays all Instruments.

- **only**
  Displays only the selected Instruments.

- **all except**
  Displays only the Instruments not selected.

The View dialog not only determines which data is displayed, but also which data is editable. Data not displayed, therefore, cannot be selected, edited, or modified.
CHAPTER 30: The Notation Window

**Play Edited Note**

When checked, Vision plays any note clicked. If transposing a note, the different transposition values are audible as the note is dragged. Notes inserted with the Pencil tool are also audible. When unchecked, note editing does not trigger any sound.

**Show Vertical Line**

When checked, Vision displays a scrolling vertical line in the Notation Window, indicating the location of the Counter as the sequence advances.

Both the bouncing ball and vertical line may be displayed simultaneously.
Vision can print any number of tracks in standard music notation. Printing commands are available only when a Notation Window is active. The contents of the active Notation Window determine which tracks will print.

THE PRINT PREVIEW WINDOW

Open the Print Preview Window by choosing File>Print Preview. Print Preview allows the addition of a title, comments, author name, as well as changes to basic page layout. The score prints exactly as depicted in the Print Preview Window.

Page Properties

The top of the Print Preview Window contains fields that determine how Vision prints your music.

Title Space

This field determines the amount of space between the top of the page margin and the top of the first staff.

Figure 31.1: Print Preview Window

Figure 31.2: Title Space
**System Spacing**

Use this field to specify the amount of space between systems for each page.

**Staff Spacing**

Use this field to specify the distance between staves within the same system.

**Staff Indentation**

This field specifies the amount of space each staff is indented from the left and right page margins.

**Bars per Line**

This field sets the number of measures displayed and printed per system.
CHAPTER 31: The Print Preview Window

**Systems per Page**

This is the number of systems displayed, and printed, per page. You cannot change this number directly—it is determined by the numbers you chose for the Title Space, System Spacing, and Staff Spacing.

**Number of Pages**

This field displays the number of pages that comprise the current score. You cannot change this number directly—use it to see how changing other properties affects the number of printed pages.

**Current Page**

Use this field to specify the currently displayed page.

**Show Bar Numbers**

Check this option to display and print bar numbers. Bar numbers are displayed every measure, and are placed directly above the barlines.

**Barline thru System**

When checked, the barline extends between each staff in the system. If unchecked, the barline stops at each staff.

Extending a barline through a system can make an instrument grouping more apparent.

![Figure 31.8: Barline thru System on](image)

![Figure 31.9: Barline thru System off](image)

**Show Page Numbers**

When checked, page numbers are displayed and printed in the lower right corner of each page.

**Title Font**

This field displays the selected font for the three text blocks.

**Units of Measurements**

All measurements can be viewed in either inches or centimeters. Click on the unit to toggle between inches and centimeters.

![Figure 31.10: Changing inches to centimeters](image)
Adding Text to a Page

Three text blocks can be used to add text to the top of the first page. To add text, click in one of the text blocks and type whatever you wish. The text blocks appear only on the first page.

Changing the Font of the Text

You can change the font of all three text blocks by selecting a font from the Font menu.

PAGE SETUP

Choose File>Page Setup to open the Page Setup dialog box, which is used to change the orientation or percentage size of the printed pages.

The Page Setup dialog looks different depending on the type of printer being used. Consult your printer’s documentation for details.

A BRIEF DISCUSSION OF NOTATION TERMS

The following sections define terms that are necessary to understand Vision’s notation features as they apply to printing.

Grand Staff

When a track containing low notes is displayed in a Notation Window, Vision uses a bass clef. When a track contains high notes, Vision uses a treble clef. If the track contains both high and low notes, Vision uses a grand staff, consisting of both treble and bass clefs.

Vision uses a grand staff if the track contains notes higher than F above middle-C and notes lower than G below middle-C. Figure 31.12 illustrates the criteria for grand staff usage.
Part
Each Vision track normally constitutes one part. Printing music for musicians to read and play usually requires separate parts.

To accommodate piano players and any other instruments capable of playing multiple parts, multiple tracks can be combined to create a single part. For example, a bass and melody track can be combined into a single piano part, and displayed on a grand staff.

System
A system consists of all tracks displayed in the active Notation Window. A system can consist of one staff or it can include many staves if multiple tracks were selected when the Notation Window was opened.

Voice
When notating a track, Vision analyzes the notes to detect different rhythmic patterns occurring simultaneously. These independent rhythms are called voices.

Figure 31.13: Two-voices in one track

TIPS FOR GOOD-LOOKING SCORES
Vision contains powerful mechanisms to enhance the appearance of printed music. This section explains these features and concludes with Notation Troubleshooting (pg. 291), answering common questions about notational problems.

Changing the Order of Notation Tracks
Tracks print in the same order as they appear in the Tracks Window. To change the order that tracks print, change their order in the Tracks Window. The Print Preview and Notation Windows automatically update to reflect the new order.
PART 6: Windows

290 Opcode Systems, Inc.

Figure 31.14: The relationship between track order and printing

Shifting the Music by Octaves

Notated tracks containing very high or low notes can be hard to read due to an excess of ledger lines. The octave shift feature changes the octave used to notate the music without changing the actual MIDI data.

1. Position the cursor underneath the clef of the staff to shift.
   The cursor changes into an “8.”
2. Click the mouse.
   The Octave Shift pop-up menu appears.

3. Select one of the five Octave selections in the pop-up.

   \[ \begin{array}{|c|}
   \hline
   15ma & 8va & loco & 8va bassa & 15ma bassa \\
   \hline
   \end{array} \]

Figure 31.15: The Octave Shift pop-up menu.

Different octaves can be used for each track. Each octave shift option is explained below:

- **15ma**
  The music is notated two octaves lower than it actually sounds.
- **8va**
  The music is notated one octave lower than it actually sounds.
- **loco**
  The music is notated in the same octave it is played.
- **8va bassa**
  The music is notated one octave higher than it actually sounds.
- **15ma bassa**
  The music is notated two octaves higher than it actually sounds.
CHAPTER 31: The Print Preview Window

Notation Troubleshooting

Problems with Vision Notation

“I have too many extra voices.”

Use the Graphic Window to find where extra voices have been generated. If the track doesn’t require a second voice to play correctly, then realign the note locations to become either sequential notes or chords. Lowering the notation resolution sometimes helps alleviate extra voices. By elongating notes to the beginning of the next note, the Legato tool in the Strip Chart (page 244) can also help clear up ambiguous note overlaps that sometimes yield extra voices.

“I’m playing swing, and all my eighth notes are showing up as triplets.”

If swung eighth notes turn out as triplets and you want straight eighths, try moving the second note of each group a little to the left in the Graphic Window, or try quantizing the music to eighth notes.

“Notes are printing off the page.”

Before printing, check the Print Preview Window for notes appearing outside the margin or covering the page number.

“When trying to print, I get a dialog box telling me there’s a printing problem”

Check to make sure that the printer port isn’t being used for MIDI communication.

Also, if your printer requires AppleTalk, check to see if AppleTalk is on or off. If it’s off, use the Chooser to turn it back on (you can turn it back off when you’re finished printing and need to resume using MIDI).

“It’s barely more than a page. Can’t I make it fit?”

Use the Bars per Line, Title Space, System Spacing, and Staff Spacing fields in the Print Preview Window to fit the music on one page. This may cause adverse effects such as note collisions.

If you can’t fit the desired number of bars to the line without collisions, try the settings in the Page Setup dialog box to print either landscaped or scaled.

“There’s a rest between every note!”

You may need to adjust the Notation Resolution (see page 280). Use the minimum resolution necessary to accurately notate the track. If a track contains primarily ♭ and ♮ but has one ∪ then the notation resolution should be set to ♭.

The Legato tool in the Strip Chart elongate notes to the beginning of the following note, erasing rests between notes (see page 244). Quantize Durations (pg. 132) can also change the way rests and notes are notated, which usually improves the notation.

“Why are there so many ledger lines?”

If notes are generally way above or below a staff, try using 8Va (see page 290).
“If my music looks good it sounds terrible, and vice-versa.”

There are some cases where a good sounding piece cannot be accurately notated without considerable editing. A reasonable solution involves using two copies, one for printing, the other for playing:

1. Optimize one copy for notation using quantization and other techniques discussed in this section to simplify the notation.

2. Edit the second copy to fix only minor playback errors. Leave the timing and duration of notes as raw as possible to preserve the original performance.

Problems with Other Notation Applications

NOTE: Each notation application has its own rules for converting real-time created performance data to notation. Opcode does not take any responsibility for how other music notation programs implement this very complex process. Vision exports the data correctly!

Following are some techniques that can help clean up tracks in Vision prior to exporting them to another application.

“Large sections appear to be missing from the score.”

Sequences must be captured before being exported. Vision ignores sequence events that aren't captured during export, and this could cause large sections to “disappear” from the score. Use File>Export to Clipboard, paste to a sequence, then export that sequence to automatically capture the tracks.

“I have chords covering many octaves in a single staff.”

Use Do>Split Notes to split the MIDI information into different tracks before exporting it. See page 424 for more information on splitting notes.

“Large sections appear to be missing from the score.”

Sequences must be captured before being exported. Vision ignores sequence events that aren't captured during export, and this could cause large sections to “disappear” from the score. Use File>Export to Clipboard, paste to a sequence, then export that sequence to automatically capture the tracks.

“I have chords covering many octaves in a single staff.”

Use Do>Split Notes to split the MIDI information into different tracks before exporting it. See page 424 for more information on splitting notes.

Problems with Other Notation Applications

NOTE: Each notation application has its own rules for converting real-time created performance data to notation. Opcode does not take any responsibility for how other music notation programs implement this very complex process. Vision exports the data correctly!

Following are some techniques that can help clean up tracks in Vision prior to exporting them to another application.

“Large sections appear to be missing from the score.”

Sequences must be captured before being exported. Vision ignores sequence events that aren't captured during export, and this could cause large sections to “disappear” from the score. Use File>Export to Clipboard, paste to a sequence, then export that sequence to automatically capture the tracks.

“I have chords covering many octaves in a single staff.”

Use Do>Split Notes to split the MIDI information into different tracks before exporting it. See page 424 for more information on splitting notes.
CHAPTER 32: The Instruments Window

Vision tracks are not directly assigned to specific MIDI channels. Instead, they are assigned to Instruments, which, in turn, are assigned to MIDI channels of devices contained in the current OMS Studio Setup.

The Instruments Window is extremely useful when working with sequences that contain lots of sequence events. Rather than making changes to tracks contained within the referenced sequences and segments, you can instead make global changes with the controls in the Instruments Window.

**INSTRUMENTS WINDOW**

Choose `Windows » Instruments` (or type option-I) to open or activate the Instruments Window.

The following sections discuss each column found in the Instruments Window.

**Select and Move**

As discussed in Selector Dots and Move Cursor (pg. 22), Instruments or groups of Instruments can be selected and highlighted with the selector dots. Once selected, an Instrument can be deleted, copied and pasted to another Instrument, or even moved to another position within the window.
PART 6: Windows

Instrument

Instrument Names

Instruments are automatically named according to the devices and channels in your OMS Studio Setup. You can, however, enter your own custom names for each Instrument; to do so, simply click in this field and type in the new name. To revert back to the default name, highlight the custom name and delete it.

Instrument names are displayed wherever an Instrument is referred to, such as in the Thru Instrument pop-up, each of the edit windows, the Faders and Consoles windows, the Input Map Window, and many other locations.

Instrument Colors

An Instrument’s color is used when displaying track data in the various edit windows. To change an Instrument’s assigned color, click on the color square and choose from the pop-up menu of colors.

Vision’s available colors can be customized by choosing Setups > Colors. The colors can also be reinitialized to their default values by choosing Initialize Colors from the Instruments Window menu.

Mute and Solo

Click in the Mute column to mute one or more MIDI Instruments, thereby ceasing MIDI transmission to those Instruments.

Click in the Solo column to “solo” one or more MIDI Instruments, thereby restricting MIDI transmission to only those Instruments.

NOTE: Muting and soloing of Instruments affects not only track playback, but also MIDI routing to the Thru Instrument and Input Maps.

NOTE: Instruments can also be muted and soloed from a Console Window (and, in Acadia mode, the EQ and Plug-in Edit windows).
Muting and Soloing Tracks vs. Muting and Soloing Instruments

Muting or soloing an instrument is not the same as muting or soloing a track, although in many cases it produces the same audible effect. Muting or soloing an instrument will mute or solo all note events assigned to that instrument (in all tracks). Muting or soloing a track will mute or solo all events (of any kind) in that track.

Muting an instrument does not mute all events assigned to the instrument; specifically, all automation events assigned to a particular instrument will play even if the instrument is muted (or unsoloed).

Muting instruments and tracks is cumulative. If you mute both an instrument and a track assigned to a different instrument, the track and all note events assigned to that instrument will be muted.

Solo events are also cumulative, but the effect is different. If you solo both an instrument and a track assigned to a different instrument, you will hear nothing. This is because the instrument solo mutes all events that aren’t assigned to that instrument, and the track solo mutes all events that aren’t on that track. Since there are no events assigned to the instrument and on the track, no events will sound.

Transpose Maps and Drum Instruments

There are several transpose options for Instruments. The easiest is a simple octave or chromatic transposition. Since this can be done separately for each line of an instrument, these settings are located in the right half of the Instruments Window (see Transpose (pg. 298)).

In addition to these simple transpositions, each Instrument can use a Transpose Map, allowing more complex transpositions. When clicking in this column, the Transpose Map dialog appears, allowing arbitrary transpositions. For details, see Transposing with Vision Instruments (pg. 83).

Drum Instruments

The Drum Instrument setting ( ) prevents notes assigned to that Instrument from being changed with Vision’s Transpose command. Transposing most drum tracks usually results in a somewhat random reassignment of drum sounds—something that most users will wish to avoid.

To turn an Instrument into a Drum Instrument, move the cursor over the column and click the mouse button—a small picture of a snare drum appears in the column. Click again to make it a normal transposing Instrument (the snare drum disappears).
Even when an Instrument is assigned as a Drum Instrument, Vision still uses the Transpose Map. This lets you use a Transpose Map to map drum sounds from one device to another.

Drum Instruments do not allow a note to be retriggered until that note is finished playing. Also, notes assigned to Drum Instruments don't sound if playback begins after the note's onset. This is useful when working with drum loops on samplers, where it doesn't make sense to trigger the note anywhere except at the start. For example, a note beginning on beat 1 and ending on beat 4 won't play if playback begins on beat 2. This concept applies to mutes and solos as well; if a drum instrument or track is soloed or unmuted on beat 2, a note beginning on beat 1 and ending on beat 4 won't play.

**Instrument Line Settings**

The Columns to the right of Transpose Map pertain to each line (or layer) within an Instrument and are called Instrument Line settings. To add a line to an Instrument, see page 300.

### Mode

If an Instrument has more than one line, its mode is shown on the second line, just below the name. The mode can be either **Layered** or **Overflow**. Click the word to toggle between them.

**Layered**

A **Layered** Instrument transmits data to each device in each of its lines simultaneously. Each layer can play on a different channel, allowing the creation of a large "stacked" sound using different patches. Another useful option involves playing layered Instruments on the same channel but transposed an octave higher or lower.

**Overflow**

An **Overflow** Instrument can link several synthesizers with limited voices to function as a single synthesizer. For each line of an Overflow Instrument, set the MIDI device, channel, and the number of voices that the synthesizer can produce. Voices are entered in the far right column of the Instruments Window and are only active when Overflow mode is selected.
You can use an Overflow Instrument to simulate a monophonic patch. This is useful if you have a track that should only play as if it were on a mono patch, but you want to hear it on some patches that may be polyphonic.

1. **Set the desired device and channel for the first line and set its number of Voices to 1.**
2. **Add a second line and set its number of Voices to 0.**
   
   Vision limits itself to sending only one voice to the first line, and when it tries to overflow onto the second, it cuts itself off.

### Output (Device and Channel)

<table>
<thead>
<tr>
<th>Output</th>
<th>Device</th>
<th>Ch</th>
<th>Channel</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sound Canvas</td>
<td>1</td>
<td>1</td>
<td></td>
</tr>
</tbody>
</table>

The Output column specifies the Device and Channel for each line in the Instrument.

The **Device** determines which OMS device is used to transmit events for this Instrument or line. Devices shown in italics are not defined in the current OMS Studio Setup document, and will not play. Click the italic text and choose a defined device from the pop-up menu.

The **Channel** determines which MIDI channel is used to transmit events for the Instrument or line. The available channels are those defined in the current Studio Setup for the selected device. If the channel is shown in italics, it is not defined in the current Studio Setup and nothing will play on that channel. Click the italic text and choose a defined channel from the pop-up menu.

Reassigning undefined devices and channels affects only the current Vision file. The process must be repeated for any other Vision files referencing the same undefined devices and channels.

Instead of manually reassigning undefined devices and channels, you can choose **Setups>Undefined Channels**. This opens the Undefined Channels dialog, which controls remappings for all Vision file objects that use device and channel assignments (such as MIDIKeys, Input Maps, faders and consoles, etc.). The remappings can then be applied to any Vision file opened in the future. See **Undefined Channels (pg. 431)** for details.

### Velocity Scale

The **Velocity Scale** checkbox allows enabling and disabling of velocity scaling for a particular instrument. If the box is checked, velocity scale events assigned to the selected instrument will be followed. If the box is unchecked, those events will be ignored.
This box is particularly useful if you’ve been working with velocity scale and suddenly find that you can’t hear an instrument. A very low velocity scale setting could cause that scenario. You can simply uncheck the Velocity Scale checkbox in the Instruments window to determine whether this is the cause of the problem.

The **Velocity Scale %** number ranges from 1% to 250% and controls the scaling of velocities for the Instrument or line. The default value is 100% and does not change note velocities during playback. Numbers less than 100% reduce outgoing velocities and numbers greater than 100% increase them. This still affects the velocities even if a fader is controlling them, so several lines can be controlled by the same fader, each with different scalings.

Faders from the Faders and Consoles Windows can be used to control velocity for the Instrument. A fader value of 127 equals the full scaled velocity level. For example, a note recorded at a velocity level of 64, with **Velocity Scale %** set to 50, results in a velocity level of 32 (50% of 64) with the fader at 127. Changing the percentage to 150, but keeping the fader at 127, outputs the same note with a velocity level of 96 (150% of 64). See **Using Faders to Control Instrument Velocities** (pg. 346) for further information.

### Transpose

<table>
<thead>
<tr>
<th>Trans</th>
<th>Oct #</th>
</tr>
</thead>
<tbody>
<tr>
<td>+2</td>
<td>0</td>
</tr>
</tbody>
</table>

The **Oct** column shows the number of octaves transposed for the Instrument or line. It may be set to any value from -5 to +5.

The column on the right sets the number of semitones the Instrument or line is transposed. This may only be between -5 (down a fourth) and +6 (up a tritone). Changes outside this range spill over into the Octave transpose column.

### Range (key)

<table>
<thead>
<tr>
<th>Range</th>
<th>Lo</th>
<th>Hi</th>
</tr>
</thead>
<tbody>
<tr>
<td>C2</td>
<td>G8</td>
<td></td>
</tr>
</tbody>
</table>

The **Range** column specifies the range of notes played by the Instrument or line. Notes outside this range are not played. Valid ranges are between C-2 and G8 (the full 127 note MIDI range) and are expressed by the note name followed by the octave number.
AVAILABLE INSTRUMENTS

Vision can store up to 512 Instruments for use at any one time. The following sections discuss various methods for Instrument assignment and storage.

OMS Studio Setup Document Instruments

Each Vision Instrument is associated with a particular device channel. When Vision is first started, it creates one Instrument for each receiving MIDI channel in your OMS Studio Setup. These Instruments have the same names as the devices in the current OMS Studio Setup. For example, if the only device in your OMS Studio Setup is named “Synth” and is receiving on MIDI channels 1-4, Vision creates four Instruments named “Synth-1” through “Synth-4”.

You can change an Instrument’s name, and other parameters as well. Renamed Instruments are called “custom” Instruments.

Vision Setup File Instruments

Custom Instruments can be saved in the Vision Setup file and, like other file objects, are applied to any newly opened Vision files. New Instruments can be created and unused Instruments can be deleted.

Custom Instruments saved in the Vision Setup file take precedence over the automatically generated Instruments made from the OMS Studio Setup document.

For more information, see Vision Setup (pg. 157).

INSTRUMENTS WINDOW MENU

Following is a description of the items in the Instruments Window menu:

New Instrument

To create a new Instrument:

1. Click an existing Instrument’s selector dot.

2. Choose New Instrument from the menu in the Instruments Window.

A duplicate of the selected Instrument appears at the bottom of the Instruments Window (you may have to scroll in order to see it).
PART 6: Windows

300 Opcode Systems, Inc.

 Rename the duplicate by clicking its name and typing in a new, custom name that distinguishes it from the other Instrument on the same device and channel.

Add Line to Instrument (Option-=)

Adding lines to an Instrument allows it to either play on more than one channel (Layered mode), or to overflow to another device when the first device's maximum polyphony is exceeded (Overflow mode).

NOTE: Click the desired Instrument's selector dot before choosing Add Line to Instrument.

Most Instruments have only one line, indicating that they play through one MIDI channel. You can add lines, each line playing through a different MIDI channel to create “stacked” Instruments.

See Chapter 22: Custom Instruments for details on creating multi-line Instruments.

Remove Line from Instrument

To remove an Instrument line, click on any parameter of the desired Instrument line and choose Remove Line from Instrument (from the menu in the Instruments Window).

Make from Studio Setup

Choosing Make from Studio Setup opens the following dialog:

![Make from Studio Setup dialog]

Figure 32.5: Make from Studio Setup dialog

Clicking Make creates one Instrument for each device's channel in the current OMS Studio Setup. Instruments are retained only if they're being used by the sequence. All non-custom Instruments that are not in use by sequence are removed if they don't correspond to defined devices.

Since unused custom Instruments are not deleted by Make from Studio Setup, naming an Instrument ensures that it will remain in the sequence.

Vision automatically makes Instruments from the current OMS Studio Setup document the first time the program is launched. Thereafter, whenever the current Studio Setup changes (and if the Always Make from Studio Setup option is checked), Vision prompts you to update the Instruments to match those in the OMS Studio Setup.
CHAPTER 32: The Instruments Window

Making Instruments from your Studio Setup has the disadvantage of losing all non-custom Instruments not used by the current sequence, or not associated with a device in the current Studio Setup. Regardless of where an Instrument comes from, unused, undefined Instruments are removed from the Instruments Window after using Make from Studio Setup.

If Instruments are not made from the OMS Studio Setup document and the Vision Setup file contains Instruments that don’t match Instruments created from the Studio Setup, then the device channels need to be remapped. See Undefined Channels (pg. 431) for more information on remapping undefined channels.

NOTE: Working with Instruments is usually less complicated by saving them with each sequence file, rather than using the Vision Setup file for this purpose.

Always Make from Studio Setup is checked by default.

Select Unused Instruments (Command-A)

Choose this command to quickly delete unused Instruments. If an Instrument is in use by the current sequence, it can not be deleted. You can use the Show Use of Selected Instruments command to find out where it’s being used so you can go to the source and clear or change it.

Show Use of Selected Instruments

Choose Show Use of Selected Instruments to reveal where the selected Instruments are used.

Instruments can be used by tracks, the Thru Instrument, the metronome sound, Input Maps, faders, the Clipboard, or the Undo buffer.

Clear Clip & Undo

Choosing Clear Clip & Undo clears the Vision Clipboard and the Undo buffer. This is helpful to remove an Instrument that Vision considers “in use” by the sequence only because it is stored in the Clipboard following an edit procedure.

NOTE: You cannot undo this command.

Initialize Colors

This sets the Instrument colors to the Vision defaults.
GLOBAL INSTRUMENT SOLO INDICATOR

The Control Bar displays a Global Instrument Solo Indicator whenever any Instrument (Audio or MIDI) is soloed.

If no Instruments are soloed, then the Control Bar displays the standard Instrument button ( ).

Why have a Global Solo Indicator?

Numerous Vision windows let you solo an Instrument, including:
- MIDI Instruments Window
- Audio Instruments Window
- Console Windows
- EQ and Plug-In Edit Windows
- Graphic Window (Audio Instruments only)

With so many windows letting you control Instrument soloing, it's easy to accidentally leave an Instrument soloed, resulting in unexpected playback problems. The Global Instrument Solo Indicator reminds you that an Instrument is soloed somewhere in Vision.

NOTE: The Solo column in the Tracks Window soloos entire tracks, not individual Instruments, so it does not turn on the Global Instrument Solo Indicator.

Using the Solo Indicator

The Solo Indicator lights whenever any MIDI Instrument or Audio Instrument is soloed in any window.

Once lit, the Solo Indicator blinks whenever a sequence plays, or whenever Vision transmits MIDI data, such as when...
- you play an external MIDI controller and Vision is in Keyboard Thru mode (Setups>Keyboard Thru is checked).
- you edit MIDI notes and the Do>Edit Window>Play Edited Note option is checked.
- you scrub across MIDI data.

Finally, you can click the Solo Indicator to open any windows that contain soloed Instruments (as discussed in the next section).
Automatically Unsoloing Soloed Instruments

All soloed instruments (MIDI and Audio) can be automatically unsoloed by option-clicking on the Global Instrument Solo Indicator.

Finding Soloed Instruments

The Global Instrument Solo Indicator goes beyond reminding you that an Instrument is soloed—it helps you find the soloed Instrument(s).

1. In the Control Bar, click the Global Instrument Solo Indicator. Vision opens any window that contains a soloed Instrument.

Specifically:

• If a MIDI Instrument is soloed, clicking the Solo Indicator automatically opens the MIDI Instruments Window, so you can turn off any soloed Instruments.

• If an Audio Instrument is soloed, clicking the Solo Indicator automatically opens the Audio Instruments Window, so you can turn off any soloed Instruments.

• If both MIDI Instruments and Audio Instruments are soloed, clicking the Solo Indicator automatically opens both the MIDI Instruments Window and the Audio Instruments Window.
CHAPTER 33: The Names Window

Choose Windows>Names to open the Names Window, which is a component of the OM S Name Manager.

The Name Manager integrates patch documents from a variety of sources:
- Galaxy Bundles
- Typed-in Patch Name documents
- Documents from other OM S-2 compatible librarians

Once you set up the Name Manager, Vision displays patches, notes and controllers by name, as opposed to just numbers. The Name Manager also takes care of the housekeeping involved when you open a file that uses a different set of patch names.

TERMINOLOGY

Every MIDI device manufacturer seems to use different terminology to describe similar features in their devices. For example, different synthesizer manufacturers use the terms “patch,” “voice,” “part,” “program,” or “sound” to mean the same thing—a collection of programmable parameters that work together to create a unique sound.

Because Opcode has no way of knowing which MIDI devices you own, we must describe certain Name Manager functions generically. The following mini-glossary lists the terms we’ll use in describing the Name Manager.

Patch
A collection of parameters in a device that define the sound played when recalled. For example, one patch might create a trumpet sound and another might create a guitar sound.

Bank
A collection of patches stored in a MIDI device. Most modern MIDI devices have storage for hundreds (or even thousands) of different patches. However, the MIDI specification only provides program change messages for 128 patches. In order to access more than 128 patches, a device must store them in banks, which are accessed via bank select messages. The actual bank select messages vary from device to device.
**Mode**

The state of a device that determines how MIDI program changes are interpreted.

Imagine a synthesizer with three different modes:

- **Patch Mode**: Individual sounds, such as “Electric Piano,” “Acoustic Guitar,” or “Flute.”
- **Effect Mode**: Effects programs such as “Hall Reverb,” “Slap Delay,” or “Flange.”
- **Performance Mode**: A combination of several individual sounds with an effects patch, such as an “Electric Piano” patch layered with a “Flute” patch and assigned to a “Hall Reverb” effect.

Usually devices access the different modes by interpreting patch change messages differently for different channels. For instance, General MIDI devices have “patch” channels and “drum” channels. Sending program change #1 to a channel in “patch mode” calls up a piano, whereas sending program change #1 to a channel in “drum mode” calls up a standard drum kit.

By using different device modes, OMS applications can display and select any patch type contained in your MIDI device.

Do not confuse modes with banks; a bank of patches for one mode might contain an entirely different number of patches than a bank for a different mode.

**Patch Name Document**

A document that stores and provides patch names and device modes for one or more devices. There are subtle differences in the way the Name Manager handles different types of documents; these will be noted throughout the rest of this chapter.

**Current Patch Name Document**

If a Patch Name document is current, OMS thinks that the patches in the document are loaded into the device. You can manually make a document current, or a librarian program like Galaxy might automatically do it for you when sending sounds to a device.

**Patch Name Provider**

An application that can create a Patch Name document readable by the OMS Name Manager.

**Name Setup**

A mapping that associates each MIDI device in your current OMS Studio Setup document with a specified Patch Name document. There is only one Name Setup active at a time, and it “lives” inside OMS, not the application.

Since the Name Setup is handled by OMS, changes made to the Name Setup in Vision affect the names seen in other OMS 2.0-compatible applications.
When you save a Vision file, the current Name Setup is saved along with it.

**NAMES WINDOW**

To open the Names Window, choose Windows>Names.

Figure 33.1: Anatomy of the Names Window

**Names Window Anatomy**

As you can see in Figure 33.1, the Names Window contains numerous elements:

1. **Device column**: This column shows the name of each MIDI device contained in your current OMS Studio Setup document. You cannot edit the contents of this column. Its contents change whenever the current Studio Setup document changes.

   Devices stored in a Name Setup but not defined in the current Studio Setup appear in italics.

2. **Patch Name Document column**: This column shows the Patch Name document referred to by each of the devices. For more information, see Patch Name Document Column (pg. 308).

3. **MIDI Channel column**: Some MIDI devices let you select different modes on different MIDI channels. This column shows which MIDI channel uses the mode shown in the Device Mode column. For more information, see Channel and Device Mode Columns (pg. 310).

4. **Device Mode column**: If a device supports multiple modes, then this column shows which mode it is using. You can change the mode directly in this column's pop-up menu.

5. **Name Setup control**: Use this pop-up menu to determine how changes made in other applications affect the Name Setup. For more information, see Name Setup Control (pg. 309).

The information contained in this window is saved with the Vision file when using the File>Save or File>Save As commands.

The following sections discuss the Names Window in greater detail.
PART 6: Windows

Patch Name Document Column

Use this column to select which Patch Name document or Galaxy bundle is referenced by each MIDI device. This is called subscribing to a document. To subscribe to a Patch Name document or Galaxy bundle:

1. Click in the Patch Name Document column next to a MIDI device.
2. Choose Names>Subscribe.
   A standard Open dialog box appears.
3. In the following dialog, navigate to and select the desired Patch Name document or Galaxy bundle. Then click OK.
   The column now shows the Patch Name document or Galaxy bundle to which you subscribed.

NOTE: If you don’t know where to find Patch Name documents, read the following section.

Where To Find Patch Name Documents

There are three sources for Patch Name documents:

- The Name Manager recognizes Bundles created by Galaxy and other OMS-2.0 compatible librarians as Patch Name documents.
- You can create your own “typed-in” Patch Name documents directly from the Name Manager.
  To do so, double-click in the Patch Name column to open the Patch Name Editor. Use the Patch Name Editor to create or edit a Patch Name document as described in Patch Name Editing (pg. 313).

- Opcode supplies a collection of “factory” Patch Name documents for many popular synthesizers. If there is a factory Patch Name document for your device, choosing Names>Use Factory/GM Names enables it. See Use Factory/General MIDI Names (pg. 311).
Current and Missing Documents

The Patch Name Document column displays additional information about subscribed documents by using italicized text and the small diamond icon:

- A small diamond appears before the name of each current Patch Name document. A current Patch Name document is the document that the Name Manager uses to supply names to all OMS 2.0-compatible applications. For more information, see Name Setup Control (pg. 309).

In Figure 33.3, the MU80’s Patch Name document is not current. This means that the patches actually resident in the MU80 don’t match those currently subscribed.

- The Patch Name document is italicized if the Name Manager can’t locate the document. In Figure 33.3, the document for the Wavestation SR is missing.

Name Setup Control

Since the OMS Name Manager only references one Name Setup at a time, changes made to the Name Setup in other applications can affect Vision. Use the Name Setup control to determine what happens when changes are made to the Name Setup:

- **Always use current patches:** Making Patch Name documents current in another application changes the Name Setup in Vision to match.

- **Keep using these patches:** “Locks in” the current Name Setup. Subscriptions can’t be changed in Vision by changing them in another OMS 2.0-compatible application.

This setting is not remembered between sessions. Whenever you open Vision, the control is reset to **Always use current patches**.
Channel and Device Mode Columns

The Channel and Device Mode functions are interrelated and are described here together.

If a device supports multiple device modes, then the Device Mode column contains a pop-up menu listing all possible modes.

Since each MIDI channel can access a different device mode, the Ch (Channel) column displays which MIDI channels access which device modes. You can view every enabled MIDI channel or just a summary of all MIDI channels by clicking the desired device’s selector icon, then choosing Names>Show Channels.

Show Channels is a toggle whose value is changed by choosing it repeatedly.

- When Show Channels is checked (on), the Names Window displays a separate row for every MIDI channel in that device (as defined in the OMS Studio Setup document). You can then select a device mode for each MIDI channel.

- When Show Channels is not checked (off), the Names Window displays a single row for that MIDI device and the Ch column is labeled all. Changing the device mode affects all channels simultaneously.

The word various in the Device Mode column indicates that not all channels are in the same mode.

Figure 33.4: Channel mode indicators
Editing Device Modes when Show Channels is Off

If Show Channels is off and every MIDI channel is set to the same device mode, then that mode appears in the Device Mode column.

If Show Channels is off and different MIDI channels use different device modes, then the device mode column displays various, indicating more than one device mode is active for this device (see Figure 33.4).

Editing Patch Name Documents for Multi-Mode Devices

If different MIDI channels reference different device modes, there is only one way to edit each mode’s Patch Name document:

1. Double-click a number in the Ch column.
   A Patch Name Editor opens for that MIDI channel’s mode. Patch Name Editing is discussed in Patch Name Editor Anatomy (pg. 314).

IMPORTANT: This is the only way to edit the patch names for a device with multiple modes.

NAMES MENU

The Names Menu is available whenever a Names Window is active.

Names

Figure 33.5: Names Window menu

The following sections describe each command in the Names Menu.

Subscribe

This command selects a Patch Name document to which all selected devices are subscribed.

Use Factory/General MIDI Names

If you’re using a General MIDI synth, choose this command to subscribe to the General MIDI Patch Name document located in the Factory Names folder (in the OMS Folder inside the System Folder).
OMS also provides Factory Name documents for many popular instruments. If your device is supported, this command subscribes to these names.

If the device doesn’t have an associated Factory Name file, the General MIDI patch names are used instead.

**Copy Subscription**

This command copies the subscription for the selected device(s) to the Clipboard.

**Paste Subscription**

This command pastes subscriptions from the Clipboard onto the selected device(s). Any previous subscription is replaced and the new Patch Name document becomes current.

**Clear Subscription**

Removes the subscription information from selected device(s).

**Make Current**

When choosing this command, the following alert appears:

Clicking **Don’t Make Current** retains the previous subscription.

If the **Send the patches** option is available and checked, the Name Manager attempts to transmit the patches to the device when you click the **Make Current** button. The application that created the Patch Name document must be capable of this operation. For example, names obtained from a Galaxy Bundle can be sent (if Galaxy is available on your system), but typed-in Patch Name documents cannot and the **Send the patches** option won’t appear in the alert.

**Use Current Instead**

**Use Current Instead** replaces the selected device(s)’ non-current subscriptions with subscriptions to the current Patch Name document(s).

**New Patch Document**

Creates a blank, untitled Patch Name document for the selected device(s).

**View/Edit Patch Names**

Selecting a device and choosing this command is equivalent to double-clicking a device’s Patch Name document column.
Tell Patch Provider

This menu item contains a sub-menu listing the commands that can be sent to the Patch Name provider.

If the Patch Name Provider understands the selected message, it performs that action. For example, if patch names come from a Galaxy Bundle and Send Patches to Device is the selected command, Galaxy sends the bundled patches to the selected device.

Show Channels

Show Channels controls whether the Names Window displays one row per MIDI channel or a single row representing all MIDI channels. To assign different device modes to different MIDI channels, this option must be enabled (checked).

For more information, see Channel and Device Mode Columns (pg. 310).

PATCH NAME EDITING

Use the Patch Name Editor to display or edit Patch Name documents.

To open the Patch Name Editor:

1. In the Names Window, double-click in the Patch Name Document column next to a device.

The Patch Name Editor opens for that Patch Name document. The Editor shows all the Patch Names for that device.

If you open a Patch Name Editor for an unsubscribed device, a blank Patch Name Editor opens, which you may use
to create a Patch Name document. Documents created this way are called “typed-in” Patch Name documents.

NOTE: If a Patch Name document contains multiple device modes, the Patch Name Editor displays names only for the selected channel’s current device mode. For more information, see Channel and Device Mode Columns (pg. 310).

Patch Name Editor Anatomy

Figure 33.7 shows the various elements in the Patch Name Editor. These are:

1. **MIDI Program Number**: The MIDI column in the Patch Name Editor displays MIDI representations of patches in the form bank0/bank32/patch number (0-127). For example, if the current bank requires a bank32 message with value “1” to be sent to access the patches, each patch will have “1/x” as its program number, where x is the number within the bank.

   Bank0 and bank32 are each omitted when not used, which is the case for the default first bank. Consult your synthesizer’s documentation to determine how bank0 and bank32 messages affect patch selection. These numbers can’t be changed directly, and if the Patch Name document comes from an external librarian, they can’t be changed at all. If the document in question is a typed-in Patch Name document, the numbers are affected by settings in the Bank Select/Numbering dialog box. See Bank Select/Numbering (pg. 319).

2. **Device Program Number**: This column shows how the MIDI device’s internal program numbering corresponds to the actual MIDI program number. For example, some devices number their internal programs 1-128, which corresponds to MIDI programs 0-127. This results in the pattern shown in Figure 33.8 in the MIDI and Numbers column.

   The device shown in this example, organizes its programs in banks of 50, which are numbered 0-49.

   ![Figure 33.8: MIDI and device numbering](image)

   This column numbers patches as they appear in the actual device.

3. **Patch Name**: This column shows the name of each patch. New patch names can be typed directly into this column if this Patch Name document was created in the Name Manager (Galaxy and other librarian documents can’t be edited from here). These names appear wherever patch names are seen in any OMS 2.0-compatible application.
GM Equivalent: If this patch corresponds to a General MIDI patch, choose the relevant GM patch from the pop-up menu in this column. The Name Manager applies all attributes and benefits of General MIDI groupings to that patch.

For example, assume you have a piano sound in your Patch Name document, and you assign “GrandPno1” as its GM Equivalent. Then, if you choose to display patch names by General MIDI Groups, this piano sound appears whenever you ask to see all the piano sounds in your MIDI device. For more information about selecting patches by General MIDI Groupings, see Using Patch Groupings (pg. 321).

Note Name Indicator: The OMS Name Manager can store custom MIDI note names along with patch names. Custom note names have many uses. For example, names can be assigned to the notes in a drum kit patch, causing edit windows to display notes named “kick” and “snare,” instead of “C3” and “D3.”

This column uses a small note icon to indicate that a patch has custom note names. The Note Name Editor can be opened by double-clicking in this column. For more information, see Note and Control Names (pg. 320).

Control Name Indicator: The OMS Name Manager allows storage of custom MIDI control names along with the name of the patch. Custom control names have many uses. For example, a MIDI effects device might use MIDI control numbers to edit its internal parameters. By entering custom control names, edit windows display controls named “Reverb Time” and “Pre-Delay,” instead of “Control 48” and “Control 37,” making it easier to edit these devices within OMS 2.0-compatible applications.

This column indicates that a patch has custom control names if it contains a small knob icon. The Control Name Editor can be opened by double-clicking in this column. For more information, see Note and Control Names (pg. 320).

Program Selector Dot: If you are pasting names into a typed-in Patch Name document, you can select the range where the names will be pasted by Shift-clicking or dragging over the Program Selector dots. If no dots are selected, names are pasted starting at the top and working down until the names on the Clipboard are exhausted. See Paste Name List (pg. 317) for more information.
**Patches Menu**

The Patches menu is available whenever a Patch Name Editor is active.

![Image](image.jpg)

**Figure 33.9: Patches menu**

NOTE: Most of these menu items apply only to typed-in Patch Name documents; they're disabled for Patch Name documents that come from other applications, such as Galaxy.

**Save**

Choose this command to save any changes you've made to the current Patch Name document. If you've previously saved a document, then the Save command replaces the old document with the new version. If you haven't yet saved the active document, choosing Save opens the Save As dialog box, in which you can name the document and select a location in which to store it.

This command behaves differently depending on where the document comes from:

- Typed-in Patch Name documents are saved normally.
- Documents from Galaxy or other OMS-compatible Patch Name providers are converted to typed-in Patch Name documents. For this reason, the Save command is not available when you are in a librarian’s document. In this situation, only the Save As command is available.

**Save As**

Use this command to save a copy of the active document using a different name. Choosing Save As opens the Save As dialog box, in which you can name the document and select a location in which to store it.

**Saving Note/Control Names**

If Note or Control Names have been added to a document created by another application, the Save Note/Control Names command becomes available. This command adds the note and control name information to the saved Patch Name document.

**Copy Name List**

Choose Copy Name List to copy the list of patch names from a Patch Name document onto the Clipboard.
Names are copied to the Clipboard as text, and can be pasted into other applications. For example, you can paste names into a word processor or database to format, search, or print name lists. Each line is copied as:

Patch Number <tab> Patch Name

**Paste Name List**

Choose **Paste Name List** to copy text from the Clipboard into the Patch Name Editor. If the lines of text contain tabs, they are interpreted as:

Patch Number <tab> Patch Name

Otherwise, each line of text becomes a patch name. If you have access to a scanner and OCR (optical character recognition) software, you can scan patch name lists for your synthesizers, convert them to word processing files, then paste them into the Patch Name Editor.

If any patches in the Patch Name Editor are selected (that is, their selector dots are black), then pasting names overwrites only the selected patches. For example, if you have ten patch names on the Clipboard, but select only three patches, only the first three names on the Clipboard are used (see Figure 33.10).

<table>
<thead>
<tr>
<th>MIDI Number</th>
<th>Patch Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Set Jame</td>
</tr>
<tr>
<td>1</td>
<td>Entrance</td>
</tr>
<tr>
<td>2</td>
<td>Player</td>
</tr>
<tr>
<td>3</td>
<td>Raavader</td>
</tr>
<tr>
<td>4</td>
<td>LeadRockGuitar</td>
</tr>
<tr>
<td>5</td>
<td>Software</td>
</tr>
<tr>
<td>6</td>
<td>Cascade Falls</td>
</tr>
<tr>
<td>7</td>
<td>Blow The Bottle</td>
</tr>
<tr>
<td>8</td>
<td>Magic Guitar</td>
</tr>
<tr>
<td>9</td>
<td>Will I Dream?</td>
</tr>
<tr>
<td>10</td>
<td>FireRanger</td>
</tr>
</tbody>
</table>

**Figure 33.10:** Only patches 1-3 will be pasted, regardless of the Clipboard's contents

**Clear Name List**

This command erases the currently selected name list, should you wish to start with a “clean slate.”

**Add Mode**

Choose **Add Mode** to create an entirely new device mode for the document, and open a new window to display it.

**Remove Mode**

Choose **Remove Mode** to delete the device mode displayed in the active window.
PART 6: Windows

Mode Name

Choose **Mode Name** to name (or rename) the device mode displayed in the active window. The mode name appears on the top line of the window.

Default Modes

Choose **Default Modes** to open a window in which you select a default mode for each channel. Whenever this Patch Name document is subscribed, the channels are set to the modes designated in this window.

For example: General MIDI devices have two modes: **standard** and **drums**. Channel 10 is always in drums mode, and all other channels are in standard mode. Figure 33.11 shows the default mode screen setup for a General MIDI device.

![Figure 33.11: Default Mode Window](image)

Add Bank

Choose **Add Bank** to create a new bank of 128 patches following the bank containing the currently selected patch, or at the end of the document if there is no selected patch. When you choose this command, the Bank Select/Numbering dialog box opens as discussed in Bank Select/Numbering (pg. 319).

Remove Bank

Choose **Remove Bank** to delete the bank in which the selected patch resides.

NOTE: If the device has less than 128 patches in a bank, leave the unused patches blank—blank patches won't be displayed in patch selection menus and dialog boxes.
Bank Select/Numbering

Adding a bank or choosing the Bank Select/ Numbering command opens the Bank Select/ Numbering dialog box:

Figure 33.12: Bank Select/Numbering dialog box

1. A Bank Select message may be specified by checking one or both of the Bank Select checkboxes, and by entering a bank select value in the box to the right. Consult your synthesizer's documentation to determine the appropriate values for these boxes.

2. IMPORTANT: Each bank must have a unique combination of bank select messages. A warning message appears if two banks have the same bank select combination.

3. If the Automatically number patches in bank option is checked, the patches are automatically numbered according to the selected numbering convention:
   - **0-127**: Used for synthesizers with a “0 based” numbering convention.
   - **1-128**: Used for synthesizers with a “1 based” numbering convention.
   - **A11-B88**: Used for synthesizers with a “bank based” numbering convention (most Roland devices use this scheme).

4. Patch prefixes can be entered in the Prefix box. For example, a synth may use banks with names such as “RAM 1.” The patches could be numbered “RAM 1-0” thru “RAM 1-127” by entering “RAM 1-” in the Prefix box and selecting **0-127**.

5. If the Assign GM equivalents to all patches option is checked, each patch is assigned a General MIDI patch equivalent. This sets each patches' number equal to the GM equivalent. This is useful to configure a bank to match the GM defaults without changing the names.

<table>
<thead>
<tr>
<th>MIDI</th>
<th>Number</th>
<th>Patch Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>*</td>
<td>125</td>
<td>Tibetan Dreams</td>
</tr>
<tr>
<td>*</td>
<td>126</td>
<td>Downward Spiral</td>
</tr>
<tr>
<td>*</td>
<td>127</td>
<td>String Scream</td>
</tr>
<tr>
<td>*</td>
<td>0/0</td>
<td>Blew It Known</td>
</tr>
<tr>
<td>*</td>
<td>0/1</td>
<td>Big Brands</td>
</tr>
<tr>
<td>*</td>
<td>0/2</td>
<td>Prepared Piano</td>
</tr>
</tbody>
</table>

End of first bank
Beginning of second bank

Figure 33.13: Using the Prefix feature
Note and Control Names

Double-click the Cnts column in the Patch Name Editor to open a Control Names Window. Similarly, double-click the Notes column to open a Note Names Window.

Control names are useful if you perform real-time edits to synthesizer or effects patches. For example, it's easier to edit controllers named “RevTime” and “HPFiltr” than controllers named “Control 41” and “Control 73.”

Default Note and Control Names

At the top of every Patch Name document is a line marked Default. You can add a set of default note and controller names to a Patch Name document by double clicking in the appropriate column and typing names into the Note Names or Control Names Window. These default Names are used for every patch that doesn’t specifically override them.

In Figure 33.15, there is a set of default Note Names. All the patches in this bank use these note names. However, the note icon in the row for patch number 2 indicates that it has its own set of Note Names that override the defaults.

Note names are useful for drum machines or samplers. For example, it’s easier to edit MIDI data for a drum machine if notes appear named “Kick” and “Snare” rather than “C2” and “D2.” Similarly, if you’re using a sampler to trigger sound effects, notes named “Crash” and “Gunshot” are more useful than notes named “G3” and “D5.”
SELECTING NAMES

Once the Name Setup is configured properly, Vision displays names in all appropriate places (such as in the Current Patch pop-up in the Control Bar, or in the Patch column of the Tracks Window).

There are two ways to choose names:

- A simple pop-up menu of choices, either sorted alphabetically or numerically. This appears when you click on a name field.
- The **Names Browser** is a more sophisticated window where you can view names numerically or alphabetically—or even group them by keyword or patch type. The Names Browser Window appears when you Command or Option-click a name field.

Figure 33.16 shows the pop-up menu that appears when you click on a patch name field.

Names Browser

If you Option or Shift-click on a name field, the Browser Window opens:

![Names Browser](image)

The Name Manager sends the necessary commands (program change/bank select) each time a patch is selected. The **By number/By name** radio buttons sort the list by number or name; this is global and applies to pop-up menus as well.

Using Patch Groupings

The Grouping pop-up menu allows you to choose a grouping assignment for the current Patch Name document. For example, the General MIDI patch names contains the groupings **None, General MIDI**

![Grouping Menu](image)
Groups and General MIDI Patches. If you select General MIDI Groups from the Grouping pop-up menu, you will be presented with this list of groupings in the Browser Window:

![Figure 33.18: General MIDI Groups](image)

Selecting an item from this list narrows the list of available patches to show only those patches that belong to the selected group. For example, patches in the Piano group include Grand Piano, Brite Piano, and so forth.

An additional advantage to using groupings is that patch selection menus display their contents hierarchically; that is, arranged by group (as shown in Figure 33.19).

![Figure 33.19: Hierarchical Patch Selection](image)

You can create your own groupings with Galaxy, Opcode’s patch librarian application. Also, Galaxy automatically provides groupings for certain synthesizers. You cannot create groupings with typed-in Patch Name documents.

Browser Menu

![Figure 33.20: Browser menu](image)

When you use the Names Browser, the menu shown in Figure 33.20 becomes available.
sort by number/sort by name
these commands duplicate the function of the "by name/by number" buttons in the browser window.

show patches in any/all selected group(s)
with "any selected group" selected, shift-clicking multiple groupings in the browser displays patches that belong to any of the selected groups (if you have programming experience, think of this as the "or" condition).

with "all selected groups" selected, shift-clicking multiple groupings in the browser only displays patches that belong to all of the groups (programmers can think of this as the "and" condition).

as an example, imagine you have a grouping for "bright" and a grouping for "piano." with "all selected groups" chosen, you would see only bright pianos listed, whereas with "any selected group," you would see all bright patches and all piano patches listed together.

edit selected patch
tells the patch provider to open an edit window for the selected patch, if the application supports the command.

opening files with different name setups
vision saves name setups in its sequence files. when you open a file that references a different name setup, you have to answer some questions to let the name manager know how you want to handle the different assignments. this section discusses the possible options.

first, you see the following dialog box:

figure 33.21: different name setups, first dialog box

you have two choices at this point. the following sections describe these choices.

make current
this choice overrides all current name setup information with the information in the file being opened.
Usually if you want to change subscriptions, you also want to send the new patches to your synthesizers, and the Name Manager assumes that this is what you want to do. You will see a dialog box similar to the following, letting you know that transmission is going to start:

Figure 33.22: "Getting Ready To Send" dialog box

Typed-in patch documents have an asterisk (*) next to their name, letting you know that they can’t be sent automatically. You should load up your devices with these patches in whatever manner is appropriate.

Documents that can’t be found are displayed in italics.

When you are ready, you can click...

- **Send**: to send the bundles to the devices.
- **Don’t Send**: to proceed without sending any data.
- **Go Back**: to return to the previous dialog box.

Don’t Make

Clicking **Don’t Make** leaves the current patches current. However, you still have a choice to make: do you want to change the document being opened to use the current Name Manager subscriptions, or do you want to leave the file alone?

If you click...

- **Keep**: the document is unchanged.
- **Change**: the document is updated to use the current Name Manager subscriptions. If you save the file without changing its name, any record of the old subscriptions is lost.
- **Go Back**: returns to the previous dialog box.
CHAPTER 34: The Input Map Window

The Input Map Window allows reassignment of MIDI events received from an Instrument, defined by a device and channel, to a different Instrument. Reassigned events can also trigger and transpose sequence playback.

**Input Device and Channel**

Selecting a MIDI device and channel defines the source for incoming events. Vision intercepts MIDI signals from this device and channel, and remaps them to the Instrument or trigger defined in the Thru/Trigger field.

The available devices are determined by the Input Devices defined in the current OMS Studio Setup document.

**Range**

These columns allow specification of the note range, on the selected device and channel, that will be remapped. Notes outside this range are not affected by the Input Map. MIDI note numbers can be entered from the numeric keypad or by selecting the field and playing a note on a MIDI controller.

**NOTE:** Notes assigned in MIDIKeys have precedence over the Input Map. For example, a note falling within the note Range in the Input Map, but having an assignment in MIDIKeys, will not be processed by the Input Map.

**INPUT MAP DISPLAY**

Each line in the Input Map controls the mapping for a range of notes on a MIDI device and channel to an Instrument or a trigger mode. Vision compares each incoming MIDI event to each line in the Input Map, beginning with the top line. If the event is in the specified range of notes and it's on the specified device and channel, then the MIDI event is reassigned. If more than one line matches, the first one is used. If no line matches, the event is routed to the Thru Instrument set in the Control Bar.
PART 6: Windows

Base

The Base is the note that acts as middle C for the remapped keyboard zone. This is useful when splitting a keyboard into two or more zones. For example, assuming C3 is middle C, setting the Base to C2 transposes each note up an octave before being remapped or routed to the Thru Instrument.

The Base also acts as a reference point for the transpose and trigger modes.

NOTE: Middle C can be either C3 or C4, depending upon what has been specified in the Settings Window.

Thru/Trigger

Clicking here gives you the same Instrument pop-up as the Thru Instrument pop-up in the Control Bar. You can choose either an Instrument to assign to this line’s zone, or you can choose a trigger or transpose mode.

If you want to assign a trigger mode, you can then set the sequence and Player number. This is discussed below and in Trigger and Transpose Modes (pg. 326).

Sequence and Player

When selecting a trigger mode for a line, these fields allow specification for both the sequence played and the Player it’s played on.

Unlike the Thru Instrument setting, where the trigger mode requires you to hit a letter key to make a sequence triggerable, Vision will start a sequence when it receives a MIDI signal from the device and channel in this line.

TRIGGER AND TRANSPOSE MODES

Although the trigger and transpose modes can also be set using the Thru Instrument pop-up menu, the operation is effective only until sequence playback stops. The Input Map settings remain active between playback sessions.

Transpose Mode

Transpose mode remaps valid incoming MIDI notes to transpose sequences currently playing, without playing the incoming notes. Transpose mode doesn’t affect sequences being recorded.
Notes played within the selected note Range transpose playing sequences relative to the Base note. For example, if the Base note is C3 and a D3 is played (and D3 falls within the note Range), all playing sequences are transposed up a whole step. The D3 is not played but acts only as a transposition value and signal.

If two keys are played simultaneously, and both fall within the note Range, both notes affect their own transpositions relative to the Base note.

**Trigger Modes**

The trigger modes allow notes falling within the note Range to trigger sequence playback for the sequence specified in the Sequence field. Each valid note starts playback for one copy of the sequence. The sequence is also transposed according to the rules discussed in the previous section. Multiple valid notes, played simultaneously, transpose and play separate copies of the sequence.

**Trigger Mode**

Trigger mode stops and restarts the selected sequence, using the relative transposition, upon receiving valid trigger notes. Notes played simultaneously start and transpose separate copies of the sequence.

**Continuous Trigger Mode**

Continuous Trigger mode does not stop currently playing sequences when valid notes are directed to that sequence. After the sequence finishes playing, it is restarted and transposed according to the note previously received.

**Gated Mode**

Gated mode plays and transposes the sequence, when receiving notes within the note Range, only while notes are held down. This can provide an interesting interactive environment for creating interwoven lines.

**INPUT MAP WINDOW MENU**

<table>
<thead>
<tr>
<th>Option</th>
<th>Key Combination</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input Map Enabled</td>
<td>⌘ ⌥ E</td>
</tr>
<tr>
<td>Add Line</td>
<td>⌘ S</td>
</tr>
<tr>
<td>Remove Line</td>
<td>⌘ ⌥ R</td>
</tr>
<tr>
<td>Make One Line per Channel</td>
<td>⌘ ⌥ M</td>
</tr>
<tr>
<td>Load From...</td>
<td>⌘ ⌥ L</td>
</tr>
<tr>
<td>Clear All</td>
<td>⌘ ⌥ C</td>
</tr>
</tbody>
</table>

Figure 34.3: Input Map Window menu

**Input Map Enabled**

When this toggle is enabled, Vision routes incoming MIDI signals to the Input Map. If the MIDI note doesn’t apply to any line in the Input Map, the signal is routed to the Thru Instrument. When the toggle is disabled, Vision routes incoming MIDI signals directly to the Thru Instrument, bypassing the Input Map.
Add Line (Option-=)

Choosing this item creates a new line in the Input Map. Selecting an item on an existing line, before choosing Add Line, duplicates that line below the line containing the selected item.

Remove Line (Option—)

Selecting any parameter in a line and choosing Remove Line, removes that line from the Input Map.

Make One Line per Channel

Choosing this command sets up one Thru/Trigger Instrument for each device enabled for MIDI Input in the Studio Setup document. Instruments appear in the same order as in the Instruments Window.

To quickly add one line per channel for a specific device, choose Setups>Enable Input Devices and disable all input devices except the specific device being added to the Input Map. Then choose Make One Line per Channel. Disabled devices may then be enabled without disturbing the Input Map.

Load From

This opens a standard open dialog box allowing the Input Map from another Vision file to become the active Input Map for the current file.

The Load From command loads only the Input Map from the Vision file. This mechanism allows the creation of templates for commonly used Input Maps.

Clear All

The Clear All command deletes all lines from the Input Map and cannot be undone. If your use of Vision doesn’t require an Input Map (see When to Use an Input Map (pg. 328)), you should keep the Input Map clear. This allows your controller keyboard to use the Thru Instrument setting, which can be changed more easily than the Input Map.

WHEN TO USE AN INPUT MAP

For those using Vision with a single controller keyboard, Input Maps are not essential and their inadvertent use can create confusing routing problems. Choosing Clear All from the Input Map Window pop-up clears all lines from the Input Map and disables all assignments (page 328).

The following examples suggest several common uses for the Input Map:

- The OMS Studio Setup has more than one MIDI controller;
- Permanent assignment of MIDI notes to trigger certain sequences (see Trigger and Transpose Modes (pg. 326));
- Enable recording from another sequencer;
- Split the controller keyboard.
Multi-Channel Recording

Several MIDI channels can be recorded simultaneously from a separate sequencer into Vision by using the Input Map to assign each incoming MIDI channel to a different Vision Instrument. See Multi-Channel Recording (pg. 46) for details.

Multiple Keyboards and Keyboard Splits

To set up a split controller keyboard, clear the Input Map by choosing Clear All from the menu in the Input Map Window. Then, for each zone on the keyboard:

1. Choose Add Line from the Input Map’s Window menu.
2. Make sure the Input Map’s device and channel assignments match the controller’s output assignments.
3. Click in the low Range note field in the new line, and play the low note of the range on your keyboard controller.
4. Click on the high Range note field and play the high note of the range on your keyboard controller.
5. Set the Base note for the zone to the note that will function as C3.
CHAPTER 35: The Settings Window

The Settings Window contains preference settings for a number of different edit and display options. The Settings Window displays a different set of preference items based on the selection in its pop-up menu, see Figure 35.1.

![Figure 35.1: Settings Window pop-up menu](image)

Changes in the Settings Window take effect immediately. In fact, you can keep this window open, making changes as needed, while continuing to use Vision.

Any changes made in the Settings Window are remembered when relaunching Vision. Information from the Settings Window is saved to the Vision Prefs file (located in the Preferences folder inside your System Folder).

The following sections discuss each of the preference groups accessed from the Settings Window.

**INSERT NOTE**

The Note Settings allow precise control over the duration, spacing, and velocity of notes entered with the Pencil and Magic Drumstick. You can use standard note durations, tuplets, or construct arbitrary durations.

The Note Settings can be opened automatically by double-clicking the Pencil or Magic Drumstick tools.

**Spacing**

Specifies the spacing of notes inserted when dragging with the Magic Drumstick. For details on using the Spacing pop-up and Tuplet option, see Spacing (pg. 337).
PART 6: Windows

Duration

Specifies the duration of notes inserted with the Pencil and Magic Drumstick. For details on the Duration parameters, see Duration (pg. 339).

Velocity

Specifies the velocity of notes inserted with the Pencil and Magic Drumstick.

STRIP CHART & NUDGE

Strip Chart Settings

Density

Sets the density of continuous controller events inserted in the Strip Chart. This value can also be changed in the Strip Chart area. For more details, see Using the Density Setting (pg. 256).

Waveform Period

Sets the period length for the Strip Chart’s Oscillator Shapes. This length can be based on a number of bars, beats, units, seconds, SM PTE frames, or SM PTE bits. For more details, see Oscillator Shapes (pg. 247).

The Waveform Period also has an option called Use Meter. Check this item when using “bars” as the period; this ensures that the bar’s size is based on the Meter for the affected track region.

Nudge Settings

Move Amount (leftrightarrow)

Determines how far events are nudged left or right. This amount can be based on a number of bars, beats, units, seconds, SM PTE frames, or SM PTE bits.

The Move Amount also has an option called Use Meter. Check this item when using “bars” as the nudged amount; this ensures that the bar’s size is based on the Meter for the edited track region.

Transpose Amount (uju)

Determines the type of transpose used when nudging notes up or down. This value can be based on a number of semitones, octaves, or scale degrees.
The Transpose Amount also has an option called **Use Key Signature**. Check this item when using “degrees of scale,” which ensures that the transposition is in the Key Signature used by the edited track region.

**EDITING**

**Auto Scroll Top Window Only**

Check this option to restrict Auto Scrolling to the top window. This can free up processing power for slower computers. If unchecked, all windows for the current sequence scroll.

**Set Insertion Point to End of Paste Region**

When checked, the Insertion Point is automatically moved to the end of a pasted region—which makes it easier to cleanly paste another copy. This option is also used with Insert Blank Time, Insert Clipboard, Merge, and Repeat Paste.

When unchecked, pasted events remain selected (so they can be modified, if desired).

**Clear Beat/Unit when Entering Bar**

If checked, typing into a field for bar, beat, hours, minutes, or seconds clears all fields to the right.

If unchecked, typing into any of these fields leaves fields to the right unaffected—typing the Period key, however, moves the cursor to the next field and clears it.

**Punch Points follow Edit Points**

When checked, any changes made to the Edit In/Out points (while playback is stopped or paused) are automatically echoed to the Punch In/Out Points.
PART 6: Windows

Clean Tempo Display

When checked, tempos are displayed with 2 decimal points. Uncheck this option to display tempos with four decimal points.

NOTE: Not all four digit tempos are possible, but you will be able to access Vision’s full tempo accuracy.

Define Middle C

This pop-up menu specifies whether “middle C” (MIDI note number 60) is displayed as C3 or C4. Most instruments define “middle C” as C4. Yamaha instruments, on the other hand, use C3.

Default Edit Window

This pop-up specifies the edit window opened when double-clicking a track from the Tracks and Pulse Windows (regardless of the type of data contained in the track).

If Graphic or Notation is specified, Option-double-clicking a track opens the List Window. If List is chosen, Option-double-clicking opens the Graphic Window.

In all cases, double-clicking a drum track from the Tracks Window opens the Pulse Window.

Modify Window Option

This pop-up specifies what happens to the Select and Modify Window after an action is performed. You can specify that the window: stay in front, go behind the target editing window, go behind all windows, or close after invoking the Select & Modify command (by either clicking the Modify button or typing Return).

REAL-TIME

Figure 35.5: Real-Time settings

Silent when Paused

When checked, all notes are turned off when playback is paused. If unchecked, all notes are sustained when paused, which can be used as a “fermata” effect.

Sustain Notes across Segments

When checked, notes playing back from a sequence event play for their full duration, even if the referenced segment or sequence stops playing.
**Sustain Audio Across Segments**
When checked, audio events played from a sequence event last for their full duration—even if the referenced segment or sequence stops playing.

If you uncheck this option, the audio will stop playing when the sequence event ends, or when it reaches the loop end point (if it is set to repeat).

**Aftertouch Sets Effect Velocity**
When checked, aftertouch affects the velocities of notes played with the Input Effect (Repeat or Arpeggiate).

**System Exclusive Thru**
When checked, Vision routes system exclusive messages from your MIDI controller to the Current Thru Instrument (or with the Input Map, if enabled).

If unchecked, Vision receives the information but does not route it.

**Solo Audio and MIDI independently**
When checked, soloing of one or more Audio Instruments will not mute MIDI Instruments, and soloing of one or more MIDI Instruments will not mute Audio Instruments. Instruments can be soloed from the Instruments or Audio Instruments window, Consoles, Plug-in edit windows, and EQ edit windows.

This does not apply to audio or MIDI tracks, however. Soloing tracks still behaves as it always has; if one or more tracks are soloed, only the soloed tracks can be heard (regardless of whether they are MIDI, audio, or multi tracks).

If unchecked, soloing an Instrument (Audio or MIDI) will mute all remaining instruments (Audio or MIDI).

**Audio edits occur...**
Select “immediately” from this pop-up menu to have audio edits reflected almost instantaneously for playback. Choosing this option does, however, cause audio edits to interrupt audio playback briefly.

If you instead select “smoothly,” edits are reflected more slowly, but with no disruption in audio playback.

**Record Quantize Source**
The settings used for Record Quantize can be the Quantize settings residing in the Select & Modify Window or Input Effect Windows or the Play Quantize settings of the record-enabled track.

The default choice for this pop-up is “track,” which (when selected) represents no change in the way Record Quantize in previous versions of Vision.

From the Real-Time section of the Settings Window, choose either “track,” “Modify,” or “Input Effect” from the Record Quantize source pop-up to specify the Record Quantize source.
PART 6: Windows

**Maximum Playable Tracks**

This is the maximum number of tracks (parent sequences and sequence events included) that Vision can play at any one time.

Decreasing this number frees up more memory for recording and editing.

**CONTROLLERS**

![Figure 35.6: Controllers settings](image)

**Favorite Controllers**

These pop-ups specify the eight continuous controllers you use most often. These controllers appear in many of Vision's dialogs and windows, wherever you must make a controller selection.

**Fine Controller Values**

When checked, continuous controllers 0-31 use a finer range of controller values (0-16383, as opposed to 0-127). Also, the Strip Chart generates “fine” controller data for any inserted values.

If unchecked, all MIDI controllers are treated equally as having a range of 0-127. Consult your user manual to see if your devices support “fine” mode.

**APPEARANCE**

![Figure 35.7: Appearance settings](image)

**Window Background**

This pop-up menu determines the graphic background patterns used in Vision's windows and dialogs.

**Fader Slots in Instrument Color**

Check this option to display Instrument colors in the fader and console slots.
CHAPTER 36: The Step Window

The Step Window specifies how notes are step recorded. It opens automatically when entering step record mode. For details on step recording, see Step Recording (pg. 42).

![Step Window](image)

The Step Window is divided into three sections: Spacing, Duration, and Velocity. The following sections discuss these three components of the Step Window.

### SPACING

Spacing determines the amount of time the Counter advances each time you play a note. The value is displayed as both a note duration and number of units (there are 480 units per quarter note). It also can affect the duration of the note.

One of the easiest ways to set the Spacing value is to choose a note value from the note pop-up. The units field is automatically updated with the selected note value.
PART 6: Windows

You can also click in the units field and type a new value, or click and drag with the mouse.

If you enter a value in the units field that is not an equal subdivision of the beat, the note pop-up shows a “>” or “<” symbol along with the current note size, which indicates the approximate value.

![Figure 36.2: Approximate note sizes](image)

In Figure 36.4, the Spacing specifies three notes within the space of an 8th note. In this instance, the Counter advances a third of an 8th note (80 units) for each step.

**Using Keystrokes to set the Spacing**

Perhaps the fastest way to change the Spacing size is by typing keys on your computer keyboard. This only works if the Step Window is open.

The following table summarizes the keystrokes:

<table>
<thead>
<tr>
<th>Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Toggle triplet setting on or off</td>
</tr>
<tr>
<td>2</td>
<td>Toggle dot on or off</td>
</tr>
<tr>
<td>4</td>
<td>Add the next value to the current value</td>
</tr>
<tr>
<td>6</td>
<td>Subtract the next value from the current value</td>
</tr>
<tr>
<td>.</td>
<td>Add the next value to the current value</td>
</tr>
<tr>
<td>+</td>
<td>Subtract the next value from the current value</td>
</tr>
</tbody>
</table>

**Tuplet Checkbox**

If using complex timing divisions, use the Tuplet checkbox to define the Spacing. With it you can specify, for instance, 5 notes in the space of 1 for quintuplets.

To enable the Tuplet, click its checkbox and enter the values for each of its fields. Vision calculates the Spacing size and the units field is updated automatically.

![Figure 36.3: Exact note sizes](image)
The following mnemonics may be useful in remembering the keystroke for each note duration:

- **1**: One whole note per measure.
- **2**: Bottom number of 1/2 note.
- **4**: Bottom number of 1/4 note.
- **6**: “6”teenth note.
- **5**: $2^5 = 32$ for 32nd note.
- **3**: triplet has 3 notes.

### Adding and Subtracting Durations

The “+” and “−” keys can help calculate the Spacing value, for example:

1. **With the Spacing value set to 8th notes (240 units), type `1`**.
   - Make sure the note is not highlighted.
   - Click on any inactive window area or on another field to de-select the Size pop-up.

2. **Next type `6` to add a 16th note (120 units) to the 8th note**.
   - The Spacing’s note pop-up switches to a dotted 8th note (360 units).

You can also use the “+” key for long notes—type “1 + .4” to create a whole note tied to a dotted quarter note. As you can imagine, with one hand on the computer keyboard, and one on your MIDI controller, you can step record music very efficiently.

### DURATION

The Duration section of the Step Window determines the lengths of step recorded notes. The Duration pop-up menu offers the following four options:

#### Independent

- **Independent** sets the note durations to a length independent of the Spacing size. To set the Independent duration, choose a value from the note pop-up or change the value in the units field; changing either of these items updates the other automatically.

Independent ensures all recorded notes are of uniform length, even if the Spacing size changes. Figure 36.5, for example, illustrates the Spacing size varying while the Duration stays constant with Independent set to 16th notes.

![Figure 36.5: Independent set to 16th notes](image)
Spacing Minus Gap

Specifies the size of the “gap” (rest) between each step recorded note. As a result, the actual length of the recorded notes is equal to the Spacing size minus this Duration size. In this mode, the gap between the recorded notes is constant, even if the Spacing size changes.

Percent of Spacing

Calculates the durations based on a percentage of the Spacing size. To enter staccato notes, use smaller percentage values such as 50%. To enter legato notes, use percentage values near 100% or even larger.

As Played (Duration)

Records durations as you actually play them, with respect to the current tempo setting of the sequence—even though the metronome doesn’t sound while step recording.

The Counter still advances based on the Spacing setting but the actual duration entered can be arbitrarily long or short.
CHAPTER 36: The Step Window

VELOCITY

The Velocity section of the Step Window determines the velocities of step recorded notes. The following two options are available:

**Constant**

<table>
<thead>
<tr>
<th>Velocity</th>
<th>Constant</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>C4</td>
</tr>
</tbody>
</table>

**Constant** specifies that all step recorded notes are entered with a specified value. To change the Constant velocity, highlight the field and use the mouse or keyboard to change the value.

**As Played (Velocity)**

<table>
<thead>
<tr>
<th>Velocity</th>
<th>As Played</th>
</tr>
</thead>
</table>

**As Played** step records velocities as you actually play them on your MIDI controller. This method ensures more natural sounding velocities than with Constant.
CHAPTER 37: The Faders Window

ABOUT FADERS

Vision supports up to 800 faders that are divided into two categories:

- Faders 1-32 are controlled from the Faders Window, as shown in Figure 37.1.
- The sixteen Console Windows, each represented as a mixing board, control the other 768 faders.

NOTE: Each Console Window can contain up to 24 channels, and each channel contains 2 faders. The fader that appears to be a pan control is, in fact, fully assignable, as is the main fader.

Each fader can be set to send any MIDI controller (except pitch bend and after-touch) or volume or pan for any audio Instrument, Bus, Input, or Output. Each fader can be controlled directly with the mouse or by an external MIDI controller. Faders can also be grouped and controlled from the same external MIDI controller. One fader can control tempo.

When a fader’s movements are recorded and its window is open, the results are audibly and visually represented during playback. These movements are recorded as automation events in the record-enabled track. These events can be viewed and edited in either the List Window (see page 261) or the Strip Chart (see page 241). Specific events can be selected for editing or remapping using the Select & Modify Window (see page 119).

Vision handles automation events identically whether they originate from the Faders or Console Windows. Although this chapter discusses the Faders Window, feel free to consult Chapter 38: The Console Windows and the Automation chapter of your Audio Reference Manual to correlate ideas between these related features.
THE FADERS WINDOW

The Faders Window can be displayed in a single column consisting of 16 faders, beginning with either Fader 1 or Fader 17; or in two columns, showing all 32 faders. This display option is controlled in the bottom right of the window.

To the left of the display options, at the bottom of the Faders Window, is a toggle that controls what the window displays:

- **Send**: The controllers the faders are sending data to
  - or
- **Rcv**: The external controllers the faders are controlled from

Fader Values

The field to the right of the fader name (F1, F2 etc.) shows the numerical value for that fader. Clicking and dragging up or down in the fader value numerical allows the value to be precisely set. Values may also be typed in from the computer keyboard. The range of values is 0-127.

Although Console faders assigned to certain parameters may have different value ranges, faders in the Faders window will always have a range of 0-127. These values are automatically remapped to appropriate values when recording, and vice versa. For example, if you set the **Maximum Fader Position** value to +6 dB, record a fade from 127 to 0 on a fader assigned to Audio Volume, and then view those events in the List window, the values for the events will be between +6 dB and -∞. Playing those events (with +6 dB to -∞ values) will still result in the fader numerical displaying values between 0 and 127.

Fader Sliders

The fader’s slider may be dragged to change the value in the numerical field. Faders that are controlled by external devices move automatically in response to their assigned controller. Dragging the slider sets the fader to even-numbered values (and 127).

If the **Fader Slots in Instrument Color** option is checked in the Settings Window, the fader slots are displayed in the color of the assigned Send Instrument.

Instrument, Device, Channel Number and Controller

When the Faders Window is showing the Send settings, the Instrument and Controller pop-ups determine where the fader sends its data.

When the Receive settings are shown, the Device, Channel and Controller pop-ups determine the source of the fader’s control.

Tempo Fader Assign

One fader can be set to control the tempo. See **Using a Fader to Record Tempo Changes (pg. 138)** for more information.
**Tempo Fader Range**

These numericals determine the range available to the Tempo fader.

**Send/Receive Settings Display**

Clicking this field toggles the Faders Window display between the **Send** and **Rcv** settings.

**Send Settings**

Each fader can be used to send an automation event to a selected Instrument, Bus, Input, or Output:

1. **Set the Send/Receive toggle to Send.**
2. **Activate the desired fader by clicking on its selector dot.**
   The selector dot changes into a hollow triangle.
3. **Select an Instrument, Input, Output, or Bus from the Instrument pop-up menu.**
4. **Select a controller from the Controller pop-up menu.**
   Volume (7) is the default that is initially displayed. Pitch bend and aftertouch are not available.
   If an Audio Instrument, Input, Output, or Bus is selected, the only available send destinations are Volume and Pan. Clicking on the setting alternates between the two options.

Whenever the fader is moved, the assigned automation events are sent to the selected Instrument. Moving a fader while recording causes Vision to record the automation events for the record-enabled track.

One fader can control the volume of several MIDI channels by setting up an Instrument with several layers, each layer set to one of the desired MIDI channels, and then selecting that Instrument to receive the fader’s volume information.

**Receive Settings**

To control a fader using an external MIDI controller such as a modulation wheel, MIDI fader unit, or continuous pedal:

1. **Select Fader Remotes Enabled from the menu in the Faders Window.**
   This allows the information from remote MIDI controllers to reach the faders.
2. **Set the Send/Receive toggle to Rcv.**
3. **Enable the fader by clicking its selector dot.**
   The device, channel and controller number are displayed that currently provide external control for that fader.
4. **Each numerical can be individually set using any of Vision’s standard procedures.**
   An easier method is to click on each field and then move the external MIDI controller that controls that fader. The information is automatically transmitted to the selected field.
This process results in the external MIDI controller moving the fader to which it is assigned. The fader, in turn, sends the automation information assigned in the Send mode to the assigned Instrument, Input, Output, or Bus. Multiple faders can be controlled from a single external MIDI controller.

**Fader Display Mode**

Three different display modes are available for the Faders Window by clicking the 1, 17 or 32 fields in the bottom right corner of the window:

- **1**: The Faders Window consists of 16 faders in one column beginning with Fader 1.
- **17**: The Faders Window consists of 16 faders in one column beginning with Fader 17.
- **32**: The Faders Window consists of 32 faders in two columns beginning with Fader 1.

**FADER FUNCTIONS**

**Using Faders to Remap MIDI Controllers**

Faders can remap a MIDI controller’s function by selecting one controller type to control the fader (with the Rcv setting) while assigning a different controller type to be sent by the fader (with the Send setting).

**Using Faders to Control Instrument Velocities**

Most MIDI synthesizers respond to MIDI Volume (control #7) but certain older synthesizers do not. Vision allows a pseudo-volume mix by using faders to control Instrument velocities instead of volume. Since velocity normally corresponds to note amplitude on most synthesizers, varying a note’s velocity is similar to varying channel volume.

**NOTE**: Although velocity usually corresponds to note volume, it may also affect the timbral aspects of the sound as well. Check the synthesizer manual for details.

Each Instrument layer can modify the velocities of the notes it plays. Two columns in the Instruments Window control this action:

- **Velocity Scale Checkbox**: Any of Vision’s 800 faders can be assigned to control Velocity Scale for any instrument. This checkbox enables the instrument to respond to Velocity Scale messages. Unchecking this box will cause the instrument to ignore Velocity Scale information assigned to it.
- **Velocity Scale %**: The amount can range from 1% to 250%.

At the fader’s maximum level (127), the velocity output is the recorded velocity multiplied by the scaling factor. These settings affect all note velocities played by that Instrument layer.
CHAPTER 37: The Faders Window

For example, if a note is recorded at a velocity level of 64 and the Velocity Fade Amount is set to 50% then a fader level of 127 equals a velocity of 32 (50% of 64).

Moving the fader while the sequence is playing changes the velocity of notes assigned to that Instrument. Fader movements can now be recorded and used as pseudo-volume controllers for MIDI devices that don’t respond to Volume (control #7).

For more details, please see Velocity Scale (pg. 297).

Copying Fader Settings

When the Fader Window is active, choosing Edit>Copy Faders places an automation event for each defined fader’s current value onto the Clipboard. The fader events can then be pasted into a track, creating a “snapshot” of the current fader values.

This is particularly useful for creating a mix at the beginning of a sequence. To ensure that your sequence begins with the correct mix, it is a good idea to place a fader snapshot at the beginning of the sequence. This process is very important, but it is often overlooked.

For example, you might use volume faders to create a “fade out” at the end of a song, with each instrument’s volume setting ending at 0. The first time the sequence is played, it sounds correct. After the sequence ends, you press play again, but can’t hear anything. If you let the sequence play long enough, you’ll hear only the fade out.

This happens because, at the end of the song, each instrument receives a volume setting of 0. If there’s no volume data at the beginning of the sequence, the instrument doesn’t know to change its volume until the first volume event of the fade out. Creating a set of initial volume settings (a “snapshot” of the Console and Faders windows) will alleviate this problem.

Copy Faders now automatically inserts Mute and Solo automation events for MIDI Instruments in addition to any other MIDI controller events that are assigned in the Faders or Console windows.

For more information about the Copy Faders command, please see Saving a Mixer Snapshot (pg. 89).

CHANGES IN THE WAY VISION HANDLES FADE

Removal of “fader events”

In previous versions of Vision, faders were a type of interface between you and your MIDI controller data.
PART 6: Windows

Figure 37.2: The old way

Faders still act as an interface, but now they generate data directly. Instead of creating a fader event assigned to another parameter (such as a controller), faders now create controller (or automation) events.

Faders still act as an interface, but now they generate data directly. Instead of creating a fader event assigned to another parameter (such as a controller), faders now create controller (or automation) events.

Figure 37.3: The new way

In short, we’ve “eliminated the middle-man” by completely removing “fader events”.

Visual and Audible Effect

In most cases, the visual and audible effects of recorded fader movements will not change. In fact, faders themselves have become much more flexible. For example:

1. Open the Faders window and assign the first fader to control pan for a MIDI instrument.
   This example uses JD-800-1.

2. Record enable a track.

3. Press the Record button.

4. Click on the fader and drag it back and forth to record pan information.

5. Press the Stop button and open the List window.
   You can see the pan events in the list window.
CHAPTER 37: The Faders Window

Notice that these are not fader events assigned to pan; they are pan events.

6 Press Play
Watch the first fader move just as you recorded it.

7 Disable the first fader by clicking on its selector dot.

8 Enable a different fader and set it to JD-800-1 Pan.

9 Press Play.
Now the new fader moves to the recorded pan events.

You could also assign a Console channel to JD-800-1 and the pan fader in that console would move in unison as well.

Notes About Audio Volume and Pan
As in previous versions of Vision, audio volume and pan can be displayed in the Faders window and controlled by its sliders.

Audio pan now has a range of -100.00 to 100.00, and audio volume now has a range of \(-\infty\) to the Maximum Fader Position (as set in the Audio Preferences dialog box). However, displayed fader values in the Faders window are still 0-127.

These values are mapped to the appropriate range of values (for the selected parameter). In the case of audio pan, 0 corresponds to -100.00 (left) and 127 corresponds to 100.00 (right). For audio volume, 0 corresponds to \(-\infty\) and 127 corresponds to the Maximum Fader Position.

If you wish to see the correct numeric values for these parameters, use the Consoles rather than the Faders window.

For more information, see your Audio Reference Manual.

Changes in Copy Faders
The Copy Faders command is most often used to create a “snapshot” of fader values for several different instruments.
Since fader values are now mapped directly to controller values (as described on page 347) which are in turn assigned to instruments, pasting the information gathered during Copy Faders into a track will now result in a multi track.

The track’s instrument is now set to multi, and automation events have been inserted for each instrument’s faders and mute and solo buttons.

If desired, you can use the Separate Multi Track command to put each instrument’s events onto separate tracks. See page 49 for details.

Copy Faders and Audio Channels

When using the Copy Faders command with audio channels defined in the Console, you may end up with more data than you were expecting. For instance, EQ Enable, EQ Band Enable and EQ Band Parameters, Plug-in Bypass, and Send Levels are some of the event types that can be copied. See your Audio Reference Manual for more information about Copy Faders and audio channels.
CHAPTER 38: The Console Windows

Vision offers sixteen separate Console Windows, each of which contains 24 channels. Console Windows can be configured as desired to perform a number of different functions:

- Record dynamic MIDI and Audio Instrument mixes (or create static mix “snapshots”);
- Create real-time controllers for important synthesizer and effects parameters, and record those parameter changes as part of the sequence;
- Assign EQs and VST plug-ins to Audio Instruments, busses, inputs, and outputs and edit them (in Acadia audio mode). See your Audio Reference Manual for details.
- Assign TDM plug-ins to Audio Instruments and edit them (only if you own Studio Vision Pro and a Digidesign TDM-equipped digital audio system). See your Audio Reference Manual for details.

Like the Faders Window, the Console Windows control Vision’s automation events. The Faders Window is discussed in the previous chapter and automation events are discussed in the Automation chapter of your Audio Reference Manual.

In the current version of Vision, each fader directly controls an automation parameter, such as volume, pan, velocity scale, or any MIDI controller.

Vision can automate up to 800 different faders—each assigned to a different Instrument, channel, or MIDI control. Faders 1-32 are controlled from the Faders Window. The others are controlled from the Console Windows.

OPENING A CONSOLE WINDOW

To open a Console Window:

1. Press and hold the mouse over the Windows>Console command. Vision produces a submenu of console choices.

ABOUT CONSOLES

Console Windows are similar to the Faders Window, but offer more control. You should understand the Faders Window before using Consoles.
Select one of the sixteen consoles from the submenu.
Vision opens that Console Window.

Vision offers numerous display choices for each console, including:
- Channel width (narrow or wide)
- Fader assignment displays
- Remote devices display
- Masking Tape display

Figure 37.4 shows a console with all display options disabled. It contains three major elements:

1. **Console Name**
   This area always displays the name of your console (as assigned in the Console Window Menu).

2. **Console Window Menu**
   Use this pop-up menu to set numerous display options, as discussed in The Console Window Menu (pg. 355).

3. **Individual Console Channels**
   The Console Window contains one vertical strip for each console channel. The next section details the elements in a channel.

**The Basic Console Channel**

As you can see in Figure 37.5, a basic console channel contains the following elements:

1. **Channel Number**
   Displays the number for each console channel. This area is highlighted for the channel that contains the active control.
CHAPTER 38: The Console Windows

2 Instrument Selector
Use this pop-up menu to select the Instrument that’s controlled by this channel. Faders can control either MIDI Instruments, Audio Instruments, Buses, Inputs, or Outputs.

3 Volume Fader
By default, this fader controls volume (MIDI control #7), but you can reassign it to any MIDI control number as discussed in Show Selected Fader Info (pg. 357) or Show All Fader Info (pg. 359).

The active fader always appears highlighted.

TIP: You don’t have to drag faders to change them—simply click where you want the fader to be and it jumps to the new value immediately.

NOTE: If the fader is assigned to an Audio Instrument, it can only control the audio’s volume.

NOTE: If the Fader Slots in Instrument Color option is checked in the Settings Window, the fader slots are displayed in the color of the assigned Send Instrument.

4 Volume Thumb
Click and drag the Volume Thumb to adjust the fader value. Each thumb is color-coded as follows:
MIDI channels are teal.
Audio channels are blue.
Busses are pink.
Inputs are purple.
Outputs are red.

TDM SampleCell inputs are orange.

NOTE: The Bus, Input, and Output colors are only applicable to Acadia users or Studio Vision Pro users with TDM-compatible hardware. SampleCell colors are only available to Studio Vision Pro users with SampleCell TDM. ReWire channels are available only to Acadia users with ReWire compatible soft synths. For more information, see your Audio Reference Manual.

Click here...
...and the fader jumps to that value.
Volume Fader Value
Displays the numerical value set by the Volume Fader. You can change this numerical directly and the Volume Fader will move to reflect the new value.
Any time you reassign a channel to a different Instrument (either manually or with one of the Build Console From commands), the faders change to display the current fader value of the new Instrument.
Audio volumes are now displayed in decibels. The value can range from negative infinity to the Maximum Fader Position setting (see your Audio Reference Manual for details).
If you reassign a channel to a MIDI Instrument that does not currently have a volume value, Vision sets the fader level to 127. If you reassign a channel to an Audio Instrument that does not currently have a volume value, Vision sets the fader level to 0 dB.

Volume LEDs
Displays MIDI or audio volume levels graphically.
If your audio hardware does not support output level metering, then the channel hides the level LEDs.

Clipping Indicator
In Acadia audio mode, this indicator works only with audio Outputs—it indicates a clipped digital audio signal. In Acadia mode, Audio Instruments, Busses, and Inputs never clip. This is because Acadia uses floating point in its computations, and with floating point there is practically no limit to the dynamic range for these audio signals.
In all other modes, this indicator works only with Audio Instruments; it indicates a clipped digital audio signal.

Pan Fader
By default, this fader controls pan (MIDI control #10), but you can reassign it to any MIDI control number when working with MIDI Instruments. This fader can only control pan when working with Audio Instruments, Busses, Inputs, and Outputs.

Pan Fader Value
Displays the numerical value set by the Pan Fader. You can change this numerical directly and the Pan Fader will move to reflect the new value.
For MIDI Instruments, this value can range from <64 (left) to 63>(right).
For Audio Instruments, Busses, Inputs, and Outputs, this value can range from -100.00 to 100.00.

Mute Button
Click this button to mute playback of the Instrument, Bus, Input, or Output controlled by this channel.
**Solo Button**

Click this button to solo playback of the Instrument, Bus, Input, or Output controlled by this channel. Soloing a channel automatically mutes playback of any non-soloed channels.

Soloing an audio bus automatically results in all pre sends routed to that bus being heard (post sends are muted).

**CREATING A CONSOLE “SNAPSHOT”**

You can use the Copy Faders command to create a snapshot of fader values (including all Console faders). This is particularly useful for setting the mix at the beginning of a sequence.

For information about Copy Faders, see Copying Fader Settings (pg. 347) and Saving a Mixer Snapshot (pg. 89).

---

**THE CONSOLE WINDOW MENU**

<table>
<thead>
<tr>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Channel Width</td>
</tr>
<tr>
<td>Audio Sends</td>
</tr>
<tr>
<td>Plug-Ins</td>
</tr>
<tr>
<td>EQs</td>
</tr>
<tr>
<td>Show Selected Fader Info</td>
</tr>
<tr>
<td>Show All Fader Info</td>
</tr>
<tr>
<td>Show Remote Devices</td>
</tr>
<tr>
<td>Show Masking Tape</td>
</tr>
<tr>
<td>Fader Remotes Enabled</td>
</tr>
<tr>
<td>Master Instrument</td>
</tr>
<tr>
<td>Console Name...</td>
</tr>
<tr>
<td>Build Console From</td>
</tr>
<tr>
<td>Clear Console...</td>
</tr>
<tr>
<td>Save Console Layout</td>
</tr>
<tr>
<td>Save Console Layout As...</td>
</tr>
<tr>
<td>Load Console Layout...</td>
</tr>
</tbody>
</table>

Figure 37.6: The Console Window Menu

The following sections discuss each item in the Console Window Menu:

**Channel Width**

Use the Channel Width command to specify one of two channel widths:

- Narrow
- Wide

The following sections discuss these two options in detail.
PART 6: Windows

Narrow
Select this option to reduce the display width of each console channel.

Figure 37.7: Channel Width set to Narrow

This option has pros & cons:

PRO: You can view more channels at a time on your computer screen.

CON: You lose some channel display capabilities. Specifically, if you select the Narrow option, channels won’t display:
  • Volume bargraph (LED’s)
  • Optional detailed channel information (such as Pan Fader Info, Fader Control selectors, and Remote Devices). These options are described later in this chapter.

Additionally, Instrument names in the Instrument Selector pop-up menu contain very few characters.

Wide
Select this option to display each console channel at its maximum width.

Figure 37.8: Channel Width set to Wide

This option has pros & cons:

PRO: You can view all of the detailed information for each channel in the console.

CON: Each channel, since it’s wider, requires more screen space. Therefore, your computer screen can display fewer console channels at one time.

Audio Sends
The Audio Sends menu item (disabled for unsupported audio systems) allows you to create advanced routings using Acadia or Digidesign’s DAE with TDM-equipped hardware. This feature is discussed in your Audio Reference Manual.
Plug-Ins

The **Plug-Ins** menu item (disabled for unsupported audio systems) lets you apply VST or TDM plug-ins. This menu item is enabled only if you:

- are in Acadia mode
- own Studio Vision Pro and are using it to control TDM-equipped Digidesign audio hardware.

See your Audio Reference Manual for details.

EQs

The **EQs** menu item (disabled for unsupported audio systems) lets you apply Vision’s realtime EQs to audio channels. This menu item is enabled only when you are in Acadia audio mode. This feature is discussed in your Audio Reference Manual.

Show Selected Fader Info

Select this option if you want the top of the Console Window to display detailed information about the selected (highlighted) fader.

You can turn this option on and off by selecting it repeatedly—when the option is checked, it’s enabled and the fader info appears at the top of the Console Window. When the option is unchecked, it’s disabled and the fader info does not appear at the top of the Console Window.
Figure 37.10 illustrates the different elements displayed by the **Show Selected Fader Info** option.

**Figure 37.10: Anatomy of the Selected Fader Info Area**

These are:

1. **Instrument Selector**
   - This is the same as the Instrument Selector pop-up menu in the channel, but is wide enough to show the full Instrument name.

2. **MIDI Control Selector**
   - Use this pop-up menu to assign a MIDI control number to the selected fader. It's the same as the MIDI Control Selector displayed in each channel when **Show All Fader Info** is enabled as discussed in Show All Fader Info (pg. 359).
   
   **IMPORTANT:** If the fader is assigned to an Audio Instrument, it can only control the audio’s volume or pan.

3. **Fader Value**
   - This numerical displays the current value of the selected fader.

4. **Remote Device Selector**
   - Use this pop-up menu to assign an external MIDI device to control the selected fader. This is particularly useful if you own a MIDI fader unit and wish to use it to control Vision’s faders.

5. **Remote Device Channel**
   - Use this numerical to designate which MIDI channel is used by the Remote Device.

6. **Remote Controller Selector**
   - Use this pop-up menu to select which MIDI controller on the external device will control the selected fader.

**NOTE:** Remote control of faders will not work until you check the **Fader Remotes Enabled** option in the Console Window Menu (or the Setups menu) as discussed on page 362.
Show All Fader Info

Select this option if you want Vision to display detailed instrument and MIDI controller assignments for each fader in each channel.

You can turn this option on and off by selecting it repeatedly — when the option is checked, it's enabled and all fader information appears in each channel. When the option is unchecked, it's disabled and the fader information does not appear in the channel.

NOTE: There is not enough room to show all fader information if the console's Channel Width is set to Narrow. Therefore, the option is disabled when narrow channels are displayed.

Figure 37.11: Wide Console with Show All Fader Info enabled

Figure 37.12: Anatomy of a console channel with Show All Fader Info selected

These are:

1. Pan Instrument Selector
   Use this pop-up menu to select the Instrument that's controlled by the pan fader in this channel. Faders can control either MIDI Instruments or Audio Instruments.

2. Pan MIDI Control Selector
   Use this pop-up menu to assign a MIDI control number to the pan fader for this channel.
   IMPORTANT: If the fader is assigned to an Audio Instrument, it can only control the audio's volume or pan.

3. Volume MIDI Control Selector
   Use this pop-up menu to assign a MIDI control number to the volume fader for this channel.
   IMPORTANT: If the fader is assigned to an Audio Instrument, it can only control the audio's volume or pan.
Show Remote Devices

Select this option if you want Vision to display the remote control assignments for the volume fader in each channel.

IMPORTANT: If you want to see remote device assignments for the pan faders, you’ll need to check the Show Selected Fader Info option as discussed in Show Selected Fader Info (pg. 357).

NOTE: Remote control of faders will not work until you check the Fader Remotes Enabled option in the Console Window Menu as discussed in Fader Remotes Enabled (pg. 362).

You can turn this option on and off by selecting it repeatedly—when the option is checked, it’s enabled and the remote devices appear in each channel. When the option is unchecked, it’s disabled and the remote devices do not appear in the channel.

NOTE: There is not enough room to show remote devices if the console’s Channel Width is set to Narrow. Therefore, the option is disabled when narrow channels are displayed.

Figure 37.14 illustrates the elements that are added to a single channel when you enable this option.

Figure 37.13: Wide console with Show Remote Devices enabled

Figure 37.14: Anatomy of a console channel with Show Remote Devices enabled
These are:

1. **Remote Device Selector**
   Use this pop-up menu to assign an external MIDI device to control the volume fader.

2. **Remote Device Channel**
   Use this numerical to designate which MIDI channel transmits the remote data.

3. **Remote Controller Selector**
   Use this pop-up menu to select which MIDI controller on the external device will control the volume fader.

**Show Masking Tape**

This option adds a blank “masking tape” region to the bottom of each console channel. The Masking Tape area can be used to label each channel. After choosing **Show Masking Tape** from the Console Window Menu, simply click in the Masking Tape area and type in the name you want to display (see Figure 37.15, below).

You can type anything you wish into this field; Masking Tape doesn't necessarily correspond to the name of a specific track. For example, even though you may use the same Instrument for several tracks, this Instrument has only one Console channel. In this case, you could label the Console channel “Synths” to refer to all of the tracks that it controls.

**Naming an Instrument vs. using Masking Tape**

Many users find that they wish for a quick way to add names to a console's channels. Vision’s consoles are designed to mimic a physical mixing console, so the Masking Tape region was added to give users more flexibility. You can use it to quickly label your console channels.

Vision also has the capability to rename Instruments (MIDI and Audio), Busses, Inputs, and Outputs. For instructions, please see Instrument Names (pg. 294). Renaming an instrument is actually a more thorough labeling method. The instrument's name appears throughout the program, including the Thru Instrument popup, all edit windows (including the Tracks window), and the Record Monitor, but the Masking Tape field only appears in the console.

In general, it's best to use Masking Tape as a “scratch pad” while you’re working on the fly and then rename your instruments when you're ready for serious editing.
Fader Remotes Enabled

Select this option if you want to remotely control Vision’s software faders with hardware MIDI controllers.

TIP: Fader remotes are particularly useful if you own a MIDI fader unit. You can assign each hardware fader to remotely control one of Vision’s software faders.

You can assign a different MIDI device, channel, and controller number to each fader in each console channel. For more information, see Show Selected Fader Info (pg. 357) and Show All Fader Info (pg. 359). This command is also in the Setups menu.

Master Instrument

Use this option to determine how faders are assigned in each channel. Specifically:

- **Enabled** (checked)
  - If the Master Instrument option is enabled (checked), Vision assigns both faders in a channel to the same Instrument.
  - This is the default console because, in most instances, you’ll use the vertical fader to control volume and the horizontal fader to control the same Instrument’s pan.

- **Disabled** (unchecked)
  - If the Master Instrument option is disabled (unchecked), Vision lets you assign each fader in a channel to a different Instrument.

For example, look at Figure 37.16. Console channels 1-4 control the volume and pan of K2000 MIDI channels 1-4.
Figure 37.17: Master Instrument mode disabled

For example, look at Figure 37.17. Console channels 1-4 use their 8 faders to control the volume on 8 K2000 MIDI channels.

**Console Name**

Use this command to rename the active console. To do so:

1. **Choose Console Name.**
   Vision opens a renaming dialog box.

   ![Screenshot of the naming dialog box](image)

   **Change the Console name to:**

   Console 1

   ![OK and Cancel buttons](image)

2. **Type a new name.**
3. **Click the OK button.**
   Vision renames the console.

**Build Console From**

Select the **Build Console From** command to produce a submenu of building options.

![Build Console From menu](image)

**Figure 37.18: Build Console From submenu**

Vision gives you the following options, each of which automates the console-building process:

- Selected Tracks` Instruments
- All Instruments In Use
- MIDI Instruments In Use
- Audio Instruments In Use
- Audio Instruments
- Enabled ReWire Channels

There are, however, several important points to consider when you ask Vision to build a console for you:

- When Vision builds a console, Vision automatically enables **Master Instruments** mode, ensuring that the two faders in each channel control the volume and pan of the same Instrument.
- When Vision builds a console, it “wipes out” any fader assignments you may have already made in that console. Should you wish to keep the console assignments you’ve already made, you should choose the appropriate option from the menu and then use the command to rename the console.
The following sections discuss in detail each option for building consoles.

**Selected Tracks’ Instruments**

Choose this option if you want Vision to automatically build a console using the Instruments in all the selected tracks:

1. In the Tracks Window, select those tracks you want to use to build a console.

2. Open a new Console Window and choose **Build Console From>Selected Tracks’ Instruments** from the Console Window Menu.

Vision creates a console that contains channels assigned to the Instruments in the selected tracks.

Notice that the console contains fader assignments for the four Instruments used by the selected tracks.

**Build Console From All Instruments In Use**

If you choose this command, Vision creates one or more consoles containing every Instrument (Audio and MIDI) used in every sequence in the entire Vision file. It first assigns all the MIDI Instruments to console channels. It then assigns all the Audio Instruments to console channels.

**NOTE:** This option creates console channels for both MIDI Instruments and Audio Instruments.
Build Console From MIDI Instruments In Use

If you choose this command, Vision creates one or more consoles containing every MIDI Instrument used in every sequence in the entire Vision file. It ignores all Audio Instruments in the build.

Build Console From Audio Instruments In Use

If you choose this command, Vision creates one or more consoles containing every Audio Instrument used in every sequence in the entire Vision file. It ignores all MIDI Instruments in the build.

Build Console From Audio Instruments

If you choose this command, Vision automatically builds one or more consoles containing all of Vision’s Audio Instruments (whether they’re used in a Vision sequence or not).

Build Console From Enabled Rewire Channels

If you choose this command, Vision automatically builds one or more consoles containing every enabled ReWire channel. ReWire channels are enabled in the Audio Instruments window. For more information, see your Audio Reference Manual.

Clear Console

Choose this command to clear all Instrument assignments in the Console Window. If one or more audio channels in the Console has plug-in, send, or EQ assignments, you will see the following dialog.

If Clear plug-ins, sends, and EQs as well is checked, all plug-in automation data will be cleared. EQ and send automation data will remain, but it won’t have any direct effect on the sequence unless EQs or sends are reassigned.

Fader values are not cleared.

Save Console Layout

Choose this command to save the information in the Console to a template file. A “Console Layout Templates” folder is created within the Vision folder the first time you choose this (or the Save Console Layout As...) command. Each Console Layout template is stored as a separate file within this folder. When you choose Save Console Layout, one of these files is created in the Console Layout Templates folder. The name of the file is the name of the current Console.
PART 6: Windows

Choosing this option multiple times within the same Console will simply update the previously saved file. However, if you change the name of the Console and then choose **Save Console Layout** again, a new file with the Console's new name will be generated.

The following information is stored in a Console Layout template:

- Console name (stored as the name of the Console Layout Template file);
- Channel width;
- Enabled display options ("Show" options under the Console menu);
- Number of Sends displayed;
- Number of Plug-ins displayed;
- EQ display settings;
- Instrument assignments;
- Remote device assignments;

The following information is not stored in a Console Layout template:

- Fader values;
- Plug-in assignments or parameters;
- Send assignments or parameters;
- EQ parameters;
- Output assignments.

This feature is designed so that loading a Console Layout will NOT delete your current fader values, output assignments, or plug-in, send, and EQ settings. Console layouts affect only the display of the console, not the information that is already saved elsewhere in the sequence.

**Save Console Layout As...**

This option works exactly like **Save Console Layout** except that it gives you an opportunity to name the file you're saving. After choosing **Save Console Layout**, this dialog box appears.

![Save Console Layout As dialog box](image)

Type in a name for the Console Layout template file here. This will not change the name of the current Console. It will name the file within the Console Layout Templates folder.

**Load Console Layout**

Use this option to recall a Console Layout template you've already saved (using the **Save Console Layout** or **Save Console Layout As...** commands). Choosing this command will apply the Console Layout's settings to the current Console.

![Load Console Layout dialog box](image)
Select the Layout you want to load and press Open. The Layout settings stored in the selected Console Layout file are applied to the current console.

Again, loading a Console Layout will NOT delete your current fader values, output assignments, or plug-in, send, and EQ settings. Console layouts effect only the display of the console, not the information that is already saved elsewhere in the sequence.

You may need to navigate (in the Load Console Layout dialog box) to the “Console Layout Templates” folder in your Studio Vision folder in order to see your available Console Layouts.

IMPORTANT NOTE: A Console Layout Template cannot be opened by double-clicking its icon. You must use the Load Console Layout Template command. Double-clicking a Console Layout Template will launch Vision, but it will not open (or load) the template itself.

**FADER GROUPING**

You can select multiple faders and move them as a group. Fader groupings are temporary and disappear once the selection is disabled.

**Selecting Multiple Faders**

You can select multiple faders using one of two methods:

- **contiguous** selection— all faders in a group are physically next to each other in the console.
- **discontiguous** selection— selected faders can be anywhere in the console. They don’t have to be next to each other.

To create a contiguous selection:

1. **Click a fader to select it.**
   Vision highlights the fader to show it’s selected.

2. **Shift-click a second fader some distance from the first.**
   Vision selects the second fader and every fader in between it and the first.

   ![Figure 37.19: Contiguous Selection](image)

   This is a contiguous selection, and is a quick way to select a long block of faders with only two clicks.
To create a discontiguous selection:

1. **Click a fader to select it.**
   Vision highlights the fader to show it's selected.

2. **Command-click a second fader some distance from the first.**
   Vision adds the second fader to the grouping.

   Notice in this example that, unlike Figure 37.19, the middle fader isn’t selected.

3. **Continue to Command-click additional faders until you’ve completed your grouping.**

   **NOTE:** To clear a fader grouping, click in any non-active area of the console.

---

### Moving Faders as a Group

Once you’ve created a group of faders, Vision offers you three different ways in which to move them:

- **Absolute fading**— all grouped faders move the same amount up or down.
- **Proportional fading**— all grouped faders move proportionally, so that they all reach their minimum or maximum positions simultaneously.
- **Snap fading**— all grouped faders move to a single level.

Each of these methods is discussed in the following sections.

#### Absolute Fading

Drag any one fader and all grouped faders move by the same amount. The following example illustrates how to perform absolute fading with a group of faders:

1. **Create a group of faders.**
   This is discussed in Selecting Multiple Faders (pg. 367).

   **Figure 37.21: Three grouped faders**
Drag any fader up or down. All grouped faders move the same amount. In this example, notice that each fader value was reduced by 40.

Continue dragging until the fader "bottoms out." In this example, the dragged fader is the first to reach "0," so no additional decrease can occur in the values of the other faders.

If you dragged that same fader up, it would be the last to reach 127.

Proportional Fading
Option-drag any one fader and all grouped faders move proportionally, so that they all reach the bottom (or top) of their fade simultaneously. The following example illustrates how to perform proportional fading with a group of faders:

Create a group of faders.
This is discussed in Selecting Multiple Faders (pg. 367).
FIGURE 37.22: Three grouped faders

**2** Option-drag any fader up or down.
All grouped faders move proportionally.
In this example, notice that the dragged fader was reduced by 40, but that the other two grouped faders were reduced substantially more.

This is because, in proportional fading, all the faders move so that they reach the bottom (or top) of their fade simultaneously.

**3** Continue Option-dragging until the fader “bottoms out.”
With proportional fading, all faders reach their minimum or maximum values simultaneously.

**Snap Fading**
Control-click within any one fader and all grouped faders snap to that value. The following example illustrates how to perform snap fading with a group of faders:

**1** Create a group of faders.
This is discussed in Selecting Multiple Faders (pg. 367).

---

**FIGURE 37.23: Three grouped faders**
REARRANGING CONSOLE STRIPS

Dragging Strips Horizontally

It is now possible to rearrange the order console strips by dragging them horizontally. To do this:

1. **Set up your console.**
   In this example, console strip 1 will be moved. Its volume and pan have been set to make it easily recognizable.

2. **Control-click anywhere along a fader path.**
   All grouped faders snap to that value.

3. **Click and hold on the number at the top of the strip you’d like to move.**
3 Drag the mouse to your destination (where you want the strip to be in the Console).
   In this example, strip 1 will be moved between strips 3 and 4.

4 Release the mouse button.
   Strips 2 and 3 are moved to the left and strip 1 is inserted between strips 3 and 4.

Dragging Plug-Ins Vertically (Acadia only)

Just as Console strips can be dragged horizontally, VST plug-ins can be dragged vertically within a Console strip. This provides a quick and easy way to change the order in which plug-ins affect your audio signal. Plug-ins are always applied to the audio signal in ascending numerical order (1, 2, 3, and then 4).

To vertically drag a plug-in:

1 Click and hold in the Plug-In Type area of the plug-in you wish to move.

Notice that the Console strips are always numbered from left to right. This does not (in any way) change their functionality.
Drag to the plug-in's desired location.
In this example we're moving the third plug-in so that it will be first.

Release the mouse.
The plug-ins are rearranged.

NOTE: It is not possible to drag plug-ins to incompatible locations. For example, you cannot drag a mono plug-in to occur after a stereo plug-in or a mono in/stereo out plug-in. For more information about mono and stereo plug-ins and audio plug-ins in general, see your Audio Reference Manual.

It is not possible to rearrange TDM plug-ins by dragging.
CHAPTER 39: The MMC Window

Use the MMC Window to control devices compatible with MIDI Machine Control, such as hard disk recorders and digital multitracks.

In this chapter you will learn:
• how to set up your MMC devices
• the anatomy of the MMC Window
• how to control an external MMC device using Vision

SETTING UP YOUR MMC DEVICES

Before you begin using Vision with MMC devices, you must:
• Connect your MIDI Machine Controlled hardware to your MIDI interface as specified by the manufacturer’s documentation.
• Add the MMC device to your OMS Studio Setup document—make sure it is set to send and receive MIDI Time Code and MMC.

IMPORTANT: Also make sure the Device ID in OMS Setup matches the Device ID of your MMC device.

Once your MMC devices are connected to your MIDI interface and defined in your OMS Studio Setup document, you can control them from Vision’s MMC Window (discussed in the following section).

ANATOMY OF THE MMC WINDOW

To open the MMC Window:

1 In Vision, choose Windows>MMC.
Vision opens the MMC Window.

In general, you’ll use the MMC Window to control the transport and recording functions of an external MMC device from within Vision.
Figure 38.1 shows the basic elements contained in a typical MMC Window. These are:

1. **Transport Controls**
   Use these buttons to remotely control the start, stop, play, rewind, and fast-forward controls on your external MMC device. For more information, see Transport Controls (pg. 376).

2. **MMC Device Information**
   Use these various parameters to further define your MMC device, to set its communication options, and to record-enable various tracks. For more information, see MMC Device Information (pg. 377).

3. **Preroll Time**
   Use this numerical to enter the amount of preroll time required by your external MMC hardware. For more information, see PreRoll Time (pg. 378).

4. **Record Mode**
   Use this pop-up menu to select how your MMC device(s) will respond to Vision’s MMC recording controls. For more information, see Record Mode (pg. 379).

5. **MMC Window Menu**
   Use this pop-up menu to reset your MIDI Machine Control parameters. For more informations, see MMC Window Menu (pg. 380).

The following sections discuss each of these areas in detail.

**Transport Controls**

Use the transport controls to remotely control the operation of your MMC device.

![Transport Controls](image)

**Figure 38.2: Transport Controls**

The MMC device transport controls include the buttons described in the following sections.

**Stop Button**

Click this button to stop the transport on your MMC device.

**Play Button**

Click this button to make your MMC device start playing from its current location.

**Record Button**

Click this button to put your MMC device into Record mode (if the device is a recorder and has a record-enabled track).
CHAPTER 39: The MMC Window

Fast Forward Button
Click this button to start fast forwarding your M M C device.

Rewind Button
Click this button to start rewinding your M M C device.

MMC Device Information
This section displays an information line for each M M C device you use (as defined in your current O M S Studio Setup document).

Device Name
This is the name of your M M C device(s) as entered in your O M S Studio Setup document. You'll see a separate entry for every M M C device in your studio. This example contains two M M C devices, named “M M C Device #1” and “M M C Device #2.”

Device Options
Use this pop-up menu to select various M M C device options, as shown below:

- **Test Device**: Select this command to test communication with your M M C device and to check its status. This command works only if you use “Closed Loop communications” (as set in the M M C Communications Setup, discussed below).

- **MMC Communications Setup**: Select this command to open the M M C Communications Setup dialog box for an M M C Device.

Device Options
Track Enable buttons

MMC Device Information includes the areas discussed in the following sections.

Figure 38.3: MMC Device Information

Figure 38.4: MMC Device Options

The Device Options pop-up has the following three options:

- **Test Device**: Select this command to test communication with your M M C device and to check its status. This command works only if you use “Closed Loop communications” (as set in the M M C Communications Setup, discussed below).

- **MMC Communications Setup**: Select this command to open the M M C Communications Setup dialog box for an M M C Device.

Figure 38.5: MMC Communications Setup
The various communication options are described within the dialog box, itself.

NOTE: If your Studio Setup document contains more than one MMC device, use the “Suppress MMC Transport Commands” option to disable any devices that you don’t want to respond to MMC messages.

• Reset Debug Logs: Select this command to save the communications test log as a text file.

Number of Tracks

Set this numerical to the number of tracks contained in your MMC device. For example, if your MMC device is a 16-track tape recorder, set this numerical to “16”.

Track Enable Buttons

Click one or more of these buttons to record-enable the corresponding track on your MMC device.

The number of Track Enable buttons displayed for each MMC device is determined by the Number of Tracks numerical. For example, if you set that numerical to “16”, then you would see 16 Track Enable buttons, as shown in Figure 38.6.

PreRoll Time

Different devices take different amounts of time to shuttle back and forth to various locations. Use the PreRoll numerical to set the amount of time your device needs to locate to an edit point.

For example:

• The original Alesis ADAT requires 5 - 10 seconds to locate to a point on the tape. Therefore, you should set a PreRoll time of between 5 and 10 seconds.

• A Tascam DA-88 requires about 5 seconds to locate to a point on the tape, so set a PreRoll time of 5 seconds.

• Most hard disk recorders (like the Akai DR-8) don’t require any PreRoll time since they use random access playback and recording and don’t require fast-forwarding or rewinding of tape.
The **PreRoll** time works in conjunction with Vision’s Begin Record mode. Specifically:

- If Vision is in **Wait for Note** mode, it will actually count off for the amount of time specified in the **PreRoll** numerical.
- If Vision is in **Countoff** mode and if the **PreRoll** time exceeds the amount of time required by that countoff, then your MMC device begins to play after the period specified by the **PreRoll** time.
- If Vision is in **Countoff** mode and if the **PreRoll** time is less than or equal to the amount of time required by that countoff, then your MMC device begins to play after Vision’s countoff is complete.

**PreRoll Caveats**

Keep the following points in mind when using **PreRoll**:

- In the Sync Options dialog box, you must set the **Receive Sync** mode to **MTC/Machine Control** in order for the **PreRoll** time to have any affect. Also, you must select your MMC device from the Receive Sync selector.

- If your MMC device uses tape, make sure to create about a minute of blank leader so that your first song has enough PreRoll time ahead of it.

**Record Mode**

Use this pop-up menu to select the desired MMC record mode.

As you can see in Figure 38.7, there are three different record modes. These are:

**Enabled**

Select this option to completely slave the record operations of your machine to Vision. In this mode:

- your MMC device completely locks to all of Vision’s transport controls—fast forward, rewind, stop, play, and record.
- your MMC device records on any record-enabled tracks. If you use punch points, your MMC device will begin recording at the punch-in point and stop recording at the punch-out point.
Rehearse

This mode works very similarly to **Enabled**, except that the Record button never actually engages at the record points.

This lets you rehearse what you want to record before actually recording it. In this mode:

- your M M C device locks to Vision’s fast forward, rewind, stop, and play transport controls.
- your M M C device will not automatically record on any record-enabled tracks. If you use punch points, your M M C device will shuttle between them as in **Enabled** mode, but will not actually engage the Record button. This lets you rehearse your audio overdub without actually recording it.

Safe

Recording is completely disabled in this mode. Specifically, clicking a Track Enable button in the M M C Window will not put your M M C device into record mode.

MMC Window Menu

To open the M M C Window Menu:

1. **Press and hold the mouse on the little down-pointing arrow to the left of the MMC Window’s Title Bar.**

   ![Figure 38.8: MMC Window Menu](image)

   **Figure 38.8: MMC Window Menu**

   The M M C Window Menu contains only one command:

   - **Reset MMC System**: Choose this command to reset all M M C device parameters to their default conditions, clearing any existing time code messages (which are constantly being sent by VITC devices).
REAL-WORLD EXAMPLE—
TASCAM DA-88

This section provides a step-by-step tutorial for controlling a Tascam DA-88 from Vision.

NOTE: Although this discussion is specific to the DA-88, anyone wishing to use MMC should read through this tutorial and use similar techniques with their own hardware.

First, set up your DA-88:

1. Set dip switch #2 (located on the left side of the DA-88 SY-88 expansion board) to the UP position.
2. Set dip switch #6 to the down position.
   The DA-88 needs to be in “Timecode controlled mode,” and its timecode out must be set to “Absolute.”
3. Check the DA-88’s Device ID number (see your DA-88 manual). Its default value is “1,” which is the value used in this example.
4. After setting the dip switches and the Device ID, turn your DA-88 off, then back on again.
5. Connect the DA-88’s MIDI In and MIDI Out ports to your MIDI interface.

Next, tell OMS Setup about the DA-88:

1. Launch OMS Setup and open your current OMS Studio Setup document.
   
   2. Create a new device in your OMS Studio Setup document for the DA-88, and connect it to your MIDI interface.
   
   See your OMS Manual if you need assistance.

   Your DA-88 MIDI Device Info dialog box should look like the one shown in Figure 38.9.

   ![Device Info for DA-88](image)

   - Enter Device ID here. The DA-88’s default Device ID = 1
   - Check these Sync Boxes as indicated here
   - Disable all MIDI channels since you don’t want to be able to send any MIDI note data to the DA-88

   Figure 38.9: Typical Device Info for DA-88

   The device defined as the DA-88 in OMS should be set to an ID of “0,” which is one less than the actual unit (unfortunately, the ID numbering scheme on the DA-88 is off by one).

   Figure 38.10: Also, make sure to set the device to receive and send both MIDI Time Code and MIDI Machine Control.
Save your Studio Setup document, and make it current.

The concept of a current Studio Setup document is discussed in your OMS Manual.

Then, set up Vision to work with the DA-88:

1. Launch Vision.
2. If you’re creating a new sequence, set its length to 999.
3. Choose Options>Sync Options.
   Vision opens the Sync Options dialog box.
4. Set the Receive Sync Mode to “MTC/Machine Control” and the Receive Sync Device to “Tascam DA-88” (or whatever you name your MMC device).
   This lets Vision’s transport controls operate your DA-88.
5. Select the desired SMPTE format, then click OK to close the Sync Options dialog box.
   The DA-88’s default SMPTE format is “30 fps, non-drop.”
6. Choose Windows>MMC.
   Vision opens the MMC Window.
7. From the Device Options pop-up menu, select MMC Communications Setup.
8. Click the Use Open Loop communications radio button, then click OK.
9. Leave the PreRoll numerical set to 5 seconds.

To test communication, press the Play button in the MMC Window and see if the DA-88 responds.
If not, check your Device ID settings and cables.

10. At the top of the Tracks Window, click the Information Toggle (the little “i”).
    The Tracks Window now displays SMPTE offset information at the top of the window.
11. Set the SMPTE offset to match the DA-88’s.
    See your DA-88 manual to see how to view and set its SMPTE offset.
12. In Vision, press the Play button.
    The DA-88 will locate to the PreRoll or countoff time—as discussed in PreRoll Time (pg. 378)—and start to play. At the same time, Vision will lock to MTC coming from the DA-88.
13. In Vision, press the Stop button.
    This stops both Vision and the DA-88.

Finally, use Vision to control DA-88 recording:

1. In Vision, set a punch-in and punch-out point.
   In this example, we set a punch-in at 4 bars and a punch-out at 8 bars.
2. Choose Windows>MMC and set the Record Mode to Rehearse.
3. In the MMC Window, click a Record Enable button for any track.
   In this example, we record-enabled track 1.
   Note that the DA-88’s record indicator light blinks for track 1.
In Vision's Control Bar, set the Begin Record Mode to Countoff with a countoff time of 3 measures.
This is completely arbitrary. You can use any value you desire.

Press the Tab key.
The DA-88 locates to the PreRoll time or countoff number and starts to play.
Vision counts down and starts to play. When it reaches the punch-in point, its record button turns solid, but the DA-88's record enable light continues to blink. This is because the MMC Window's Record Mode is set to “Rehearse.”

In Vision, press the Stop button.
In the MMC Window, change the record mode to Enabled.

Press the Tab key.
When Vision reaches the punch-in point, the DA-88's record indicator turns solid and stays solid until the punch-out point is reached. This indicates that the DA-88 is recording between the punch-in and punch-out points.
CHAPTER 40: The QuickTime Movie Window

Use the QuickTime Movie Window to open and play QuickTime movies. You can even import the audio and MIDI from the movie into your Vision tracks, edit the imported tracks and add others—once you’re done scoring the movie, export the tracks back into the QuickTime movie.

REFERENCING A QUICKTIME MOVIE

Each Vision file can reference its own QuickTime movie. To establish this reference:

1. Choose File>Open.
   A standard Open dialog box appears.

2. Navigate to the folder containing the desired movie, select the movie, and click Open.
   What happens next depends on what type of data is contained in the QuickTime movie. Specifically:
   1) If the movie contains only video (no audio or MIDI), then Vision automatically opens the movie in the QuickTime Movie Window. Go to step 8.
   2) If the movie contains only audio and/or MIDI (no video), then Vision imports the MIDI and/or audio into a new sequence. This procedure is discussed thoroughly in the Audio Reference Manual.
   3) If the movie contains BOTH Video AND audio (and/or MIDI), you’ll see an alert box asking you what, exactly, to open.

Import causes Vision to import the movie’s audio and/or MIDI tracks into Vision tracks, but does not establish a reference to the movie, nor does it open.
the QuickTime Movie Window. This allows you to further edit and refine the movie’s soundtrack.

View causes Vision to open the movie in the QuickTime Movie Window. The movie’s audio and/or MIDI will play back using the standard QuickTime elements contained in the QuickTime Movie Window.

Import & View causes Vision to import audio and/or MIDI as described above, plus it opens the movie into the QuickTime Movie Window.

If you saw an Import/View alert box, click either Import & View or View.

If you clicked View, go to step 8.
If you clicked Import & View, Vision opens a Save As dialog box.

Look at the bottom of the dialog box to see what format Vision will use to save the imported audio.

If you want to change the format, click the Format button.

Vision opens a subset of the standard Audio Format dialog box.

Definition: When you import audio from a QuickTime movie, you might want to save it in some format other than what was stored with the movie. For example, the QuickTime audio might be an 8-bit AIFF file, but you need to work with 16-bit SDII files in your sequence.

\[\text{Figure 39.3: Audio Format Dialog Box for Imported QuickTime Audio}\]

Define the type of audio file you want to work with, then click OK.


Click Save.

Vision imports the audio from the QuickTime movie, saves it to your hard disk in the selected audio format, and creates a new audio event in your sequence.

Vision opens the selected QuickTime movie in its QuickTime Movie Window and establishes a reference to that movie.
Once you've established a reference to a QuickTime movie, Vision remembers that reference. Whenever you open that Vision file, you need only choose Windows>QuickTime movie to view the movie.

NOTE: If you move a referenced movie to a different folder, Vision is smart enough to find it. However, Vision will lose the reference if you move the movie to a different volume.

To change the QuickTime movie that Vision references, use the Open command to open a different QuickTime movie.

NOTE: Importing Audio and MIDI from a QuickTime movie is discussed further in the Audio Reference Manual.

OPENING THE QUICKTIME MOVIE WINDOW

You can open a QuickTime Movie Window for any Vision file that references a QuickTime movie. To do so:

1. Choose Windows>QuickTime Movie.

A QuickTime Movie Window opens similar to the one shown in Figure 39.4.

NOTE: If the Windows>QuickTime Movie command is disabled, it's because your Vision file does not yet reference a QuickTime movie. To establish a reference, see Referencing a QuickTime Movie (pg. 385).

QUICKTIME MOVIE WINDOW ANATOMY

As seen in Figure 39.4, the basic QuickTime Movie Window contains the following elements:

1. QuickTime Movie Title: This is the name of the QuickTime movie file.

2. QuickTime Movie Window Menu: This menu contains numerous options to control the window's operation and its integration with Vision. For more information, see QuickTime Movie Window Menu (pg. 389).

3. Movie Screen: This is the movie playback area.


PART 6: Windows

4 Standard Movie Controller: This is a standard QuickTime movie controller.

5 SMPTE Offset: This field displays the movie’s SMPTE start time. For example, if you set the Offset to 01:05:10:00, then the movie won’t start playing until Vision’s counter reaches a SMPTE time of 1 hour: 5 minutes: 10 seconds: and 0 frames.

6 SMPTE Counter: This area displays the movie’s absolute SMPTE time (defined below). When the movie is playing, it shows a running SMPTE time stream. When the movie is stopped, it shows the current cursor location.

The SMPTE counter always shows absolute SMPTE time, which includes the SMPTE offset. For example:

IF the offset is set to 01:00:00:00, AND the movie plays for five seconds, THEN the SMPTE counter shows 01:00:00:05.

Figure 39.5: Counter Shows Absolute SMPTE

Offset time + Actual time = Absolute SMPTE time
CHAPTER 40: The QuickTime Movie Window

QUICKTIME MOVIE WINDOW

The following sections discuss the commands included in the QuickTime Movie Window menu.

Lock to Timing

Selecting this option repeatedly will toggle it between checked and unchecked.

- Checked (enabled): The movie plays back in sync with Vision. When Lock to Timing is enabled, Vision transport controls are used to start, stop, locate, or scrub the QuickTime movie.
- Unchecked (disabled): The movie does not respond to Vision’s transport controls, but you can still use the QuickTime Movie Window’s controls to start, stop, fast forward, and rewind through the movie.

Mute QuickTime Audio

Selecting this option repeatedly will toggle it between checked and unchecked.

- Checked (enabled): The audio playback from within the QuickTime Movie Window is muted. This option is checked by default because QuickTime and a Vision sequence might “compete” for the rights to play a movie’s sound.
- Unchecked (disabled): The movie’s audio can play back from the QuickTime Movie Window. This is the best option only if your movie’s soundtrack has not been imported into a Vision sequence.
PART 6: Windows

Show SMPTE Offset

Selecting this option repeatedly will toggle it between checked and unchecked.

- Checked (enabled): Displays a numerical with which you can see or set the movie's SMPTE offset (start time).
- Unchecked (disabled): Hides the SMPTE offset display.

Show SMPTE Counter

Selecting this option repeatedly will toggle it between checked and unchecked.

- Checked (enabled): Displays a SMPTE counter at the bottom of the QuickTime Movie Window.
- Unchecked (disabled): Hides the SMPTE counter.

Figure 39.7: Showing/Hiding SMPTE Offset

Figure 39.8: Showing/Hiding SMPTE Counter
Window Size

Select any of these options to scale the movie's size by the indicated amount.

- **Quarter Size**
- **Half Size**
- **Full Size** (checked)
- **Double Size**
- **Quadruple Size**

![Figure 39.9: Window Size Options](image)

The window can never shrink so much that you can't view your SMPTE times. For example:

**IF** your movie shows either the SMPTE Offset or the SMPTE Counter

**AND** your movie is smaller than the width of either of the time fields

**THEN** Vision shrinks the movie to the selected size, but leaves the window size large enough to display the SMPTE times.

### SETTING SMPTE FRAME RATES FOR MULTIMEDIA MOVIES

If you're scoring for multimedia, your QuickTime movies will probably have a slower frame rate than any of the standard SMPTE frame rates.

Opcode recommends that, if possible, you set Vision's SMPTE frame rate to a whole number multiple of your QuickTime movie's frame rate.

**NOTE:** Set SMPTE frame rates in the new Sync Options dialog box, as described in Sync Options (pg. 433).

For example:

- If your QuickTime movie plays at 10 fps, set Vision to 30 fps (10 fps x 3 = 30 fps).
- If your QuickTime movie plays at 12 fps, set Vision to 24 fps (12 fps x 2 = 24 fps).
- If your QuickTime movie plays at 6 fps, set Vision to either 24 fps (6 fps x 4) or 30 fps (6 fps x 5).

This practice will result in a linear correlation between the SMPTE frame rate and the QuickTime frame rate. For example, if Vision is set to count at 30 fps and your QuickTime movie plays at 10 fps, then the movie advances 1 frame for every 3 frames of SMPTE time (see Figure 39.10).
WORKING WITH SMPTE OFFSETS

If you’re using Vision to control the movie’s playback (that is, Lock to Timing is checked), keep in mind that Vision sequences can have their own SMPTE offsets, which may or may not be the same as the movie’s SMPTE offset.

Specifically:

- **if movie offset = sequence offset**
  When you click Vision’s Play button, both the sequence and the movie start playing simultaneously, from their beginnings.

- **if movie offset > sequence offset**
  When you click Vision’s Play button, the sequence begins to play, but the movie does not. When Vision reaches the time specified by the movie’s offset, the movie begins to play.
• if movie offset < sequence offset
  When you click Vision’s Play button, the sequence begins to play and the movie begins playing from the sequence’s offset point.

**USING THE MOVIE PLAYER WINDOW**

The following tutorial details one of many ways to score a QuickTime video using Vision.

1. Choose File>Open.
   A standard Open dialog box appears.

2. Use the dialog box to select a QuickTime movie to open, then click Open.
   If the movie contains both video and audio, select either View or Import & View from the subsequent dialog box depending on your needs.
   Vision opens the selected QuickTime movie in its QuickTime Movie Window.

3. Choose Options>Sync Options.
   Vision opens the Sync Options dialog box.

4. Set the SMPTE Format pop-up to a whole number multiple of your movie’s frame rate.
   If you don’t know your movie’s frame rate, there are numerous applications (such as Adobe Premiere™) that provide that information.

5. Click OK.

6. In the menu for the QuickTime Movie Window, check the options for Lock to Timing, Show SMPTE Offset and Show SMPTE Counter.

7. In the QuickTime Movie Window’s Offset field, set the SMPTE start time of the movie, if necessary.

8. Use Vision’s scrub control to shuttle through the movie.

9. Each time you spot a point where you want to create a musical cue, choose Do>Insert SMPTE Marker.
   Vision opens the Meter Track Window and inserts a SMPTE marker at the selected time.

10. Name each marker.

11. From the Meter Track Window Menu, select Absolute SMPTE.
Vision now displays Absolute SMPTE times in the Meter Track Window.

The Meter List Window basically acts as your Edit Decision List (EDL).

Jump to any point in the movie by selecting an Edit Point from the Control Bar’s Marker pop-up.

Using Vision to create the EDL and to control the movie’s playback, you can now go about the business of creating a musical score.

Use a General MIDI Module for MIDI Scoring

IMPORTANT: When you compose a MIDI score that you plan to export as a QuickTime movie, Opcode recommends that you always score the movie using a General MIDI Module rather than Apple’s QuickTime Musical Instruments extension.

QuickTime Musical Instruments has a built-in delay that, if used for creating a movie, could cause synchronization problems when exported.

So...

IF you use a General MIDI module to create a score AND you export the MIDI data as a QuickTime movie THEN end-users will be able to playback your movie using either QuickTime Musical Instruments or their own General MIDI Module—the soundtrack will be in sync with the video.
CHAPTER 41: The File Menu

NEW

New closes the current project (you are first prompted to save any changes) and opens a new Sequences Window with one empty sequence. This is similar to quitting Vision then immediately re-launching it—a new file appears that has all of your default settings.

If you have a file called “Vision Setup” in the same folder that the Vision application is in, all setup objects (including Instruments, Input Maps, MIDIKeys, and Fader and Console information) are read in from that file.

If you do not have a file called “Vision Setup” in the same folder as Vision, the Instruments are made from your current Studio Setup. See Vision Setup (pg. 157) for more information.

New does not affect the contents of the Clipboard. Its contents are preserved, enabling you to copy and paste between different Vision files.
OPEN (COMMAND-O)

Choose **File>Open** to open an existing Vision file, or to import a MIDI file into a new sequence. The Vision Open dialog appears:

![Open dialog](image)

**Figure 40.2: Open dialog**

When you have located and selected the file you wish to open, click **Open** to open the file.

**What to Open**

Click **What to Open** to specify which items are opened with the selected Vision file.

![What to Open dialog](image)

**Figure 40.3: What to Open dialog**

This dialog contains all the file objects that you can choose to open. Click the checkbox next to each object you wish to open, then click **OK** to return to the Vision Open dialog box. Generally, you will want to open everything in a file. The default setting has all items checked.
Use Setup Instruments

**Use Setup Instruments**

Sometimes a Vision file contains Instruments that are not the same as the ones in your current Vision Setup document. The **Use Setup Instruments** option allows you to determine what happens when you open such a file:

- If **Use Setup Instruments** is unchecked, the Instruments in the file that you are opening are used. If other Instruments are currently in use by the metronome, faders and consoles, Input Map, etc., then Vision also adds those Instruments if they aren’t already present in the file being opened.

- If **Use Setup Instruments** is checked, Instruments contained in the opened file that differ from the Setup Instruments are added. This option gives you a more consistent set of Instruments from one file to the next, so that the same command key selects the same Instrument.

The file plays exactly the same regardless of the condition of this checkbox. This option only determines the number of Instruments used and their order.

Possible Warnings

There are two situations that could interrupt an Open operation:

- When opening a file that contains patch names that conflict with the current Name Manager subscriptions, you are asked to resolve the conflict before the file can be opened. See Opening Files With Different Name Setups (pg. 323) for a description of this process.

- If the file refers to devices that aren’t defined in the current Studio Setup, the Remap Undefined Channels dialog appears. See Undefined Channels (pg. 431) for more information.

About MIDI Files

There are two types of MIDI files: single track (Type 0) and multitrack (Type 1). Both can be imported with Vision’s Open command.

Single-track (type 0) MIDI files, when opened, are unmerged so that each channel is assigned to a separate Vision track.

When importing a MIDI file, if a track doesn’t contain the name of a defined device, Vision creates a device called “MIDI File.” You can then remap this device so that future MIDI files automatically associate themselves with the right devices. For more information on remapping, see page 431.
CLOSE WINDOW
(COMMAND-W)

This command closes the active window.

If the active window is the Sequences Window, the current Vision file is closed. You will be asked to save changes before closing. You can choose to save or discard changes, or cancel the close.

You cannot close the Control Bar.

CLOSE ALL
(COMMAND-OPTION-W)

Choose this command to close all windows in Vision except the Sequences Window.

SAVE (COMMAND-S)

This command saves the current file to disk. If the Sequences Window is untitled, you will be asked to name the file and find a location for saving it.

Once you have named your file, the Vision Save dialog no longer appears when choosing File > Save—your file simply overwrites the previous version.

If you are saving for the first time, you can choose the file objects that you wish to save:

- Sequences
- Instruments
- Input Map
- MIDI Keys
- Fader Assignments
- Fader Values

Figure 40.5: What to Save Dialog

You must save sequences and Instruments (that’s why their checkboxes are grayed out—you don’t have the option of unchecking them), but you may also save other items that differ from your Vision Setup file.

SAVE AS

Choosing File > Save As opens the Save dialog box (see Figure 40.4 on page 400). Use this command to save your file under another name, and keep an older version of your file untouched.
After finishing a Save As command, the current file has the name with which it was just saved. The original file is still in its original location. This is good for creating successive versions of the same project.

You can also see the current file objects by choosing this item.

SAVE A COPY AS

This command is very similar to Save As, but it lets you save any combination of file objects to any file at any time, without changing the current file. When you choose File>Save a Copy As, you are not required to save Sequences and Instruments, as you must do with normal Save operations.

However, if you use it to save either sequences, an Input Map, or fader assignments, then you are strongly encouraged to save Instruments as well—sequences, Input Maps and fader assignments refer to Instruments by number.

Save a Copy As leaves the current file completely unchanged, enabling the creation of backup copies to other disks without returning to the Finder.

SAVE AS SETUP

When you choose this command, Vision saves the following file objects in a file called "Vision Setup" to the same folder as the Vision application:

- Instruments
- Input Maps
- MIDIKeys
- Commands
- Fader and console assignments
- Fader and console values

If Vision Setup doesn't exist, Vision creates it when you invoke this command. If it already exists, Vision updates it by saving the current state of the file objects.

If you would like to update only certain file objects in the Vision Setup file:

1. Choose File>Open.
2. Select the Vision Setup file.
3. Click What to Open.
   The What to Open dialog opens.
4. Uncheck the file object(s) you wish to keep unchanged in Vision Setup.
5. Click OK to close the What to Open dialog.
6. Click Open to open the Vision Setup file.
7. Choose File>Save as Setup.
REVERT

This command discards any changes you have made since the last Save operation. When you invoke this command, Vision re-reads the file from disk.

If the Names Window is open when you choose Revert, the names are reverted and the sequences remain untouched.

Caution: Reverting a file causes all changes in the current document since the last Save operation to be lost.

EXPORT AS MIDI FILE (OPTION-X)

Select a sequence before choosing Export. The Export dialog box is similar to the Save dialog box:

Decide if you want to create a Type 0 MIDI file (single track) or Type 1 (multi-track). If you leave the Multitrack option unchecked, the sequence is written to a single track MIDI file. Loops are unlooped and played as if you had recorded it in real time.

If you check the Multitrack checkbox, each track remains separate. Loops are also expanded in this format.
CHAPTER 41: The File Menu

EXPORT TO CLIPBOARD

This command translates the current selection into standard MIDI data (Type 1—multitrack), and places it on the Clipboard. This is useful for transferring data between applications without saving and importing new files. If both applications are open, you can use this command to easily transfer data between them.

This command is slightly different from Edit>Copy (see page 407). Copying data places the information on the Clipboard in Vision’s native format, which cannot be understood by other MIDI applications. Using File>Export to Clipboard translates the data into a format (Type 1—multitrack) that other applications can understand.

If the current selection contains loops or sequence events, they are expanded before being exported. Multiple tracks that have the same Instrument assignments are not merged together into a single track, as Edit>Capture Seq->Track (see page 414) does.

The data from Export to Clipboard is also available on Vision’s Clipboard and can be pasted into sequences and tracks. This command is useful for preparing sequences to be notated.

EXPORT AS QUICKTIME MOVIE

Choose this command to export selected MIDI or audio as a QuickTime movie. Consult the Audio Reference Manual for details.

IMPORT AUDIO (OPTION-H)

Choose this command to import audio into the selected track. Consult the Audio Reference Manual for details.

IMPORT AUDIO USING QUICKTIME

This command imports audio or MIDI from QuickTime movies, and audio from standard audio CDs. In addition, this command can be used to import various industry-standard audio formats that are not native to Vision (such as .AU and .wav). Consult the Audio Reference Manual for details.

EXPORT AUDIO MIX

Use this command to create stand-alone audio files for multimedia or web applications. Consult the Audio Reference Manual for details.
PART 7: Menus

EXPORT AUDIO EVENTS
Use this command to export each selected audio event into its own audio file. This is particularly useful for creating sounds or loops for triggering with a sampler. Consult the Audio Reference Manual for details.

PAGE SETUP
Choosing File>Page Setup opens the standard Page Setup dialog box for your printer. Whenever you change printers, you should choose this menu item. This dialog box allows you to make printer-specific decisions about how your document will look. See your printer documentation for more information.

PRINT PREVIEW
Choosing Print Preview opens the Print Preview Window, where you can view your music as it appears on the printed page, and make some adjustments. A Notation Window must be active for this item to be available.

PRINT (COMMAND-P)
When you choose this menu item, Vision prints your music as it appears in the Print Preview Window. A Print Preview or Notation Window must be active for this item to be available.

QUIT (COMMAND-Q)
When you choose File>Quit and you haven’t saved your most recent changes, Vision presents a message box requesting you to either:
• Save and quit;
• Discard changes since your last save;
• Cancel the Quit command and continue working.

Vision closes if either of the first two options are chosen.
CHAPTER 42: The Edit Menu

### UNDO (COMMAND-Z)

This command reverses the effect of the last command. The name of the **Undo** command changes depending on the action (e.g., Undo Clear, Undo Record, Undo Make Segment, etc.).

**NOTE:** Most, but not all, commands can be undone.

After you choose this command, it becomes **Redo**, allowing you to quickly audition the effect of any change or edit.

Generally, you can undo all changes to sequences, tracks, events, or text. You cannot undo the following actions:

- Save commands
- Copy commands
- changes to Instruments
- changes to Names
- changes to MIDIKeys
- changes to the Input Map

<table>
<thead>
<tr>
<th>Edit</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Z</td>
</tr>
<tr>
<td>Cut</td>
<td>X</td>
</tr>
<tr>
<td>Copy</td>
<td>C</td>
</tr>
<tr>
<td>Paste</td>
<td>V</td>
</tr>
<tr>
<td>Clear</td>
<td>B</td>
</tr>
<tr>
<td>Merge into Track</td>
<td>M</td>
</tr>
<tr>
<td>Insert Clipboard</td>
<td>N</td>
</tr>
<tr>
<td>Repeat Paste</td>
<td></td>
</tr>
<tr>
<td>Clone</td>
<td>E</td>
</tr>
<tr>
<td>Get Clipboard Times</td>
<td>~</td>
</tr>
<tr>
<td>Insert Track</td>
<td>H</td>
</tr>
<tr>
<td>Delete Track</td>
<td>D</td>
</tr>
<tr>
<td>Move Events...</td>
<td></td>
</tr>
<tr>
<td>Separate Multi Track</td>
<td>U</td>
</tr>
<tr>
<td>Capture Seq&gt;Track</td>
<td>K</td>
</tr>
<tr>
<td>Make Segment/Loop...</td>
<td></td>
</tr>
</tbody>
</table>

**Figure 41.1: Edit menu**
You cannot undo the Copy command. This has the distinct advantage of allowing you to change a track then, if you like both the old and new versions, you can retain them both. To do so:

1. Make a change to part of a sequence.
2. Copy the new version.
   Vision places a copy on the Clipboard.
3. Choose Undo.
   Vision reverts to the old version.
4. Select a new location and choose Edit>Paste.
   Since the new version is still on the Clipboard, Vision pastes it into the new location. Vision now contains both the old and new versions of the track.

**Undo and Recording**

It is important to understand how editing during recording affects the Undo command. After editing during recording, choosing File>Undo restores the file to the state it was in prior to the last edit.

Clicking the Stop button and choosing Undo undoes the entire recording, negating all edits made while recording.

If you are in replace mode, any edits made may be lost when recording stops and the recording replaces the track’s previous contents, including the edits.

**CUT (COMMAND-X)**

This command removes the selected items from the active window and places them on the Clipboard.

Vision recognizes any MIDI events you cut as a sequence—this ensures that you can cut and paste between different types of windows. The name of this menu item changes depending upon which window is active and what you have selected (e.g., Cut Track, Cut Selection, Cut Instrument, etc.).

Cutting does not affect the length of a track or sequence. When the selected events are removed, the information around them does not change. To erase the time as well as the data, use Delete Selected Time (see page 412).
COPY (COMMAND-C)

This command places the selected items on the Clipboard without changing the source MIDI data. The selected items remain unchanged.

Vision will recognize any MIDI events you copy as a sequence—this ensures that you can cut and paste between different types of windows. The name of this menu item changes depending upon which window is active and what you have selected (e.g., Copy Track, Copy Selection, Copy Instrument, etc.).

Copy Faders

When the Faders Window or a Console Window is active, this command is Copy Faders, which will copy all the assigned fader parameters and values, mute and solo status, and other automation parameter values (for audio instruments). You can take a “snapshot” of these fader values, then paste them into a single track. When Vision plays these fader events, the faders will be reset to their copied values.

For more information about Copy Faders and Audio instruments, Busses, Inputs, and Outputs, see your Audio Reference Manual.

PASTE (COMMAND-V)

This command places a copy of the Clipboard data into the active window. The name of this menu item changes depending upon the type of information contained in the Clipboard, which window is active, and what you have selected (e.g., Paste Track, Paste Instrument, Paste Sequence Event, etc.).

When pasting certain types of information, you must make a selection first. For example, if you want to paste an Instrument, you must select an Instrument (in the Instruments Window) before you can paste. The contents of the Clipboard will overwrite the current selection.

Vision will automatically number items that contain the same name. For example, if you have copied a track called “Bass” from the Tracks Window and paste it in the same window (or any Tracks Window with an identical name), the new track will be renamed “Bass #2.”

Pasting in the Sequences Window

When you paste a sequence in the Sequences Window, a new sequence will be added after the last one, unless you have already selected one or more sequences. If you would like to replace
one or more sequences with the contents of the Clipboard, select the sequences and choose Paste.

If you want to paste the sequence into a new sequence location, be sure to de-select all sequences in the active Sequences Window. You can easily do this by clicking in the selection column header, or click after the last sequence in the list.

**Working with Multiple Sequences**

If the Clipboard contains a different number of sequences than you have selected in the Sequences Window, Vision will confirm that you wish to replace the current selection with the contents of the Clipboard.

For example, if you copied three sequences and then pasted them into one sequence, you would see the following alert:

![Replace alert]

You can also paste sequences into the Track Overview or List Window to create sequence events. See Sequence Events (pg. 96) for more information.

**Pasting in the Tracks Window**

If you are pasting entire tracks in the Tracks Window (i.e. you've clicked on one or more track selector dots), all the tracks you've selected will be replaced by all the tracks on the Clipboard, regardless of their number. Tracks are inserted and deleted as necessary.

If you are pasting into an edit window (including the Track Overview) or doing a Merge Paste, track counting works differently. In these cases, if the Clipboard contains more tracks than you have selected, it will paste only the first Clipboard tracks to the selected tracks. For example, if there are three tracks on the Clipboard and two tracks selected, only the first two tracks will be pasted.

**Pasting MIDI Data**

When pasting MIDI events into an edit window, the Clipboard will be placed at the Edit In point. If there are any events already present, they are replaced. If you don't want this, use Merge or Insert Clipboard (explained later in this chapter) instead.

**CLEAR (COMMAND-B)**

Clear is similar to Cut, but does not save the selection to the Clipboard. Clearing MIDI events does not affect the length of
a track or sequence. When the selected events are removed, the information around them does not change.

You can clear many types of data, and the name of the menu item will change depending upon which window is active and what you have selected (e.g., Clear Selection, Clear Sequence, Clear Instrument, etc.).

**MERGE (COMMAND-M)**

This command merges the contents of the Clipboard with that of the destination track (at the Edit In point). It doesn't change any data that is already in the track.

**Merge** is different than **Paste** because the previous track contents are not replaced.

**Instrument Reassignment**

When the Clipboard contains only one track with only one Instrument and you merge it into a track with a different Instrument, all of the merged data will use the Instrument of the destination track. It will not make a multi-track (containing several Instrument channels). To make a multi-track, paste to an empty track and then combine the tracks with the **Combine Tracks** command.

**Merge Markers As Text**

When you cut or copy a Meter track to the Clipboard and select a normal track, the **Merge** command becomes the **Merge Markers As Text** command. The only information in a Meter track that is compatible with a normal track are the markers. Choosing this command merges the marker events into the destination track as text events.

**INSERT CLIPBOARD (COMMAND-N)**

This command pastes the contents of the Clipboard at the Edit In point of the selected track. Any MIDI events that are already present will be shifted later in time to make room for the Clipboard data. This command changes the track length, because it retains all the previous information and adds the length of the Clipboard.

**Insert Clipboard** is different than **Paste** because the previous track contents are moved, but not replaced.

**Instrument Reassignment**

When the Clipboard contains one track with one Instrument and you insert it into a track with a different Instrument, all of the inserted data uses the Instrument of the destination track. It does not make a multi-track (containing several Instrument channels). To make a multi-track:

1. **Paste** to an empty track.
PART 7: Menus

2. Insert an equivalent amount of blank time into the original track.
3. Combine the tracks with the Combine Tracks command.

REPEAT PASTE (OPTION-;)

Choose this menu item to open the Repeat Paste dialog. Use this command to paste, merge, or insert the Clipboard information several times, beginning at the Edit In point of the destination track.

You can specify the number of times to paste the Clipboard (in the Repeat field), or the number of bars/beats/units the pasted data should occupy. Changing either of these fields automatically updates the other.

TIP: By selecting a time region before choosing Edit>Repeat Paste, Vision computes the necessary number of repetitions to fill the selected time.

If the specified number of bars/beats/units is not an exact multiple of the time on the Clipboard, the data is pasted the indicated number of Repeat times, along with any remainder needed to fill the specified time.

NOTE: Unless you are pasting into a sequence with a different time signature, you’ll seldom have to change the time signature fields.

With the Repeat Paste command, material can be pasted in one of three ways:

- **Paste over track**
  Replaces the contents of the destination track with the contents of the Clipboard.

- **Merge with track**
  Merges the contents of the Clipboard with those of the destination track.

- **Insert into track**
  Shifts the contents of the destination track to make room for the pasted material.
CHAPTER 42: The Edit Menu

CLONE (COMMAND-=)

The Clone command is only available when a sequence event is selected in the Track Overview or List Window. Choose this command to clone the sequence or segment referenced by the selected sequence event.

The Clone command makes a copy of the referenced sequence or segment and puts it in the Segments section of the Sequences Window, the sequence event is updated to point to the clone.

NOTE: If the previously referenced item is a segment and is no longer referenced by any other sequence events, it is deleted.

For more information on using segments and sequence events, see Chapter 13: Segments, Loops, and Sequence Events.

GET TIMES FROM CLIPBOARD (COMMAND-‘)

This command gets the Edit In/Out points from the Clipboard and pastes them into the edit points of the current edit window.

Suppose you copied a section of a track to the Clipboard. If you change the Edit In point of the destination track, you may not know where to paste the information. By choosing Get Times from Clipboard before pasting, you are assured that the information will be pasted to the correct location.

INSERT (COMMAND-H)

The Insert command has different functions, depending on the active window.

Insert Track(s)

When the Tracks Window is active and one or more tracks are selected (with the name, length, and Instrument for the tracks highlighted), choosing Insert Tracks will create the same number of new tracks that you have selected and place them above the top selected track.

Insert Blank Time

This command inserts an amount of blank time (empty time, no events) equal to the selection. All MIDI events after the Edit In point are shifted to the end of the Edit Out point.
PART 7: Menus

412 Opcode Systems, Inc.

Figure 41.4: Insert Blank Time shifts events by the amount of the selection

DELETE (COMMAND-D)

The Delete command has different functions, depending on the active window.

Delete Track(s)

When the Tracks Window is active and one or more tracks are selected (with the name, length, and Instrument for the tracks highlighted), choosing Delete Tracks erases the selected tracks, and shifts all remaining tracks to fill the empty space. This will not affect the Clipboard.

NOTE: If you select a time range in the Ruler of the Tracks Window, Delete Selected Time deletes the selection across the entire sequence for all tracks.

Delete Selected Time

When you have defined a selection in an edit window, this command cuts the selected MIDI events to the Clipboard and shifts all remaining events after the Edit Out point to fill the empty space.
MOVE EVENTS (COMMAND-,)

Choose this menu item to open the Select & Modify Window automatically configured for Move Events. This command moves selected events to a specific location, or forward or back in time by any increment.

Choose one of the following options and click the Move button to move the events.

- **Move earlier**
  Moves selected events back in time by the specified number of bars, beats, units, SMPTE frames, or SMPTE bits.

- **Move later**
  Moves selected events forward in time by the specified number of bars, beats, units, SMPTE frames, or SMPTE bits.

- **Move so selection starts at**
  Places the selected events at the specified bar/beat/unit location.

Values for the move can be in “bars & beats” or “SMPTE time,” as specified by the Move by pop-up.

You can click the **Double** button to move a copy of the selected events, leaving the original data unchanged—which is useful for creating echo effects.

COMBINE/SEPARATE TRACKS (COMMAND-U)

This command is available only if you have tracks selected in the Tracks Window. If more than one track is selected, the Combine Tracks command collapses them into a single track in the location of the first track. Other tracks in the sequence move up to fill the void.

If the tracks were using different Instruments, the new track will be a multi-track.

This is especially useful if you are using more than one Instrument to create a sound that you think of as a single Instrument. For example, if you are building a drum set, you may love the kick and snare sounds in one device, but prefer the hi-hat sound in another. After you have finalized the tracks, you may want to refer to all three tracks as one.

Vision automatically names the combined track “Track n” where n = the next available track number.
If the selected track is already a multi-track, this command becomes **Separate Multi Track**, which unmerges the channels into separate tracks (located next to each other). Other tracks in the sequence are shifted as necessary. Vision automatically names the tracks based on the original track name followed by numbers. For an example, see page 49.

Separate Multi Track is also available if a drum track is selected. In this case, choosing Separate Multi Track will separate each note of the track onto its own track. See page 225 for details.

**CAPTURE SEQUENCE**

Capturing is a process that internally plays and records the selected sequence into a new track. Capturing creates a chronological stream of events—all looped data is unlooped as if it were played in real time. Sequence events are also played into the new track as if you played them in real time.

You must copy a selection of MIDI events before you can use this command. When you copy any MIDI selection, Vision internally refers to it as a “sequence,” even if the original data was a specific selection within a track or sequence. There are two possible names for this command: **Capture Seq->Track** and **Capture Seq->Seq**.

**To use Capture Sequence:**

1. **From the Sequences or Tracks Window, or from one of the edit windows, make a selection.**
2. **Choose Edit>Copy.**
3. **Select a destination track or sequence, or have the Sequences Window active with no sequence selected.**
4. **Choose Edit>Capture Seq->Track** (or **Edit>Capture Seq->Seq**).

**Capture Seq->Track**

If you have a track selected in the Tracks Window, Vision will capture the Clipboard information into the selected track. All loops and sequence events are transcribed into a continuous stream of MIDI data. If the Clipboard information contains many tracks, Vision will create a multi-track so that all Instruments are retained. Only 16 Instruments can fit into a track—if your sequence has more than 16 Instruments, capture to a sequence instead.

**Capture Seq->Seq**

If the Sequences Window is active, Vision captures the Clipboard information into a sequence. If a sequence is selected, the data on the Clipboard replaces the selected sequence. All loops and sequence events are transcribed into a
continuous stream of MIDI data. Each Instrument will be placed on a separate track, but information from separate tracks with the same Instrument will be merged into the same track.

MAKE SEGMENT/LOOP
(OPTION-U)

Use this command to turn track regions into segments, which can be used as song sections, music layers, reoccurring phrases and riffs, or even nested track loops.

The selected material is replaced by a sequence event block that references the new segment. The original material then resides in the newly created segment, which is listed in the Segments section of the Sequences Window.

Following is a description of the various options in the Make Segment/Loop dialog:

1. **Start/End**
   These fields specify the time range of data used for the segment. Check the “Round to nearest barline” option if you want the selection to fall cleanly on the beat.

2. **Loop**
   Check this option if you want the resulting sequence event to loop. Enter the number of repeat times in the accompanying field.

3. **Name**
   Specifies the name used for the new segment.

4. **Make one segment with multiple tracks**
   If several tracks are selected, this option places them into a single segment containing multiple tracks.

5. **Make single-track segments**
   If several tracks are selected, this option makes them into separate segments, each containing a single track.

For more information, please see Segments (pg. 93).

Unmake Sequence Event

When selecting a sequence event in the Track Overview or List Window, this command becomes **Unmake Sequence Event**. Invoking this command places the original tracks (from the referenced segment or sequence) into the parent sequence.

See Unmaking Sequence Events (pg. 102) for details.
NEW RECORD TRACK

This command will record-enable the next empty track in the current sequence. If there are no sequences selected or open, Vision automatically selects the first sequence in the Sequences Window. This command is especially useful if you want to start recording immediately—it ensures that an empty track is placed in record mode.

The Tracks Window does not need to be open or active for this command to work, so you may not see the track you are recording into.

Record Enabling Neighboring Tracks

After choosing this menu item, you can type Command-↑ to record-enable the previous track and Command-↓, the next track.
CHAPTER 43: The Do Menu

The Window submenu contains the same commands found in the Window menu of the active window.

TIP: One reason the Window submenu is provided in the Do menu is so you can use a macro program to make keyboard equivalents for any menu items that don't already have one—which can automate many tasks.

TIP: One reason the Window submenu is provided in the Do menu is so you can use a macro program to make keyboard equivalents for any menu items that don't already have one—which can automate many tasks.

WINDOW SUBMENU

The Window submenu is the first item in the Do menu. The exact name of this menu item changes depending on which window is currently active.
PART 7: Menus

TRANSPOSE (COMMAND-T)

Choose this command to open the Select & Modify Window automatically configured for Transpose. For information on the Transpose command, see the following:

• The Transpose Command (pg. 80);
• Transpose Types (pg. 134);
• Quantize and Transpose Templates (pg. 163).

QUANTIZE (OPTION-G)

Choose this command to open the Select & Modify Window automatically configured for Quantize. For information on the Quantize command, see the following:

• The Quantize Command (pg. 74);
• Quantize Parameters (pg. 129);
• Quantize and Transpose Templates (pg. 163).

MODIFY (COMMAND-Y)

Choose this command to open the Select & Modify Window automatically configured for Modifying notes. The following note properties can be modified:

• velocity
• release velocity
• durations

For details, see Modifying Note Properties and Automation Values (pg. 126).

REASSIGN

Choose this command to open the Select & Modify Window automatically configured for Reassign.

The Reassign command changes one continuous controller type (MIDI controllers, pitch bend, aftertouch, velocity scale, audio volume and pan, send levels, continuous EQ parameters, and continuous plug-in parameters) to another.

Selected events can be changed to any MIDI controller, pitch bend, aftertouch, velocity scale, audio volume and pan, send levels, continuous EQ parameter, or continuous plug-in parameter.

For more information, see Reassign (pg. 127).

SET INSTRUMENT (COMMAND-I)

Choose this command to open the Select & Modify Window automatically configured for Set Instrument.

For details, see Modifying Note Properties and Automation Values (pg. 126).
To reassign events to a new Instrument:

1. **Select the desired track or track region and choose Do>Set Instrument.**
   The Select & Modify Window opens, automatically configured for Set Instrument.

2. **Specify the new Instrument from the Instruments pop-up.**

3. **Click the Set button to reassign the previous selected events.**
   You can also click the **Double** button assign a copy of the data, leaving the original material assigned to the original Instrument.

---

**SUBSTITUTE**

Choose this command to open the Select & Modify Window automatically configured for Substitute. Substitute replaces selected events with the contents of the Clipboard.

Following is a description of each option for Substitute:

1. **Replace each event with a single sequential event from the Clipboard**
   Vision replaces each event in the current selection with a one-to-one correspondence to each event on the Clipboard. If the following notes represent the contents of the Clipboard:

   ![Figure 42.4: Substitute command](image)

   ...and the following notes represent the current selection:

   ![Figure 42.4: Substitute command](image)

   Then clicking Substitute yields this result:

   ![Figure 42.4: Substitute command](image)
2 Replace each event with the entire contents of the Clipboard

Vision replaces each selected event with the entire contents of the Clipboard. Notice that Vision does not transpose the Clipboard contents to match the selection it’s replacing. If the following notes represent the contents of the Clipboard:

...and the following notes represent the current selection:

Then clicking Substitute yields this result:

3 Controllers to notes

This option specifies what happens when substituting continuous events for notes events, and vice versa. The continuous event values can be used for the note’s pitch, velocity, or durations.

4 Preserve options

When using the Substitute command, three aspects in the current selection may be preserved: durations, velocities, and Instruments. For each box checked, Vision retains the appropriate property for Substitute operations on the current selection.

Substitute Ideas

Substitute may be used to replace the current selection with the contents of the Clipboard. Although it would be impossible to outline every possible use for this powerful feature, here are some suggestions and possibilities:

• You can change the pitches of the current selection to the pitches on the Clipboard without changing the rhythmic content of the current selection.
• You can substitute every note in the selection with the contents of the Clipboard, creating “riffs” without using a trigger.

NOTE: If you have more than one track on the Clipboard, Substitute uses only the first track. All other tracks are ignored.
SELECT/MODIFY TEMPLATES

This submenu lists all Select & Modify templates stored in the Vision Editing Templates file (see Editing Templates (pg. 163) for details).

To recall a template, simply choose it from the submenu and the Select & Modify Window is automatically reconfigured.

QUANTIZE (COMMAND-G)

Choose this command to permanently Quantize the selected material. Unlike other Select & Modify commands, Quantize is always available—regardless of the current state of the Select & Modify Window. The Quantize parameters used are those last specified in the Select & Modify Window.

The name of this command changes depending on the type of material selected (i.e. Quantize Sequences, Quantize Track, Quantize Selection).

For information on the Quantize command, see the following:
- The Quantize Command (pg. 74);
- Quantize Parameters (pg. 129);
- Quantize and Transpose Templates (pg. 163).

SELECT & MODIFY (COMMAND-R)

Choose this command to perform the function specified in the current configuration of the Select & Modify Window.

The name of this menu item changes depending on the command specified in the Select & Modify Window and the type of material selected (i.e. Transpose in Track, Change Duration in Selection). If a Select & Modify template has been selected, its name appears for this menu item.

For details on using the Select & Modify Window, see Chapter 16: Select & Modify.

COPY PATCHES (OPTION-C)

Choosing Copy Patches copies the last patch change event sent to each Instrument in the current sequence to the Clipboard. If more than 16 Instruments are used by a sequence, the Clipboard will contain more than one track. This is helpful when making a "setup" track containing patch events for the sequence.

To use Copy Patches:

1. With the Tracks Window active, select an empty track.
   - You can also select an existing obsolete "program change" track—this track will be replaced by patch events.
PART 7: Menus

Choose Do>Copy Patches, or type Option-C.
The current patches (for Instruments used in the current set of tracks) are copied to the Clipboard.

Choose Edit>Paste Track, or type Command-V.
The current patches are pasted into the selected track.

REVERSE TIME
This command reverses the order of events in the current selection. This results in a “retrograde” effect, which can be a useful tool for composition. Notice that this is not the same as playing a sound recording backwards, because this command only affects the order of MIDI events, not the sound of the Instruments.

CHANGE TEMPO (OPTION-')
Choose this command to open the Change Tempo dialog, which lets you:
- Fit a range of measures into a precise time range;
- Create tempos that accelerate or ritard;
- Scale existing tempos.
For details, see Change Tempo (pg. 139).

RELOCK
Choose this command to open the Reclock dialog. Reclock takes a sequence recorded without a metronome (or from an audio source) and aligns it to bars and beats. See Reclock (pg. 142) for details.

INSERT BAR MARKER (COMMAND-')
This command opens the Meter track’s List Window and puts a bar marker at the current Counter location (not necessarily the Edit In point). In this window, you can name the marker.
The marker appears in the Marker pop-up in the Control Bar and in the Track Overview Ruler.
For more information on markers, see Marker Pop-up (pg. 193).
CHAPTER 43: The Do Menu

INSERT SMPTE MARKER
(COMMAND-;)  
This command opens the Meter track’s List Window and puts a SMPTE marker at the current Counter location (not necessarily the Edit In point). In this window, you can name the marker.

The marker appears in the Markers pop-up in the Control Bar and in the Track Overview Ruler.

SMPTE Markers retain their SMPTE times, even if you change the tempo or SMPTE Offset of the sequence using any method. However, they will move if you use Move Events—they are not “locked.”

PLAY FROM SELECTION
(COMMAND-SPACE)  
This command plays the current track or sequence starting with the current selection. This changes depending on what you have selected:

- If the current selection is a sequence, Vision plays from the sequence Start Point to the end of the sequence.
- If the current selection is a track, Vision plays from the track’s start time to the end of the track.
- If the current selection is a range of MIDI data, Vision plays from the Edit In point to the end of the track.

Of course, you can manually stop or pause playback at any time.

PLAY SELECTION
(OPTION-SPACE)  
This command plays only the selected events in the current sequence from the Edit In to the Edit Out point, then stops.

THE SELECT SUBMENU  
This submenu allows you to define the current selection according to rules you specify.

Select by Rule (Command-E)  
Choose this command to open the Select & Modify Window automatically configured for Select. Use this command to make precise and exacting selections for selected tracks or sequences.

Figure 42.5: Select & Modify Window configured for Select  
For details on using the Select command, see Select Attributes (pg. 121).
Select All (Command-A)

If the Sequences Window is active, choosing Select All selects all sequences.

If the Graphic or Notation Window is active, Select All selects all events for the displayed track and sets the Edit In and Edit Out points to the length of the track.

If a Tracks Window in “Events” mode is active (cursor in Track Overview), Select All selects all events and sets the Edit In and Edit Out points accordingly.

If a Tracks Window in “Tracks” mode is active (one or more tracks selected and highlighted), Select All selects all recorded tracks. For more information on the distinction between Tracks mode and Events mode, see Two Windows in One (pg. 203).

Split Notes (Command-\)

Choose Split Notes to open a dialog that allows notes to be selected based on their harmonic position.

Figure 42.6: Split Notes dialog

There are three ways to split notes:

1. **Selects a specified number of notes based on their position (highest or lowest) within a chord.**
   
   This option could be used for extracting parts.

2. **Selects a specified number of (highest or lowest) notes that occur throughout the entire length of the track.**
   
   This option could be used to select one or more drum notes.

3. **Selects notes occurring within a specified number of semitones of the highest or lowest note in each chord.**
   
   This option could be used to select all notes played with the right hand.
Select Duplicates

Use this command to recover from the rare situation in which a track has two of every event in it. Usually the events occur at the same time, have the same value, and are the result of a MIDI transmission or keyboard error. If they are separated by a few ticks then set the “units” field to a number slightly greater than 0.

You may not be able to see the selected events in a graphic window because they are covered up by their twin events. Nevertheless, choosing Edit>Cut or Edit>Clear will cause them to disappear.

NOTE: This command is particularly useful when a track is accidentally recorded with a layered MIDI channel.

NUDGE SUBMENU

This submenu contains the following Nudge commands, which move or transpose selected events (as specified by the Nudge amount defined in the Settings Window; see page 332).

Earlier (Command←)

Choose this command to nudge the selected events back in time by the amount specified in the current Nudge Settings in the Settings Window.

Later (Command→)

Choose this command to nudge the selected events forward in time by the amount specified in the current Nudge Settings in the Settings Window.

Up (Command↑)

Choose this command to transpose the selected notes up by the value specified in the current Nudge Settings in the Settings Window.

Down (Command↓)

Choose this command to transpose the selected material up by the value specified in the current Nudge Settings in the Settings Window.
PART 7: Menus

MUTE SUBMENU

The Mute submenu contains the following commands for muting and unmuting sequence events and audio events:

**Mute Seq & Audio Events**

Choose this command to mute the selected sequence events and audio events. Muted events become grayed out in the Track Overview area of the Tracks Window and do not sound during playback.

**Unmute Seq & Audio Events**

Choose this command to unmute the selected sequence events and audio events.

**Toggle Mutes**

Choose this command to toggle the mute status of selected events—muted events become unmuted, unmuted events become muted.
CHAPTER 44: The Setups Menu

Figure 43.1: Setups menu

KEYBOARD THRU

When checked, Keyboard Thru routes all MIDI events it receives to the Current Thru Instrument's device and channel. If an Input Map is enabled, Vision routes MIDI to the appropriate devices according to the map.

If Keyboard Thru is unchecked, Vision sends MIDI data during playback only.

THRU IN BACKGROUND

When checked, Thru in Background continues to route MIDI events (to either the Current Thru Instrument or Input Map) even when you switch to a different application. When unchecked, Vision suspends “Thruing” until you bring Vision to the front.

For this item to be available, Run MIDI in background must be checked in the OMS MIDI Setup dialog (see page 430).
PART 7: Menus

INPUT EFFECT ENABLED
This menu item turns on and off the Input Effect. When checked, MIDI input is processed according to the configuration of the Input Effect Window.

You can also check and uncheck Input Map Enabled from the menu in the Input Effect Window. For details on using the Input Effect, see Input Effect Window (pg. 115).

INPUT MAP ENABLED
This menu item turns on and off the Input Map. When checked, MIDI is routed according to the current Input Map (as long as Keyboard Thru is enabled).

When unchecked, Vision instead routes MIDI to the Current Thru Instrument; in addition, all lines in the Input Map Window are grayed out.

You can also check and uncheck Input Map Enabled from the menu in the Input Map Window. For details on using an Input Map, see Chapter 34: The Input Map Window.

MIDIKEYS ENABLED
When checked, this item activates the current set of MIDI keys. You can also check and uncheck MIDIKeys Enabled from the menu in the MIDI Keys Window. See The MIDI Keys Window (pg. 171) for details.

FADER REMOTES ENABLED
When checked, faders in the Faders and Console Windows can be controlled from an external MIDI source. You can also check and uncheck Fader Remotes Enabled from the menu in the Faders and Console Windows.

RECORD QUANTIZE ENABLED
This menu item turns on and off Record Quantize. When checked, Vision quantizes all recorded performances based on the Play Quantize settings of the record track. When Record Quantize is enabled, it is indicated in the Record Mode pop-up, see Figure 43.2.

Figure 43.2: Record Quantize Indicator

NOTE: Since each track has its own settings for Play Quantize, recorded MIDI data is quantized differently for each track.

NOTE: Record Quantize can also be disabled or enabled by clicking the Record Quantize button in the Play Quantize area of the Tracks and Pulse Windows.
CHAPTER 44: The Setups Menu

RECORD FILTER

This menu item opens the Record Filter dialog, where you can select the types of data Vision records.

![Record Filter Dialog]

Figure 43.3: Record Filter dialog

Use the three radio buttons to tell Vision whether you want to record all events, only the events selected in this dialog, or all events except those selected in this dialog. For instance, in Figure 43.3, all events are recorded except “Channel Aftertouch” and “Old DX7 Aftertouch.”

Up to eight continuous controllers can be specified in the Record Filter dialog. Simply choose the desired controllers from any of the pop-ups and click the corresponding checkboxes.

ENABLE INPUT DEVICES

This menu item opens the Enable Input Devices dialog:

![Enable Input Devices Dialog]

Figure 43.4: Enable Input Devices dialog

Use this dialog to specify the devices from which you will record MIDI data. Input devices are enabled by clicking their checkboxes. Vision only listens to these devices when recording or routing MIDI.

The devices from your current Studio Setup are listed in this dialog. If multiple devices are connected to the same port of your MIDI interface, all devices on that port appear as single input device.

NOTE: Disabled input devices can still be defined as sync sources in the Sync Options dialog.
**OMS STUDIO SETUP**

Choose this menu item to launch or activate the OMS Setup application with the current Studio Setup.

**OMS MIDI SETUP**

This menu item opens the **OMS MIDI Setup** dialog.

<table>
<thead>
<tr>
<th><strong>OMS MIDI Setup</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>External ports to use</strong> determines which serial ports OMS uses for MIDI communication.</td>
</tr>
<tr>
<td><strong>Run MIDI in background</strong> retains control of the serial ports used by MIDI interfaces until all OMS applications have quit. This means you can begin playing in Vision, switch to another application, and Vision will continue to play in the background.</td>
</tr>
<tr>
<td><strong>New Easy Setup</strong> starts the “Easy Setup” procedure for configuring a new OMS Studio Set. See your OMS Manual for details.</td>
</tr>
<tr>
<td><strong>Edit Custom Setup</strong> opens the current Studio Setup in the OMS Setup application. See your OMS Manual for a full explanation of the OMS Setup application.</td>
</tr>
<tr>
<td><strong>Error Log</strong> opens a dialog displaying a report of serial errors that have occurred since installing Vision.</td>
</tr>
</tbody>
</table>

Figure 43.5: OMS MIDI Setup dialog

Following is a brief description of the items in the OMS MIDI Setup dialog:

**Figure 43.6: OMS Serial Port Errors dialog**
UNDEFINED CHANNELS

Choose this command to open the Undefined Channels dialog. You also encounter this dialog automatically when channels become undefined in Vision (such as when opening a file, or after changing your current Studio Setup).

To remap a device, simply select from the device pop-up directly to its right (these pop-ups are labeled as “Undefined”).

If the option for Remap all matching channels is checked, remapping a single device channel automatically remaps all other channels for that device. This saves you from individually remapping each channel in a device.

Check the option for Remember remappings to reapply later and Vision will automatically apply these remappings when encountering the same undefined channels. You can edit these remappings in the Auto Remappings dialog, see Auto Remappings (pg. 432).

And if you check the option for Auto-open this dialog when needed, this dialog appears whenever Vision encounters undefined channels.

Remappings affect assignments for tracks, Instruments, Metronome Sound settings, Input Maps, faders and consoles, MIDIKeys, and many others.
AUTO REMAPPINGS

This menu item opens the Auto Remappings dialog. Use it to edit the remappings for undefined channels.

NOTE: The information in the Auto Remappings dialog is stored in the current Studio Setup document.

![Auto Remappings dialog](image)

Figure 43.9: Auto Remappings dialog

The undefined channels, listed on the left, represent devices and channels not in the current Studio Setup. When encountering a Vision file with undefined channels, they are mapped automatically to the devices and channels listed on the right.

To edit a remapping, simply choose from the Device and Channel pop-ups for the desired line. To delete a remapping, select it and click the Remove Line button.

COMMANDS

Choose this menu item to open the Commands Window, which lets you assign key equivalents and MIDI events to practically any function or menu item in Vision. See The Commands Window (pg. 169) for details.

COLORS

This menu item opens a dialog that lets you modify the display colors used by Vision’s MIDI and Audio Instruments.
CHAPTER 45: The Options Menu

SYNC OPTIONS

Choose this menu item to open the Sync Options dialog. The Sync Options dialog specifies the Receive Sync Mode and device, the Send Sync format and device, and the SMPTE format. For detailed information on each item, see Anatomy of the Sync Options Dialog (pg. 433).

Anatomy of the Sync Options Dialog

As you can see in Figure 44.2, the Sync Options dialog contains numerous options, each of which is discussed in this section.

Figure 44.1: Options menu

Figure 44.2: Sync Options dialog
Receive Sync Mode: This pop-up menu specifies the type of sync used by Vision. The choices include:

- Internal: Uses the internal clock of the Macintosh. In this mode, sequences play at their own tempo.
- External Beat Clock: Uses the sync from an external source, usually from a hardware-based sequencer or drum machine. In this mode, sequences play at the tempo of the external sync device, and locate and play as determined by MIDI Song Pointer messages.
- MIDI Time Code: Uses time code from a SMPTE or MTC source. This sync source is usually a tape track but could be from another application or MIDI device that sends MTC. In this mode, Vision reads the incoming time code and begins playback when the sequence’s SMPTE offset is encountered; the sequence uses its own tempo.
- MTC/Machine Control: Synchronizes Vision to an MMC compatible device. In this mode, Vision automatically sends MMC commands to control the sync device.

Receive Sync Device: This pop-up menu displays a list of available sync sources. Choose an item from this list to make it the active sync source.

Vision receives all Song Pointer, MIDI Beat Clock, MIDI Time Code, or MIDI Machine Control messages from the Receive Sync device and ignores these messages from all other devices. Any devices that are defined as “sending” sync in the current Studio Setup appear in this pop-up.

Remote Start: Check this option to automatically start or stop Vision from an external device or program. For example, when syncing to MTC or Beat Clock, enabling Remote Start “slaves” Vision to the start/stop controls of the sync source.

In addition, if Vision’s Receive Sync Mode is set to Internal, then Galaxy (or any other OMS Timer-compatible application) can be used to start/stop playback.

With Remote Start enabled, Vision’s Play button flashes in the Control Bar, indicating that it is waiting for you to start the remote machine.

Lock Audio to Tape: When checked, this option adjusts the sample rate playback of audio to compensate for fluctuations of incoming SMPTE time code.

For more details on this feature, consult your Audio Reference Manual.
CHAPTER 45: The Options Menu

Send Sync: Check this box to enable Vision to send synchronization information. If unchecked, no MIDI Time Code or MIDI Beat Clock will be sent to any device, regardless of the state of the MIDI Time Code and Beat Clock Enable checkboxes.

You can send Beat Clock (usually to a drum machine or hardware sequencer) or MIDI Time Code (usually to an external sync box, or to another application). Choose “none” if you don’t want to send any sync.

NOTE: When choosing Beat Clock, MIDI Song Pointer information is also transmitted.

MIDI Time Code Enable: Check this box to enable Vision to send MIDI Time Code to one or more devices (as defined in the MIDI Time Code Send Sync Device List).

MIDI Time Code Send Sync Device(s): This is a list of devices from your current Studio Setup that are set to “receive” MIDI Time Code.

Figure 44.3: MIDI Time Code Send Sync Device List

To send sync to one or more devices, simply check the box to the left of each device. Devices are available as MIDI Time Code sync destinations if they are defined as such in your current OMS Studio Setup.

In the example shown in Figure 44.3, the BRC is enabled to receive MIDI Time Code.

NOTE: When using a MIDI interface that does not channelize sync information (such as the MIDI Timepiece or Studio 4), only the interface, not the connected devices, appears as a sync destination. Sending sync to this type of MIDI interface sends it to all connected devices.

MIDI Beat Clock Enable: Check this box to enable Vision to send MIDI Beat Clock to one or more devices (as defined in the MIDI Beat Clock Send Sync Device List).
MIDI Beat Clock Send Sync Device(s): This is a list of devices from your current Studio Setup that are set to “receive” MIDI Beat Clock.

To send sync to one or more devices, simply check the box to the left of each device. Devices are available as sync destinations if they are defined as such in your current OMS Studio Setup.

In the example shown in Figure 44.4, the LinnDrum and Wavestation are enabled to receive MIDI Time Code. The BRC is disabled and, therefore, will not receive MIDI Time Code.

NOTE: When using a MIDI interface that does not channelize sync information (such as the MIDI Timepiece or Studio 4), only the interface, not the connected devices, appears as a sync destination. Sending sync to this type of MIDI interface sends it to all connected devices.

SMpte Format: This pop-up menu determines the SMPTE format Vision uses in all displays and calculations. This format must match the format of the SMPTE time code to which you are syncing. If you change the format, Vision will adjust the SMPTE offset frame number of all your sequences.

Vision stores the SMPTE format with each Vision file, and recomputes the SMPTE start time (if it differs from the current format) when it reads the file. For more information on these formats, see SMPTE Time Code Rates (pg. 150).

Remember these settings in sequence files: Check this option if you want to save the sync settings with the sequence file. If you enable this option, then every file can have its own set of sync options, which is convenient if your studio works with many different types of media.
SEND SYNC ENABLED (COMMAND -)

This menu item turns on and off the transmission of sync. The type of sync sent is determined by the settings in the Sync Options dialog (see Sync Options (pg. 433)).

CLICK IN RECORD (OPTION-[])

This menu item turns on and off the metronome sound for recording.

CLICK IN PLAY (OPTION-[])

This menu item turns on and off the metronome sound for playback.

CLICK IN COUNTOFF ONLY

When this menu item is checked, the metronome sound plays only during the countoff.

METRONOME SOUND (OPTION-\)

Choose this menu item to open the Metronome Sound dialog. This dialog determines whether the metronome sound is a MIDI note or a click from the Macintosh speaker. In addition, the menu items for Click in Record/Play/Countoff Only are duplicated here as checkbox options.

To configure the metronome sound:

① Choose Options>Metronome Sound.

The Metronome Sound dialog opens.

② Specify MIDI Note as the type of click you’ll use.

![Metronome Sound dialog](image)
PART 7: Menus

3 Select the desired Instrument from the Channel pop-up for Accented and Unaccented.

4 Select the desired click sound from the Note pop-ups.

You can also highlight the Note fields and play a note from your MIDI controller.

5 Adjust the Velocity and Duration fields as desired.

COUNTOFF IN PLAY

This menu item turns on and off the metronome sound for the countoff.

This item has no effect if the Begin Record Toggle (see page 190) is set to Wait for Note.

STOP AT PUNCH OUT

If this item is checked, Vision automatically stops at the Out Point when “punch” recording.

REAL TIME CAPTURE

If you disable Real Time Capture and type sequence letters while a track records, the sequences are recorded as sequence events.

If you enable Real Time Capture and type sequence letters while a track records, the sequences are played in real time and captured to the track. This allows you to record, in real time, any changes you make as that sequence plays (such as quantize values, track mutes and solos, or generated sequence parameters). Changes in the Instruments Window are not recorded.
LOCAL SEQUENCE TIMES

When this item is checked, double-clicking a sequence event block opens an edit window that numbers its first measure as bar 1. In addition, these windows will play and record independently of the parent sequence.

If **Local Sequence Times** is not checked, the sequence event is treated within the context of its parent sequence. Double-clicking the sequence event block opens an edit window that numbers its first measure according to the sequence event's location within its parent sequence. Playing or recording from these windows also plays the parent sequence so you can hear the sequence event in context.
CHAPTER 46: The Windows Menu

Choose one of the following menu items to open or activate the corresponding window.

<table>
<thead>
<tr>
<th>Windows</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Sequences</td>
<td>Q</td>
</tr>
<tr>
<td>Tracks</td>
<td>S</td>
</tr>
<tr>
<td>List</td>
<td>L</td>
</tr>
<tr>
<td>Pulse</td>
<td>D</td>
</tr>
<tr>
<td>Graphic</td>
<td>E</td>
</tr>
<tr>
<td>Notation</td>
<td>N</td>
</tr>
<tr>
<td>Instruments</td>
<td>I</td>
</tr>
<tr>
<td>Audio Instruments</td>
<td>J</td>
</tr>
<tr>
<td>Select &amp; Modify</td>
<td>Y</td>
</tr>
<tr>
<td>Names</td>
<td>P</td>
</tr>
<tr>
<td>Input Map</td>
<td>M</td>
</tr>
<tr>
<td>MIDI Keys</td>
<td>K</td>
</tr>
<tr>
<td>Faders</td>
<td>F</td>
</tr>
<tr>
<td>Consoles</td>
<td></td>
</tr>
<tr>
<td>Control Bar</td>
<td>A</td>
</tr>
<tr>
<td>Counter</td>
<td></td>
</tr>
<tr>
<td>Record Monitor</td>
<td>W</td>
</tr>
<tr>
<td>Input Effect</td>
<td></td>
</tr>
<tr>
<td>Players &amp; Queue</td>
<td></td>
</tr>
<tr>
<td>Settings</td>
<td></td>
</tr>
<tr>
<td>MMC</td>
<td></td>
</tr>
<tr>
<td>QuickTime Movie</td>
<td></td>
</tr>
</tbody>
</table>

**SEQUENCES WINDOW (OPTION-Q)**

The Sequences Window lists all sequences, segments, and sequence templates for the current file. For more information, see Chapter 24: The Sequences Window on page 197.

**TRACKS WINDOW (OPTION-S)**

The Tracks Window displays tracks for the current sequence and allows global selections and edits. For more information, see Chapter 25: The Tracks Window on page 203.

**LIST WINDOW (OPTION-L)**

The List Window displays a chronological list of all events in a track, which can include MIDI notes, copyright notices, system exclusive data, lyrics as text, and many others. For more information, see Chapter 29: The List Window on page 261.
PART 7: Menus

PULSE WINDOW (OPTION-D)

The Pulse Window displays and edits all drum tracks for the current sequence. The Pulse Window contains a Note Grid area for creating and editing drum patterns. For more information, see Chapter 26: The Pulse Window on page 221.

GRAPHIC WINDOW (OPTION-E)

The Graphic Window allows display of MIDI data in a "piano roll" format. Although only one track can be displayed at a time, many Graphic Windows can be open at the same time.

For more information, see Chapter 27: The Graphic Window.

NOTATION WINDOW (OPTION-N)

The Notation Window displays MIDI information using standard music notation. Vision interprets the MIDI information and displays it in a staff. Each track is normally represented by a single staff. Multiple tracks can be viewed in this window and several Notation Windows can be open simultaneously.

For more information, see Chapter 30: The Notation Window on page 275.

INSTRUMENTS WINDOW (OPTION-I)

The Instruments Window provides access to all settings for the MIDI Instruments. For more information, see Chapter 32: The Instruments Window on page 293.

AUDIO INSTRUMENTS (OPTION-J)

Choose this command to open the Audio Instruments Window.

Figure 45.2: Audio Instruments Window for Acadia

NOTE: Your Audio Instruments Window may look different depending on your particular audio hardware.
Use the Audio Instruments Window to set various audio playback parameters, including:

- playback voice assignments
- audio output assignments
- Audio Instrument mute/ solo
- Audio Instrument names

There are many other important aspects to this window. To learn about it in detail, consult your Audio Reference Manual.

For more information, see Chapter 33: The Names Window on page 305.

**INPUT MAP WINDOW (OPTION-M)**

The Input Map Window allows assignment of MIDI channels for each device to a different range, Instrument, and/or sequence. For more information, see Chapter 34: The Input Map Window on page 325.

**MIDIKEYS WINDOW (OPTION-K)**

The MIDIKeys Window allows events generated from a MIDI controller to map to virtually any computer key combination. For more information, see The MIDIKeys Window (pg. 171).

**FADERS WINDOW (OPTION-F)**

Vision supports up to 800 faders, the first 32 of which are accessed through the Faders Window. Faders can be set to send any MIDI controller (other than pitch bend or aftertouch) or perform a velocity scale on any Instrument. One fader can control the tempo. For more information, see Chapter 37: The Faders Window on page 343.
PART 7: Menus

CONSOLE WINDOWS

The 668 faders not controlled by the Faders Window are accessed through the Console Windows. For more information, see Chapter 38: The Console Windows on page 351.

CONTROL BAR (OPTION-A)

The Control Bar contains the major controls for Vision. It’s normally located just below the application menu bar. For more information, see Chapter 23: The Control Bar on page 183.

COUNTER

Choose this menu item to open the Counter Window. This window provides a much larger display of the Control Bar’s Counter.

Use the menu in the Counter Window to specify the displayed font, and which time formats (bar/beat/unit, absolute SMPTE, or relative SMPTE) are used.

To make the Counter Window larger or smaller, simply resize it like any other normal Macintosh Window.

For more information, see The Counter (pg. 191).

RECORD MONITOR (OPTION-W)

Choose this menu item to open the Record Monitor Window.

NOTE: Your Record Monitor Window may look different depending on your particular the audio hardware.

Use the Record Monitor Window to record digital audio. For details, consult your Audio Reference Manual.

INPUT EFFECT

The Input Effect Window processes notes from your MIDI controller. Depending on the mode of the Input Effect, the processed notes are either repeated or arpeggiated. For more information, see Input Effect Window (pg. 115).
CHAPTER 46: The Windows Menu

PLAYERS & QUEUE

With the Players & Queue Window you can “queue up” several sequences to audition a playback order, and you can even have multiple sequences playing at the same time on different “Players.” For more information, see Players & Queue Window (pg. 113).

SETTINGS

The Settings Window contains preference settings for a number of different editing and display options. For more information, see Chapter 35: The Settings Window on page 331.

MMC

The MMC Window lets you control MIDI Machine Control devices from Vision. For more information, see Chapter 39: The MMC Window on page 375.

QUICKTIME MOVIE

Use the QuickTime Movie Window to open and play QuickTime movies in sync with your Vision sequences. For more information, see Chapter 40: The QuickTime Movie Window on page 385.
CHAPTER 47: The Help Menu

In addition to the Apple Help items and All Notes Off command, there are several Vision help screens accessible from the Help menu.

<table>
<thead>
<tr>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>About Balloon Help...</td>
</tr>
<tr>
<td>Show Balloons</td>
</tr>
<tr>
<td>About Online Help</td>
</tr>
<tr>
<td>MIDI Data Flow</td>
</tr>
<tr>
<td>Studio Vision Files</td>
</tr>
<tr>
<td>Generated Sequences</td>
</tr>
<tr>
<td>Sequences and Segments</td>
</tr>
<tr>
<td>✔ Popup Help</td>
</tr>
<tr>
<td>All Notes Off</td>
</tr>
</tbody>
</table>

Figure 46.1: Help menu

VISION FILES

This command displays basic information about Vision files and what gets saved with them. For more information, see Chapter 19: What's Saved Where.

GENERATED SEQUENCES

This command displays some basic information about generated sequences. When you have finished reading one window, click in the window to display the next page. For more information, see Chapter 14: Generated Sequences.

SEQUENCES AND SEGMENTS

This command displays general information about sequences and segments—for example, how to chain existing sequences to make song structures, and how to turn existing track material into segments for looping.

For details, see Chapter 13: Segments, Loops, and Sequence Events.
POP-UP HELP

If you check this option, Vision's online help screens stay up until you click the mouse. For details, see Vision On-Screen Help (pg. 16).

ALL NOTES OFF (!)

This command sends note-off messages for all 128 notes on all Instruments. It also turns off all sustain pedals and centers pitch bend.
INDEX

A
Absolute SMPTE
   Graphic window menu 238
   List window menu 272
   Notation window menu 282
   Pulse window menu 231
Add (Select & Modify) 126
Add Amount tool, Strip Chart 244
Add Bank (Patches menu) 318
Add Line
   (Input M ap window menu) 328
Add Line to Instrument
   Instruments window menu 300
Add Mode (in Patches menu) 317
Adding to selection 120
Aftertouch
   in Strip Chart 253
   inserting in List Window 266
   poly aftertouch in Strip Chart 253
Aftertouch Sets Effect Velocity
   in Real-Time 335
All Instruments In Use
   building Console from 364
All Notes Off command 448
Always Make from Studio Setup 300
Always use current patches 309
Appearance
   Fader Slots in Instrument Color 336
   Window Background 336
Arpeggiator
   with Input Effect 115
Arranging and mixing 85
Arranging sequences 85
   example 85
Arrow tool 57
   selecting blocks in Track Overview 216
Assign GM equivalents to all patches 319
Assigning key commands 170
Attribute conditions for select 122
Attribute types for select 122
Audio edits occur...
   in Real-Time 335
Audio Events
   inserting in List Window 264
Audio Instruments
   building Console from 365
Audio Instruments In Use
   building Console from 365
Audio Instruments Window 442
Audio Pan
   in Strip Chart 254
   inserting in List Window 266
Audio Sends
   in Console Window menu 356
Audio Volume
   in Strip Chart 254
   inserting in List Window 266
Auto Map (Select & Modify) 135
Auto Map transpose 135
Auto Remappings dialog 432
Auto Scroll
   Graphic window menu 237
   List window menu 272
   Notation window menu 281
   Pulse window menu 231
Auto Scroll Top Window Only
   in Settings>Editing 333
Automatically number patches in bank 319
Automatically Remove Unused Segments 93,
98
Automation submenu
   in List Window 266
   in Strip Chart 254
Auto-open this dialog when needed
   in Undefined Channels 431

B
B0 B32 PC 264
B0 PC 264
B32 PC 264
Bank 305
Bank Select 264, 319
Bank Select/Numbering
  0-127 319
  1-128 319
  A11-B88 319
Assign GM equivalents to all patches 319
Automatically number patches in bank 319
  in Patches menu 319
Prefix 319
Bar/Beat/Unit
  fields, editing with Markers pop-up 28
  fields, typing into 28
  Graphic window menu 237
  Notation window menu 281
  Pulse window menu 231
Barline thru System 287
Bars per Line 286
Base
  in Input Map window 326
Begin Record toggle 32, 190
  Countoff 191
  Wait for Note 190
Blocks 62
Blocks mode, Track Overview 214
Build Console From
  All Instruments In Use 364
  Audio Instruments 365
  Audio Instruments in Use 365
  Enabled Rewire Channels 365
  in Console Window menu 363
  MIDI Instruments In Use 365
  Selected Tracks’ Instruments 364
Change Duration (Select & Modify) 124
Change Release Velocity (Select & Modify) 124
Change Tempo command 422
Change Tempo dialog 139
Change Value (Select & Modify) 124
Change Velocity (Select & Modify) 124
Changing (Select & Modify) 126
Changing controller values
  in Select & Modify Window 126
Changing note durations
  in Notation window 278
Channel column
  in Names Window 307, 310
Channel Width
  and remote devices 360
  in Console Window menu 355
  Narrow 356
  Wide 356
Channels
  showing all in the Names Window 313
Choose 5
Chromatic (Select & Modify) 134
Chromatic transpose 134
Clean Tempo Display
  in Settings>Editing 334
Clear All
  Input Map window menu 328
Clear Beat/Unit when Entering Bar
  in Settings>Editing 333
Clear Clip & Undo 301
Clear command 408
Clear Console
  in Console Window menu 365
Clear Name List
  in Patches menu 317
Clear Subscription 312
Click in Countoff Only command 437
Click in Play command 437
Click in Record command 437
Click track
  for Reclock 142
Clone command 411
Close All command (in File menu) 400
Close command 400
Close Window command 400
Cntls 320
     in Patch Name Editor 315
Colors 432
     for Instruments 294
     initializing 301
Columns
     re-ordering 23
     resizing 23
Combine Tracks command 413
Commands Window 169
     Commands section 169
     Digits section 169
Commands Window menu 170
Comments
     in Sequences Window 199
     in Tracks Window 210
Compress (Select & Modify) 126
Compress tool
     in Strip Chart 245
Console Layout Templates
     opening 367
     saving 366
Console Name
     in Console Window menu 363
Console strips
     rearranging 371
Console Window menu 355
     Audio Sends 356
     Build Console From 363
     Channel Width 355
     Clear Console 365
     Console Name 363
     EQs 357
     Fader Remotes Enabled 362
     Load Console Layout 366
     Master Instrument 362
     Narrow 356
     Plug-Ins 357
     Save Console Layout 365
     Save Console Layout As 366
     Show All Fader Info 359
     Show Masking Tape 361
     Show Remote Devices 360
     Show Selected Fader Info 357
     Wide 356
Consoles 351
     about 351
     anatomy of 352
     build from 363
     channels 352
     grouping faders 367
     Loading a template 366
     Masking Tape 361
     rearranging audio plug-ins 372
     rearranging strips 371
     saving a snapshot 407
     Saving a template 365
Constant (Select & Modify) 126
Constrain to Scale (Select & Modify) 134
Continuous Trigger
     in Input Map window 327
Control Bar 13, 183
     Begin Record toggle 190
     big green "S" 302
     Counter 191
     Current Patch pop-up 186
     Current Sequence pop-up 184
     Current Track pop-up 184
     Global Instrument Solo Indicator 302
     Marker pop-up 193
     Memory Display pop-up 193
     opening the Names browser 321
     Punch and Loop controls 194
     Record Mode pop-up 183
     Sync pop-up 189
     Tempo Display 192
     Thru Instrument pop-up 184
     transport controls 187
     Window buttons 196
Control names
Index

default 320
Controller
  Show Selected Fader Info 358
Controller events
  changing values 126
  in Strip Chart 253
  inserting in List Window 266
  reassigning 127, 418
  Set Density 127
  thinning in Strip Chart 245
Controllers
  Favorite Controllers 336
Controllers to notes
  in Substitute window 420
Controls
  for looping 194
  for punching 194
  for sequences 53
  for tracks 54
  for tracks, Graphic window 55
  for tracks, List window 55
Copy command 407
Copy Faders command 89, 347, 407
  example 89
  inserts Mute/Solo events 347
Copy Name List
  in Patches menu 316
Copy Patches command 88, 421
Copy Subscription 312
Copying
  blocks in Track Overview 63
  fader values 89, 347, 407
  patch events 88, 421
Copyright
  in Strip Chart 251
Counter Window 444
Counter, Control Bar 191
Countoff in Play command 438
Countoff mode, Begin Record toggle 32, 191
Cue Points
  in Strip Chart 252
Current Page 287
Current Patch pop-up 186
Current Sequence pop-up 184
Current Track pop-up 184
Cursor Display 37, 58, 215
  SMPTE 215
Cursor Quantize 37, 58
Cursor tools 57
Custom Instruments 177
  in overflow mode 179
  layered 177
  splits 178
Cut command 406

D
Default Edit Window
  in Settings>Editing 334
Default Modes
  in Patches menu 318
Define Middle C
  in Settings>Editing 334
Delete (Select & Modify) 125
Delete command 412
Delete Selected Time command 412
  vs. Cut command 406
Delete Template
  Select & Modify Window menu 125
Deleting
  Instruments, Clear Clip & Undo 301
  selected time 412
  tracks 412
Density
  in Strip Chart 256
  in Strip Chart & Nudge 332
Detailed Track Overview 220
Device column
  in Names Window 307
Device Mode Column 310
Diatonic (Select & Modify) 134
Diatonic transpose 134
Display modes
  for Note Grid 225
  for Track Overview 214
Drum note line columns
re-ordering 23
resizing 23
Drum Note lines 224
Play Quantize settings 225
rearranging 225
removing 225
re-ordering with move cursor 22
selecting 225
selector dots 22
using Separate Multi Track 225

Drum tracks 11, 223
see also Pulse window
Drum Track column 55
playback notes 223
toggle 207

Duration
cursor 60
editing in Strip Chart 249
in Insert Note window 332
in Select & Modify 122

E
Edit Custom Setup
in OMS MIDI Setup 430

Edit menu 405
Capture Sequence 414
Clear 408
Clone 411
Combine Tracks 413
Copy 407
Copy Faders 407
Delete 412
Delete Selected Time 412
Get Times from Clipboard 411
Insert 411
Insert Blank Time 411
Insert Clipboard 409
Make Segment/ Loop 415
Merge 409
Move Events 413
New Record Track 416

Do menu 417, 418
Change Tempo 422
Copy Patches 421
Insert Bar Marker 422
Insert SMPTE Marker 423
Modify 418
Mute submenu 426
Nudge submenu 425
Play from Selection 423
Play Selection 423
Quantize Selection 421
Reassign 418
Reclock 422
Reverse Time 422
Scale Time 422
Select & Modify 421
Select All 424
Select by Rule 423
Select Duplicates 425
Select Split Notes 424
Set Instrument 418
Substitute 419
Transpose 418

Window submenu 417

Drum note line columns
re-ordering 23
resizing 23
Drum Note lines 224
Play Quantize settings 225
rearranging 225
removing 225
re-ordering with move cursor 22
selecting 225
selector dots 22
using Separate Multi Track 225

Drum tracks 11, 223
see also Pulse window
Drum Track column 55
playback notes 223
toggle 207

Duration
cursor 60
editing in Strip Chart 249
in Insert Note window 332
in Select & Modify 122

E
Edit Custom Setup
in OMS MIDI Setup 430

Edit menu 405
Capture Sequence 414
Clear 408
Clone 411
Combine Tracks 413
Copy 407
Copy Faders 407
Delete 412
Delete Selected Time 412
Get Times from Clipboard 411
Insert 411
Insert Blank Time 411
Insert Clipboard 409
Make Segment/ Loop 415
Merge 409
Move Events 413
New Record Track 416

Do menu 417, 418
Change Tempo 422
Copy Patches 421
Insert Bar Marker 422
Insert SMPTE Marker 423
Modify 418
Mute submenu 426
Nudge submenu 425
Play from Selection 423
Play Selection 423
Quantize Selection 421
Reassign 418
Reclock 422
Reverse Time 422
Scale Time 422
Select & Modify 421
Select All 424
Select by Rule 423
Select Duplicates 425
Select Split Notes 424
Set Instrument 418
Substitute 419
Transpose 418

Window submenu 417

Drum note line columns
re-ordering 23
resizing 23
Drum Note lines 224
Play Quantize settings 225
rearranging 225
removing 225
re-ordering with move cursor 22
selecting 225
selector dots 22
using Separate Multi Track 225

Drum tracks 11, 223
see also Pulse window
Drum Track column 55
playback notes 223
toggle 207

Duration
cursor 60
editing in Strip Chart 249
in Insert Note window 332
in Select & Modify 122

E
Edit Custom Setup
in OMS MIDI Setup 430

Edit menu 405
Capture Sequence 414
Clear 408
Clone 411
Combine Tracks 413
Copy 407
Copy Faders 407
Delete 412
Delete Selected Time 412
Get Times from Clipboard 411
Insert 411
Insert Blank Time 411
Insert Clipboard 409
Make Segment/ Loop 415
Merge 409
Move Events 413
New Record Track 416
Paste 407
Redo 405
Repeat Paste 410
Separate Multi Track 413
Undo 405
Unmake Sequence Event 415
Edit Points 66
Edit Selected Patch
  in Names browser menu 323
Edit windows 14
Ruler 59
Editing
  Auto Scroll Top Window Only 333
    basic procedures 57
    changing pitches without rhythms 420
  Clean Tempo Display 334
  Clear Beat/Unit when Entering Bar 333
  commands you cannot undo 405
  Cursor Display 58
  Cursor Quantize 58
  cursor tools 57
  Default Edit Window 334
  Define Middle C 334
  dragging blocks in Track Overview 217
  durations in Strip Chart 249
  edit indicators in Ruler 59
  events in List Window 273
  Exact Mode 59
  field values 27
    in Note Grid 228
    in Track Overview 213
    making music fit on a page 286
  M et er track 210
  M odify Window Option 334
    music recorded without a metronome 142
    note properties with mouse 60
    note velocities in the Strip Chart 61
    notes in Graphic window 236
    notes in List Window 61
    notes in Notation Window 277
    options in Settings Window 333
    pasting without replacing (merging) 409
    patch names 313
    permanently quantizing track data 74
    permanently shifting track data 77
  Punch Points follow Edit Points 333
  Quantize templates 163
  random editing in Strip Chart 247
  reassigning controller types 127
  relocking to a click track 144
  referenced sequence events 100
  release velocities 273
  rubato performances 144
  segment loop lengths 96
  Select & Modify templates 165
  sequence events 98
  sequence events in List Window 103
  Set Insertion Point to... 333
  setting density of controller values 127
  thinning controllers in Strip Chart 245
  tools 57
  tracks recorded without a metronome 144
  Transpose templates 163
    values with a MIDI controller 27
    velocities in Note Grid 229
    velocities in Strip Chart 249
    while looping 66
    with note edit cursors 60
    working with track blocks 62
    zooming 24
  Enable Input Devices command 429
  Enabled (record mode) 379
  Enabled Rewire Channels
    building Console from 365
  Enabling
    fader receive 428
    input devices 429
    Input Effect 428
    Input Map 428
    Keyboard Thru 427
    MIDIKeys 428
    Record Quantize 428
    send sync 437
Index

in Strip Chart 255
inserting in List Window 268
EQ Band Frequency
in Strip Chart 255
inserting in List Window 268
EQ Band Gain
in Strip Chart 255
inserting in List Window 268
EQ Band Parameter submenu
in List Window 268
in Strip Chart 255
EQ Band Type
in Strip Chart 255
inserting in List Window 268
EQ Band Width
in Strip Chart 255
inserting in List Window 268
EQ Enable
in Strip Chart 255
EQ Enable inserting in List Window 267
EQs
in Console Window menu 357
Erase MIDIKey 173
Error Log
in OMS MIDI Setup 430
Event end times
in List Window 273
Event Type (Select & Modify) 122
Exact Mode 59
Export as MIDI File command 402
Export as QuickTime Movie command 403
Export Audio Events command 404
Export Audio Mix command 403
Export to Clipboard command 403
Exporting
as QuickTime movie 403
audio events 404
audio mix 403
MIDI files 402
to Clipboard 403
Extend MIDIKey 173
External Beat Clock, sync mode
External Beat Clock 434
External ports to use
in OMS MIDI Setup 430
External sync
and Auto Punch 149
and Wait for Note 149
switching to internal automatically 149
F
Factory/General MIDI names 311
fader events
changes 347
Fader Remotes Enabled 358, 360, 428
in Console Window menu 362
Fader Slots in Instrument Color
and Faders Window 344
in Settings>Appearance 336
Fader Values
inserting using Copy Faders 89
Faders
about 343
changes from previous versions 347
controlling the tempo with 138
controlling velocity 346
copying values 347
device assignments 344
enabling external control 428
example (recording, viewing, playing) 348
grouping 367
moving as a group 368
Absolute Fading 368
Proportional Fading 369
Snap Fading 370
remapping MIDI controllers 346
saving a snapshot 407
sliders 344
Tempo Fader Range 345
the new way 348
the old way 348
using (the new way) 348
values 344
Faders Window 344
Index

1 346
17 346
32 346
display modes 346
Rcv 345
Send 345
Send/Receive settings 345
tempo fader 344
Favorite Controllers
  in Settings>Controllers 336
File menu 397
  Close 400
  Close All 400
  Close Window 400
  Cut 406
  Export as MIDI File 402
  Export as QuickTime Movie 403
  Export Audio Events 404
  Export Audio Mix 403
  Export to Clipboard 403
  Import Audio 403
  Import Audio Using QuickTime 403
  New 397
  Open 398
  Page Setup 404
  Print 404
  Print Preview 404
  Quit 404
  Revert 402
  Save 400
  Save a Copy As 401
  Save As 400
  Save As Setup 401
Find Patch 313
Finding soloed instruments 303
Fine Controller Values
  in Settings>Controllers 336
  in Strip Chart 254
Fitting music
  to bars 422
  to click track 142
Free shape
  in Strip Chart 246
Font
  changing in Print Preview 288
G
Gated
  in Input Map window 327
  Sequence Event 104
Generated sequences
  about 107
  Attack mode 109
  creating 108
  Duration mode 110
  looping 112
  Note track 111
  Order mode for tracks 112
  Rhythm track 111
Get Times from Clipboard command 411
Global Instrument Solo Indicator 186
  blinking 302
  lit 302
GM Equiv column
  in Patch Name Editor 315
Go Back
  Patch names 324
Grand Staff 288
Graphic mode, Note Grid 226
Graphic window 233
  Changing a Note's Duration 236
  clicking to select 234
  I-beam tool 234
  Marquee tool 234
  modifying notes 39, 236
  Moving Notes 236
  pencil tool 39
  selecting a pitch range 235
  selecting a time range 234
  track controls 55
  Transposing Notes 236
  viewed Instruments 238
Index

X events 233
Graphic window menu
  Absolute SMPTE 238
  Auto Scroll 237
  Bar/Beat/Unit 237
  Jump to Selection 237
  Play Edited Note 239
  Relative SMPTE 238
  Set Default Location 238
  Show Piano keyboard 239
  Show Vertical Line 239
Tools 237
View 238
Zoom Back 237
Zoom to Fit 237
Grid Quantize 69
  parameters 130
Groove Quantize 70
  applying to a track region 75
  example 75
  making your own grooves 167
  parameters 133
Grooves file 167
Grouping faders 367

H
Hand cursor
  scrolling with 25
Harmonize 82
Harmonize button (Select & Modify) 124
Help menu 447
  About Online Help 447
  All Notes Off 448
  Generated Sequences 447
  MIDI Data Flow 447
  Pop-up Help 448
  Sequences and Segments 447
  Vision Files 447
Help, online 16
Hide
  Note Grid 221
  Track Overview 204

I
I-beam tool 57
  in Graphic Window 234
  in Notation Window 277
  in Strip Chart 243
  in Track Overview 216
Import Audio command 403
Import Audio Using QuickTime 403
Importing QuickTime movies 385
In Point field 195
Info area
  in Pulse window 222
  in Tracks Window 205
  Play Quantize settings 72
  sequence event parameters 96
Information toggle 54, 212
Initialize Colors 294, 301
Input Channel
  in Input Map window 325
Input Device
  in Input Map window 325
Input Effect
  Arpeggiate 115
  duration 116
  recording with 117
  Repeat 115
  spacing 116
  with Grid or Groove Quantize 116
Input Effect Enabled command 428
Input Effect MIDIKey 173
Input Effect Window 115
Input Map
  and Trigger modes 327
  enabling/ disabling 327
  keyboard splits 329
  multi-channel recording 329
  multiple Keyboards 329
  triggering sequences 326
  when to use 328
Input Map Enabled command 428
Input Map window 325
  Base 326
Index

Continuous Trigger 327
Gated 327
Input Device and Channel 325
input lines 325
Player 326
Range 325
Sequence 326
Thru/Trigger 326
Transpose Mode 326
trigger 327
trigger modes 327
Input Map window menu 327
Add Line 328
Clear All 328
Input Map Enabled 327
Load From 328
Make One Line per Channel 328
Remove Line 328
Insert
+ Sequence Event 104
Gated Sequence Event 104
Stop Sequence 104
Transpose (Sequence Event) 104
Insert Bar Marker command 422
Insert Blank Time command 411
Insert Clipboard command 409
Insert command 411
Insert into track
in Repeat Paste 410
Insert Note
Spacing 331
Insert Note window
duration 332
velocity 332
Insert SMPTE Marker command 423
Inserting
bar markers 422
blank time 411
Clipboard 409
events in List Window 263
notes in List Window 263
notes with Magic Drumstick tool 40, 227
patch events in List Window 264
patch events in Strip Chart 251
sequence events in List Window 103, 270
SMpte markers 423
tracks 411
velocities in Pulse window 227
see also List window
Installation 3
Instrument
Show Selected Fader Info 358
Instrument (Select & Modify) 122
Instrument pop-up 55
Instruments 293
and multi-tracks 413
and OMS Studio Setup 299
assigning in Tracks Window 208
color 294
creating splits 178
custom 177
customizing colors 294
drum instruments 295
finding soloed Instruments 302
finding soloed instruments 303
Global Instrument Solo Indicator 186
in Strip Chart 251
initializing colors 294
key range 298
Layered mode 177, 296
Make from Studio Setup 300
Mono mode 297
multi-line Instruments 296
muting and soloing 294
naming 294
naming vs. using Masking Tape 361
output channel (Chan) 297
output device 297
Overflow mode 179, 296
remapping 431
re-ordering with move cursor 22
selecting unused 301
selector dots 22
setting 418
simple transposing 298
Thru Instrument pop-up 184
transpose 295
transpose maps 295
transposing 83
unsoloing all 303
velocity fader 298
Velocity Scale 297
Velocity Scale % 298
Instruments button 186
Instruments window 293
names 294
opening with Instruments button 186
Instruments window menu 299
Add Line to Instrument 300
Clear Clip & Undo 301
Initialize Colors 301
New Instrument 299
Remove Line from Instrument 300
Select Unused Instruments 301
Show Use of Selected Instruments 301
Internal (sync mode) 434
Internal Click (metronome sound) 437
Interval (Select & Modify) 134
Interval transpose 134
Invert (Select & Modify) 135
Invert transpose 135
is (Select & Modify) 122
is from... thru (Select & Modify) 122
is not (Select & Modify) 122
is not from... thru (Select & Modify) 122
is... or (Select & Modify) 122
is... or less (Select & Modify) 122
is... or more (Select & Modify) 122
Jump to Selection
Graphic window menu 237
List window menu 272
Notation window menu 281
Pulse window menu 231
K
Keep (Patch names) 324
Keep Sequences End-to-End 99, 262
Keep using these patches 309
Key equivalents
for commands, reassigning 169
for sequences 198
Key range
for Instruments 298
key signature changes
in Meter track 210
in Notation window 279
inserting in List window 271
Key/Scale (Select & Modify) 135
Key/Scale transpose 135
Keyboard Splits
with Input Map 329
Keyboard Thru command 427
Layered 296
Legato tool, Strip Chart 244
List window 261
see also inserting
Automation submenu 266
editing notes 61
EQ Band Parameter submenu 268
inserting Aftertouch 266
inserting Audio Events 264
inserting Audio Pan 266
inserting Audio Volume 266
inserting Controller events 266
inserting EQ Band Enable 268
inserting EQ Band Frequency 268
inserting EQ Band Gain 268
inserting EQ Band Type 268
inserting EQ Band Width 268
inserting EQ enable 267
inserting key changes 271
inserting markers 271
inserting meter changes 270
Index

inserting MIDI events 265
inserting Mute events 267
inserting Notes 263
inserting patch events 264
inserting phase invert events 267
inserting pitch bend 265
inserting plug-in bypass events 267
inserting Poly aftertouch 266
inserting send level events 267
inserting sequence events 270
inserting solo events 267
inserting system exclusive events 269
inserting tempo changes 271
inserting text-type events 265
inserting Velocity Scale events 266
Meter track 270
moving events 274
Plug-in Parameter submenu 268
re-ordering simultaneous events 274
sequence events 103
showing event durations 273
showing release velocities 273
Tempo track 271
track controls 55
track lengths 55
viewed events and Instruments 272
List window menu 271
Absolute SMPTE 272
Auto Scroll 272
Jump to Selection 272
No SMPTE 272
Play Edited Note 273
Relative SMPTE 272
Set Default Location 272
Show Event Durations 273
Show Event End Times 273
Show Release Velocities 273
View 272
Load Console Layout
in Console Window menu 366
Load From
Input Map window menu 328
Select & Modify Window menu 125
Local Sequence Times command 100, 439
Locator buttons 189
Lock Audio to Tape 434
Lock Event SMPTE Times 263
Lock to Timing
and SMPTE offsets 392
in QuickTime Movie window menu 389
Locking track and sequence lengths 206
Loop
editing (example) 66
in Make Segment/Loop 415
recording 35
toggle 194
Looping
and editing 66
generated sequences 112
in the middle of a track 95
loop indicators in Ruler 59
sequences 207
track regions with segments 95
tracks 207
Lyrics
in Strip Chart 251
inserting in List Window 265
M
Magic Drumstick tool 40, 57
inserting notes in Pulse window 40
Make Current 312
Don't Make Current 312
Patch names 323
Send the patches 312
Make from Studio Setup 300
Make One Line per Channel
Input Map window menu 328
Make one segment with multiple tracks 87, 94
Make Segment/Loop 86, 94, 415
Loop 415
Make single-track segments 415
Name 415
Start/End 415
M anual
   conventions 5
   how to use this manual 4
   organization 4
M anual Map (Select & Modify) 136
M anual Map transpose 136
M argin
   zooming in the 25
M arker pop-up 193
M arkers 211
   bar markers 422
   in Strip Chart 250
   inserting in List window 271
M arker pop-up 193
   merging as text 409
   Next M arker button 188
   Previous M arker button 188
   SMPTE markers 423
M arkers Break Blocks 63, 214
M arquee tool 57
   extending selection 64
   in Graphic window 234
   in Notation Window 276
   in Track Overview 216
   selecting with 63
M asking Tape 361
   in Consoles 361
   vs. naming Instruments 361
M aster Instrument
   in Console Window menu 362
M aster Tempo display 192
M atrix mode, Note Grid 226
M ax Limit to (Select & Modify) 126
M ax Limit tool
   in Strip Chart 244
M aximum Fader Position
   and Faders Window 344
M aximum Playable Tracks
   in Real-Time 336
M emory display 193
M enus
   window specific menus 26
M erge command 409
M erge markers as text 409
M erge with track
   in Repeat Paste 410
M eter
   changing in Notation window 279
   meter vs. meter track 53
M eter changes
   inserting in List window 270
M eter track
   constant vs. changing meter 210
   in List Window 261
   in List window 270
   in Tracks Window 210
   switching to in the List Window 20
M etronome Sound dialog 437
MIDI
   about 7
   common misconceptions 9
   terminology 8
MIDI Beat Clock
   Enable (in Sync Options) 435
   Send Sync Device(s) 436
MIDI column
   in Patch Name Editor 314
MIDI files
   about 399
   exporting 402
MIDI Instruments In Use
   building Console from 365
MIDI Machine Control
   MMC Window 375
   real-world example 381
   setting up a device 375
   sync mode 434
   with Tascam DA-88 381
MIDI submenu
   in List Window 265
   in Strip Chart 252
MIDI Time Code
Index

Enable (in Sync Options) 435
MIDI Time Code (MTC) 434
MIDIKeys
defining 174
drum machine-style loop recording 45
enabling 174
for sequences 199
special 172
MIDIKeys Enabled command 428
MIDIKeys Window 171
MIDIKeys Window menu 174
MIDIShift MIDIKey 173
M in Limit to (Select & Modify) 126
M in Limit tool
in Strip Chart 244
Mix settings, saving 89
MMC
real-world example 381
MMC Communications Setup
in MMC window 377
MMC window 375
anatomy of 375
Enabled (record mode) 379
MMC Communications Setup 377
Num 378
PreRoll 378
Rec Tracks (Track Enable Buttons) 378
Rehearse (record mode) 380
Reset Debug Logs 378
Safe (record mode) 380
Test device 377
transport controls 376
MMC Window menu 380
Reset MMC System 380
MMC, sync mode
MTC/ Machine Control 434
Mode 306, 307
Mode Name
in Patches menu 318
Modify command 418
Modify types 124
Modify Window Option
in Settings>Editing 334
Modifying note properties
in Select & Modify Window 126
Mouse
editing notes with 60
scrubbing with 26
zooming with 25
Move (Select & Modify) 124
Move Amount
in Strip Chart & Nudge 332
Move cursor 22, 60
with multiple items 22
Move Events command 77, 413
Moving
barlines to fit notes 144
blocks in Track Overview 63, 217
events in List Window 274
events with Move command 413
notes in Notation window 278
rearranging Instruments in window 22
rearranging lines in Pulse window 22
rearranging sequences in window 22
rearranging tracks in window 22
Moving columns 23
MTC/ Machine Control
in Sync Options 434
Multi-channel recording 46
example 48
with Input Map 329
Multi-line instruments 296
Multiple Keyboards
and Input Map 329
Multiple Pulse windows 230
Multiple tracks
in Notation Window 21
in Strip Chart 257
Multi-tracks
reassigning Instruments 208
Mute column 54
Mute command 426
Mute events
in Strip Chart 254
inserted with Copy Faders command 347
inserting in List Window 267
Mute QuickTime Audio
in QuickTime Movie window menu 389
Mute submenu
Mute Seq & Audio Events 426
Toggle Mutes 426
Unmute Seq & Audio Events 426
Muting
Instruments 294
sequence events 97
tracks 54, 206
tracks vs. instruments 295

N
Name
in Make Segment/Loop 415
Name Setup 306
Name Setup control
in Names Window 307
Names
Instruments 294
Patch Name Provider 306
Names browser 321
By name 321
By number 321
General MIDI groups 321
grouping 321
menu 322
Names browser menu
Edit Selected Patch 323
Show Patches In All Selected Group(s) 323
Show Patches In Any Selected Group(s) 323
Sort By Name 323
Sort by Number 323
Names menu 311
Show Channels 310
Names Window 305
see also Patch Names
always use current patches 309
anatomy of 307
Channel column 307, 310
control names 320
current patch name documents 309
Device column 307
Device Mode column 307, 310
Keep using these patches 309
missing patch name documents 309
Name Setup control 307
Names menu 311
note names 320
opening with Patch button 187
Patch Name Document column 307, 308
Patch Name Editor 314
Patches menu 316
subscribing 308
Use Factory/General MIDI Names 308
Names Window menu
Clear Subscription 312
Copy Subscription 312
Don’t Make Current 312
Find Patch 313
Make Current 312
New Patch Document 312
Open Patch Document 313
Paste Subscription 312
Send Patches to Device 313
Send the patches 312
Show Channels 313
Tell patch Provider 313
Use Current Instead 312
View/Edit Patch Names 312
Naming
Instruments 294
sequences 198
tracks 206
Narrow (Channel Width) 356
Navigation techniques 19
Nested
loops, from pasting 410
sequence events 101
New command 397
Index

New Drum Track 223, 230
New Easy Setup
  in OMS MIDI Setup 430
New Instrument
  Instruments window menu 299
New Patch Document 312
New Record Track command 416
Next Marker button 188
No SMPTE
  List window menu 272
Non-Continuous Events
  in Strip Chart 248
Notation
  and swing 291
  avoiding ledger lines 291
  octave shift 290
  troubleshooting 291
Notation Resolution 280
Notation terms
  Grand Staff 288
  part 289
  system 289
  voice 289
Notation tips
  changing track order 289
  shifting by octaves 290
Notation troubleshooting
  extra rests 291
  fitting on a page 291
  ledger lines 291
  looking good vs. sounding good 292
  notes tied together 292
  other applications 292
  printing off the page 291
  printing problem dialog box 291
  single staff 292
  swing eighth notes/triples 291
  too many voices 291
Notation Window 275
  changing key 279
  changing meter 279
  changing note durations 278
  changing track order 21
  getting rid of rests 279
  inserting notes with Pencil tool 38
  meter changes 279
  modifying notes 277
  Moving Notes 278
  multiple tracks 21
  Notation resolution 280
  octave selections 290
  resolution 280
  selecting a pitch range 277
  selecting a time range 277
  selecting tracks in 275
  shifting octaves 280
  showing and hiding tracks 21
  Transposing Notes 278
  viewed Instruments 282
Notation window menu 281
  Absolute SMPTE 282
  Auto Scroll 281
  Bar/Beat/Unit 281
  Jump to Selection 281
  Play Edited Note 283
  Relative SMPTE 282
  Set Default Location 282
  Show Vertical Line 283
  Tools 281
    View 282
    Zoom Back 281
    Zoom to Fit 281
Note edit cursors 60
  in Graphic window 236
  in Notation Window 277
  in Pulse Window 228
Note Grid 225
  Display modes 225
  editing notes in 228
  Graphic mode 226
  Matrix mode 226
  showing/hiding 221
  toggle 221
Note names
Index

default 320
Note Names window 320
Notes
  editing durations in Strip Chart 249
  editing velocities in Strip Chart 249
  inserting in List Window 263
  modifying in Graphic window 236
  modifying in Notation Window 277
  modifying in Note Grid 228
Notes column
  in Patch Name Editor 315
Nudge
  Down 425
  Earlier 425
  in Pulse window 229
  Later 425
  Up 425
Nudge command 425
Nudging
  events forward or back in time 78
  pitches up or down 80
Num
  in MMC window 378
Number column
  in Patch Name Editor 314
Number of Pages 287
Numericals, editing values 27

O
Oct (transposing Instruments) 298
Octave Map (Select & Modify) 135
Octave Map transpose 135
Octave shift 280
Octaves (Select & Modify) 134
Off/ Speed/ Start 54
Offset, SM PTE 54, 212
OM S
  about 11
  OM S Studio Setup 11
  opening current Studio Setup 430
  Studio Setup document 156
OM S MIDI Setup dialog 430
OM S Studio Setup 430
  and Instruments 299
Online help 16
Opcode
  contacting 4
  software registration 3
Open command 398
Open Music System
  see OM S
Open Patch Document 313
Open Windows pop-up 21
Opening
  Console Layout Templates 367
  MIDI Files 399
  QuickTime movies 385
  Use Setup Instruments 399
  What to Open 398
Options menu 433
  Click in Countoff Only 437
  Click in Play 437
  Click in Record 437
  Countoff in Play 438
  Local Sequence Times 100, 439
  Metronome Sound 437
  Real Time Capture 438
  Send Sync Enabled 437
  Stop at Punch Out 438
  Sync Options 433
Opts menu 99, 262
  Keep Sequences End-to-End 99, 262
  Lock Event SMPTE Times 263
Song Track 99, 262
Oscillating (Select & Modify) 127
Oscillator shapes
  Strip Chart 247
  Waveform Period 248
Out Point field 195
output channel (Chan)
  Instruments 297
output device
  Instruments 297
Overdub (record mode) 31
Overview 296

P
Page Properties 285
Page Setup command 288, 404
Parabola shape
  Strip Chart 246
  part 289
Paste command 407
Paste Name List
  in Patches menu 317
Paste over track
  in Repeat Paste 410
Paste Subscription 312
Pasting
  MIDI data 408
  nested loops 410
  sequences 408
  tracks 408
Patch 305
Patch button 187
Patch change types 264
Patch column
  Tracks window 88
Patch events
  and Tracks Windows 209
  copying 88
  inserting in List Window 264
  inserting in Strip Chart 251
  inserting in Tracks window 88
  inserting using Copy Patches 88
  placement 89
  saving 88
Patch Name column
  in Patch Name Editor 314
Patch Name Document column
  in Names Window 307, 308
Patch Name Documents
  current 306, 309
  editing 311
  missing 309
  where to find 308
Patch Name Editor
  Cntls 315
  GM Equiv 315
  MIDI column 314
  Notes 315
  number column 314
  opening Control Names window 320
  opening Note Names window 320
  Patch Name column 314
  Program Selector Dot 315
Patch Name Provider 306
Patch names
  see also Names Window
  about 12
  bank definition 305
  bank select 319
  Browser Window 321
  Change 324
  default control names 320
  default note names 320
  document 306
  Don't Make 324
  Don't Send 324
  editing 313
  Factory/General MIDI names 311
  Go Back 324
  grouping 321
  Keep 324
  Make Current 323
  Mode 306, 307
  mode examples 306
  Name Setup 306
  patch definition 305
  Send 324
  subscribing 311
  terminology 305
Patch popup
  Tracks window
  patch popup 55
Patches menu
  Add Bank 318
  Add Mode 317
Bank Select/ Numbering 319
Clear Name List 317
Copy Name List 316
Default Modes 318
Mode Name 318
Paste Name List 317
Remove Bank 318
Remove Mode 317
Save 316
Save As 316
Saving Note/ Control Names 316
Pause button 188
PC (program change) 264
PC PC 264
Pencil tool 37
click-dragging with 39
in Notation Window 38
in Pulse Window 227
in Strip Chart 243
inserting notes with 37
painting notes with 39
Phase Invert events
in Strip Chart 255
inserting in List Window 267
Phrase 62
Phrases mode, Track Overview 214
Pickup measures 212
Pitch (Select & Modify) 122
Pitch Bend
in Strip Chart 252
inserting in List Window 265
Play Edited Note
Graphic window menu 239
List window menu 273
Notation window menu 283
Pulse window menu 232
Play from Counter button 188
Play from Selection command 423
Play from Start button 187
Play Quantize 72
Drum Note lines vs. drum tracks 225
enabling 56, 72
settings 55
settings for sequence events 98
Play Selection command 423
Play Shift 73
enabling 56, 73
Player
in Input Map window 326
Players 113
and sequence events 97
and Sync mode 114
and Trigger modes 114
stopping 114
Players & Queue Window 113
Playing
from selection 423
Play from Counter button 188
Play from Start button 187
selection 423
with the Command key 26
Plug-in Bypass events
in Strip Chart 255
inserting in List Window 267
Plug-in Parameter submenu
in List Window 268
in Strip Chart 256
Plug-Ins
in Console Window menu 357
Poly aftertouch
in Strip Chart 253
inserting in List Window 266
Pop-up fields, selecting from 27
Position (Select & Modify) 122
Position in bar (Select & Modify) 122
Position in beat (Select & Modify) 122
Position in every group (Select & Modify) 122
Position is between bracketed events (Select & Modify) 122
Prefix
in Bank Select/ Numbering 319
PreRoll (in MMC window) 378
Preserve options
in Substitute window 420
Previous Marker button 188
Print command 404
Print Preview
  adding text to a page 288
  Barline thru System 287
  bars per line 286
  changing font 288
  Current Page 287
  margins 286
  Number of Pages 287
  Show Bar Numbers 287
  Show Page Numbers 287
  staff indentation 286
  staff spacing 286
  System Spacing 286
  systems per page 287
  Title Font 287
  title space 285
  Units of Measurements 287
Print Preview command 404
Print Preview Window 285
  opening 404
Printing
  page properties 285
Program Selector Dot
  in Patch Name Editor 315
Pulse window 221
  see also drum note lines
  see also drum tracks
  adding a new drum track 230
  divider 222
  editing velocities 229
  info area 222
  inserting notes in drum track 40
  Magic Drumstick tool 227
  nudge 229
  opening multiple 230
  Quantize settings 224
  similarities with Tracks window 221
  Strip Chart 222
  velocities of inserted notes 227
  velocity toggle 228
  viewing velocities 228
Pulse window menu 230
  Absolute SMPTE 231
  Auto Scroll 231
  Bar/Beat/Unit 231
  Jump to Selection 231
  New Drum Track 223
  Play Edited Note 232
  Relative SMPTE 231
  Set Default Location 231
  Show Offset Info 232
  Show Vertical Line 232
  Tools 231
  Zoom Back 231
  Zoom to Fit 231
Punch controls 194
Punch Points follow Edit Points
  in Settings>Editing 333
Punch recording 34
Punch toggle 194

Q
Quantize 418
  about 69
  applying 70
  command 74
  duration and velocity (Groove) 133
  durations 132
  enabling Record Quatize 428
  experimenting with 76
  for Input Effect 116
  Grid parameters 130
  Groove (example) 75
  Groove parameters 133
  Groove source 133
  parameters 129
  Play Quantize 72
  Quantize Type pop-up 130
  Quantize Value pop-up 75
  Record Quantize 76
  Record Quantize Source 335
  sensitivity 130
shift 132
shortcuts with Quantize Value pop-up 75
smear 132
strength 130
swing 132
templates 163
value 130
while recording 428
with Grid 69
with Groove 70
Quantize (Select & Modify) 124, 129
Quantize command 74, 421
Quantize Value pop-up 75
Queue mode 113
QuickTime Movie Window 385
anatomy of 387
size of window 391
QuickTime Movie Window Anatomy 387
QuickTime Movie window menu 389
Lock to Timing 389
Mute QuickTime Audio 389
Show SMPTE Counter 390
Show SMPTE Offset 390
Window Size 391
QuickTime movies
exporting 403
importing 385
referencing in Vision 385
scoring with General MIDI module 394
setting SMPTE frame rates 391
SMPTE offsets 392
using (tutorial) 393
Quit command 404

R
Random shape
in Strip Chart 247
Range
in Input Map window 325
Instruments window 298
Tempo Fader 345
Rcv
in Faders Window 345
Real Time Capture command 438
Real-Time
Aftertouch Sets Effect Velocity 335
Audio edits occur... 335
Maximum Playable Tracks 336
Record Quantize Source 335
Silent when Paused 334
Solo Audio and MIDI independently 335
Sustain Audio Across Segments 335
Sustain Notes across Segments 334
System Exclusive Thru 335
rearranging
audio plug-in order 372
Console Strips 371
drum note lines 225
Instruments in Instruments window 22
lines in Pulse window 22
sequences in sequence window 22
tracks in tracks window 22
Reassign (Select & Modify) 124, 127
Reassign command 127, 418
Rec Tracks (Track Enable Buttons)
in MMC window 378
Recalling patch selections 88
Receive sync device 434
Receive sync mode 434
Reclock command 422
Reclock dialog 143
Record
button in sequence info area 97
record-enable track 54
Record button 187
Record Filter dialog 429
Record Indicator button 183
Record Mode 31
pop-up 183
Record mode
Enabled (in MMC window) 379
Rehearse (in MMC window) 380
Safe (in MMC window) 380
Record Monitor Window 444
Record Quantize 76
Record Quantize Enabled command 428
Record Quantize Source
  in Real-Time 335
Record setup 31
Recording
  advanced techniques 45
  Begin Record toggle 32
  choosing what to record 429
  enabling neighboring tracks 416
  from an external sequencer 47
  in real time 33
  in step time 42
In/Out Point fields 195
into a single-track sequence event 97
key equivalents 31
loop recording 35
multi-channel (example) 48
multiple channels from Input Map 329
on multiple channels 46
punch recording 34
Record button 187
Record Mode pop-up 183
record modes 31
Step Window 337
stop at punch out 438
tempo changes 137
Undo command and editing 406
viewing received MIDI 183
while in external sync 149
with an Input Map 47
with Input Effect 117
with metronome 32
with quantize 76, 428
Redo command 405
References for sequences and segments 100
Refining selection 120
Rehearse (record mode) 380
Relative SMPTE
  Graphic window menu 238
  List window menu 272
  Notation window menu 282
Pulse window menu 231
release velocities in List Window 273
Remap all matching channels
  in Undefined Channels 431
Remapping undefined channels 431
Remember remappings to reapply later
  in Undefined Channels 431
Remember these settings in sequence files
  in Sync Options 436
Remote Device
  Show Selected Fader Info 358
Remote Device Channel (Chan)
  Show Selected Fader Info 358
Remote start 434
Remove Bank
  in Patches menu 318
Remove Line
  Input Map window menu 328
Remove Line from Instrument
  Instruments window menu 300
Remove Mode
  in Patches menu 317
Re-ordering columns 23
Re-ordering simultaneous events (in List window) 274
Repeat Paste command 410
Repeated notes
  with Input Effect 115
Replace (record mode) 31
Replace each event...
  in Substitute window 419
Reset Debug Logs
  in MMC Window menu 380
Reset MMC System
  in MMC Window menu 380
resizing
  columns 23
  Strip Chart 258
Reverse Time command 422
Revert command 402
Rubato performances
  editing 144
reclocking 144
Ruler
edit indicators 59
in edit windows 59
loop indicators 59
scaling time in 141
selecting in Track Overview 217
zooming in the 25
Run MIDI in background
in OMS MIDI Setup 430

S
Safe (record mode) 380
Save
in Patches menu 316
Save a Copy As command 401
Save As
in Patches menu 316
Save As command 400
Save as Setup command 401
Save command 400
Save Console Layout 365
in Console Window menu 365
Save Console Layout As
in Console Window menu 366
Save Settings
Select & Modify Window menu 125
Save Settings As
Select & Modify Window menu 125
Saving
a mixer snapshot 89
Console Layouts 365
patch events 88
Save a Copy As 401
Save As 400
Save As Setup 401
volume and pan settings 89
What to Save 400
Sawtooth shape
in Strip Chart 247
Scale
in Strip Chart 244
Scale by (Select & Modify) 126
Scale Time command 422
Scale Time dialog 140
Scaling tempos 139
Scaling time
in the Ruler 141
to fit audio loops 141
Scrolling
with hand cursor 25
Scrubbing
with the mouse 26
with the Shuttle bar 188
Segments
about 93
Automatically Remove Unused Segments 93
differences from sequences 93
looping in the middle of a track 95
looping track regions 95
making 86, 94
references 100
resizing graphically 96
Select 5
Select & Modify
Add 126
attribute conditions 122
attribute types 122
Auto Map 135
Change Duration 124
Change Release Velocity 124
Change Value 124
Change Velocity 124
Changing 126
Chromatic 134
Compress 126
Constant 126
Constrain to Scale 134
Delete 125
Diatonic 134
Double button 124, 125
Drum Map 136
Duration 122
Index

Event Type 122
Harmonize button 124
Instrument 122
Interval 134
Invert 135
is 122
is from... thru 122
is not 122
is not from... thru 122
is... or 122
is... or less 122
is... or more 122
Key/Scale 135
making a selection 123
Manual Map 136
Max Limit to 126
Min Limit to 126
modify types 124
Move 124
Octave Map 135
Octaves 134
Oscillating 127
Pitch 122
Position 122
Quantize 124, 129
Reassign 124, 127
Scale by 126
select attributes 121
Set Density 124, 127
Set Instrument 125
Set Legato to 126
Set to 126
Substitute 125
templates 165
Transpose 124, 134
Trim Start Time 125, 129
Value 122
Velocity 122
Select & Modify Window 119
anatomy of 120
buttons 121
Event Type pop-up 120
Modify Type pop-up 120
Select & Modify Window menu 125
Delete Template 125
Load From 125
Save Settings 125
Save Settings As 125
Templates 125
Select All command 424
Select attributes 121
Select by Rule command 423
Select Duplicates command 425
Select Unused Instruments
Instruments window menu 301
Select/Modify Templates command 421
Selected Tracks' Instruments
building Console from 364
Selecting
a pitch range 65
a time range 64
all 424
another sequence 19
another track 19
by rule 423
complex selections 123
data regions 63
duplicates 425
multiple drum note lines 65
multiple tracks 65
names 321
notes in Graphic Window 234
playing only the current selection 423
sequences 198
split notes 424
tracks 205
tracks in Notation Window 275
unused Instruments 301
with Add To 120
with I-beam tool 64
with Marquee tool 63
with Refine 120
Selector dots 22
Send
in Faders Window 345
Patch names 324
Send Level events
  in Strip Chart 254
  inserting in List Window 267
Send Patches to Device 313
Send Sync Enabled command 437
Send the patches 312
Sending sync 151
Separate Multi Track command 413
  example 49
  with Drum Note lines 225
Seq button 184
Sequence
  in Input Map window 326
Sequence columns
  re-ordering 23
  resizing 23
Sequence events 104
  about 96
  and players 97
  cloning 411
  in List Window 103
  inserting in List Window 103, 270
Local Sequence Times 100, 439
muting 97
nested 101
parameters 96
parent-child relationship 98
recording into single-track 97
resizing graphically 96
step recording 85
sync mode 98
transposing 97
types 103
Sequence information 54
  SMPTE Offset 54
  Start Point 54
  Sync Mode 54
Sequence Length 53
Sequence Loop 53
Sequence Select pop-up 19
Sequence templates 161
Sequence/segment pop-up 97
Sequences
  about 13
  and pickup measures 212
  breaking into segments 86
  capturing 414
  capturing in real time 438
  chaining 85
  controls for 53
  Current Sequence pop-up 184
  duplicating 200
  key equivalents 198
  locking length 206
  looping 207
  MIDI keys for 199
  naming 198
  pasting 408
  references 100, 199
  re-ordering with move cursor 22
  selecting 198
  selector dots 22
  SMPTE offset 54, 212
  Start Point 212
  step recording as sequence events 85
  switching the current sequence 19
  Sync Mode 212
  templates 161
  triggering from Input Map 326
  triggering in real time 113
Sequences Window 197
  column descriptions 198
  comments 199
  opening with Seq button 184
  references 100, 199
Segments section 197
Sequences section 197
  setting default location 201
Templates section 197
Sequences Window menu 200
Set Default Location
  Graphic window menu 238
Index

List window menu 272
Notation window menu 282
Pulse window menu 231
Set Density (Select & Modify) 124, 127
Set In Point button 195
Set Insertion Point to End of Paste Region in Settings>Editing 333
Set Instrument (Select & Modify) 125
Set Instrument command 418
Set Legato to (Select & Modify) 126
Set Out Point button 195
Set to (Select & Modify) 126
Settings Window
Appearance 336
see also Appearance
Controllers 336
see also Controllers
Editing 333
see also Editing
Insert Note 331
see also Insert Note
Real-Time 334
see also Real-Time
Strip Chart & Nudge 332
see also Strip Chart & Nudge
Setup file 155
Setups menu 427
Auto Remappings 432
Colors 432
Commands 432
Enable Input Devices 429
Fader Remotes Enabled 428
Input Effect Enabled 428
Input Map Enabled 428
Keyboard Thru 427
MIDI Keys Enabled 428
OMS MIDI Setup 430
OMS Studio Setup 430
Record Filter 429
Record Quantize Enabled 428
Thru in Background 427
Undefined Channels 431
Shift

permanently shifting track data 77
Play Shift 73
Show 220
Note Grid 221
offset info in Tracks Window 220
Track Overview 204
use of selected Instruments 301
Show All Fader Info
in Console Window menu 359
Show Bar Numbers 287
Show Channels 310, 313
inged device mode when off 311
inged device mode when on 310
Show Event Durations
List window menu 273
Show Event End Times
List window menu 273
Show Masking Tape 361
Show Offset Info
Pulse window menu 232
Show Page Numbers 287
Show Patches In All Selected Group(s) in Names browser menu 323
Show Patches In Any Selected Group(s) in Names browser menu 323
Show Piano Keyboard 239
Show Release Velocities
List window menu 273
Show Remote Devices
in Console Window menu 360
Show Selected Fader Info 360
Controller 358
in Console Window menu 357
Instrument 358
Remote Device 358
Remote Device Channel (Chan) 358
Value (fader value) 358
Show SMPTE Counter
in QuickTime Movie window menu 390
Show SMPTE Offset
in QuickTime Movie window menu 390
Show Use of Selected Instruments
Index

Instruments window menu 301

Show Vertical Line
  Graphic window menu 239
  Notation window menu 283
  Pulse window menu 232

Shuttle bar 188

Silent when Paused
  in Real-Time 334

Sine shape
  in Strip Chart 247

Slaving to external sync device 147

SM PTE
  frame rates 150
  frames and bits 192
  offset 150
  time code, viewing in Counter 191

SM PTE cursor display 215

SM PTE Offset
  for QuickTime movies 392
  for sequences 54, 212

Snapshot of Faders 407

Solo
  inserted with Copy Faders command 347

Solo Audio and MIDI independently
  in Real-Time 335

Solo column 55

Solo events
  in Strip Chart 254
  inserting in List Window 267

soloed instruments
  finding 303
  unsoloing 303

Soloing
  Instruments 294
  tracks 55, 206
  tracks vs. instruments 295, 302

Song Track 99, 262

Sort By Name
  in Names browser menu 323

Sort by Number
  in Names browser menu 323

sound effects track
  using Lock Event SM PTE Times 263

Spacing
  in Insert Note 331

Special MIDI Keys 172

Split Notes command 424

Splits
  with custom Instruments 178
  with Input Map 329

Square shape
  in Strip Chart 247

Staff Indentation 286

Staff Spacing 286

Standard MIDI files 399

Start
  sequence information 54

Start/End
  in Make Segment/Loop 415

Step Overdub (record mode) 31

Step recording 42
  Changing Spacing Size 44
  Deleting Notes 43
  Entering Chords 43
  Entering Patch Events 43
  Entering Rests 43
  Sequence Events 43
  sequence events 85
  Step Window 337
  Sustaining Individual Notes 43
  tips 43

Step Replace (record mode) 31

Step Window 337
  Duration settings 339
  Spacing settings 337
  Spacing, changing with keystrokes 338
  tuplets 338
  Velocity settings 341

Stop at Punch Out command 438

Stop Sequence 104

Straight shape
  in Strip Chart 246

Strip Chart
  about 241
Index

Add Amount 244
Aftertouch 253
Audio Pan 254
Audio Volume 254
Automation submenu 254
Compress tool 245
Contents pop-up 242
Controllers 253
Copyright 251
Cue Points 252
Density setting 256
drawing fade outs 246
Duration 249
Edit Shapes pop-up 246
editing velocities 61
EQ Band Enable 255
EQ Band Frequency 255
EQ Band Gain 255
EQ Band Parameter submenu 255
EQ Band Type 255
EQ Band Width 255
EQ Enable 255
event types 241
Flat shape 247
for multiple tracks 257
Free shape 246
I-beam tool 243
in Tracks Window 205
Instruments 251
Lyrics 251
Markers 250
Max Limit tool 244
MIDI submenu 252
M in Limit tool 244
modifying events 243
Mute events 254
Non-Continuous Events 248
opening 242
Oscillator shapes 247
Oscillator shapes & Waveform Period 248
Parabola shape 246
patch events 251
Pencil tool 243
Phase Invert 255
Pitch Bend 252
Plug-in Parameter submenu 256
Poly aftertouch 253
Random shape 247
resizing 258
Sawtooth shape 247
Scale 244
Send Levels 254
Sine shape 247
Solo events 254
Square shape 247
Straight shape 246
tempo events 250
Text 251
Text-type submenu 251
Thin tool 245
tools 243
Triangle shape 247
uses 249
Variable pop-up 243
Velocity 249
Velocity Scale 253
zooming 258
Strip Chart & Nudge
Density 332
Move Amount 332
Transpose Amount 332
Use Key Signature 333
Waveform Period 332
subscribing 311
to patch name documents 308
Subsequences
about 104
 converting 104
Substitute (Select & Modify) 125
Substitute command 419
ideas for using 420
Substitute window
Controllers to notes 420
Preserve options 420
Replace each event... 419
Sustain Audio Across Segments in Real-Time 335
Sustain Notes across Segments in Real-Time 334
Swing
notating 291
Sync mode 54, 100
sequence events 98
sync mode
internal 434
MIDI Time Code 434
Sync Options
Remember these settings in sequence files 436
Sync Options dialog 433
Sync pop-up
in the Control Bar 189
Synchronization 147
lock audio to tape 434
receive sync device 434
receive sync modes 434
remote start 434
send sync device 435
send sync mode 435
settings, remembering in sequence files 436
slaving devices to Vision 151
SMPTE format 436
SMPTE frame rates 150
SMPTE offset 150
Sync pop-up 189
Syncing
to MIDI Beat Clock 147
to SMPTE time code 148
system 289
System Exclusive events
inserting in List Window 269
System Exclusive Thru
in Real-Time 335
System requirements 3
System Spacing 286
Systems per Page 287

T
Tapping the tempo 138
technical support 4
Tell Patch Provider 313
Templates
quantize 163
Select & Modify 165
Select & Modify Window menu 125
sequence 161
transpose 163
Tempo
clean display 334
fader assignment 344
field in Tracks Window 211
scaling 139
setting for sequence 211
setting in the Control Bar 192
tapping with the keyboard 138
tempo vs. tempo track 53
Tempo changes
inserting in List window 271
Tempo Display 192
Tempo track
constant vs. changing 211
editing in Strip Chart 250
in List Window 261
in List window 271
in Tracks Window 211
recording 137
switching to in the List Window 20
Test Device
in MMC window 377
Text
in Strip Chart 251
inserting in List Window 265
Text fields, editing 27
Text-type submenu
in Strip Chart 251
inserting in List Window 265
Thin tool
Index

Strip Chart 245
Thru in Background command 427
Thru Instrument pop-up 184
Thru/Trigger
  in Input Map window 326
Time signature 279
Title Font 287
Title Space 285
Tools
  Graphic window menu 237
  Notation window menu 281
  Pulse window menu 231
Track columns
  re-ordering 23
  resizing 23
Track lengths
  in List Window 55
  in Tracks Window 206
  locking 206
Track Loop 55
Track Overview 213
  block size 216
  Blocks mode 214
  Display modes 214
  Phrases mode 214
  selecting a time range 216
  silence size 216
  toggle 204
  Tracks mode 214
  working with track blocks 62
  zooming vertically 217
Track Select pop-up 19
  in Graphic Window 20
  in List Window 20
  in Notation Window 21
Tracks 62
  about 11
  add new track 20
  comments 210
  containing multiple Instruments 208
  controls for 54
  creating patch event track 421
Current Track pop-up 184
  deleting 412
  drum track toggle 207
  drum tracks 223
  generated sequences 111
  inserting 411
  locking length 206
  looping in Tracks Window 207
  looping with segments 95
  making into segments 94
  multi-tracks 413
  muting 206
  naming 206
  pasting 408
  Play Quantize 72
  Play Shift 73
  record-enabling 205
  recording 33
  re-ordering with move cursor 22
  selecting 205
  selecting in Notation Window 275
  selector dots 22
  separating multis 49
  showing/hiding in Notation Window 21
  soloing 206
  switching the current track 20
Tracks mode, Track Overview 214
Tracks Window 203
  column descriptions 205
  cursor display 215
  divider 204
  for generated sequences 107
  info area 205
  Information toggle 212
  Instruments column 208
  Mute column 206
  Patch column 88, 209
  Record column 205
  set default location 220
  show detailed Track Overview 220
  show offset info 220
  SM PTE cursor display 215
Solo column 206
Strip Chart 205
Track Overview 213
two windows in one 203
Tracks Window menu 219
Trans (Instruments window) 295
Transport controls 187
Locator buttons 189
MMC window 376
Next/ Previous Marker buttons 188
Pause button 188
Play from Counter button 188
Play from Start button 187
Record button 187
Shuttle bar 188
Transpose
Transposing Notes
in Notation window 278
Triangle shape
in Strip Chart 247
Trigger
in Input Map window 327
Trigger modes
continuous 185
from Control Bar 185
gated 185
in Input Map window 327
transpose 185
trigger 185
Trim Start Time (Select & Modify) 125, 129
Tuplets in Step Window 338

U
Undefined Channels 297, 431
Auto-open this dialog when needed 431
Remap all matching channels 431
Remember remappings to reapply later 431
Undo
and editing commands 405
and recording 406
while loop editing 67
Undo command 405
Units (PPQ) 192
Units of Measurements 287
Unmake Sequence Event command 415
Use Current Instead 312
Use Factory/ GM Names 308, 311
Use Key Signature
Index

in Strip Chart & Nudge 333
Use Meter 248, 332
Use Setup Instruments 157, 399

V

Value (fader value)
  Show Selected Fader Info 358
Value (Select & Modify) 122
Velocity
  for notes in Strip Chart 61
  in Insert Note window 332
Strip Chart 249
  using faders to control 346
Velocity (Select & Modify) 122
Velocity fader
  for Instruments 298
Velocity Scale
  checkbox 297, 346
  example 347
  in Strip Chart 253
  inserting in List Window 266
  Instruments 297
  Percent 298
  using a fader 346
Velocity Scale %346
  Instruments 298
View
  Graphic window menu 238
  List window menu 272
  Notation window menu 282
View/ Edit Patch Names 312
Viewing
  event durations in List window 273
  events in List Window 272
  Note Grid 221
  release velocities in List window
  Velocity 273
  SMPTE offset 212
  Track Overview 204
Vision
  basics 11
  Control Bar 13
edit windows 14
files 155
Instruments 293
navigation techniques 19
online help 16
system requirements 3
Vision Editing Templates file 155
Vision files 155
  creating new 397
  stored file objects 156
  what to save 156
Vision Grooves file 156
  editing 167
Vision Prefs file 155
  stored configuration settings 158
Vision Setup file 155
  and new Vision files 397
  items saved 157
  saving custom instruments 299
voice 289

W

Wait for Note mode 32
  Begin Record toggle 190
Waveform Period
  in Strip Chart & Nudge 332
  Use Meter 248
What to Open 398
Wide (Channel Width) 356
Window Background
  in Settings>Appearance 336
Window buttons
  in Control Bar 196
Window Size
  in QuickTime Movie window menu 391
Window specific menus 26
Windows
  accessing all open windows 21
  closing all 400
  edit 14
  menus 26
  navigating 19
opening from Control Bar 196
Windows menu 441
  Audio Instruments 442
  Consoles 351, 444
  Control Bar 183, 444
  Counter 444
  Faders 344, 443
  Graphic 233, 442
  Input Effect 115, 444
  Input Map 325, 443
  Instruments 293, 442
  List 261, 441
  MIDI Keys 171, 443
  M MC 375, 445
  Names 305, 443
  Notation 275, 442
  Players & Queue 113, 445
  Print Preview 285
  Pulse 221, 442
  QuickTime Movie 385, 445
  Record Monitor 444
  Select & Modify 119, 443
  Sequences 197, 441
  Settings 445
  Tracks 203, 441

X
  X events in Graphic window 233

Z
  Zoom Back
    Graphic window menu 237
    Notation window menu 281
    Pulse window menu 231
  Zoom In buttons 24
  Zoom Out buttons 24
  Zoom to Fit
    Graphic window menu 237
    Notation window menu 281
    Pulse window menu 231
  Zoom to Fit button 24

Zooming 24
  in the margin 25
  in the Ruler 25
  in Track Overview 217
  with the Mouse 25
  with Zoom In buttons 24
  with Zoom Out buttons 24
  with Zoom to Fit button 24
  zooming in the Strip Chart 258